none
HTTP Error 403.14 - Forbidden

    Question

  • I am running Vista Ultimate SP2 and Visual Studio 2008.  I am getting the following error and would like to know how to fix it and how to fix it so that I am not asked for admin privilages all the time.  I am the administrator,  Here is the error I am getting:

     

    Server Error in Application "DEFAULT WEB SITE/BALLOONSHOP"

    Internet Information Services 7.0

    Error Summary

    HTTP Error 403.14 - Forbidden

    The Web server is configured to not list the contents of this directory.

    Detailed Error Information
    Module DirectoryListingModule
    Notification ExecuteRequestHandler
    Handler StaticFile
    Error Code 0x00000000
    Requested URL http://localhost:80/BalloonShop/
    Physical Path C:\inetpub\wwwroot\BalloonShop\
    Logon Method Anonymous
    Logon User Anonymous
    Most likely causes:
    • A default document is not configured for the requested URL, and directory browsing is not enabled on the server.
    Things you can try:
    • If you do not want to enable directory browsing, ensure that a default document is configured and that the file exists.
    • Enable directory browsing using IIS Manager.
      1. Open IIS Manager.
      2. In the Features view, double-click Directory Browsing.
      3. On the Directory Browsing page, in the Actions pane, click Enable.
    • Verify that the configuration/system.webServer/directoryBrowse@enabled attribute is set to true in the site or application configuration file.
    Links and More InformationThis error occurs when a document is not specified in the URL, no default document is specified for the Web site or application, and directory listing is not enabled for the Web site or application. This setting may be disabled on purpose to secure the contents of the server.

    View more information »



    Thank you for your assistace.

    LadyDee
    Monday, August 17, 2009 10:39 PM

All replies

  • Have you already tried the resolutions proposed in http://support.microsoft.com/default.aspx/kb/942062/?

    Steve
    Tuesday, August 18, 2009 4:30 PM
  • Yes, I have tried that and I used this when I was using Windows XP. I have a new computer now with Vista Ultimate SP2, and that is what I am getting.  Trying to study for my test.
    Tuesday, August 18, 2009 7:03 PM
  • Does anyone have an answer for this problem?

    Thank you
    Ladydee
    Wednesday, August 19, 2009 5:41 PM
  • I have the exact same problem with IIS7 on Server 2008.

    Thing is, I have one website that I used the 'default web site' for.  This works fine. 

    Any new site I create pointing to a different port (in this instance :8080) gets the 403.14 error, and yes I have the default document configured.  I would prefer not to enable directory listing for obvious reasons.

    When I specify the document name in the URL, I get a 404.0 file not found though the file does in fact exist.  Permissions on the directory are the same as on the default website:  I am using anonymous access and the IIS user has appropriate access.  When I test access through 'basic settings' everything is good.  

    So why can't I get to it through a browser?  Even on the localhost?

    I would copy the 'default web site' but I haven't figured out how to do that in the 'new and improved' IIS.  Might be an Apache download in my near future.  Anyone?? 


    Thanks,
    Shambie
    Wednesday, October 21, 2009 10:32 PM
  • Hi ladydee,

      I have faced the same problem...and solved..

    Please follow the steps ..

    http://www.smallworkarounds.net/2010/01/http-error-40314-forbidden-web-server.html

     

     


    Thanks RK
    Tuesday, April 27, 2010 8:24 AM
  • Check your internet options security tab and see if it has been reset. Sometimes a program will reset your security settings. Also check for content and see if the content tab has been reset to other than standard settings.

    Monday, June 14, 2010 5:52 AM
  • HTTP Error 403
    403.7 Forbidden: Client certificate required
    Monday, November 08, 2010 10:59 AM
  • Hi Ravi,

     

    this does not solve the problem:

    this solution requires directory browsing to be enabled - not all people can do this (shared hosting etc.).

     

    i have a strange similiar situation (to Shambie)

    on my dev machine at home (W2K8 R2) i dont have a problem with this, but on the live system i have - funny thing is, this is also a W2K8 R2; and heck, this is since the last update of the system and i don't know what to do, since i can't rollout latest version of our system

    (and yes: on my dev machine directory browsing is *disabled*, and it still works - config on live system is same as on dev machine)

     

    Has anybode experienced same issues?


    • Edited by alexbaker2008 Sunday, June 12, 2011 9:25 PM small edit/add ontext
    Sunday, June 12, 2011 9:23 PM
  • Hi,

    Have you tried these:

    1.) Run a command prompt as Administrator.

    2.) Copy and paste the following text “C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet_regiis.exe -i”

    • Proposed as answer by Chris1201 Wednesday, August 24, 2011 9:19 AM
    Tuesday, July 26, 2011 6:25 AM
  • Hi,

    Have you tried these:

     

    1.) Run a command prompt as Administrator.

    2.) Copy and paste the following text “C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet_regiis.exe -i”

     

    That worked for me! Thank you Amir!
    Tuesday, August 02, 2011 5:19 PM
  • This did not work for me. It says the path specified cannot be found. I looked at the folder and the latest version seems to be v3.5.

     

    What can I do now?

    Thursday, August 25, 2011 12:50 AM
  • http://www.google.com.au/search?q=dotnet+4+download
    --
    ..
    --
    "karan.manglani" wrote in message
    news:a3b4742b-79fa-4f0f-b16e-dd0797470aaf...
    > This did not work for me. It says the path specified cannot be found. I
    > looked at the folder and the latest version seems to be v3.5.
    >
    >
    >
    > What can I do now?
    >
     
     
    Thursday, August 25, 2011 12:57 AM
  • I did that but now there is a different error:

    'C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet_regiis.exe-i' is not recognized as an internal or external command, operable program or batch file.

    Thursday, August 25, 2011 1:12 AM
  • There is a space towards the end between exe and the -i. So
     
    C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet_regiis.exe -i
    --
    ..
    --
    "karan.manglani" wrote in message
    news:b953bb06-5b5f-4840-bc17-c0afce0caa04...
    >I did that but now there is a different error:
    >
    > 'C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet_regiis.exe-i' is
    > not recognized as an internal or external command, operable program or
    > batch file.
    >
     
     
    Thursday, August 25, 2011 1:27 AM
  • Thanks for the help David. Got it installed; however, i still have the same problem that I had originally which is a problem with my default document.

     

    HTTP Error 403.14 - Forbidden

    The Web server is configured to not list the contents of this directoy.

    Module: DirectoryListingModule

    Notification: ExecuteRequestHandler

    Handler: StaticFile

    Error Code: 0x00000000

    Requested URL: https://localhost:443/

    Physical Path: C:\Windows\Web

    Logon Method: Anonymous

    Logon User: Anonymous

     

    I am trying to set up Remote Desktop Web Access on my own domain. If I browse to the application in IIS, the webpage is displayed; however, when browsing to the actual site, I am forbidden. My default document is enabled and has the following entries:

    Default.htm

    Default.asp

    index.htm

    index.html

    iistart.htm

    default.aspx

    All entries are inherited. I do not want to enable Directory Browsing. I just want the app to open when I visit the domain. All help is greatly appreciated!

    Thursday, August 25, 2011 1:45 AM
  • I don't know anything about IIS.
     
    --
    ..
    --
    "karan.manglani" wrote in message
    news:0370a1a7-67b6-4e02-a2d4-cee3f61d5555...
    > Thanks for the help David. Got it installed; however, i still have the
    > same problem that I had originally which is a problem with my default
    > document.
    >
    >
    >
    > HTTP Error 403.14 - Forbidden
    >
    > The Web server is configured to not list the contents of this directoy.
    >
    > Module: DirectoryListingModule
    >
    > Notification: ExecuteRequestHandler
    >
    > Handler: StaticFile
    >
    > Error Code: 0x00000000
    >
    > Requested URL: https://localhost:443/
    >
    > Physical Path: C:\Windows\Web
    >
    > Logon Method: Anonymous
    >
    > Logon User: Anonymous
    >
    >
    >
    > I am trying to set up Remote Desktop Web Access on my own domain. If I
    > browse to the application in IIS, the webpage is displayed; however, when
    > browsing to the actual site, I am forbidden. My default document is
    > enabled and has the following entries:
    >
    > Default.htm
    >
    > Default.asp
    >
    > index.htm
    >
    > index.html
    >
    > iistart.htm
    >
    > default.aspx
    >
    > All entries are inherited. I do not want to enable Directory Browsing. I
    > just want the app to open when I visit the domain. All help is greatly
    > appreciated!
    >
     
     
    Thursday, August 25, 2011 1:57 AM
  • Ok, thanks for the prior help, David! 

     

    Anyone else that might be able to help me?

    Thursday, August 25, 2011 4:41 AM
  • Hi ladydee,

      I have faced the same problem...and solved..

    Please follow the steps ..

    http://www.smallworkarounds.net/2010/01/http-error-40314-forbidden-web-server.html

     

     


    Thanks RK
    This fixed my connection issues to WSUS. Thanks!
    Thursday, October 20, 2011 9:03 PM
  • Thanks Amir..It worked for me.

    Monday, March 26, 2012 1:42 AM
  • Hi,

    Have you tried these:

    1.) Run a command prompt as Administrator.

    2.) Copy and paste the following text “C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet_regiis.exe -i”

    Yup, worked for me too, thank you very much, Amir. :)
    Saturday, May 05, 2012 7:55 PM
  • Hi,

    Have you tried these:

    1.) Run a command prompt as Administrator.

    2.) Copy and paste the following text “C:\Windows\Microsoft.NET\Framework64\v4.0.30319\aspnet_regiis.exe -i”


    Good Solution! Thx!
    Wednesday, August 01, 2012 12:26 PM
  • Thank you, Amir. 

    Its works for me.


    prakash patel

    Friday, February 15, 2013 3:39 PM
  • Worked for me too!
    Monday, August 05, 2013 8:56 PM
  • Steve,

    Directory browsing for a web application is not a solution. The support document you referenced is basically useless (unless, you really want to be able to browse a directory from your browser). I'm still not even sure why MS lists this as a solution to the 403.1* error. Ridiculous....


    • Edited by shadowsurfs Friday, November 08, 2013 5:43 PM
    Friday, November 08, 2013 5:43 PM
  • Hi LadeDee,

    This is one of the most common issue that developed faces when they start the New Website published with IIS or IIS Express.

    I searched internet a lot to find the exact issue and the solution that I found is to enable "Directory Listing" for the web site, similar guidance will be shown on the error page itself, but it is not recommended for security reasons.

    So to fix this issue, the easiest and best way is to add the default page or document that IIS should look while you click on browse or F5 from Visual Studio.

    1. Open IIS (Type InetMgr)

    2. Go to the WebSite you are facing the issue

    3. Click on Default Document Button, you will find it on the right side tab in IIS.

    4. You can see a list of default documents, but your default page (aspx file) is not mentioned here and that is causing the issue.

    5. Add your file here. (For example: Login.aspx)

    Now run the website again .. and yes .. that will work now.

    You can also find useful information related to this post here

    Thanks,

    Ambuj

    • Proposed as answer by Ambuj.Saxena Saturday, February 08, 2014 9:29 AM
    Saturday, February 08, 2014 9:29 AM