none
How do I create an association in the Default Programs control panel of Windows 7?

    Question

  • How do I create an association in the Default Programs control panel of Windows 7?
    Monday, November 30, 2009 10:31 AM

Answers


  • Hi Carl T Martin,

    If you would like to create association for new file type, you can however use the Open With option, attached the steps for your reference:
    ==================================
    1. Find a file with the extension that you wish to add

    2. Right-click the file and choose Open with -> Choose default program… (or choose Open, if this type of file does not have any associated program yet)

    3. Click Select a program from a list of installed programs

    4. Click OK

    5. If the application is not listed in the Open With dialog, click Browse and locate the executable.

    6. Make sure that the following checkbox is enabled:

    Always use the selected program to open this kind of file

    7. Click OK.

    Thursday, December 03, 2009 5:31 AM

All replies

  • Hi,

    I wonder what association you are trying to set in the Default Programs. Generally, you can try the following steps to create an association.

    Type 1:
     
    Change the file association
    ================
    1. Click the Start Button and click Default Programs.
    2. Click "Associate a file type or protocol with program."
    3. Click the XXX file extension and verify whether it is correctly set to open with the program which you want to use.
    4. If the configuration is not set correctly, please highlight this XXX file extension and click the Change program button.
    5. Check whether the program is listed in the Recommended Program or Other Programs. If so, please choose the program and click OK.
    6. If not, please click the Browse button to locate the correct program.
    7. Click OK.

    Type 2:

    Set the default programs
    ================
    1. Click the Start Button and click Default Programs.
    2. Click "Set your default programs".
    3. Highlight the XXX< program in the Program pane and click "Set this program as default".
    4. If you would like to manually choose which file types and protocols to open by the selected program, please click "Choose defaults for this program".
    5. Verify whether the related options are checked.
    6. Click Save after changing the related settings.

    If any error messages are received, please capture the screenshots and upload them to to SkyDrive and provide us the link for analyzing.


    Judy :)
    Tuesday, December 01, 2009 6:51 AM

  • Hi Carl T Martin,

    If you would like to create association for new file type, you can however use the Open With option, attached the steps for your reference:
    ==================================
    1. Find a file with the extension that you wish to add

    2. Right-click the file and choose Open with -> Choose default program… (or choose Open, if this type of file does not have any associated program yet)

    3. Click Select a program from a list of installed programs

    4. Click OK

    5. If the application is not listed in the Open With dialog, click Browse and locate the executable.

    6. Make sure that the following checkbox is enabled:

    Always use the selected program to open this kind of file

    7. Click OK.

    Thursday, December 03, 2009 5:31 AM
  • You all gave answers how to modify an existing entry.

    The questions clearly states how to create, add a new entry.

    There is no such option.

    You have to do it from a different place. Maybe that is easy with a file extension. Create a blank file with that extension, open, it asks you what with... etc. That is more like a trick than a Microsoft way to do it. Let's face it. That [Create] or [Add] button is missing and it should be there!

    And how about if you wish to add a protocol? like FTP etc... ?

    When I run a such protocol, I get the following error:

    There is no program associated to perform the requested action.. Please install a program or, if one is already installed, create an association in the Default Programs control panel.

    Well... My program is installed. But there is no [Create] option in the Default Programs control panel.

    Let me know when one option like that gets there...


    Monday, May 17, 2010 7:00 PM
  • un1golan, did you get a resolution to your problem?  I think we are talking about the same thing.  I setup my email with Windows Live but the computer doesn't recognize any email program and I would like to make it the default.  Thanks.
    Wednesday, May 19, 2010 12:02 PM
  • MailTo and FTP protocol associations used to be in Internet Explorer > Tools. Programs tab > button for "Internet Programs".

    You can still get there that way. I'm not sure which OS you are on, but in Windows 7, the button goes back to the Windows control panel screen Default Programs\Set Associations, which doesn't allow creating a new ones as you mentioned.

    However, in that list of apps and protocols, I see protocols are listed at the bottom of the list such as MAILTO and FTP that you discussed. If they exist, then you could just edit them there. 

    I think the Protocols associations are saved into registry keys such as

    HKEY_CLASSES_ROOT\ftp
    HKEY_CLASSES_ROOT\IE.FTP
    HKEY_CLASSES_ROOT\mailto

    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\ftp
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\IE.FTP
    HKEY_LOCAL_MACHINE\SOFTWARE\Classes\mailto

     


    Didn't get enough help here? Submit a case with the Microsoft Customer Support team for deeper investigation - http://support.microsoft.com/select/default.aspx?target=assistance
    Friday, February 18, 2011 7:16 PM
  • I still prefer this cool tool:

    http://defaultprogramseditor.com/


    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Friday, February 18, 2011 9:52 PM
  • How in the hell is a newbie suppose to know or understand what you guys are all talking about.    Come on.  break this down in a layman's terms.   Go here , click this etc. and explain what all these (3) letter terms mean.  Give us a break  All of you started the same place that I am.  ---jim---
    Sunday, October 09, 2011 5:58 PM
  • Under Default Programs\Set Associations - and at the very bottom of that window is the Protocols section where you will see FTP. However, when you try and change the associated program using Change Program... the only options are (in my case) Firefox  &  Internet Explorer. I would like to set the FTP association back to Windows Explorer. The choice of FTP programs should include Windows Explorer, but doesn't

    I am running Windows 7 and up until a couple of weeks ago I could I could use Windows Explorer to access ftp sites. I would just enter ftp.myhostname.com into the WE folder field and voila, the ftp site was treated like any other folder. I have no idea what has changed, but now if I enter ftp.myhostname.com into the WE folder field it opens either Firefox or IE (depending on the choice you made above). How do I revert back to the previous behaviour of FTP working very nicely with Windows Explorer.

    Tuesday, November 29, 2011 7:07 PM
  • OK I have solved the problem for the FTP configuration.

    First: use Control Panel Default Programs\Set Associations - and at the very bottom of that window is the Protocols section where you will see FTP. Use Change Program... and make sure FTP is associated with Internet Explorer.

    Now, use Windows Explorer to try and access the FTP site, i.e enter ftp.myhostname.com

    The FTP site will open in Internet Explorer (not what you want but...)  In Internet Explorer look for the Page menu on the tool bar and on that menu select Open FTP Site in Windows Explorer (very bottom menu item).

    Unfortunately in my case for the FTP site I'm trying to access I get the message:

           This FTP Site cannot be viewed in Windows Explorer

    Hopefully others have more luck! (I suspect it's weird firewall or security issue)

    Tuesday, November 29, 2011 7:22 PM
  • Andre.Ziegler YOU are my new hero thanks bunches
    Saturday, December 08, 2012 1:37 AM