none
Microsoft Security Essentials high CPU useage

    Question

  • Hello everyone,

    I am currently using Microsoft Security Essentials and I've noticed that every so often the CPU useage of it spikes and causes slowdown on my running applications, mainly any games that I am playing.  For example, if I am playing Mass Effect, it will run fine but every 30 seconds - 1 minute it will have massive lag for about 5 seconds.  I found the culprit to be MSE, and I have to shut off the service to be able to play the game without this problem.

    Has anyone else encountered this problem before?

    4GB ram
    3.2Ghz CPU
    Dual 9800GT's

    If you find my post helpful, please hit the "Vote as helpful" button on the top left of my post so that others may see that it is helpful as well. Thank you, Shawn
    Monday, January 04, 2010 7:22 PM

Answers

  • Hi Shawn,

     

    I also have MSE installed, but everything works fine.

     

    I would like to suggest you start into Clean Boot and manually start MSE to test the issue. In this way, we can determine if the cause is MSE.

     

    If MSE is the root cause, I also would like to suggest you reinstall it to check the issue.

     

    What’s the result?

     

    If it still cannot work, you may also disable Monitor file and program activity on your computer under MSE Settings/Real-time protection.

     

    Regards,


    Arthur Li - MSFT
    Friday, January 08, 2010 5:44 AM

All replies

  • I've not seen that, I've got somewhat lower system specs:  4GB or RAM, but only a 2.1 gHz CPU and a 7700 nVidia card (the Asus Gaming G1 laptop).

    Is MSE trying to do a scan or update?  One troubleshooting step I might try if it was me would be to go to the Real-Time Protection options in MSE, and turn off only the middle option:  "Monitor file and program activity on your computer"

    Or, try excluding your games' directory (maybe MSE is scanning the textures or maps every time the game accesses them?)

    Not exactly direct fix, but that's what I might do.





    If this was helpful, please vote. If it solves the issue, please click Propose as Answer. Thanks!
    Monday, January 04, 2010 10:28 PM
  • If I turn off real-time protection of file/program activity on my computer, it would only check for downloads then wouldn't it?

    I'll try and exclude the game's directory and see if that stops it, as it may be scanning textures the entire game :)

    If you find my post helpful, please hit the "Vote as helpful" button on the top left of my post so that others may see that it is helpful as well. Thank you, Shawn
    Tuesday, January 05, 2010 8:38 PM
  • Hi Shawn,

     

    I also have MSE installed, but everything works fine.

     

    I would like to suggest you start into Clean Boot and manually start MSE to test the issue. In this way, we can determine if the cause is MSE.

     

    If MSE is the root cause, I also would like to suggest you reinstall it to check the issue.

     

    What’s the result?

     

    If it still cannot work, you may also disable Monitor file and program activity on your computer under MSE Settings/Real-time protection.

     

    Regards,


    Arthur Li - MSFT
    Friday, January 08, 2010 5:44 AM
  • I was seeing CPU spikes from MSE too -- effectively rendering my system unusabel; I had to turn off MSE's Real Time Scanning feature to be able to use it at all.

    Over the course of a couple weeks I identified a couple processes on my system that were causing MSE to freak.  I rarely used the apps that spawned the culprit processes so I just uninstalled them uninstalled them and turned on the the Real Time Protection feature and bingo, no more CPU hogging by MSE.

    vcpcollector.exe -- a VMware capacity planne part of Virtual Center that I had on my system.  I got rid of this and it made MSE happy.
    usenext.exe -- a usenet client was also causing MSE to freak out.   Getting rid of it made a huge difference in MsMpEng.exe cpu usage.

    In summary, you most likely have a process running that, while not malicous, is doing low-level activities that causes MSE to bird-dog it and use up too much CPU while doing so.
    Thursday, January 14, 2010 10:10 PM
  • You are correct in stating that MSE slows what seems to me, most non-malicious programs that MSE isn't familiar with. I've written a small text-parser application for my work and was horrified to see that after multi-threading my tiny app, it still managed to write to disk at about 1-5 KB/sec. I was terrified, couldn't believe that my newly built PC is that slow. So i just wondered if it might be MSE (because I've see it's quiet CPU hungry if you monitor it). So all I did was disable the RTP: Monitor real time applications and program option and now i'm getting 250-350 KB/sec output from my application as I expected.
    Saturday, March 20, 2010 5:43 PM
  • Unchecking "Disable Monitor file and program activity on your computer" under MSE Settings/Real-time protection and disabling file indexing (Windows Search) greatly improved performance on my Vista Home Premium 32-bit / AMD 64 Athlon X2 2.7 GHz / 4 GB machine. Most of the time I couldn't complain, but every two weeks or so some unfortunate combination of factors would make my system almost unresponsive for a couple of hours; rebooting didn't help, I had to wait it out. Using the performance monitors and Process Explorer I managed to narrow down the issue to high disk access by a svchost.exe processing multiple large files on my hard drive. Overall CPU usage stayed rather low, however MsMpEng.exe CPU usage was around 25%. I suspect that indexing and/or defragmentation of those files was monitored by MSSE. This is consistent with a similar behavior I noticed upon chosing Avast or Avira instead of MSSE.

    IMO, if the only external source of files is the Intenet then enabling "Scan all downloaded files and attachments" under MSE Settings/Real-time protection should be sufficient for protection.

    Thursday, March 25, 2010 12:52 AM
  • I have the same problem and found a possible solution posted at: http://www.1stbyte.com/2010/02/01/microsoft-security-essentials-msmpeng-exe-using-high-cpu-time/

     


    • Edited by WanFactory Sunday, September 18, 2011 4:56 AM
    Sunday, September 18, 2011 4:56 AM
  • Arthur Li is definitely right on this one.

    I've had the same problems, it has gotten much worse. The entire system freezes. With my ATI CCC for the graphics card the system is a bit glitchy with windows already, but I found the problem to be another program.

    When you run a program that typically scans files and is connected to the internet, I believe MSSE is built to check if these actions or scripts/processes are safe.

    For example,

    Everytime I start-up µTorrent, MSSE goes a bit awry. Especially when µTorrent is verifying data.

    So if you have a program(s) that interfers with MSSE at times, such as µTorrent, 

    1. Change some settings in µTorrent and MSSE & see what works.

    2. Avoid using the program.

    3. If you must use it, then turn off MSSE real-time protection temporarily and maybe run a scan afterward.

    However if you believe this is not your problem...

    1. Try to reinstall MSSE.

    2. Report the problem to microsoft or in a forum such as this.

    3. Try another good free alternative such as Avast or many others to see what works.

    4. Look up TDSSkiller, it is really great and small tool for rooting out rootkits. : p



    • Edited by Austin_J_H Sunday, September 25, 2011 1:45 AM
    Sunday, September 25, 2011 1:44 AM