none
How to get an ipv6 stateful dhcp address on Windows 7 workstation?

    Question

  • In the past we worked with IPv4. Now we have both, IPv4 and IPv6 parallel. If I switch off IPv6 on my new Windows 7 Laptop, all runs well. But if I use additionally IPv6, I get problems. The reason is, I need a stateful DHCP address. This is an address, which is added to the DNS by DHCP, when I get the address from DHCP. When I use a Linux-Laptop, it runs well again, after some changing in the net configuration. This I want to do with my Windows 7 Laptop too. I wrote this only, to tell, that the reason is not the Cisco Router and the DNS-Server, it is the configuration of the laptop.

    If I look to the extended properties (erweiterte Eigenschaften) of TCP/IPv6 and TCP/IPv4 in the network managenent, I see the explaining diffence: TCP/IPv4 = DHCP activated and TCP/IPv6 = Only automatic configuration. But automatic configuration is stateless, but I need stateful. How can I manage this? I played with system management, netsh, ipconfig and route, but I am not the expert in Windows configuration. So I would be pleased, to be teached like a beginner.

    Thanks for help.

    Tuesday, August 17, 2010 10:03 AM

Answers

  • Thank you, the hint to Windows Server 2008 was right.

    It works now.

    But I must change your command a bit, because it does not work like you wrote it:

    netsh interface ipv6 set int ## advertise=enable managed=enable

    with the command

    netsh interface ipv6 show interfaces

    I get the numer ##

    Thank you.

    • Marked as answer by mml_uni-kl Thursday, August 19, 2010 3:34 PM
    Thursday, August 19, 2010 3:33 PM
  • Hi mml_uni-kl,

     

    To enable state of interface to Dhcpv6 Stateful mode, Run the following netsh command from elevated command prompt:

     

    netsh interface ipv6 set interface ipv6 <interface_name> advertise=enable managed=enable

     

    Refer to this thread: How to configure DHCP IPV6 Stateful configuration using Windows Server 2008

     

    Regards,

    Linda

     

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by mml_uni-kl Thursday, August 19, 2010 3:34 PM
    Thursday, August 19, 2010 7:20 AM

All replies

  • Hi mml_uni-kl,

     

    To enable state of interface to Dhcpv6 Stateful mode, Run the following netsh command from elevated command prompt:

     

    netsh interface ipv6 set interface ipv6 <interface_name> advertise=enable managed=enable

     

    Refer to this thread: How to configure DHCP IPV6 Stateful configuration using Windows Server 2008

     

    Regards,

    Linda

     

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    • Marked as answer by mml_uni-kl Thursday, August 19, 2010 3:34 PM
    Thursday, August 19, 2010 7:20 AM
  • Thank you, the hint to Windows Server 2008 was right.

    It works now.

    But I must change your command a bit, because it does not work like you wrote it:

    netsh interface ipv6 set int ## advertise=enable managed=enable

    with the command

    netsh interface ipv6 show interfaces

    I get the numer ##

    Thank you.

    • Marked as answer by mml_uni-kl Thursday, August 19, 2010 3:34 PM
    Thursday, August 19, 2010 3:33 PM
  • Glad to hear the issue is resolved. :-)
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Monday, August 23, 2010 2:08 AM
  • Just for completeness, what is the command to set this back to the default? 

    netsh interface ipv6 set int ## advertise=disable managed=disable???  

    Would that be it? 

    Friday, October 11, 2013 10:39 PM