none
Devices & Printers Not Showing

    Question

  • Running Windows 7 Professional.  I noticed that the devices and printers do not show anything there.  I can install printers and they are there when I try to print in word but I can't delete printers, change the default or see the printers I have listed nor any devices.  I do not have any blue tooth as I've seen some posts saying I should activate that service.  I don't know how to fix this.  Any help would be appreciated.
    Wednesday, March 03, 2010 3:14 PM

Answers

  • Do you get any message when you register IE files?

    It's better to collect a screenshot for the Device and printers, then upload it to the SkyDrive for analyzing.

    At the same time, you can try the following steps to set the "Bluetooth Support Service" to automatic and start.

    1. Click the Start Button, in Start Search box, type: "services.msc" (without quotes) and press Enter.
    2. Double click the service "Bluetooth Support Service".
    3. Click on the "General" tab; make sure the "Startup Type" is "Automatic". Then please click the "Start" button under "Service Status" to start the service.

    After that, please test again.

    Good luck!


    John
    • Marked as answer by Linda Yan Tuesday, March 09, 2010 8:27 AM
    Monday, March 08, 2010 4:41 AM

All replies

  • check if u have the soopler server started!  write in run "services.msc" and search for spool service.


    regards
    I want to be a MVP! | Computer Technician
    Wednesday, March 03, 2010 9:13 PM
  • Hi,

    You can try to registry the IE8 dll files to fix your issue, please download it from the following link:

    http://iefaq.info/attachments/133/ie8-rereg.zip

    After that, you should be able to see your devices in the Devices & Printers Windows Explorer.

    Good luck!

     


    John
    Thursday, March 04, 2010 6:50 AM
  • Unfortunately that did not solve the problem.

    Thursday, March 04, 2010 1:21 PM
  • Printer spooler is set to automatic
    Thursday, March 04, 2010 1:21 PM
  • Do you get any message when you register IE files?

    It's better to collect a screenshot for the Device and printers, then upload it to the SkyDrive for analyzing.

    At the same time, you can try the following steps to set the "Bluetooth Support Service" to automatic and start.

    1. Click the Start Button, in Start Search box, type: "services.msc" (without quotes) and press Enter.
    2. Double click the service "Bluetooth Support Service".
    3. Click on the "General" tab; make sure the "Startup Type" is "Automatic". Then please click the "Start" button under "Service Status" to start the service.

    After that, please test again.

    Good luck!


    John
    • Marked as answer by Linda Yan Tuesday, March 09, 2010 8:27 AM
    Monday, March 08, 2010 4:41 AM
  • Is the account you're using in the Administrators group? Is the computer part of a domain?

    The spool service is set to automatic, but what is its status? It should say started.
    Monday, March 08, 2010 5:31 AM
  • I have the same issue. It's across all users.
    Tuesday, January 10, 2012 9:45 PM
  • Hi John

    Wonder if you can help is it possible for you to obtain the patch and somehow make it available as the fix that you suggested works temporarily but then causes the computer to hang.

    Am referring to this MS KB: The Devices and Printers window stops responding (hangs) after you disable the Bluetooth Support service in Windows 7 or in Windows Server 2008 R2

    http://support.microsoft.com/kb/2486635

    Looking for this fix if possible.

    Thanks.

    Thursday, January 12, 2012 5:25 PM
  • Cmorr

    Found a fix but can't download the patch! http://support.microsoft.com/kb/2486635

    Did you manage to resolve it?

    Thursday, January 12, 2012 5:44 PM
  • The hotfix in http://support.microsoft.com/kb/2486635 worked well for me after everything else failed, Thanks MS.

    Look at the top of the article for the link where it says "view and request link"

    Friday, February 03, 2012 10:27 AM
  • Trying this.  Wish me luck.  
    Monday, November 19, 2012 4:40 AM