none
Windows 7 reports IP address conflict over address 0.0.0.0

    Question

  • I have 2 W7 machines as well as a Mac on a home network with an ADSL router, as well as two WiFi access points. All IP allocation is dynamic. Diagnostics from W7 always say conflict is over IP address 0.0.0.0 at the same hardware address. I have checked the MAC addresses of all devices and none of them correspond to the reported address. The router admin does not reveal any double use of the same address.

    This problem occurs after either of the W7 machines has been in sleep mode and only come up on the W7 machine that has been asleep. It can be cleared by simply re-booting - but why should I have to throw away the useful facility of sleep mode?

    Why should there be a conflict over a null IP address instead of a real one? Where does the phantom MAC address come from?

    Do W7 machines lose their DHCP allocations when asleep? According to the router the allocation is still there. How does W7 detect the (supposed) conflict of addresses? From the router? Or does it scan the network itself?

    I need a permanent fix to eliminate this.

    Sunday, June 13, 2010 8:12 AM

All replies

  • Have a look at these two settings:

    1. Control Panel > All Control Panel Items > Network & Sharing Center > Change adapter settings (in the left pane), right-click on the connection you‘re using > Properties > Networking Tab. Now remove the tick from the IPv6 box. If it makes no difference or causes other problems it is completely reversible by ticking the box.

    2. Right-click Computer > Properties > Device Manager (in the left pane). Expand Network Adapters > double-click the adapter > Power Management Tab and make sure the check box is cleared against ‘Allow the computer to turn off this device……’.

    Sunday, June 13, 2010 12:47 PM
  • I suspect that your network adapter driver is not compatible with Windows 7 so that it does not work properly after resuming from Sleep Mode. Please download the latest Windows 7 compatible driver from manufacturer’s website and install it. If there is no Windows 7 compatible driver available, the work around is change the setting in Device Manager to enable this device in Sleep Mode as BurrWalnut’s suggestion.

    Additionally such issue can also be caused by software. You may boot in Clean Boot Mode to troubleshoot if the above suggestions do not work.

    Perform a clean startup to determine whether background programs are interfering with your game or program


    Arthur Xie - MSFT
    Monday, June 14, 2010 7:47 AM
  • Just a thought, is your win 7 machine IP set to dhcp in router config page or is static? (kindly verify it under router config page) Try doing a ipconfig /all and post the IP address, subnet mask, default gateway, dhcp server here using print screen
    Monday, June 14, 2010 8:45 AM