none
How to change Local Area Connection from Public to Home Group

    Question

  • I was unable to find my question listed elsewhere here.

    After installing 7 Ultimate 64, my PC found and utilized the wireless USB adapter that was present, along with the wired NIC that was unused at that time.  I created my home group, et al, and all was fine.

    However, a few weeks later I connected via the ethernet cable and when it found a connection it identified it as Unknown and placed it in the Public network.  I cannot ascertain how to modify my wired NIC from Public to Home Group, after many hours of trying and googling.

    Any suggestions?  Here's hoping it's something easy that I'm greatly overlooking.

    Thanks!
    db
    Monday, March 15, 2010 6:04 PM

Answers

  • Hi,

     

    You can also try the following steps.

     

    1. Open Device Manager and temporarily disable all other unused network adapters.

     

    2. Temporarily turn off firewall on the machine and router (If it has).

     

    3. Upgrade the NIC driver.

     

    4. Restart the computer to Safe Mode with Networking to check the result.

     

    5. Configure the connection to obtain an IP address automatically

    =======================================

    a. Click "Start", input "NCPA.CPL" (without quotation marks) to Start Search bar and press "Enter".

    b. Right-click the network connection and click "Properties".

     

    If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

     

    c. Click to highlight "Internet Protocol Version 6 (TCP/IPv6)" and click "Properties".

    d. Check "Obtain an IP address automatically" and "Obtain DNS server address automatically".

    e. Click "OK".

    f. Click to highlight "Internet Protocol Version 4 (TCP/IPv4)" and click "Properties".

    g. Check "Obtain an IP address automatically" and "Obtain DNS server address automatically".

    h. Click "OK".

    i. Reboot the computer.

     

    If the issue persists, please also try the following steps.

     

    unidentified Network

     

    Thanks,

    Novak

     

    • Marked as answer by Novak Wu Thursday, March 25, 2010 2:05 AM
    Tuesday, March 16, 2010 8:12 AM

All replies

  • It actually is something easy.
    Open Network and Sharing Center.  Under "view your active networks" will be your current network connection (your LAN connection, in this case.)  Click the "Public network" link, and you'll get the "choose a network type" selection window.  Change as appropriate, and click OK.

    HTH,
    Chris
    [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Tuesday, March 16, 2010 3:06 AM
  • Hi,

     

    You can also try the following steps.

     

    1. Open Device Manager and temporarily disable all other unused network adapters.

     

    2. Temporarily turn off firewall on the machine and router (If it has).

     

    3. Upgrade the NIC driver.

     

    4. Restart the computer to Safe Mode with Networking to check the result.

     

    5. Configure the connection to obtain an IP address automatically

    =======================================

    a. Click "Start", input "NCPA.CPL" (without quotation marks) to Start Search bar and press "Enter".

    b. Right-click the network connection and click "Properties".

     

    If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

     

    c. Click to highlight "Internet Protocol Version 6 (TCP/IPv6)" and click "Properties".

    d. Check "Obtain an IP address automatically" and "Obtain DNS server address automatically".

    e. Click "OK".

    f. Click to highlight "Internet Protocol Version 4 (TCP/IPv4)" and click "Properties".

    g. Check "Obtain an IP address automatically" and "Obtain DNS server address automatically".

    h. Click "OK".

    i. Reboot the computer.

     

    If the issue persists, please also try the following steps.

     

    unidentified Network

     

    Thanks,

    Novak

     

    • Marked as answer by Novak Wu Thursday, March 25, 2010 2:05 AM
    Tuesday, March 16, 2010 8:12 AM
  • It actually is something easy.
    Open Network and Sharing Center.  Under "view your active networks" will be your current network connection (your LAN connection, in this case.)  Click the "Public network" link, and you'll get the "choose a network type" selection window.  Change as appropriate, and click OK.

    HTH,
    Chris

    No. I have exactly the same problem, and the "public network" is written in black type not blue and cannot be changed.

    Why not, I wonder?

    Friday, July 16, 2010 10:18 PM
  • Had same problem steps that worked for me.

    disable all other interfaces. Ensure the required interface is set for dynamic IP

    Go to the command prompt with admin rights and type "netsh int ip reset" then reboot pc.

    you may have to recheck the network interface and set to dynamic ip again

     

     


    Pips Sandhu A4 IT Services Ltd
    Tuesday, April 05, 2011 7:12 PM