none
copy/paste problem in remote desktop

    Question

  • I have noticed that when I use remote desktop in vista to connect to an XP remote system, copy and paste for text content does not work.

    Any idea?
    Monday, May 05, 2008 3:26 PM

Answers

  • Hi,

     

    Please make sure that Clipboard Redirection is enabled:

     

    1.    On Windows Vista machine, type mstsc.exe and press Enter.

    2.    Click the Options button, click Local Resources tab and make sure that the Clipboard check box has been selected.

     

    Hope it helps.

     

    Tuesday, May 13, 2008 8:27 AM
    Moderator

All replies

  • Hi,

     

    Before we go further, I would like to confirm the following information with you:

     

    1.    In which scenario the copy and paste function does not work? Copying and pasting between the Windows Vista and Windows XP machines or in the Windows Vista machine or in the Windows XP machine?

    2.    Is there any error message received when pasting data?

    3.    Are you using Windows built-in Remote Desktop Connection (mstsc.exe)?

     

    In addition, here is a related article for your reference:

     

    Cannot paste information between local and remote computer during Remote Desktop connection

    http://support.microsoft.com/kb/306885

     

    Hope it helps.

     

    Wednesday, May 07, 2008 8:22 AM
    Moderator
  • I use builtin remote desktop application in vista to connect to a machine which has XP. In this type of connection clipboard copy/paste (for example I want to copy a text or url) does not work. For example I copy a text in vista to clipboard and want to paste in XP notepad.

     

    There is no error message. When I right click and select copy in vista and then right click again in XP to paste the information, the paste color is gray which mean there is nothing in clipboard.

     

    I have to say there is no problem in sharing drives and copy/paste files. The problem is only for clipboard buffer.

    Saturday, May 10, 2008 6:54 AM
  • Hi,

     

    Please make sure that Clipboard Redirection is enabled:

     

    1.    On Windows Vista machine, type mstsc.exe and press Enter.

    2.    Click the Options button, click Local Resources tab and make sure that the Clipboard check box has been selected.

     

    Hope it helps.

     

    Tuesday, May 13, 2008 8:27 AM
    Moderator
  • I am having the same problem, but not connected with Remote Desktop. Is there another place I can check. Seems this just recently happened.

     

    Thanks for any suggestions.

     

     

    Thursday, May 29, 2008 5:54 PM
  • What do you mean? You mean can't connect with remote desktop?

    Saturday, May 31, 2008 4:57 AM
  •  

    Make sure you have redirected the Clipboard so that you can use it on the remote computer. To do this:

    1. Click to open Remote Desktop Connection.

    2. In the Remote Desktop Connection dialog box, click Options, and then click the Local Resources tab.

    3. Under Local devices and resources, select the Clipboard check box, and then click Connect.

    Saturday, May 31, 2008 5:08 AM
  • Make sure you have redirected the Clipboard so that you can use it on the remote computer. To do this:

    1. Click to open Remote Desktop Connection.

    2. In the Remote Desktop Connection dialog box, click Options, and then click the Local Resources tab.

    3. Under Local devices and resources, select the Clipboard check box, and then click Connect.

    • Proposed as answer by KBuffington Thursday, April 12, 2012 8:00 PM
    • Unproposed as answer by KBuffington Thursday, April 12, 2012 8:00 PM
    Saturday, May 31, 2008 5:11 AM
  • its for normal text,
    will this work for copying and pasting files?
    some of my friends system its working from xp to 2003 server
    but in my machine, i copied one file from my D drive, and unable to paste that in remote desktop?
    any clue?
    Vivek
    Tuesday, September 15, 2009 6:46 AM
  • I found the same error in Windows 7 Professional/ RDP 7. The problem did not exist in XP Pro/RDP 6. I found no solutions online but finally managed to track this down.

    If I selected individual drives to map to the rdp session, I was unable to use the clipboard. If, however, I just checked ALL drives, clipboard works.

    • Proposed as answer by Thimmu Tuesday, September 07, 2010 8:57 AM
    Thursday, November 12, 2009 1:19 AM
  • Chris is absolutely correct.  This is a bug between machines runnign seven or the latest updates in Vista.
    Tuesday, December 15, 2009 9:21 PM
  • I have the same issue connecting from Windows 7 x64 to a Windows Server 2003 machine.

    And the supposed solution posted by Joson does not work for me.

    Friday, May 28, 2010 6:52 PM
  • I had the same problem and following chris_tmba's suggestion fixed it (selected individual drives to map to the rdp session, I was unable to use the clipboard. If, however, I just checked ALL drives, clipboard works.
    ).

     

    Thanks to Chris and all.

    Tuesday, September 07, 2010 8:59 AM
  • I was having the same problem with a Terminal server  Windows 2008 R2.

    The solution that i found was in http://brennan.offwhite.net/blog/2007/01/18/fixing-copypaste-for-remote-desktop-sessions/

    Seems that the rdpclip.exe process is hanged and is need kill it and restart it.

    • Proposed as answer by mcNux Monday, September 23, 2013 10:06 AM
    Wednesday, March 30, 2011 8:18 PM
  •  

    I was having the same problem with a Terminal server  Windows 2008 R2.

    The solution that i found was in http://brennan.offwhite.net/blog/2007/01/18/fixing-copypaste-for-remote-desktop-sessions/

    Seems that the rdpclip.exe process is hanged and is need kill it and restart it.

     

    Thank you, had the same problem and the above answers didn't work but this one solved it.
    Sunday, May 08, 2011 9:33 PM
  • Yes, simply kill/restart rdpclip.exe on the server works for me too! Genius! Thank u!
    Tuesday, July 12, 2011 4:59 AM
  • you can try www.letscopypaste.com your problem will be solved.

    letscopypaste.com is an online clipboard application which uses the internet technology to give you liberty to copy & paste beyond your local computer. You can easily copy your useful information from one computer and paste it from another computer across the globe.

    • Proposed as answer by ALEx2061 Sunday, July 15, 2012 4:07 PM
    Sunday, July 15, 2012 4:07 PM
  • you can try following commands in sequence on your remote machine.

    1. taskKill.exe /im rdpclip.exe

    2. rdpclip.exe

    This will definitely solve your problem, if not you can try using www.letscopypaste.com. This is an online clipboard application and it works great.

    • Proposed as answer by mckenziea Monday, June 24, 2013 11:13 PM
    Saturday, July 21, 2012 8:11 AM
  • THANK YOU for this post!  I have suffered for months with this issue and have been unable to solve it!  This fixed it.
    Tuesday, December 11, 2012 12:05 AM
  • This solution worked for me!
    Saturday, June 29, 2013 6:54 AM
  • Excellent, thanks for your help it finally works.
    Wednesday, August 21, 2013 4:05 PM
  • Thanks. RD worked fine until I had to kill explorer on the remote machine. Saw this, killed and restarted rdpclip. Jobs a gooden.
    Monday, September 23, 2013 10:09 AM
  • WELL DONE.  rdpclip was the problem.  I can also drag files over to the remote session again now also which saves me emailing them to myself over the web.
    Thursday, November 14, 2013 11:24 AM
  • this fixed it for me!! thank you ALEx2061.
    Wednesday, January 08, 2014 6:18 PM
  • If you use mstsc.exe to connect clipboard works ok... but if you use RDCM clipboard does not work. (or use clipboard in remote machine, or not use clipboard in remote to use good in local).
    Friday, January 17, 2014 3:39 PM
  • its very simple

    make sure you have clipboard box checked, and then on the remote computer go to Administrative tools and select remote desktop connections> then remote desktop connection manager

    in the console reset your session and then try to copy and paste.

    Friday, April 11, 2014 4:38 PM