none
Unable to resolve the server's DNS address

    Question

  • I have been searching forums and everything that I can think of and have seen and tried many different approaches, but have not yet found the solution to this particular problem.  I loaded Avast anti-virus and had it scan and fix issues with computer. After restart, my computer connects to wireless, but has no internet access.  Neither explorer or chrome will connect and both give error messages related to being unable to resolve or reach the DNS.  I have tried setting the IPv4 DNS servers to 208.67.220.220 and 208.67.222.222.  I tried flushing the DNS, but got a "Function failed during execution" message. 

    It seems that either the anti-virus deleted something important or changed some setting that I can't find.  I checked to ensure that firewalls were off and even completely uninstalled the anti-virus program completely.  I am able to connect both laptops and phone via wireless and have internet, but am not getting net via wireless or ethernet cable on desktop. 

    I would appreciate any help.  Have been fussing with this for 2 full days and am about to pull all my hair out!!!

    Monday, September 24, 2012 3:20 AM

Answers


  • on a working computer capture this info with

    ipconfig /all

    Ethernet adapter Local Area Connection:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Broadcom NetLink (TM) Gigabit Et
       Physical Address. . . . . . . . . : 78-2B-CB-A0-04-B3
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::9527:8e7b:53aa:7de%14(Pref
       IPv4 Address. . . . . . . . . . . : 192.168.1.68(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Lease Obtained. . . . . . . . . . : September-23-12 6:43:17 AM
       Lease Expires . . . . . . . . . . : September-24-12 6:43:17 PM
       Default Gateway . . . . . . . . . : 192.168.1.254
       DHCP Server . . . . . . . . . . . : 192.168.1.254
       DHCPv6 IAID . . . . . . . . . . . : 192424907
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-15-A8-EB-

       DNS Servers . . . . . . . . . . . : 192.168.1.254
                                           75.153.175.1
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Then go to your laptop that doesn't work
    go to Control Panel\Network and Internet\Network and Sharing Center
    click on Change adapter settings
    right click on "local area connection" and then go to properties
    Click on on tcp/ipv4 and then click on properties

    Copy the information from your capture and add some number like 10 for example to get unique ip

    Only the IP needs to change all the other numbers will be the same for all computers (subnet, gateway,dns)

    click on Use the following IP address
       IPv4 Address. . . . . . . . . . . : 192.168.1.78 (add 10, 68+10)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0 (same)
       Default Gateway . . . . . . . . . : 192.168.1.254 (same)

    Click on Use the following DNS server adresseses
       DNS Servers . . . . . . . . . . . : 192.168.1.254    (same)



    • Edited by Brano Lukic Monday, September 24, 2012 5:30 AM
    • Marked as answer by bullseyeqt314 Monday, September 24, 2012 5:43 AM
    Monday, September 24, 2012 5:27 AM

All replies

  • start command prompt and run "ipconfig /all"

    Post the results here.

    If you have 169.... ip address then you are not getting ip address assignment from your router.

    Monday, September 24, 2012 3:24 AM
  • Wireless LAN adapter Wireless Network Connection:

    Connection-specific DNS suffix: gateway.2wire.net

    Description: Linksys Wireless-G PCI Adapter

    Physical Address: 00-12-17-8B-74-8D

    Dhcp Enabled: yes

    Autoconfiguration Enabled: yes

    Link-local IPv6 Address: fe80::8bb:49fa:f47d:89d3%11(preferred)

    Autoconfiguration IPv4 Address:169.254.137.211(preferred)

    Subnet Mask:255.255.0.0

    DNS servers:208.67.220.220

    NetBIOS over Tcpip: Disabled

    Then I have Ethernet adapter, Tunnel adapter Teredo Tunneling Pseudo-Interface, and Tunnel adapter isatap.gateway.2wire.net and all say media disconnected and have a bunch of zeros. I have no idea what any of this means or if am giving the right information even.  :/

    Monday, September 24, 2012 4:01 AM
  • Yes, this the info i was asking for

    Autoconfiguration IPv4 Address:169.254.137.211(preferred)

    Subnet Mask:255.255.0.0

    DNS servers:208.67.220.220

    Your computer is autconfiguring itself with APIPA address because it is not able to see router or dhcp server.

    You are not able to see DNS server because you don't have default gateway, which means you can't access anything that isn't in your local network.

    In short your problem is that your computer is unable to recieve ip address from your wireless router, this could be either computer problem or router.

    Monday, September 24, 2012 4:09 AM
  • You can try either reseting TCP/IP protocol or try to set static IP address.
    Another thing to try is to see if you can connect via wired connection.

    How to reset Internet Protocol (TCP/IP)
    http://support.microsoft.com/kb/299357

    netsh int ip reset c:\resetlog.txt
    netsh int ip reset resetlog.txt

    Monday, September 24, 2012 4:14 AM
  • I am able to log onto internet from same router with laptop, which would lead me to believe that the issue is definitely computer-based.  I spent about an hour on the phone with tech from internet company who then said that she did not know enough about link-sys adapters to help.  I had no previous problems with connectivity until running the avast scan.  It picked up a couple issues and deleted them, then restarted computer.  This problem began immediately upon the restart and has been that way since. 

    Monday, September 24, 2012 4:18 AM
  • Try uninstalling your wireless adapter and reboot the computer.

    Let the windows pick the best driver for it.

    If that still doesn't work then i would receommand to go to the manufacturing website and downloade the latest driver for your wirless adapter.

    Monday, September 24, 2012 4:28 AM
  • I tried both versions of resetting that and restarted computer after with no change.  I did try connect directly via ethernet cable earlier, but was getting the same response.  Computer recognizes being connected, but not that there is internet.

    Monday, September 24, 2012 4:28 AM
  • I actually went to the site for the driver earlier and used the driver on site to update mine.  Will try uninstalling first this time.  I really appreciate your attempting to help with this!!!
    Monday, September 24, 2012 4:33 AM
  • There is no difference after uninstalling adapter, etc.  If it is having the same problem regardless of being connected via cable or wireless, I has to be something other than the adapter, right?  or do I not understand how that works?  Is there something would affect both?

    Monday, September 24, 2012 4:46 AM
  • If you are having same problem with both wireless and wired connection than i would think the problem is either corrupted tcp/ip protocol or avast somehow blocking you.

    I would say remove avast from the computer and reboot.

    Disable both wireless and wired connections and then re-enable them again and try connection to the internet.

    You can download free anti virus program from Microsoft as well

    http://windows.microsoft.com/en-CA/windows/products/security-essentials

    Monday, September 24, 2012 4:54 AM
  • Go to device manager
    Go to view
    Click on "Show hidden devices"
    Find on "Non-Plug and Play drivers" click on it to expend it.
     look for "TCP/IP protocol driver" right click on it "Uninstall".

    Reboot and try again internet

    Monday, September 24, 2012 4:58 AM
  • I get super excited that it is going to work each time I try something new, but it is still doing the same.  You mentioned something about setting a static ip earlier? I tried resetting the other thing that you mentioned, but not sure what setting a static ip is or if that was something that I was supposed to have tried.
    Monday, September 24, 2012 5:15 AM

  • on a working computer capture this info with

    ipconfig /all

    Ethernet adapter Local Area Connection:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Broadcom NetLink (TM) Gigabit Et
       Physical Address. . . . . . . . . : 78-2B-CB-A0-04-B3
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       Link-local IPv6 Address . . . . . : fe80::9527:8e7b:53aa:7de%14(Pref
       IPv4 Address. . . . . . . . . . . : 192.168.1.68(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0
       Lease Obtained. . . . . . . . . . : September-23-12 6:43:17 AM
       Lease Expires . . . . . . . . . . : September-24-12 6:43:17 PM
       Default Gateway . . . . . . . . . : 192.168.1.254
       DHCP Server . . . . . . . . . . . : 192.168.1.254
       DHCPv6 IAID . . . . . . . . . . . : 192424907
       DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-15-A8-EB-

       DNS Servers . . . . . . . . . . . : 192.168.1.254
                                           75.153.175.1
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Then go to your laptop that doesn't work
    go to Control Panel\Network and Internet\Network and Sharing Center
    click on Change adapter settings
    right click on "local area connection" and then go to properties
    Click on on tcp/ipv4 and then click on properties

    Copy the information from your capture and add some number like 10 for example to get unique ip

    Only the IP needs to change all the other numbers will be the same for all computers (subnet, gateway,dns)

    click on Use the following IP address
       IPv4 Address. . . . . . . . . . . : 192.168.1.78 (add 10, 68+10)
       Subnet Mask . . . . . . . . . . . : 255.255.255.0 (same)
       Default Gateway . . . . . . . . . : 192.168.1.254 (same)

    Click on Use the following DNS server adresseses
       DNS Servers . . . . . . . . . . . : 192.168.1.254    (same)



    • Edited by Brano Lukic Monday, September 24, 2012 5:30 AM
    • Marked as answer by bullseyeqt314 Monday, September 24, 2012 5:43 AM
    Monday, September 24, 2012 5:27 AM
  • It worked!  I am so very thrilled!  Thank you hugely for all your help!!!  I have been messing with this for 10 hours today and would give you a super big hug if I could for fixing it for me!  You are awesome!!!

    Monday, September 24, 2012 5:43 AM