none
How do I remove Home Group and Libraries icons from desktop

    Question

  • How do I remove these icons?  As previously posted, upgraded from Vista with classic mode
    Sunday, May 10, 2009 12:43 AM

Answers

  • To remove the Homegroup and Libraries icons from your desktop, open regedit.exe from the Start bar, and navigate to:

    Computer\HKEY_LOCAL_MACHINE\SOFWARE\Microsoft\Wind ows\CurrentVersion\Explorer\Desktop\NameSpace\

    In the NameSpace folder, there will be a folder (key) with the name {B4FB3F98-C1EA-428d-A78A-D1F5659CBA93} . The value of the default item should be "Other users". This is the registry entry Homegroup icon. Delete the folder from the registry.

    In the NameSpace folder, there will be a folder (key) with the name {031E4825-7B94-4dc3-B131-E946B44C8DD5} . The value of the default item should be "Libraries". This is the registry entry This is the Libraries icon. Delete the folder from the registry.

    Go to your desktop and hit F5, the icons should disappear. Libraries and Homegroup have retained their full functionality as far as I can tell, so it hasn't appeared to have affected the programs at all.

    Source: http://forums.extremeoverclocking.com/showthread.php?t=320915

    :)

    Added by Forum Moderator:

    Warning: While this solution solves the issue or problem, serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk. For more information about modifying the registry, see Microsoft support article 256986.
    Monday, June 08, 2009 3:02 AM

All replies

  • What happened previously, when you took ownership?
    Rating posts helps other users
    Mark L. Ferguson MS-MVP
    Sunday, May 10, 2009 4:06 PM
  • I assume by "take ownership" you mean when I first installed/upraded to Win7-RC.  The Libraries was there but the Home Group appeared after I went through a home group configuration and password dialogue.  Only way to remove them is select don't show desktop icons and select not to store deletes in recycle bin.  They do not show up in the desktop icons selections?  Only other concern now is the greyed out icons in my tray, they are active but no colour or animation? The wireless connection icon shows up with animation for a min or so, then greys out again.  If I click on any of them they display in pop up fine.
    Sunday, May 10, 2009 7:47 PM
  • No, 'ownership' of an object is set on the Security tab of its properties.

    The Notification icon for the wireless connection is probably showing connection failure because you do not have a good enough driver for that wireless device on Windows 7.
    Rating posts helps other users
    Mark L. Ferguson MS-MVP
    Monday, May 11, 2009 7:47 PM
  • To remove the Homegroup and Libraries icons from your desktop, open regedit.exe from the Start bar, and navigate to:

    Computer\HKEY_LOCAL_MACHINE\SOFWARE\Microsoft\Wind ows\CurrentVersion\Explorer\Desktop\NameSpace\

    In the NameSpace folder, there will be a folder (key) with the name {B4FB3F98-C1EA-428d-A78A-D1F5659CBA93} . The value of the default item should be "Other users". This is the registry entry Homegroup icon. Delete the folder from the registry.

    In the NameSpace folder, there will be a folder (key) with the name {031E4825-7B94-4dc3-B131-E946B44C8DD5} . The value of the default item should be "Libraries". This is the registry entry This is the Libraries icon. Delete the folder from the registry.

    Go to your desktop and hit F5, the icons should disappear. Libraries and Homegroup have retained their full functionality as far as I can tell, so it hasn't appeared to have affected the programs at all.

    Source: http://forums.extremeoverclocking.com/showthread.php?t=320915

    :)

    Added by Forum Moderator:

    Warning: While this solution solves the issue or problem, serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk. For more information about modifying the registry, see Microsoft support article 256986.
    Monday, June 08, 2009 3:02 AM
  • There is only one issue: yes it will make these icons dissapear from desktop but they also dissappear from navigation pane in Windows Explorer window (on the left hand side) :-(
    So the real question is: is there a way not to have these icons on the desktop but retain them in the navigation pane!
    Thanks

    PS these icons should be manageable the same way "My computer", "Trash" ... are (with a tick box) but in 7-RC, this feature is not available yet
    • Edited by Milic Thursday, July 09, 2009 11:43 AM
    Wednesday, July 08, 2009 2:23 PM
  • I just installed the release candidate. Before installing, I had used easy transfer to save my settings from XP Pro. I initially did not have the homegroup and library icons on the desktop. After I used easytransfer to restore my settings, they appeared and I cannot get rid of them. If I change my network location to work from home, the homegroup icon disappears. Once I change the network location back to home, it reappears. Anybody figure out a solution to get them off them yet?

    Thanks,

    Mitch
    Tuesday, July 14, 2009 12:20 AM
  • Please see my answer in Green, cheers.
    Tuesday, July 14, 2009 1:55 AM
  • Please see my answer in Green, cheers.

    Problem is, that gets rid of the icons in explorer too. Then I cannot access homegroup or libraries from anywhere.

    Mitch
    Tuesday, July 14, 2009 3:22 AM
  • There is only one issue: yes it will make these icons dissapear from desktop but they also dissappear from navigation pane in Windows Explorer window (on the left hand side) :-(
    So the real question is: is there a way not to have these icons on the desktop but retain them in the navigation pane!
    Thanks

    PS these icons should be manageable the same way "My computer", "Trash" ... are (with a tick box) but in 7-RC, this feature is not available yet

    I have a checkbox for "User files" and "Network" showing in Control Panel/Personalization/ see link for "Change Desktop Icons" in the left 'Tasks" pane.
    Rating posts helps other users
    Mark L. Ferguson MS-MVP
    • Proposed as answer by DemmyDemon Thursday, November 12, 2009 12:09 PM
    Tuesday, July 14, 2009 1:38 PM
  • Yes, but there is no checkbox to add or remove homegroup or libraries from the desktop. The User Files and Network boxes to not change homegroup or libraries.

    Mitch
    Tuesday, July 14, 2009 3:15 PM
  • Your fix worked beautifully on my 7 (formerly Vista) machine.  You da man! Thank you.
    Thursday, November 12, 2009 5:01 AM
  • This fix works beautifully for me also.  Didn't remove the homegroup option from the navigation pane in explorer.  Just the icon from the desktop.  So if you lose it in the navigation pane you did something wrong!
    Friday, February 26, 2010 10:27 AM
  • This fix works beautifully for me also.  Didn't remove the homegroup option from the navigation pane in explorer.  Just the icon from the desktop.  So if you lose it in the navigation pane you did something wrong!

    You are most certainly mistaken - the above mentioned "fix" to delete the {B4FB3F98-C1EA-428d-A78A-D1F5659CBA93} key does in fact remove it from both the Explorer Pane as well as from the desktop. If you want them gone altogether this regedit is sufficient.  A fix as per Markman's request is still pending.

    --

    Sunday, May 16, 2010 3:06 AM
  • that is simply amazing!
    Thursday, September 16, 2010 2:26 AM
  • Just had Home Group icon appear after Windows update I assume as it wasn't there the last 5 months since initial Windows 7 install.

    Finding this pointed me in the right direction, but I found a solution without deleting the key. I was only seeing Home Group shortcut on desktop, not Libraries. I checked {031E4825-7B94-4dc3-B131-E946B44C8DD5} and found a string named Removal Message with value @shell32.dll,-9047. I created a string with the same name and value in {B4FB3F98-C1EA-428d-A78A-D1F5659CBA93} and refreshed desktop and Home Group icon was gone. Still see both in Explorer.

    As always, be careful with the registry!

    • Edited by Greg Barr Wednesday, December 29, 2010 2:09 AM additional info
    Wednesday, December 29, 2010 2:05 AM
  • Just had Home Group icon appear after Windows update I assume as it wasn't there the last 5 months since initial Windows 7 install.

    Finding this pointed me in the right direction, but I found a solution without deleting the key. I was only seeing Home Group shortcut on desktop, not Libraries. I checked {031E4825-7B94-4dc3-B131-E946B44C8DD5} and found a string named Removal Message with value @shell32.dll,-9047 . I created a string with the same name and value in {B4FB3F98-C1EA-428d-A78A-D1F5659CBA93} and refreshed desktop and Home Group icon was gone. Still see both in Explorer.

    As always, be careful with the registry!

    That did the trick perfectly! Thank you very much. Obviously if Microsoft would have allow us to have a choice whether that icon appeared or not, we wouldn't have to edit our registry. Why all of a sudden did someone decide we needed that icon stuck to the desktop anyway? I've managed to survive without it ever since Window 7 Beta.
    Saturday, January 08, 2011 9:21 PM
  • Brilliant!

    I didn't want to lose the icon everywhere, just off my desktop. This is perfect. Greg is my hero for the day. Oh, and this is Windows7 Home Premium and I have no idea what made the icon appear

    Tuesday, January 18, 2011 7:36 PM
  • I had the same problem and tried "everything"...including registry clean and virus scans.  Then, I held the power button down until the computer turned off.  When I restarted the computer and pressed the 'enter' key starting it normally, the icon was gone when it booted up.
    Wednesday, February 09, 2011 3:50 AM
  • Try holding the power key down to turn the computer off then restart it normally.  After trying a number of other fixes I did this and when the computer rebooted the icons were gone.  They haven't reappeared on the desktop, but 'are available in the control panel if I need them.  'Have no idea why they all of a sudden appeared on the desktop to start with.  If this procedure worked for me it might work for you.  It's a lot simpler than some of the fixes mentioned on this page.
    Wednesday, February 09, 2011 3:57 AM
  • Try holding the power key down to turn the computer off then restart it normally.  After trying a number of other fixes I did this and when the computer rebooted the icons were gone.  They haven't reappeared on the desktop, but 'are available in the control panel if I need them.  'Have no idea why they all of a sudden appeared on the desktop to start with.  If this procedure worked for me it might work for you.  It's a lot simpler than some of the fixes mentioned on this page.

    I have Windows 7 Ultimate x64, tried this and it worked! I was about to start shooting my monitor!! You saved its life pooler1!
    Thursday, February 10, 2011 4:06 PM
  • tried the turn off turn back on solution by pooler1 it worked but after a while the icon returned!!! went to another forum and found a download to do the registry editing for you its http://www.sevenforums.com/tutorials/34580-homegroup-desktop-icon-add-remove.html

    also homegroup is still in explorer with libraries etc

    hope it helps those who dont want to mess with registry themselves

    Saturday, February 12, 2011 7:12 PM
  • Ok bizzybazza. I tried your solution and it worked like a charm. I just hope you didn't inadvertantly lead me to some type of viral website!

    Friday, February 25, 2011 3:23 AM
  • I got rid of it by first right clicking on the homegroup icon, selecting 'create shortcut' which got rid of the original icon... then delete the shortcut. worked for me, and you don't have to mess with the reg settings.

     

    :)

    Sunday, May 22, 2011 2:17 AM
  • I copied my Library shortcuts into Favorites and made the following Reg file to hide HomeGroup and Libraries. It deletes the original two keys and then readds keys with a differnt name. After restarting Explorer you will have  aless cluttered Explorer bar.

    This has only been tested on Win7Pro64 so use at your own risk:

     

     

    Windows Registry Editor Version 5.00

    [-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace\{B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}]
    @="Other Users"

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace\{DISABLEDBYMIKEHOMEGROUP-B4FB3F98-C1EA-428d-A78A-D1F5659CBA93}]
    @="Other Users"

    {031E4825-7B94-4dc3-B131-E946B44C8DD5}


    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace\{DISABLEDBYMIKELIBRARIES031E4825-7B94-4dc3-B131-E946B44C8DD5}]
    @="UsersLibraries"
    "Removal Message"="@shell32.dll,-9047"

    [-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace\{031E4825-7B94-4dc3-B131-E946B44C8DD5}]
    @="UsersLibraries"
    "Removal Message"="@shell32.dll,-9047"

    Saturday, June 04, 2011 4:24 PM
  • Type services.msc in RUN or Startmenu Searchbox and press Enter. It'll open "Services" window.

    Look for the following 2 services:

    • HomeGroup Listener
    • HomeGroup Provider

    Once you find them, double-click on each and change the "Startup type" to Disabled. Apply the changes and exit from Services window.

    Disable_Homegroup_Listener_Provider.png

    That's it. It'll permanently disable "HomeGroup" feature and its icon will also be removed from Windows Explorer:

    • Proposed as answer by Kossa Thursday, January 26, 2012 5:25 PM
    Thursday, January 26, 2012 5:25 PM
  • Tried this and it was gone on reboot, but 10 minutes later it was back. I cannot get rid of this icon that just appeared yesterday
    Wednesday, February 29, 2012 5:30 PM
  • thanks! that`s works very well!
    Thursday, March 01, 2012 10:11 PM
  • It worked!! Thanks!! still I have no idea what I did, could you explain it briefly?... thanks a lot :D
    Sunday, March 04, 2012 7:20 PM
  • To remove the Homegroup and Libraries icons from your desktop, open regedit.exe from the Start bar, and navigate to:

    Computer\HKEY_LOCAL_MACHINE\SOFWARE\Microsoft\Wind ows\CurrentVersion\Explorer\Desktop\NameSpace\

    In the NameSpace folder, there will be a folder (key) with the name {B4FB3F98-C1EA-428d-A78A-D1F5659CBA93} . The value of the default item should be "Other users". This is the registry entry Homegroup icon. Delete the folder from the registry.

    In the NameSpace folder, there will be a folder (key) with the name {031E4825-7B94-4dc3-B131-E946B44C8DD5} . The value of the default item should be "Libraries". This is the registry entry This is the Libraries icon. Delete the folder from the registry.

    Go to your desktop and hit F5, the icons should disappear. Libraries and Homegroup have retained their full functionality as far as I can tell, so it hasn't appeared to have affected the programs at all.

    Source: http://forums.extremeoverclocking.com/showthread.php?t=320915

    :)

    Added by Forum Moderator:

    Warning:While this solution solves the issue or problem, serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall the operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk. For more information about modifying the registry, see.
    Works great as of 26th October 2012, also working on Windows 8.
    • Proposed as answer by AidanJeep Friday, October 26, 2012 8:14 PM
    • Unproposed as answer by AidanJeep Friday, October 26, 2012 8:14 PM
    Friday, October 26, 2012 8:13 PM
  • oh look the only post here that doesnt toally lick my balls

    pretty much disable the crap and your good to go!
    thanks kossa

    msconfig it too
    Thursday, November 29, 2012 6:28 PM
  • Open-> Network and Sharing Center -> Homegroupe ->exit from home group
    Thursday, March 14, 2013 2:07 AM
  • Open Computer > Drag back to the homegroup panel > F5 Dekstop ... Work perfectly, under 10 sec ._. 
    Thursday, March 28, 2013 9:57 AM
  • Desktop Homegroup in Windows 8 seems to appear without invitation and is not easily removed. Open Control Panel's Homegroup and You may find "Homegroup is not ready yet," or words to that effect, even though Homegroup is visible on desktop. Do not touch anything, this is just a visual confirmation of the inappropriateness of the Homegroup icon's appearance.

    Next, open Task Manager. and click Services tab. Scroll down to HomeGroupListener and HomeGroupProvider. Both should be stopped, and respond to right click commands.


    Oh as I was young and easy in the mercy of his means, Time held me green and dying Though I sang in my chains like the sea.

    Friday, June 07, 2013 2:04 PM
  • It WORKS!  

    And I do not care if LIBRARIES is not visible anywhere.  Homegroups I use and I can still get to fine from CONTROL PANEL and elsewhere.  So I am grinnin' ear to nose... (Half a face is better than another one that sucks)

    Wednesday, June 19, 2013 5:37 AM
  • It's easier than that. Just press F5 in the desktop and it will dissapear.
    Sunday, September 15, 2013 3:58 PM