none
Strange outline around some desktop icons (now a different question)

    Question

  • Some of my desktop icons recently picked up a gray one-pixel rectangular outline around them. I don't remember when it started, but it wasn't present when I first installed Windows 7, nor did it ever happen during the RC, beta, or while using Vista. Here's what they look like . That's two unaffected icons, and two icons with that weird border. The borders seem specific to each program or ICO file, but I can't figure out why some will get that annoying border and others won't. They also persist after reboot. Any idea what's going on?
    • Edited by djsb Friday, November 13, 2009 6:45 PM
    Tuesday, November 10, 2009 6:11 AM

Answers

  • Oh wait, now I see the problem: the desktop has, for some reason, changed to render icons at somewhere around 53 pixels square, so icons with larger sizes get downscaled to that size; while icons that only go up to 48 pixels are displayed at their native resolution, but with the "This Icon Isn't Big Enough To Fill This Space" outline around it.

    I guess the question is therefore: how do I correct (or change at all) the desktop icon size? I can go into the "Window Color and Appearance" control panel, and then into the "Advanced appearance settings..." window, but the icon size setting starts at 32 by default, so I don't think that setting has any effect. (And when I do change it, the only thing that changes on the desktop is icon spacing, not icon size...)

    edit: I just realized that I simply CTRL+Mousewheeled on the desktop without realizing. Facepalm.
    • Marked as answer by djsb Friday, November 13, 2009 6:52 PM
    • Unmarked as answer by djsb Friday, November 13, 2009 6:53 PM
    • Marked as answer by djsb Friday, November 13, 2009 6:54 PM
    Friday, November 13, 2009 6:52 PM

All replies

  • Hi,

     

    I test it on local machine and found that some application shortcut also has this rectangular boarder.

     

    Whether there is rectangular boarder should depend on the shortcut's ICO file.

     

    To check the original file, right click on the shortcut and choose Properties. On the Shortcut tab, click Change icon button, you will see the ICO file location. Then, please go to this folder and you will see that the original ICO file has this rectangular boarder.

     

    So, it is designed by the program manufacture. To remove this boarder, you may need to change the ico file. In addition, changing the Desktop Background to a lighter color will make this boarder invisible.


    Vivian Xing - MSFT
    Thursday, November 12, 2009 3:20 AM
  • Hi, I am sure that the outline isn't part of the icon itself. A few days ago, there were no outlines around any of my icons. Also, I created a simple icon that consisted of a pure white square, and when I placed it on my desktop an outline appeared around it. The outline is actually a couple pixels outside the area of the icon (on the desktop, that's 48px square).

    In fact, I think I figured it out: the only icons that get outlines around them are the ones whose maximum sizes are 48 pixels. If I looked at the Desktop in Explorer, displaying the icons at Medium (48px), none of the icons have that unsightly outline. If I increase the view size to Large, the icons with larger dimensions will scale up, but the ones that can't will stay at their medium size with an outline around them. Looks like that's working as intended. The problem appears that on the actual Desktop, the outline appears even when those icons are at the correct size. I just don't know how to fix that.

    Last thing I installed before I got this was the Office 2007 service pack 2 and recent security fixes for it, I wonder if it's related.
    Thursday, November 12, 2009 10:53 AM
  • Oh wait, now I see the problem: the desktop has, for some reason, changed to render icons at somewhere around 53 pixels square, so icons with larger sizes get downscaled to that size; while icons that only go up to 48 pixels are displayed at their native resolution, but with the "This Icon Isn't Big Enough To Fill This Space" outline around it.

    I guess the question is therefore: how do I correct (or change at all) the desktop icon size? I can go into the "Window Color and Appearance" control panel, and then into the "Advanced appearance settings..." window, but the icon size setting starts at 32 by default, so I don't think that setting has any effect. (And when I do change it, the only thing that changes on the desktop is icon spacing, not icon size...)

    edit: I just realized that I simply CTRL+Mousewheeled on the desktop without realizing. Facepalm.
    • Marked as answer by djsb Friday, November 13, 2009 6:52 PM
    • Unmarked as answer by djsb Friday, November 13, 2009 6:53 PM
    • Marked as answer by djsb Friday, November 13, 2009 6:54 PM
    Friday, November 13, 2009 6:52 PM
  • Hi,

    Thank  you for your update. I tested it on local machine, when the icons are changed to a smaller size, the boarder disappears. As you said, the Desktop icon size can be changed by CTRL+Mousewheeled. This is a very helpful information. Thank you.


    Vivian Xing - MSFT
    Monday, November 16, 2009 3:45 AM
  • Oh wait, now I see the problem: the desktop has, for some reason, changed to render icons at somewhere around 53 pixels square, so icons with larger sizes get downscaled to that size; while icons that only go up to 48 pixels are displayed at their native resolution, but with the "This Icon Isn't Big Enough To Fill This Space" outline around it.

    I guess the question is therefore: how do I correct (or change at all) the desktop icon size? I can go into the "Window Color and Appearance" control panel, and then into the "Advanced appearance settings..." window, but the icon size setting starts at 32 by default, so I don't think that setting has any effect. (And when I do change it, the only thing that changes on the desktop is icon spacing, not icon size...)

    edit: I just realized that I simply CTRL+Mousewheeled on the desktop without realizing. Facepalm.

    Thanks so much for this helpful information!  I think I accidentally zoomed in on the desktop with my multitouch touchpad.
    Saturday, January 23, 2010 10:30 PM
  • THANK YOU SOO MUCH THIS HELPED ME... Sorry for caps, haha i get my pet peves and those little white boxes were P'Oing me sooo much haha.  again  thanx!
    Wednesday, February 03, 2010 1:26 AM