none
In IE 8, Tools > Internet Options > Browsing history > Delete button greyed out

    Question

  • I am a system administrator for lab of computers running Windows 7 and I'm running into a situation where, in Internet Explorer 8,  the Delete button is greyed out under the Browsing History section of the Internet Options dialog box. Normally I would expect that if I had set any group policies controlling this, but I have set *no* policies. What other things (policies, windows setup) can cause the Delete button to be greyed out?
    Monday, July 19, 2010 3:44 PM

All replies

  • Hi vxbush, have you checked the following group policy?

    1. Click on the Start button and type gpedit.msc at the search programs and files box
    2. Click on the gpedit.msc when it appears on the list.
    3. On the left pane, expand User Configurations, Administrative Templates, Windows Components and Internet Explorer.
    4. In Internet Explorer, you will see a folder Delete Browsing History. Expand that.
    5. Look for “Turn off Delete Browsing History functionality” and double click on it.
    6. By default Not Configured is being selected and you will need to switch it to Enabled. Click the OK button when done.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, July 21, 2010 6:22 AM
  • 5. Look for “Turn off Delete Browsing History functionality” and double click on it.

    6. By default Not Configured is being selected and you will need to switch it to Enabled. Click the OK button when done.

    I did check that policy already. It was set to "Not configured" before, which was fine; I *want* to allow my users to be able to delete their browsing history and caches (we have issues with Blackboard that can often be cleared up by clearing caches). I tried setting it to "disabled", which I would interpret (with the overuse of negatives) to mean that folks *could* delete browsing history. But that didn't work, either. The "delete" button is still grayed out. 

    So I'm thinking that something else is preventing this from working. The only group policy I have set regards the desktop image, which is customized to reflect our department name. 

    Does working in Audit mode (via sysprep) cause problems with this with or without generalizing? 

    Wednesday, July 21, 2010 2:55 PM
  • I went back because I wanted to verify that I really had set this correctly. In the same location as you listed above (User Configurations, Administrative Templates, Windows Components, Internet Explorer, Delete Browsing History), I tried to set "Turn Off 'Delete Browsing History' functionality" to Disabled, which didn't work. I also tried to disable "Prevent Deleting Temporary Internet Files." That didn't work either. (I only set one at a time; I did not try to set both.)

    Please, I need some suggestions here. I even tried to uninstall and re-install IE8 via the Control Panel > Programs and Features box, and that did no good. We seriously need this functionality for our regular users. 

    Thursday, July 22, 2010 1:34 PM
  • Hi,

    I know that this has been waiting for an answer for about 2 years, but you can try and "disable" the "Prevent Deleting Web Sites that the user has visited" policy which is in the same location.

    Tuesday, July 03, 2012 2:28 PM