none
diablo 2 compatibility issues

    Question

  • i just bought a vista computer and i just loaded diablo 2 and the expansion on my computer.  it says there are known compatibility issues.

    * Diablo II - NOTE: For best results, set Compatibility Mode for

    application to Windows XP SP2 in the shortcut's properties and run as

    Administrator. This should allow all features of game to work properly,

    including LAN and Battle.Net play. If the game takes too long to start up,

    try disabling Aero Glass (or under compatability disable desktop

    composition).

    i did that but it still won't work.



    Is the problem because of the expansion?
    Is there any way to fix it?
    Tuesday, October 02, 2007 2:00 AM

All replies

  • i loaded diablo II on my computer which is a e machine with windows vista basic and cannot get it to work.  any suggestions would be helpful.

     

    Tuesday, January 08, 2008 8:51 PM
  • if your running with vista you probably are having the same problem as i was ... do you have the LOD expansion? for me... diablo 2 would not work properly ... but when i added the expansion to it the program would boot ... it would still give me an error but it gave three options... one being run anyways ... choose that one and it should work ... at least mine did
    Monday, July 07, 2008 1:09 AM
  • Before I have Windows Vista. I install Diablo 2 and the LOD expansion pack. I change run under win 95 or 98 works and sometimes crash but at least let you play too many times. Now I have Win 7 and is not working at all. I tried all compatible combinations possible and no results. Any ideas?
    Monday, April 26, 2010 7:34 PM
  • Reinstall your diablo 2 and l.o.d and create shortcuts,Right click on your shortcuts and click on properties,Then click on compatibility,and in there run it under windows xp sp3 and disable your desktop composition,And run it as an administrator,This should allow your game to start. You'll most likely have heavy lag so heres the fix for that. On your desktop hit ctrl+alt+del and open the task manager,Select services tab and click the services button at the bottom of that screen to access your service manager,Scroll down the list until you find "Windows Media Player Network Sharing" Stop this service,Then right-click it and select "properties" and disable this service.Close out of  task manager and you should be good to go.Good Luck
    Wednesday, May 12, 2010 8:20 AM
  • hi, how to disable your desktop composition  and run it as administrator, sry im new at this. and is it nescesary to reinstall diablo 2 and lod ? because i already got shortcuts
    Wednesday, May 12, 2010 10:38 AM
  • im trying to get it working on windows 7, and a saw something, right click diablo 2 LOD and go properties then the compatability tab then click run in compatability for... box then select the box below and choose vista
    Saturday, April 09, 2011 2:16 AM
  • thank you vert much for this i have windows 7 64 bit and this work for my problems aswell
    Sunday, July 03, 2011 6:24 PM