none
File sharing between a MAC OSX 10.5.8 and windows 7 professional

    Question

  • hi,

    i have been trying to view my files on the PC from my MAC and vice versa for the past week. I have tried literally EVERYTHING!! and still no luck.

    -SMB sharing is on
    -Same workgroup name on both PC and MAC
    -fiddled around with the security policy on the PC
    -set my folder in the PC and MAC for share

    Can someone pls helpp???
    Friday, November 13, 2009 2:35 PM

All replies

  • Please follow change the NTLM authentication level.

    Network security: LAN Manager authentication level

    To change the policy, open gpedit.msc from Start Search box, locate to:

    Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options\Network security: LAN Manager authentication level

    Change the value to “Send LM & NTLM - use NTLMv2 session security if negotiated”.

    If your system is Windows 7 Home Premium, you may change it from Registry.

    1. Launch regedit from Start Search box.
    2. Find the following branch.
     
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa

    3. Create a DWORD key under Lsa and set:

    Name: LmCompatibilityLevel
    Value: 1

    4. Restart.


    Arthur Xie - MSFT
    Monday, November 16, 2009 9:54 AM
    Moderator
  • i have tried that but from the local security policy...any other suggestions?

    thanks for you help
    Wednesday, November 18, 2009 7:15 PM
  • Have you enabled “Network Discovery” and “File and printer sharing”? To check it please open Control Panel\All Control Panel Items\Network and Sharing Center and click “Change advanced sharing settings” in the left pane.

    Also please be assure that the network addresses of the two computers are in a same network.

    If the issue still occurs please temporary disable firewall and anti-virus on each computer. 


    Arthur Xie - MSFT
    Monday, November 23, 2009 3:50 AM
    Moderator
  • Have you enabled “Network Discovery” and “File and printer sharing”? To check it please open Control Panel\All Control Panel Items\Network and Sharing Center and click “Change advanced sharing settings” in the left pane. DONE

    Also please be assure that the network addresses of the two computers are in a same network. Not sure how you check this but im using the same router for both laptops

    If the issue still occurs please temporary disable firewall and anti-virus on each computer. DONE


    Arthur Xie - MSFT
    ??
    Tuesday, November 24, 2009 5:01 PM
  • i am having the same problem on 10.6.2

    on mac:
    smb sharing is activated
    public folder is shared and policy is set
    firewall is off
    antivirus is off
    little snitch is off
    (i hate doing this because i like security)
    WINS workgroup name is (let's say) "FOREST"
    network username is (let's say) "forester"
    network password matches windows computer

    on pc:
    folder sharing is enabled
    folder i want to share is shared
    group policy has been set to lm/ntlm, use vista if requested (what you said above)
    firewall is off
    antivirus is off
    all of the network settings have been changed to allow a connection other than a "homegroup" for file sharing, and the workgroup name for the computer has been set to "forest"
    network username is (let's say) "forester"
    network password matches mac computer


    VAS GIBST???????
    Wednesday, November 25, 2009 9:49 AM
  • whoops!

    just to be clear, I am having the OPPOSITE problem, I can see the files on the PC from the mac but I cannot even see the mac from the PC.

    sorry.
    Wednesday, November 25, 2009 10:12 AM
  • Can you access the other computer after entering "\\IP address" in Windows Explorer? If not, what is the exact error message?


    Arthur Xie - MSFT
    Thursday, November 26, 2009 3:06 AM
    Moderator
  • i am having the same problem on 10.6.2

    on mac:
    smb sharing is activated
    public folder is shared and policy is set
    firewall is off
    antivirus is off
    little snitch is off
    (i hate doing this because i like security)
    WINS workgroup name is (let's say) "FOREST"
    network username is (let's say) "forester"
    network password matches windows computer

    on pc:
    folder sharing is enabled
    folder i want to share is shared
    group policy has been set to lm/ntlm, use vista if requested (what you said above)
    firewall is off
    antivirus is off
    all of the network settings have been changed to allow a connection other than a "homegroup" for file sharing, and the workgroup name for the computer has been set to "forest"
    network username is (let's say) "forester"
    network password matches mac computer


    VAS GIBST???????

    Hi,

    This is a different issue. In order to avoid confusion, please create a new thread and discuss there.
    Arthur Xie - MSFT
    Thursday, November 26, 2009 3:08 AM
    Moderator
  • The bad news on this is that unless your Win 7 is Pro or Ultimate (kinda lets out most of us) this answer won't work. The Windows 7 Home versions don't support MSC or Security Policies.

    This registry hack for Vista also works with Win 7. http://macs.about.com/od/macwindows/ss/sharemacfilesvs_7.htm

    I'm not sure why Microsoft has made it so difficult for Mac Users.  Sheesh! The more I use Windows, the more I love my Mac. And Apple doesn't ship "Crippleware".
    Monday, December 21, 2009 8:57 PM

  • I'm not sure why Microsoft has made it so difficult for Mac Users.  Sheesh! The more I use Windows, the more I love my Mac. And Apple doesn't ship "Crippleware".
    I think you could easily respond to this with "I'm not sure why Apple makes it so difficult to network with non-mac users." There are 10x more PCs than Macs, why aren't they making their stuff compatible?
    Saturday, March 13, 2010 9:44 PM
  • Macintosh has made their networking software compatible with a variety of different Microsoft (and other) protocols. The problem is that Microsoft keeps changing their protocols in an attempt to avoid compatibility with OS X and UNIX systems. Don't complicate the issue. This has nothing to do with security; Microsoft has been playing the networking monopoly game for decades.
    Sunday, March 14, 2010 4:30 AM
  • Could you rephrase that in English please? I think I've done everything right, ie. created a workgroup and started sharing for my entire Windows disc (C) and turned network discovery on.

    When I type my IP address into the Mac using SMB:// code, it seems to see the workgroup I created but asks for a password. I can't figure out which password you want. I didn't make a password to create the network. If you mean the password I created to go with my name as admin, I have tried several passwords and no password. Nothing works.

    Earlier I created a password for a homegroup before realizing Mac can't apparently connect to them. I tried that password as well and that didn't work.

    Any help much apprecited.

     

    Thursday, January 06, 2011 5:42 AM
  • Not wanting to start a war.

    But Apple do the exact same thing when they have a monopoly i.e. use it to cripple competition in other markets.

    Look how they use the iTunes to dominate the music player and now smartphone (what they did with the Palm Pre) or trying to destroy Flash by not supporting it on iPhone/iPad forcing content providers to use HTML5 (something they have a lot of influence over, a lot of "open" standards are controlled by a group of companies that are looking to or at least where created to break the hold over the dominant player).

    Lets just except all companies do it but I wish they wouldn't as it's such a pain.

    All that being said: There's nothing to stop Apple from bringing out a patch everytime Microsoft change the rules and have it applied along with a bootcamp update. They're a hugely profitable company. It's not like this isn't feasible.

    The chances are that they don't really want you talking to cheap windows servers and actually quite like the fact it forces mac users to buy things like Timecapsule etc.

    You don't know why Microsoft changed the settings, there could have been a valid reason and surely it's up to the player with 10% of the market to make sure their stuff works for the player with 90%.

    Tuesday, February 08, 2011 10:23 PM
  • A guides from Trickyways.com will solve your sharing problem File sharing Mac and Windows 7
    Monday, July 25, 2011 9:51 PM