none
Windows Vista cannot connect to the printer. There is not enough memory to complete this operation.

    Question

  •  

    Hi, i am receiving the above message when i try to connect to a Dell Laser printer 1100 which is connected to my wife's pc via usb. I have enabled the network sharing on both pc's. The pc's are using a cross over network cable. Both pc's are new dell vostro 200's with 1 gb ram running Vista Business. Please can someone help me!!

     

    thanks

    Damien

    Thursday, October 25, 2007 10:16 AM

All replies

  • I have the same problem, the computer that shares the USB printer is XP SP2.

     

    /Challe

     

    Wednesday, November 07, 2007 5:41 AM
  • I do not what cause this but the workaround seems to to create a new local port manually.

     

    Use "Add a local printer/Create a new port/Local Port", type in the network share name for the printer and it should work.

     

    /Challe

     

    Wednesday, November 07, 2007 5:52 AM
  • Thank you.

     

    I had exactly the same problem. Adding a printer attached to a netorked printer using XP. Vista kept coming up with the error message that there was not enough memory etc.

    I added a Local printer as you described and it all worked fine.

     

    /Paul

     

    Sunday, February 24, 2008 9:56 PM
  • Same story here. Had an all XP based network of laptops sharing a CLP500 Samsung but when I hooked up a Vista Ultimate that one just fails to connect to the printer. Yes I have added latest drives on Vista box, yes I have added share of server via \\machine}\printershare with name and IP address, yes I have removed printer def on both server and client but same "cannot complete message appears". Added the registry fix to add more slots on both machines, rebooted, added, deleted, tried and same story all the way. Great stuff, wonder what Linux would do....
    Tuesday, May 13, 2008 6:02 AM
  • I do not what cause this but the workaround seems to to create a new local port manually.

     

    Use "Add a local printer/Create a new port/Local Port", type in the network share name for the printer and it should work.

     

    /Challe

     


    thanks -- this worked! for 2 years stuck n unable to connect to the printer and in 2 mins got it working.
    Monday, December 12, 2011 3:27 PM