none
PC refuses to automatically connect to wireless network

    Question

  • I travel frequently with my Windows 7 Ultimate laptop. I have a Windows Mobile 6.5 phone and use WMWifiRouter to tether my laptop to the phone. (WMWifiRouter actually creates a mobile Internet hotspot, using WEP encryption.) This provides my laptop with wireless Internet access just about anywhere.

    Every time I launch WMWifiRouter and use my laptop, I have to *manually* connect my Windows 7 laptop to the wireless network; there is no "Connect automatically" checkbox. I also have to type in the security key; there is no "Save password" checkbox.

    The wireless network is configured within Windows 7 as a "Public network"; I've changed it to "Work network" and "Home network", however, with the same results.

    I'm at a loss as to why I can't configure Windows 7 to automatically connect to this wireless network. I even used the Manage Wireless Networks applet to manually add the wireless network (including entering the security key), configuring it to automatically connect to the network, but Windows 7 still refuses to connect automatically to this network and I still have to type in the security key.

    The WLAN AutoConfig service is started and set to Automatic. I have no problem automatically connecting to other wireless networks; it's just this particular wireless network that I can't connect to.

    Perhaps Windows 7 is unable to be configured to automatically connect to wireless networks having WEP encryption? Or am I missing something else?
    Thursday, March 11, 2010 10:43 PM

Answers

All replies

  • As it works for all but the phone setup you should be at the forum for that software, with it working as it should every where else that shows you it is not a windows 7 issue.
    Thursday, March 11, 2010 11:02 PM
  • Hi cgwaters,
    Perhaps if you configure a static ip for your laptop in the router software, then configure those settings when you create the wireless network connection on the laptop it will save it and connect automatically properly.
    WMWiFi RouterKB0802014

    As Bubbapcguy says, not a Win 7 issue.
    Good Luck!
    Friday, March 12, 2010 12:09 PM
  • Thanks; I'll try a static IP address.

    Since this is my only WEP wireless network, I'm not convinced that it's *not* a Win7 issue. Unless someone can confirm that they can connect to a WEP wireless network from their Win7 PC.

    Just now I connected to this wireless network with a WinXP laptop; it let me save the settings and it now connects to this network automatically.

    Don't get me wrong. I'm not necessarily complaining; I'd just like to know whether this is a documented 'enhancement' in Win7. If it's not, and it's actually a bug, I'd like to see it corrected.
    Saturday, March 13, 2010 12:55 AM
  • During the Beta and RC testing WEP was an issue for some network adapters. Never did determine if it was network adapter drivers or Windows 7. Perhaps "by design" a push to the more secure encryption by both.

    Windows 7 definitely prefers WPA\WPA2, which you don't have as an option with that software. I have not tested WEP with Windows 7 as I don't use it at home or for others.

    I don't know what more to offer. I'll post back if I discover something.

    By the way, what wireless adapter is installed in your computer?


    Saturday, March 13, 2010 1:24 PM
  • ok, I think I have the solution.

    When you are creating the connection select Security type-open no authentication, Encryption as WEP, and enter the key.

    A support page at WM described the WEP type used as open.
    http://support.wmwifirouter.com/knowledge/KB0803016/

    Then save and set to auto connect if available.

    Did that do it?
    Saturday, March 13, 2010 2:51 PM