none
Marvell Yukon Network Card

    General discussion

  • Although this affects the Vista installation on my same machine I thought it would be worth mentioning here in case anyone comes across the same issue.

    I have an Asus A8N-SLi motherboard which has an onboard Nvidia and Marvell Yukon GigE network cards. I connect one or the other to my Cisco 877W router, this has 100mb ports.

    The Nvidia card works perfectly, the Marvell is dreadfully slow. By setting the Speed & Duplex settings in device manager from auto-negotiate to 100 & Full the problem goes away.



    Brendon
    Tuesday, January 13, 2009 9:30 AM

All replies

  • My Marvel yukon pci-e does the same thing. Just need to force setup the auto negotiation to manual.
    Tuesday, January 13, 2009 12:16 PM