none
Installing Microsoft Touch Mouse, Microsoft Nano Transceiver v1.0, and Microsoft Mouse and Keyboard Detection Driver All Fail (as does windows update)

    Question

  • First off, I have done my homework.  I'm a software architect myself and don't give up easily! And I've keyworded this article with all of the relevant information so others can find the fix when we get it lined out, I hope it helps.

    This happens on very plain install of Windows 7 64bit, SP1, Microsoft Touch Mouse with a Microsoft Nano Transceiver v1.0.

    Let's forget that I have a new Microsoft Touch Mouse because the problem seems to actually be when installing the Microsoft Nano Transceiver v1.0.  With the mouse off, when I just plug this small usb key in, the system recognizes it for what it is but says that it fails with the standard fail screen. "Device driver was not successfully installed.  Microsoft Nano Transceiver v1.0"

    If you go into Devices and Printers, click on the one with the yellow caution symbol, Microsoft Nano Transceiver v1.0, it will take you to the properties, clicking the hardware tab it says "Device Status: Reinstall the drivers for this device. Code 18". 

    Where it gets interesting, clicking properties it says this: "C:\Windows\system32\WdfCoInstaller01009.dll is either not designed to run on Windows or it contains an error."  If you browse to that file, I see that the file date is 7/28/2011, barely 1 month old.  So it was obviously updated very recently.

    I try trusty windows update, and luckily it finds an important update (ONLY when the transceiver usb is plugged in).  The update seems immensely relevant, it's called "Microsoft - Other Hardware - Microsoft Mouse and Keyboard Detection Driver (USB)".  But it fails installation with the very helpful "Windows Update encountered an unknown error. Code 800F020B (code changes every attempt)".  This is really rare here because remember, this is a very plain install of Windows 7.

    Ok, so I can't update with windows update, can't find the driver or hotfix online either to install it manually.  Lovely.  So I reinstalled the IntelliPoint Drivers 8.2 many times, and with the transceiver plugged in, it will fail with "Error code: 1603". Without it plugged in, the install will succeed but nothing works still, same errors trying to see the Transceiver.

    So I honed in on the file in question, WdfCoInstaller01009.dll, a dll I believe used for to install usb drivers.  I noticed on my laptop (running same type of win 7 install) that same file was dated 8/6/2009.  Hmm.  So I ran sfc.exe /scannow from a command prompt to make sure my windows files were all the right versions.  So I backed up my copy of the 7/2011 one and then put the 8/2009 back in place.

    Then I plug in the usb transceiver.  It says it installs successfully, yay!  But I need to reboot first, so I do and Windows puts the 7/28/2011 version of the file back on boot, then when it loads the Transceiver again, we're back to square 1...it fails, same reasons.

    It seems like that WdfCoInstaller01009.dll is built for a different windows environment and there is a hotfix out there to fix it, but it fails...

    When helping, please realize that I have done all of this many different ways, in safe and clean boot modes and more.  I've found and followed many articles out there including:
    http://support.microsoft.com/kb/953691  (all methods followed)
    http://www.microsoft.com/hardware/en-us/downloads (grabbed latest driver installs and re-installed many times)
    and many others.

    What should be done next?  Maybe give me the hotfix windows update is failing to install?

    SideNote: When I plug in the Microsoft Touch Mouse for the first time, it blue screens (only when the mouse was turned on).
    Monday, September 19, 2011 6:42 AM

Answers

  • Hi,

     

    I suggest testing the Mouse on other computer to verify the hardware is good. If it doesn't work on other computers, it should be hardware issue.

     

    On the problematic PC, please update its BIOS from manufacture's site and reinstall USB controllers.

    http://blogs.technet.com/b/asiasupp/archive/2010/11/23/error-message-one-of-the-usb-device-attached-to-this-computer-has-malfunctioned-and-windows-does-not-recognise-it.aspx

     

    If the issue persists, please plug in Microsoft Nano Transceiver v1.0, then check the USB filter and try the device clean boot.

     

    Delete USB filter driver

    ----------------------------------

    1. Click the Start Button, type "regedit" (without quotation marks) in the Start Search box and then press ENTER.

    2. Navigate to the following key:

     

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{36FC9E60-C465-11CF-8056-444553540000} 

     

    3. Right click the {36FC9E60-C465-11CF-8056-444553540000}  entry, choose "Export", select Desktop in the Save in box and type backup in File Name. Click Save.

     

    Please Note: The backup file is on the Desktop and named backup.reg. We can simply restore the registry by double-clicking the backup.reg file.

     

    4. Highlight this key ({36FC9E60-C465-11CF-8056-444553540000}), on the right pane, delete the upperfilter and lowerfilter entries if these strings are present.

    5. Restart your computer and check if the problem disappears.

     

    Device Clean Boot

    ------------------------------

    1. Go to Device Manager

    2. Expand "Sound, video and game controllers".

    3. Right Click on Audio device and choose disable.

    4. Please use the same method to disable other dubious hardware such as: internal modem, and CD-R drive. Please note some devices such as video adapter are not available to be disabled.

    5. After that, restart the computer and then test the issue. If it does not occur, you can enable the device one by one to narrow down this issue.

     

    After you found the device that causing the problem, you can resolve by installing last driver or replacing the device.

     

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, September 21, 2011 8:48 AM

All replies

  • Hi,

     

    I suggest testing the Mouse on other computer to verify the hardware is good. If it doesn't work on other computers, it should be hardware issue.

     

    On the problematic PC, please update its BIOS from manufacture's site and reinstall USB controllers.

    http://blogs.technet.com/b/asiasupp/archive/2010/11/23/error-message-one-of-the-usb-device-attached-to-this-computer-has-malfunctioned-and-windows-does-not-recognise-it.aspx

     

    If the issue persists, please plug in Microsoft Nano Transceiver v1.0, then check the USB filter and try the device clean boot.

     

    Delete USB filter driver

    ----------------------------------

    1. Click the Start Button, type "regedit" (without quotation marks) in the Start Search box and then press ENTER.

    2. Navigate to the following key:

     

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{36FC9E60-C465-11CF-8056-444553540000} 

     

    3. Right click the {36FC9E60-C465-11CF-8056-444553540000}  entry, choose "Export", select Desktop in the Save in box and type backup in File Name. Click Save.

     

    Please Note: The backup file is on the Desktop and named backup.reg. We can simply restore the registry by double-clicking the backup.reg file.

     

    4. Highlight this key ({36FC9E60-C465-11CF-8056-444553540000}), on the right pane, delete the upperfilter and lowerfilter entries if these strings are present.

    5. Restart your computer and check if the problem disappears.

     

    Device Clean Boot

    ------------------------------

    1. Go to Device Manager

    2. Expand "Sound, video and game controllers".

    3. Right Click on Audio device and choose disable.

    4. Please use the same method to disable other dubious hardware such as: internal modem, and CD-R drive. Please note some devices such as video adapter are not available to be disabled.

    5. After that, restart the computer and then test the issue. If it does not occur, you can enable the device one by one to narrow down this issue.

     

    After you found the device that causing the problem, you can resolve by installing last driver or replacing the device.

     

    Best Regards,

    Niki


    Please remember to click "Mark as Answer" on the post that helps you, and to click "Unmark as Answer" if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Wednesday, September 21, 2011 8:48 AM
  • Try to disable plug&play on WIN. Old days reminiscence of 95 and NT. This let's you pick your own choice of drivers.
    Monday, December 19, 2011 12:18 PM
  • For virtually all hardware, the software/drivers should be installed first, before plugging in the hardware.

    In my case, plugging in my Asus bluetooth adaptor resulted in a "properly configured" bluetooth adaptor, but properly is a relative term.  It was using the MS bluetooth stack, and just wasn't right(complete).  My own fault, I just got ahead of myself.

    So I left the device plugged in, went to the device manager and selected removed this device AND remove the drivers.  Then I pulled the adaptor and rebooted.

    After reboot I installed the Asus BT suite/drivers (fresh copies from the site as opposed to the out of date ones on the disc.)

    THEN I plugged in the BT adaptor.  After many "found new hardware" / "installed successfully" cycles (one for each supported function the BT device/suite offered) I was greeted with a truly fully functional BT adaptor with all of the features I paid for.

    I too am a developer, and having done a lot of USB hardware designs and the drivers to support them, there are few people that should have known better than I, but I got ahead of myself.  It happens.

    DAS

    • Proposed as answer by ITAssistant Saturday, December 24, 2011 6:59 AM
    • Unproposed as answer by ITAssistant Saturday, December 24, 2011 6:59 AM
    Monday, December 19, 2011 3:19 PM
  • I work in a College IT department and I have come across this problem more than a few times with several different types of USB devices mostly wired and wireless mice, but i hardly ever have the problems i am reading about here... when i get a call about a device that the driver fails to install or quits working all of a sudden 99% of the time i have the problem resolved in a matter of minutes, all i do is unplug the device, go to device manager and uninstall the failed device then plug the device back in if it fails a second time i remove and uninstall the device again shut down the system plug the device back in and bring the system back up and everything is working as it should...
    • Edited by ITAssistant Saturday, December 24, 2011 7:12 AM
    Saturday, December 24, 2011 7:11 AM
  • How does one communicate with the PC without the mouse and keyboard, we cannot even access the logon screen.
    Sunday, December 25, 2011 8:46 PM