none
The following boot-start or system-start driver(s) failed to load: i8042prt

    Question

  • Hi
    My vista keeps rebooting every 30 minutes or so and i see this event id.  Any help please.   It is a 32 bit system and i havent installed any new apps in the last few days. 

    - System
      - Provider
       [ Name]  Service Control Manager
       [ Guid]  {555908D1-A6D7-4695-8E1E-26931D2012F4}
       [ EventSourceName]  Service Control Manager
      - EventID 7026
       [ Qualifiers]  49152
       Version 0
       Level 2
       Task 0
       Opcode 0
       Keywords 0x80000000000000
      - TimeCreated
      [ SystemTime]  2008-11-21T13:51:13.000Z
       EventRecordID 88400
       Correlation
      - Execution
      [ ProcessID]  0
       [ ThreadID]  0
       Channel System
       Computer NewPc
        Security
     - EventData
      param1 i8042prt

    Friday, November 21, 2008 3:25 PM

All replies

  • Hi

     

    You posted a partial description of the error from the Event Viewer.

     

    In the Event Viewer, double click the event you want to copy to bring up the details window.

     

    At the bottom, left corner of the details window, click the 'Copy Button' and paste the results in a reply here.

     

     

    Hope this helps.

     


    If this post helps to resolve your issue, click the Mark as Answer button at the top of this message.

    Ronnie Vernon
    Microsoft MVP
    Windows Desktop Experience
    Sunday, November 23, 2008 12:04 AM
  • I have the same error and experience very unstable behavior.  I reinstalled Vista up to the current version, including SP1 and still am having issue.  the details from my event log are below.  Any suggestions would be extremely welcome.  I spent the better part of the weekend wrestling with this machine and now I am experiencing issues again..


    Log Name:      System
    Source:        Service Control Manager
    Date:          12/16/2008 8:09:01 PM
    Event ID:      7026
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      HPDeskTop
    Description:
    The following boot-start or system-start driver(s) failed to load:
    i8042prt
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Service Control Manager" Guid="{555908D1-A6D7-4695-8E1E-26931D2012F4}" EventSourceName="Service Control Manager" />
        <EventID Qualifiers="49152">7026</EventID>
        <Version>0</Version>
        <Level>2</Level>
        <Task>0</Task>
        <Opcode>0</Opcode>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2008-12-17T02:09:01.000Z" />
        <EventRecordID>26786</EventRecordID>
        <Correlation />
        <Execution ProcessID="0" ThreadID="0" />
        <Channel>System</Channel>
        <Computer>HPDeskTop</Computer>
        <Security />
      </System>
      <EventData>
        <Data Name="param1">
    i8042prt</Data>
      </EventData>
    </Event>
    Wednesday, December 17, 2008 3:38 AM
  • Hi,

    I have had the same issue and I was able to resolve it.By default the startup type for i8042prt.sys at boot time is set to enabled.
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\i8042prt > The REG_DWORD entry "START" is set to "1" which means enabled.

    The driver is not installed by default and it is stored some directories.In example :
    C:\Windows\winsxs\amd64_keyboard.inf_31bf3856ad364e35_6.0.6000.16609_none_f18fcd509427b0d2\i8042prt.sys

    The driver can only be loaded if it is under stored under system32\DRIVERS\i8042prt.sys.

    If you never plug-in a PS/2 keyboard to your PC it is never copied to the system32\DRIVERS folder and you will see everytime this event if you start your PC.

    The solution is either you should plug-in a PS/2 keyboard one time or you should change the value of the "START" registry entry to "0" which means "disable" at startup or "do not try to load"

    Thats it !

    Hope it helps.

    Best regards,
    Cengiz Kuskaya

    EDU
    Wednesday, April 22, 2009 8:33 PM
  • Hello,

    Cengiz' answer was almost perfect, except for the actual registry value you set the value to force "DISABLED"; thus preventing its startup.

    The Registry value for "Start" in the HKLM\System\CurrentControlSet\Services\<ServiceName> Key should be set to a Decimal value of 4 for disabled.

    See this KB for Reference:
    http://support.microsoft.com/kb/103000

    (excerpt from the above KB Link)

    Start     REG_DWORD     Start constant
    Specifies the starting values for the service as follows:

    START TYPE     LOADER     MEANING

    0x0            Kernel     Represents a part of the
    (Boot)                    driver stack for the boot
                              (startup) volume and must
                              therefore be loaded by the
                              Boot Loader.

    0x1            I/O        Represents a driver to be loaded
    (System)       subsystem  at Kernel initialization.

    0x2            Service    To be loaded or started
    (Auto load)    Control    automatically for all startups,
                   Manager    regardless of service type.

    0x3            Service    Available, regardless of type,
    (Load on       Control    but will not be started until
    demand)        Manager    the user starts it (for example,
                              by using the Devices icon in
                              Control Panel).

    0x4            Service    NOT TO BE STARTED UNDER ANY
    (disabled)     Control    CONDITIONS.
                   Manager

     

    Tuesday, January 18, 2011 10:18 PM