none
Dual boot hibernate not working

    Question

  • I have a dual boot system. It is windows 7 and mac osx. they are on a drive which is formatted GPT and has the following partitions
    [partition 0] - 200 mb (EFI)
    [Partition 1] - 19 gb OSX (active)
    [Partition 2] - 40 gb (active)

    I am using the chameleon boot loader.
    Everything works perfectly except for hibernate (because this is a netbook, this is essential to the usability of the computer/battery life)

    when you press hibernate the computer goes dark for a second and then when you wiggle the mouse it goes to the user login screen.

    I have tried going to an administrator command prompt and have put in powercfg -h on    to restore the hibernate image but this still does not work.

    I am really at wit's end. 

    If anyone could help me solve this problem it would be greatly appreciated.
    Sunday, November 01, 2009 4:39 AM

All replies

  • It may be a driver or program running in the background. It may not be a dual boot issue. "powercfg -energy" is a new command in Windows 7 which can be very helpful.

    http://www.bing.com/search?q=powercfg+%22windows+7%22&form=QBRE&filt=all&qs=n

    Kerry Brown MS-MVP - Windows Desktop Experience
    Sunday, November 01, 2009 5:17 PM
  • I tried typing in this command and then generated the html report. I looked through it pretty carefully and didn't see anything about the hibernation image. It just said that it was using the OEM balanced energy plan.

    I do know that the powercfg -h on command does work in windows 7 though (its just not solving my problem for some reason)


    I think it would be helpful if I knew more about where the hibernation image was stored and how it worked. It just may be something with the dual boot setup, and let me be more specific with my drive layout because I left out some details:
    formatted as gpt
    [partition 0] - 200 mb (EFI) (active)
    [Partition 1] - 19 gb OSX (active) (hfs)
    [Partition 2] - 40 gb windows 7 (active) (ntfs)

    after I finished installing windows on the 3rd parition, hibernation was working fully but the bootloader was not coming up. I marked the first two partitions as active in cmd and then i was able to use OSX and my bootloader but hibernate stopped working in windows.

    I have since tried marking the first two partitions as inactive but now it doesn't do anything. I have tried the powercfg -h on. I have tried the pwercfg -energy.  I have also tried toggling the "usb legacy support" on and off in the bios, I had heard that this was sometimes in issue on my netbook (dell mini 9/vostro a90)

    thanks again for entertaining this random problem!


    Sunday, November 01, 2009 8:15 PM
  • The problem you described in the original post does not sound like a problem with the hibernation file. It sounds like a problem caused by a driver or a program running in the background that is interfering with the hibernation process. The html report may help to identify the offending process. If powercfg -h off/on work I think you can safely assume the hibernation file is working properly. The hibernation file (hiberfil.sys, its a hidden system file) is normally in the root of whatever partition Vista calls C:. With most boot managers when hibernation is working you pick the Vista boot option then you'll get a screen about restoring Windows if you had previously hibernated Windows.

    I think the problem is that hibernation is not working not that there is a problem with where the hibernation file is.

    Kerry Brown MS-MVP - Windows Desktop Experience
    Sunday, November 01, 2009 8:30 PM
  • I have a dual boot system. It is windows 7 and mac osx. they are on a drive which is formatted GPT and has the following partitions
    [partition 0] - 200 mb (EFI)
    [Partition 1] - 19 gb OSX (active)
    [Partition 2] - 40 gb (active)

    I am using the chameleon boot loader.
    Everything works perfectly except for hibernate (because this is a netbook, this is essential to the usability of the computer/battery life)

    when you press hibernate the computer goes dark for a second and then when you wiggle the mouse it goes to the user login screen.

    I have tried going to an administrator command prompt and have put in powercfg -h on    to restore the hibernate image but this still does not work.

    I am really at wit's end. 

    If anyone could help me solve this problem it would be greatly appreciated.

    weird enough, I have the exact same setup, and the exact same problem... And I know its not a app as I just have a clean install of windows 7 installed.
    Sunday, December 27, 2009 4:03 AM
  • I had a quite similar problem with an dual boot linux. Explicitly making the windows system partition active in the grub boot manager helped me.

    See my post at:

    http://social.technet.microsoft.com/Forums/en-US/windowsserver2008r2general/thread/30514c1f-e83d-4c09-ac59-aaa41777e55f/#13bd36c3-262b-4861-803d-091be44eb41d

    Hope this helps you to get an solution for OSX, too!

    Regards
    T.
    Monday, January 04, 2010 10:33 AM
  • Due to BCD bootloader design, Windows volume has to be always the active one, because if not, Windows belives that BCD configuration is the active disk and cannot find it to write on it the default boot entry as the "Windows Resume from Hibernation". So the system will allways be booting from the Windows entry even if it should have booted from the Resume entry. To check this try runing BCDEDIT from cmd.exe (as administrator), if it says that BCD store is missing I am right if not you could have corrupted bootloader (can be fixed for Windows from Recovery CD/DVD with the command bootrec /FixBoot), mbr (can be fixed for Windows from Recovery CD/DVD with the command bootrec /FixMBR), BCD store (can be fixed fromRecovery CD/DVD with the command bootrec /RebuildBCD) or as said before by Kerry Brown you could have a damaged Hibernation file (hyberfil.sys at the root of your Windows volume (size normally the same as your ram). Additionally there are some patched bootloaders which are suposed to fix this issue if don't have Windows volume active, also, you can use EasyBCD to add mbr/EFI based real-time bootsector entries to the BCD bootloader to boot multiple OS's from BCD bootloader including Macintosh & Linux.

    Hope it helps
    JTS
    • Proposed as answer by f0rbidik Sunday, February 13, 2011 7:48 AM
    Saturday, March 13, 2010 10:11 AM
  • Please provide information about the patched bootloader.  I am having the same problem.  My config is a little different:

    Partition1: WinPE, active, custom boot record
    Partition2: Windows 7, not active

    Partition 1 boot record is always loaded and examines data stored in a hidden sector to determine if it will load the WinPE boot record or the Windows 7 boot record.  When partition 1 is active and partition 2 in inactive, Windows 7 hibernatino fails.  If partition 1 is inactive and partition 2 is active, then Windows 7 hibernation works. Since I must boot the custom boot record in partition 1, I even tried setting both partitions active.  Both OS's boot fine that way but Windows 7 hibernation still fails.

    Is there any way to make hibernation work and keep the Windows 7 partition inactive?


    Thanks,
    Evan R. Hicks 

    Monday, March 28, 2011 7:58 PM
  • The answer from FJTORSOL is correct.

     

    Windows 7 must be in the active partition in order to hibernate to operate properly. Not only hibernate, but also Service Pack 1 will not install properly if Windows 7 partition is not flagged as active.

     

    I have 3 partition HD booting up multiple operating systems, and installed a boot manager. I would like to have the boot manager partition as the active partition, in order to be able to select which OS to boot.

    Although Windows 7 boots up properly and even Sleep works, some functionality do not work. Most notably: (1) hibernation; (2) Service Pack 1 install.

    Once switched the active partition flag back to mark Windows 7 partition as active, hibernation began to work again, and Service pack 1 installed successfully.

     

    The command to switch the active partition flag to point to partition #2 :

    fdisk -e /dev/rdisk0

    > flag 2

    > write

    > quit

     

    Saturday, July 30, 2011 10:29 PM