none
Driver for 3com 3C920B Network Adapter

    Question

  • Hi all,

     

    I am using an ASUS P4R800-VM Motherboard that uses a built in 3COM 3C920B-EMB-WNM Network adapter.  I cannot get it to install with the new RC1 of Vista.  I had the Beta 2 release which was build 5308 I believe and it worked fine.

    As this adapter is used to connect to the Internet we have here at home I cannot connect to the Internet in Vista to see if there are any updates for it.

    Does anyone know where I can get a driver from for this adapter?

    Many thanks and Much appreciated.

    Johnboy1981

    Monday, September 18, 2006 8:35 PM

All replies

  • Well im using Albatron PX865 Lite Motherboard and i also need to find a 3com driver for Vista only my one is 3Com 3C920 Integaretd Fast Ethernet Controller (3C905C-TX Comapatable) and i searched for it on many sites and didnt found anything...Please help us find these drivers...
    Any help will be apriciated....thanx
    If u know where i can find this driver send me a link on my e-mail: Covenantforever@gmail.com....and make the subject "Vista driver"
    Sunday, September 24, 2006 9:47 PM
  • Hi,

    Did either of you's get anywhere with this problem?

    I also cannot connect to the internet because the driver i have does not seem to work with vista.

    Sunday, October 08, 2006 9:16 PM
  • I have the EXACT same problem with the same board... Because of this vista is useless to me..

    if anyone found a solution for this problem PLEASE help me out by letting me know what to do

     

    thanks

    Tuesday, October 10, 2006 12:27 AM
  • I have Dell with integrated 3C920 on motherboard. After installing Vista, I could not get on net at all; IPCONFIG showed nothing configured. In Device Manager, it showed the NIC but it had NO driver loaded.

    From another computer, I downloaded drivers for 3C905C from 3Com at: http://support.3com.com/infodeli/tools/nic/3c905c.htm 

    In Device Manager, I did "Update Driver" (only needed Diskette 1).

    Seems to be working OK now. Hope this works for you!

     

    • Proposed as answer by evenbetta Thursday, February 05, 2009 4:06 AM
    Monday, October 23, 2006 8:19 PM
  • This took care of my problem too.

    I have an integrated 3C905B, and it was not recongized by Vista.

     

    Thanks!

    Sunday, November 19, 2006 8:08 PM
  • Ran into the same issue with Vista on a Dell Optiplex GX-240.  The link to the driver is the one I used as well and it works.  :-)
    Monday, January 15, 2007 9:17 PM
  • I'm using p4r800-vm motherboard as well but haven't had luck installing the (intergrated) network card's drivers.

    Can anyone provide step by step instructions in what to do? that would be great. When I try to install drivers using the device manager, it is always looking for a .inf file which I don't have. What am i doing wrong ? Please help . Thanks.

    also i tried to install the 3com drivers mentioned above but after I install them it just lists the 3com card under network adapters with a "yellow exclamation" mark under device manager. If i double click it, it states, "this device is not working properly because Windows cannot load the drivers required for this device. (code 31)"

    hellllp pleassse
    Friday, February 23, 2007 12:02 AM
  • My desktop has a ASUS P4R800-VM mother board.  I have literally just finished 'phase 1' of installing Vista Home Premium with all the hastles you all identified.  I've managed to find a download of a file called "3com_3c920b.exe" from Networkdrivers.com.  I now have the integrated NIC working.  Try Googling "3com_3c920b.exe".

     

    Still struggling with the SoundMAX drivers though.  Hope the above is of use.

    Saturday, March 31, 2007 6:36 PM
  • Hi

     

    All drivers product of 3com company including:

    1 - 3C905C-TX  exist at http://www.network-drivers.com/drivers/123/123176.htm

    2 - 3C920b  exist at http://www.network-drivers.com/drivers/192/192085.htm

     

    Note that you are sign up in this site and then download the drivers.

     

    bye.

    • Proposed as answer by evenbetta Thursday, February 05, 2009 4:06 AM
    Monday, October 15, 2007 2:34 PM
  • I happened to download the Windows 7 Beta just to play around with it on an old laptop I had.  It's a Dell Latitude C610.  The 7 Beta went on there beautifully, but you all know the headache of playing around with the drivers.  I had just about given up for a ethernet driver until I happened across your post.  I went to the site downloaded this file and Voila' it worked perfectly to my surprise on the Dell Latitude.  I'm so laughing at this.  Thank you a million times for your posting this.  Now off to looking for a clone video, and sound driver.   
    Thursday, February 05, 2009 4:06 AM
  • Hi, I'm in the middle of exactly the same install (Win 7 RC to DELL C610), did you manage to get a working video &/or sound driver by any chance ?

    I can't believe how well Win 7 runs on this very old laptop (1GHz Pentium III and 512 MB RAM :-) was going to buy a netbook, but this is as good as one anyway once get the network going
    Friday, June 05, 2009 5:43 PM
  • Thanks Rohollah. these drivers work.
    Wednesday, December 09, 2009 12:46 PM
  • Thanks!

    Just manged to breath life into an old pc with an even older nic using your tip. Works with Windows 7.

     

    Wednesday, October 20, 2010 5:34 PM