none
Virtual PC with Enable Integration Features turned On I get a login dialog that I cannot successfully use to login. If I disable integration features, I can use the Virtual PC.

    Question

  • The problem:

    Within my Virtual PC with Enable Integration Features turned on I get a login dialog that I cannot successfully use to login.  If I disable integration features, I can use the Virtual PC.

    Now for a bit of history.

    • This is on my work PC with a fresh copy of win 7 ultimate logged into a corporate domain.
    • Main OS is 64 bit win 7 ultimate.
    • I am logged into the corporate domain and I have admin rights to the PC.
    • The virtual PC file was created on a win XP box and copied to my new drive.
    • I upgraded the integration features which ultimately requested login credentials. The credentials had my DOMAIN\username. I entered the correct information and from point on couldn't get past the next 'old school' login prompt.
    • I have it working just fine with the "enable integration features" turned off but as soon as I turn the "feature" on, I get a black screen with a standard login window that doesn't seem to go against the corporate "Active Directory" or my local PC user accounts.
    • I have updated the virtual PC to the latest win xp service pack 3 with all the fixes. The only thing I haven't installed is the .net 3.5 packages...
    • I do have XP mode installed with a different virtual disk working and updated. It works fine with integration turned on.

    Can I provide any other details to help track this down?

    Any advice is greatly appreciated.


    -Razor
    Wednesday, November 04, 2009 10:28 PM

Answers

  • I wanted to take a moment and report what I found on this issue. Perhaps it will help someone else.

    Nicholas has the right idea if you want your virtual PC's to have domain access. For your XP Mode version of the virtual disk that might be useful, but it really isn't needed. Any time you try to go to a protected network address within the company you usually are prompted for a login and password. If you have that, then you are good. Also, in my case I wanted the virtual pcs to be limited in what damage they could cause, meaning I did not want them to have my domain login and access.

    For me, since I have five total virtual pc disks (one being the XP mode default disk) what I didn't know at the time is that as soon as you install the latest integration software (into the virtual disk) the next login within the virtual disk - uses the login policies setup by your IT administration. In my case they have rules about password strength. My local logins for the virtual disks that I created long ago ranged from blank to very simple. Therefore any time I tried to login to the local user account I would get a not very clear login error. I also couldn't login to the domain because that PC (the virtual one) wasn't added to the domain as described by Nicholas (above).

    So as soon as I:

    1) temporarily disabled the integration features
    2) went into the virtual pc user accounts and made a strong password
    3) enabled the integration features

    I was then able to login to the local virtual pc user account and life was good!

    Thanks for your help Nicholas, you got me moving in the right direction.


    -Razor
    • Marked as answer by Occams razor Monday, November 09, 2009 4:11 PM
    Monday, November 09, 2009 4:11 PM

All replies

  • I apologize if this is in the wrong forum. Should this be moved into the Windows 7 virtualization forum? I had thought since my issue is with logging into the corporate domain (within the Microsoft virtual pc window) that I should post here.

    What do you think?

    -Razor
    Thursday, November 05, 2009 4:11 PM
  • Hi Razor,

     

    Based on our research, I would like to suggest the following

     

    1.    After joining domain, logon to XP Mode with the local administrator account.

    2.    Add the domain user account to the Administrators group:

     

    1)    In XP Mode, click Start, right click “My Computer” and select “Manage”.

    2)    In Computer Management, select “Local Users and Groups - Groups”.

    3)    Double click “Administrators” to open “Administrators Properties”.

    4)    In “Administrators Properties”, click Add and add the domain user’s account to this group.

    5)    Click OK continuously to apply the settings.

     

    3.    Then, log off this account and the logon the domain user account with Integration Features enabled.

     

    Hope this helps. Thanks.


    Nicholas Li - MSFT
    • Marked as answer by Occams razor Monday, November 09, 2009 4:11 PM
    • Unmarked as answer by Occams razor Monday, November 09, 2009 4:11 PM
    Friday, November 06, 2009 5:47 AM
  • I wanted to take a moment and report what I found on this issue. Perhaps it will help someone else.

    Nicholas has the right idea if you want your virtual PC's to have domain access. For your XP Mode version of the virtual disk that might be useful, but it really isn't needed. Any time you try to go to a protected network address within the company you usually are prompted for a login and password. If you have that, then you are good. Also, in my case I wanted the virtual pcs to be limited in what damage they could cause, meaning I did not want them to have my domain login and access.

    For me, since I have five total virtual pc disks (one being the XP mode default disk) what I didn't know at the time is that as soon as you install the latest integration software (into the virtual disk) the next login within the virtual disk - uses the login policies setup by your IT administration. In my case they have rules about password strength. My local logins for the virtual disks that I created long ago ranged from blank to very simple. Therefore any time I tried to login to the local user account I would get a not very clear login error. I also couldn't login to the domain because that PC (the virtual one) wasn't added to the domain as described by Nicholas (above).

    So as soon as I:

    1) temporarily disabled the integration features
    2) went into the virtual pc user accounts and made a strong password
    3) enabled the integration features

    I was then able to login to the local virtual pc user account and life was good!

    Thanks for your help Nicholas, you got me moving in the right direction.


    -Razor
    • Marked as answer by Occams razor Monday, November 09, 2009 4:11 PM
    Monday, November 09, 2009 4:11 PM
  • Hi Razor,

     

    I am glad to know this is resolved with your efforts.

     

    Thank you for sharing us your conclusion and steps about how to make it work. Hope this will also benefit other users who meet similar issues.

     

    In the future, if you need some help or if you have any feedbacks regarding our products, you are also welcome to post a new thread to our forum. It is always our pleasure to be of assistance.

     

    Thanks again! Have a nice day!


    Nicholas Li - MSFT
    Tuesday, November 10, 2009 3:08 AM
  • I have this exact issue and I also do not want to make VPC a domain user. I am using the IE Application Compatibility VPC Images. http://www.microsoft.com/en-us/download/details.aspx?id=11575

    I tried the steps the OP listed in setting a strong password, but that doesn't work for me. I did that, and still when I try to enabled the enhanced features I get a domain login window. I don't want these VMs to connect to the domain.

    I've used these images for many years outside of a domain, and they work fine. But now I'm stuck because they always try to use the domain login for enabling the enhanced features.

    How can I get Windows 7 to stop trying to use the domain login?

    TIA

    Friday, May 11, 2012 3:55 PM