none
Notification area icon "behavior" problem [with network and Action Center icons]

    Question

  • Went to Notification area icon control panel.  Selected ONLY SHOW NOTIFICATIONS, for the icon in system tray.  Clicked OK and exited control panel. However  icon still appears in system tray. Then did a warm boot. still no change.

    Next, i went back to the notification area icons control panel. I changed the behavior to SHOW ICON AND NOTIFICATION. [normally a tag pops up indicating that this behavior will take effect on the next bootup] However that tag did not appear. I clicked okay and then i again changed the behavior to ONLY SHOW NOTIFICATION.  still that popup message did not appear. 

    The  icon still appears on the system tray. While it is not bothersome to me, i still would like to fix it so i know that its working in case i want to change the behavior of a particular icon.

    Before my system froze and i was forced to do a warm boot, i always had the Network and Action Center icons set as ONLY SHOW NOTIFICATION and that is how i would like to have it.

    In addition. I  never had to uncheck the "always show all icons and notifications on the taskbar" for the behaviors to work as a selected. Even with that box checked AFTER MAKING ANY CHANGES, the icons that have the behavior selected as ONLY SHOW NOTIFICATION, worked properly and did not appear in the system tray ALL of the time, just when a notification occurred.

    Thank You


    JamieThompson

    Sunday, September 30, 2012 7:02 AM

All replies

  • Hi,

    Would you please let us know more details about the icon meet this issue, such as what is the program?

    Based on my understanding, I think the notification behavior may be also related to the application design, please check if it is the case.

    Notifications and the Notification Area

    http://msdn.microsoft.com/en-us/library/ee330740(VS.85).aspx

    In addition, if the issue persists, please also check this on another computer or another account.

    Thanks.

    Nicholas Li

    TechNet Community Support

    Tuesday, October 02, 2012 8:09 AM
    Moderator
  • Hello Nicholas:

    Thank you for replying.  The problem is occurring when i have the "notification area icons" portion of the Windows7 control panel open and it has to do with changing the "behavior" of the icon.  Previously, if i wanted to change an icons behavior, first i would untick the checkbox at the bottom that says Show all icons at all times, after that i would choose the behavior option i wanted and a little ballon popup note appeared for a few seconds, indicating that this option is not currently active at the moment but will become active the next time.

    Well, i decided to select the ACTION CENTER and NETWORK icons to "show icon and notifications".  That worked. However if i want to change the behaviors back to "only show notifications", i can select that BUT that little popup balloon doesnt appear, and the network & control panel icon still stay on the desktop.

    Is this problem occurring because the Network  & Control panel icons are "System" icons????  Like i said in my post, it doesn't bother me that much if these appear all the time. What bothers me is that i have "only show notifications" behavior selected for those icons ,in the control panel, and that is not responding correctly. So that is what needs to be fixed.

    Now i know about ticking the checkbox in the control panel that has ALL icons showing at all times.  Before making any changes to the behavior choices of icons, i would uncheck that box [of course i have to ,otherwise i cant make any changes], then after making the desired changes i would re check that box before exiting that control panel.
    And the icons with "show notification only" selected would not appear on the system tray ,and no overflow box or chevron symbol was visable either.

    So im wondering if something got corrupted. Any idea on how to proceed?. Any assistance would be appreciated.

    Thanks

    Jamie

    JamieThompson

    Tuesday, October 02, 2012 12:16 PM