none
File type will not associate

    Question

  • It associates fine on XP. However, when I installed Windows 7 it refuses to associate. I cannot figure out how to fix the problem.

    I have a shortcut to a .lbr file on my desktop
    I have a .exe in my program files\company name\program name

    I go to control panel->default programs->associate a file type or protocol with a program
    scroll down to .lbr and highlight it
    click change program...
    browse to the .exe
    double click the .exe

    The open with window only shows notepad and if I hit OK it associates with notepad. The program I just browsed and clicked on doesn't show up, nor is the associattion made.

    The program is just sits in its own directory. I believe it was developed without an installer. So, I can only assume associations do not work on 7 if programs didn't go through an entore install process. It is often you just have little executables that reside entirely in thier own directory that don't have installers.

    How to get this association working?



    Monday, November 16, 2009 3:35 PM

All replies

  • Hi Christopher,

    Try "OpenWithAdd"
    Registering programs with the "Open With" dialog:
    http://windowsxp.mvps.org/openwithadd.htm

    Ramesh Srinivasan, Microsoft MVP [Windows Desktop Experience]
    Wednesday, November 18, 2009 4:44 AM
  • You need to clear some info in your registry at classes root open with list


    HKEY_CLASSES_ROOT\.lbr

    and delete "user choice"
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.lbr\UserChoice

    Basically search the reg for .lbr and remove any old associations.
    Seesons greetings!
    Wednesday, November 18, 2009 5:43 AM
  • Hi,

    First, is there any issue when right click the file, choose "open with"-> "Choose default program"-> click browse..in the new window and choose the application you like. 

    If it is true that the association is corrupt, you can try the fix by running commond from CMD. Refer to http://www.ghacks.net/2007/09/22/how-to-fix-broken-file-associations/
    Wednesday, November 18, 2009 6:46 AM
  • You need to clear some info in your registry at classes root open with list


    HKEY_CLASSES_ROOT\.lbr

    and delete "user choice"
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.lbr\UserChoice

    Basically search the reg for .lbr and remove any old associations.
    Seesons greetings!

    Deleted everything in the registry when using find ".lbr"
    Does not fix the problem or change its symptoms.

    Wednesday, November 18, 2009 3:11 PM
  • Hi,

    First, is there any issue when right click the file, choose "open with"-> "Choose default program"-> click browse..in the new window and choose the application you like. 

    If it is true that the association is corrupt, you can try the fix by running commond from CMD. Refer to http://www.ghacks.net/2007/09/22/how-to-fix-broken-file-associations/

    Right clicking and choosing open with->browse has the exact same effect as the original post.
    Using the information in your link "Open the Windows command line and type the follwing ‘Assoc .ext’ replacing .ext with the file extension in question. It should display something like ‘.ext=name’."

    It displays: "File association not found for extension .lbr"

    Wednesday, November 18, 2009 3:15 PM
  • Hi Christopher,

    Try "OpenWithAdd"
    Registering programs with the "Open With" dialog:
    http://windowsxp.mvps.org/openwithadd.htm

    Ramesh Srinivasan, Microsoft MVP [Windows Desktop Experience]

    While this makes the .exe show up on the open with list. After it is opened and closed the file association was not made. It still opens with notepad thereafter.
    Even after trying to set the default program in control panel and after using open with again.
    Wednesday, November 18, 2009 3:26 PM

  • You might want to try brute force at the Command Prompt.  See FTYPE and ASSOC.

    (Type:   Help ftype   or   Help assoc   for instructions).


    If I type assoc .lbr=omnislib, I get "access is denied", which leads into my second windows 7 problem, which is even though I appear as an administrator in th users dialogs, I get access is denied left and right as if I was not an administrator.
    Wednesday, November 18, 2009 3:28 PM
  • Hi,

    First, is there any issue when right click the file, choose "open with"-> "Choose default program"-> click browse..in the new window and choose the application you like. 

    If it is true that the association is corrupt, you can try the fix by running commond from CMD. Refer to http://www.ghacks.net/2007/09/22/how-to-fix-broken-file-associations/

    Right clicking and choosing open with->browse has the exact same effect as the original post.
    Using the information in your link "Open the Windows command line and type the follwing ‘Assoc .ext’ replacing .ext with the file extension in question. It should display something like ‘.ext=name’."

    It displays: "File association not found for extension .lbr"


    Open the registry and find all of the entries that match the name of the program's .exe, also most important delete the entries from

    HKEY_LOCAL_MACHINE\SOFTWARE\example (software company's name)

    and

    HKEY_CURRENT_USER\Software\example (software company's name)

    Reinstall the program and you should be able to reassign the file extension.



    Seesons greetings!
    Wednesday, November 18, 2009 4:42 PM


  • The program is just sits in its own directory. I believe it was developed without an installer. So, I can only assume associations do not work on 7 if programs didn't go through an entore install process. It is often you just have little executables that reside entirely in thier own directory that don't have installers.



    I have nero burning rom which I removed from the bloat package on my win 7 without any installer or reg info just a folder in program files and it associates.



    Sounds easier just to reinstall the entire O/S.


    Go for it!




    Seesons greetings!
    Wednesday, November 18, 2009 7:33 PM

  • I get "access is denied" ...even though I appear as an administrator




    That would definitely pose a problem...  Does the .lbr entry still exist at all in the registry?  If so, check its permissions.  If not, maybe create the key?



    no, search registry for ".lbr" gets 0 results now.
    Thursday, November 19, 2009 12:25 AM
  • Hi,

    First, is there any issue when right click the file, choose "open with"-> "Choose default program"-> click browse..in the new window and choose the application you like. 

    If it is true that the association is corrupt, you can try the fix by running commond from CMD. Refer to http://www.ghacks.net/2007/09/22/how-to-fix-broken-file-associations/

    Right clicking and choosing open with->browse has the exact same effect as the original post.
    Using the information in your link "Open the Windows command line and type the follwing ‘Assoc .ext’ replacing .ext with the file extension in question. It should display something like ‘.ext=name’."

    It displays: "File association not found for extension .lbr"


    Open the registry and find all of the entries that match the name of the program's .exe, also most important delete the entries from

    HKEY_LOCAL_MACHINE\SOFTWARE\example (software company's name)

    and

    HKEY_CURRENT_USER\Software\example (software company's name)

    Reinstall the program and you should be able to reassign the file extension.



    Seesons greetings!

    Will try that tomorrow when back at work, thanks
    Thursday, November 19, 2009 12:26 AM

  • Sounds easier just to reinstall the entire O/S.


    Or perhaps to reinstall Vista instead, until SP1 for Win 7 comes out. I've had more problems than I care to deal with while trying to get work done on the box in question.
    Thursday, November 19, 2009 12:27 AM
  • Can you associate other file type?
    Would you mind telling us the .exe program?
    As you had Windows XP before Win7, I assume you did a clean install and reinstalled all the software.
    If the association works with other programs and files, I suggest reinstall the .exe program.

    Thursday, November 19, 2009 3:02 AM
  • I am having the same issue when dealing with .enw files that should open with the Endnote program (and worked fine when used in Windows XP). Although I have no new information for you on how to fix this, I want to let you know that you are not alone in this issue. I hope we can get this worked out soon. I tried all fixes posted above and my experience has been the same as the original poster. I hope this isn't a sign of the dis-functionality of windows 7.
    Tuesday, December 29, 2009 2:16 AM