none
Windows 7 How do I make a network printer available to all users on the same computer

    Question

  • I have a win 7 computer. Logged in with Admin rights I connected to a network printer. Logged in as a regular user that printer is not available nor can I figure out how to install it.

    1. How do I make an installed network printer available to all users on that computer?

    2. Barring that how do I install a printer when logged in as a regular user I can find the printer but the install fails with error 0x00000002 (come on Microsoft, I thought error numbers alone went out with Windows 95).

    I have NEVER been so frustrated in my life as trying to make Win 7 work the way I want.
    Friday, February 19, 2010 10:57 PM

Answers

  • Hello,

    To install the printer for all users, follow these steps:

    1. Click Start, click Control Panel and double click Devices and Printers.
    2. Click Add a Printer.
    3. Select "Add a local printer".
    4. Select "Create a new port". Choose "Local Port" as the type of the port.

    5. In the box "Enter a port name", type the address as the following format.

    \\ [IP address of the host computer]\[The Share Name of the printer]

    Then click Next.

    6. Choose the correct driver in the driver list. If no available driver, click the button Windows Update, wait for the process finishes and then look for the driver again.
    7. Shared this printer to all the users.
    8. Finish the installation.


    Thomas77
    • Marked as answer by Novak Wu Friday, February 26, 2010 2:56 AM
    Monday, February 22, 2010 6:59 AM

All replies

  • Hello,

    To install the printer for all users, follow these steps:

    1. Click Start, click Control Panel and double click Devices and Printers.
    2. Click Add a Printer.
    3. Select "Add a local printer".
    4. Select "Create a new port". Choose "Local Port" as the type of the port.

    5. In the box "Enter a port name", type the address as the following format.

    \\ [IP address of the host computer]\[The Share Name of the printer]

    Then click Next.

    6. Choose the correct driver in the driver list. If no available driver, click the button Windows Update, wait for the process finishes and then look for the driver again.
    7. Shared this printer to all the users.
    8. Finish the installation.


    Thomas77
    • Marked as answer by Novak Wu Friday, February 26, 2010 2:56 AM
    Monday, February 22, 2010 6:59 AM
  • Let me get this straight. It is not longer possible to select "Network Printer" and mak it shareable for all users?
    Tuesday, March 09, 2010 4:00 AM
  • Thomas,

       I have windows 7 64-bit and I followed your instructions above with 1 exception:  I used the host computer name instead of the IP address,  and successfully installed an HP laserjet 4350 printer.  After rebooting the computer the printer shows offline and the "Local Port" doesn't show up in the "Printer Properties" - "Port" tab?  If I try to add the port Windows tells me that the "Local Port"  already exists?

    I can set the printer up as a local IP printer but I would like my print jobs to be qued at the server and not set directly to the printer.

    Have you seen this before?  I have other computer labs where it is working fine with a "Local Port" configured with the \\servername\sharename.

     

    Wednesday, October 06, 2010 8:43 PM
  • Yeah, this sounds more complicated than it used to be. How is this an improvement?
    Thursday, October 28, 2010 10:13 PM
  • When I try this I get Access Denied.  How do I get past that?  I have made sure the Everyone has print rights on the shared printer.
    Friday, December 03, 2010 10:21 PM
  • The only way I got this to work past the Access denied part was by creating user accounts on the host machine that are the same accounts as the remote machine.

    Eg:  remote laptop - username: fred password: freddy

    so on host machine, accounted created with username: fred password freddy

    This then worked fine.

    Tuesday, January 04, 2011 3:39 PM

  • Access Denied may be one of two things in my experience... User Policy and/or LPT1.

    You can try this:
    Right Click My Computer - Manage
    Click Device Manager
    Click Ports
    Click LPT1
    Right Click Disable

    Start Run GPEdit.msc
    Computer Configuration -- Administrative Templates -- Printers
    Point and Print Restrictions -- Change To Disabled


    David D. Ditto, Jr. Managed Services / Junior Technician MCP, MCDST, N-Able Certified Administrator
    Tuesday, March 22, 2011 5:55 PM
  • The suggestion above seems to have gone wrong at this step:

    7. Shared this printer to all the users.

    Other than the typographical error, it doesn't make sense to share a shared printer on the same computer as if the local user was a remote user.

    What I am looking for is a way for the Administrator on system "A" to allow a user on system "A" to use a network printer configured by the Administrator on system "A".

    Otherwise, (it seems) I have to make the non-Administrator an Administrator in order to independently add a printer under that user ID.

    Oddly, one other printer on the network IS available, but maybe that's because it was configured as a network printer rather than a shared computer.

    Yes, this is way too difficult.  I'm an IT professional but I don't have a whole day to devote to something simple like granting print permissions to a non-Administrator.

     

     


    Wayne Erfling (aka Cornan The Iowan)
    Sunday, May 29, 2011 3:20 PM