none
CD or DVD won't autorun

    Question

  • I installed Windows 7 pro on my laptopand I have encountered a problem, I am not sure when it first started, if it started before or after SP1 was installed from the microsoft update site. I insert a cd or dvd, even a factory install disk, but nothing happens, I don't even get a message asking me what I would like to do. I have to run the setup program or access the disk through my computer, click the dvd drive and then I can run setup or do anything I need to do with the disk. I have searched the internet for answers, but no luck there, can someone here help me, this is the first time I have ever encountered this particular problem. I also need to add that this also happens when I use my thumb drive. THANKS.
    Thursday, April 28, 2011 5:13 AM

Answers

  • Hi,

     

    Try the following method to turn on autoplay:

     

    1.    Click Start and in the Search box, type gpedit.msc and press Enter, browse to Computer Configuration\ Administrative Templates\ Windows Components\ Autoplay Policies\ Turn off Autoplay.

    2.    Change the value of Turn off Autoplay to disabled.

     

    If this issue persists, I suggest you perform a Clean Boot to check how it works.

     

    Hope it helps.

     

    Alex Zhao


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, May 02, 2011 9:36 AM
    Moderator

All replies

  • Try Start\Control Panel\Programs\Default Programs and setting the auto play for the devices.

    Perhaps Start->Default Programs may be a way to get there also, depending on your installation.

    Thursday, April 28, 2011 11:13 AM
  • I did, box, checked, Use Autoplay for all media devices, below that, Media, everyone says, Ask me what to do.
    Friday, April 29, 2011 2:41 AM
  • Hi,

     

    Try the following method to turn on autoplay:

     

    1.    Click Start and in the Search box, type gpedit.msc and press Enter, browse to Computer Configuration\ Administrative Templates\ Windows Components\ Autoplay Policies\ Turn off Autoplay.

    2.    Change the value of Turn off Autoplay to disabled.

     

    If this issue persists, I suggest you perform a Clean Boot to check how it works.

     

    Hope it helps.

     

    Alex Zhao


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, May 02, 2011 9:36 AM
    Moderator
  • HI, Alex

    This is RFassbender Thank you for reply, I did just as you wrote, and that took care of it. Thanks again. Maybe some day I will be able to return the favor.

    Saturday, May 07, 2011 12:28 AM