none
How to hibernate Windows 7 ?

    Question

  • Running Win 7 in dual boot with XP sp3 on my desktop. In my city Electricity Supply is inconsistent so I simply hibernate my xp & switch off the ups before leaving. In Win 7 I have to shut it down everytime I leave for fear that electricity may go out in my absence. Apparently there is no Hibernation option in Win7,is there a way enable it? Please suggest.
    Irfan
    Monday, March 30, 2009 5:25 PM

Answers

  • The method to enable Hibernate in Windows 7 beta is the same as in Windows Vista. Run “cmd” as administrator, and enter the following command.

    powercfg –h on

    Then restart. You could change power settings related to Hibernate now.

    The following website can be referred.

    Hibernate - Enable or Disable - Windows 7 Forums 

    Important Note: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.


    Arthur Xie - MSFT
    Tuesday, March 31, 2009 5:41 AM
    Moderator
  • Hi Arthur, did run 'cmd' as adm and entered power -h on , this gave me 'hibernation' option in the power settings , by default its not there. After then"Change plan settings"- "Change advanced power settings"-pressed '+' sign next to sleep-and 'Hibernate After"-set to zero. Apply/OK. The problem is 'zero' always reverts back to 'Never'. Finally, I was able to do it, besides the above steps I had to disable 'Allow Hybrid Sleep' without touching any other button in the 'Change Advance Power Settings' so I guess all you guys including the ones at 'Hibernate-Enable or Disable-Windows 7 Forums' were only partly correct. Thanks for your assistance,you were closest to the solution 

    '   


    Irfan

    • Marked as answer by Irfanfare Thursday, April 02, 2009 5:24 PM
    • Unmarked as answer by Irfanfare Saturday, April 04, 2009 3:17 PM
    • Marked as answer by Irfanfare Sunday, April 05, 2009 12:06 PM
    Thursday, April 02, 2009 1:56 PM

All replies

  • Hi,
    Windows 7 and Vista have a function called hybrid sleep which puts the system to sleep first and then into hibernate. You can select the amount of time to wait to go into
    hibernate and set it to zero which will go to hibernate imediately.

    Go to the control panel and select Power Options.

    Then select "Change plan settings"

    Then select "Change advanced power settings"

    Press on the plus sign "+" next to sleep.

    Then select "Hibernate after" and it will probably say never.

    Press the mouse on never and set it to 0.

    Now whenyou select sleep, it will go to hibernate.

    Monday, March 30, 2009 7:23 PM
  • The method to enable Hibernate in Windows 7 beta is the same as in Windows Vista. Run “cmd” as administrator, and enter the following command.

    powercfg –h on

    Then restart. You could change power settings related to Hibernate now.

    The following website can be referred.

    Hibernate - Enable or Disable - Windows 7 Forums 

    Important Note: Microsoft provides third-party contact information to help you find technical support. This contact information may change without notice. Microsoft does not guarantee the accuracy of this third-party contact information.


    Arthur Xie - MSFT
    Tuesday, March 31, 2009 5:41 AM
    Moderator
  • Hi Arthur, did run 'cmd' as adm and entered power -h on , this gave me 'hibernation' option in the power settings , by default its not there. After then"Change plan settings"- "Change advanced power settings"-pressed '+' sign next to sleep-and 'Hibernate After"-set to zero. Apply/OK. The problem is 'zero' always reverts back to 'Never'. Finally, I was able to do it, besides the above steps I had to disable 'Allow Hybrid Sleep' without touching any other button in the 'Change Advance Power Settings' so I guess all you guys including the ones at 'Hibernate-Enable or Disable-Windows 7 Forums' were only partly correct. Thanks for your assistance,you were closest to the solution 

    '   


    Irfan

    • Marked as answer by Irfanfare Thursday, April 02, 2009 5:24 PM
    • Unmarked as answer by Irfanfare Saturday, April 04, 2009 3:17 PM
    • Marked as answer by Irfanfare Sunday, April 05, 2009 12:06 PM
    Thursday, April 02, 2009 1:56 PM
  • Thanks a lot Arthur it really worked I am so grateful

     

    Thursday, May 05, 2011 9:40 AM
  • Hi Irfan,

    Thank you for your post!

    I experience the same problem and you helped me to resolve it with disabling "Allow Hybrid Sleep".

    Nothing else was helpful for me in the forums.

    Cheers,

    eli

    Sunday, June 23, 2013 5:02 PM
  • check this video help. its work for my PC:
    http://www.youtube.com/watch?v=Ggf1UNKZuK4
    Friday, July 25, 2014 6:46 AM