none
Internet Explorer Closed Unexpectedly?

    Question

  • The first time Internet Explorer is opened after starting the system, it always displays a dialog box with two choices that reads:

    Your last browsing session closed unexpectedly
    * Restore your last session
    * Go to your home page

    After clicking either choice, IE works without a hitch.

    Actually, IE is never closed "unexpectedly". It is always closed by clicking on the X at the top right hand corner. What could be the cause of the spurious message?

    This is a clean install of W7RC Build 7100. The only add-on in my IE8 are those present after W7RC installation, plus Windows Live Sign-in Helper that was added by the installation of Windows Live Mail.

    Wednesday, May 13, 2009 11:18 AM

Answers

  • Jabez Gan:
    Thank you for the reply. Before I posted, the message occurred after every boot. After the post, it doesn't show up anymore. Task Manager is clean. How the issue fixed itself is a mystery to me: I did not make any changes, neither to the system nor to the applications. Many thanks again just the same.
    • Proposed as answer by dwoltersEditor Sunday, May 24, 2009 3:07 PM
    • Marked as answer by Nick FV Thursday, May 28, 2009 5:01 PM
    Thursday, May 14, 2009 8:00 PM

All replies

  • Hi Henry,

    Do a quick test: After closing IE by clicking on the red X, open up Task Manager, and select Process. From there, see if you can find IExplorer.exe from the list. If yes, then it shows that IE wasn't closed properly - Could be caused by an add on.

    In this case, try opening Internet Explorer (No Add-Ons) from Start -> Accessories -> System Tools, and see if this issue persists.

    Thanks.
    Jabez Gan [MVP] - http://www.msblog.org Contributing Author for: (Sybex) MCTS: Windows Server 2008 Applications Infrastructure Configuration Study Guide: Exam 70-643
    • Proposed as answer by mesques Tuesday, August 10, 2010 11:54 AM
    Wednesday, May 13, 2009 6:02 PM
    Answerer
  • Jabez Gan:
    Thank you for the reply. Before I posted, the message occurred after every boot. After the post, it doesn't show up anymore. Task Manager is clean. How the issue fixed itself is a mystery to me: I did not make any changes, neither to the system nor to the applications. Many thanks again just the same.
    • Proposed as answer by dwoltersEditor Sunday, May 24, 2009 3:07 PM
    • Marked as answer by Nick FV Thursday, May 28, 2009 5:01 PM
    Thursday, May 14, 2009 8:00 PM

  • "The first time Internet Explorer is opened after starting the system, it always displays a dialog box with two choices that reads:

    Your last browsing session closed unexpectedly
    * Restore your last session
    * Go to your home page

    After clicking either choice, IE works without a hitch.

    Actually, IE is never closed "unexpectedly". It is always closed by clicking on the X at the top right hand corner. What could be the cause of the spurious message?"




    Henry i had to copy your post because its exactly what i am having right now and for many days. Sure it's caused by some installed add-ons or what ever but its enoying anyway. i will fix it soon when i have time for and will post here again.

    • Proposed as answer by 197019741941 Wednesday, July 04, 2012 10:15 AM
    Sunday, May 24, 2009 9:15 AM
  • Henry I'm having the same issue and it's driving me nuts.  Also for some reason in addition to the annoying "Your last browing session...etc" box I can't log onto my igoogle home page... I say's "Redirecting" and it never connects. Once that happens I can't do anything.  This all happend today...

    Did you find out anything?   Nancy
    Wednesday, July 01, 2009 6:46 AM
  • Henry, I fixed both problems... I first figured out that I can open up my browser with no annoying message and no "Redirecting" by using the "No Add-On feature"

    Go to Start - All Programs - Accessories - System Tools - Internet Explorer (no add-ons) 

    After opening your browser this way (I have XP) and it works correct alls I did was un-install my google tool bar and then re-intalled it.  It kept my same setting.   The google tool bar has the add-ons and needed to be fixed.

    Good Luck, this took me 6 hours.   Nancy
    • Edited by illucy Wednesday, July 01, 2009 7:33 AM spelling
    Wednesday, July 01, 2009 7:32 AM
  • I too have the above issue but haven't been able to fix it.  This morning there were 11 sessions open and I had to close each one by itself.  My computer is set to install updates at 3am and it is always after the computer has rebooted.  Thank you in advance for any advice.
    Sunday, August 30, 2009 12:58 PM
  • To turn off the warnings.

     

    GPEdit.msc

    Administrative Templates - > Windows Components -> Internet Explorer

    Enable - Turn off Automatic Crash Recovery Prompt

     

    This also might be useful:

    Enable - Turn off Crash Detection

    • Proposed as answer by 197019741941 Wednesday, July 04, 2012 10:18 AM
    Wednesday, October 27, 2010 6:14 PM
  • IE8 still frequently forgets the full list of pages opend during the previous session. Had >15 open and only 1 was recovered after a forced quit using the feature.

    Sunday, December 26, 2010 2:59 AM