none
Windows 7 and NAS login problem

    Question

  • I'm sure this problem has been covered before since i have been searching for a solution for hours now and for the most part i get directed to the Microsoft forum. But the problem is, i have read so many forums and solutions and none have worked for me. so i have decided to post a question too in the hopes that a solution will be found.

    As a background i have always used windows XP, and when vista came out i tried it and didn't like it. so i still used XP as of a lot of people. When the windows 7 beta came out i was skeptical but from all the forums and reviews i have read and heard i decided to test it out at home with an extra PC. I was very happy with it and it seems that it handles memory and CPU usage better than my XP. So i decided to test it out on my PC at the office so that when the official OS is launched the company can easily migrate from using XP to the new windows 7. I have already installed it here at the office and i am actually using it now, with just one minor setback. We have a NAS here and altho i can see the drive when viewing the Netwrok i cant seem to log on to it.

    Systems and Equipment : I am using a core 2 duo PC with a 2Gb RAM running Windows 7 (7600). There are 7 computers here (all windows XP) connected to a switch connected to a Netgear RangeMax 240 wireless router (altho wireless all the computers are connected thru LAN) on the network there is a netwrok printer and a network storage device and all are in the same workgroup MSHOME. the NAS is a Raid+ Dual Bay NAS. I dont know what it uses, Samba, Linux? i'm not sure. but it has a simple program that if you log in thru the IP address you get directed to a webpage where you can create folders and users and assign which folders can be accessed by which users. Normally you can just double click the icon on the network and log in and you can now access your files freely. But under windows 7 everytime i double click the icon, it asks the username and password, but when i enter the details it re pops the window again and says wrong username or password. I have tried all the usernames and even created a new one and it just keeps poping up without letting me log in. thats when i started searching for solutions.

    Solutions tried and failed:
    1.  Restarted NAS and Computer - Nothing really happened
    2.  Reformated computer and reinstalled windows 7 - Still the same problem
    3.  disabled Anti Virus and firewalls - still the same problem
    4.  Changed options in Advance sharing Setting toggling the options on or off multiple cariations (turn on file sharing, turn on network discovery, turn off password protect, ect..) - still the same problem
    5.  Added user password to the windows 7 user, and had the same User and password on the NAS - Still the same problem
    6.  Tried the popular solution in the Network Security: LAN Manager authentication level - Send LM & NTLM - use NTLMv2 session security if negotiated. - This did get me out of the user name password loop but it ended up giving me a \\NASstoragename is not accessible  you may not have permission to use this network resource. and the error is either a network error (1208) or A Remote Procedure Call (RPC) protocol error. which i am currently stuck at.
    7.  Ive also tried mapping the drive and crating shortcuts both are found in the forums here but its not possible. Everytime i map the network drive and click on the drive same error occurs. even if i type in the location same error, that also includes the shortcut solution.

    Its a good thing that i can still access the NAS thru an FTP client or else i wouldn't be able to get my files from the NAS. Altho i can log in thru ftp which thankfully the NAS has built in, shouldn't windows 7 be able to access it seamlessly? even windows Vista has the ability to access our NAS so why cant windows 7 do it?

    I am looking for a solution soon, i wouldnt want to go back to XP anymore after using win7. its just a better overall experience. Hopefully this problem will be resolved before the official launch which is coming very soon.

    Thanks

    Thursday, September 03, 2009 7:04 AM

All replies

  • Hi Jekmyster,
    I've been having the exact same problems with an Addonics NAS Adaptor and Windows 7 RC (build 7100). I finally found the solution myself and have posted an explanation in my post; "Windows 7 RC (Build 7100) and Addonics NAS Device"
    http://social.technet.microsoft.com/Forums/en-CA/w7itpronetworking/thread/32976d2f-aae2-4caf-90db-4b2c27096885

    It turns out to be a problem with the default authentication methods used by Windows 7, that are not supported by the Linux based OS used on most NAS devices. I think you will resolve your problems if you follow the instructions in the above linked message.

    All the best,

    Jonathan R. Portwood.
    Technical Director,
    PQSA Services.
    "Assisting NGO's with IT Services."
    Friday, September 04, 2009 3:52 PM
  • Thanks JontyRp for the help, but tried the solution you have found but still wont work..
    All that happens now is that when i double click on the NAS icon a username/password windows pops up, but after i type it in, i get the

    "\\Storage is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permission.

    Network error (1208)."

    still no luck...
    Thursday, September 17, 2009 6:06 AM
  • Hi Jekmyster
    Did you ever figure this error out??
    Im having the same problem right now and holding off on upgrading all 3 of my computers to win7 until I can figure out how to access the NAS.

    thanks
    Thursday, January 14, 2010 1:34 AM
  • I'm sure this problem has been covered before since i have been searching for a solution for hours now and for the most part i get directed to the Microsoft forum. But the problem is, i have read so many forums and solutions and none have worked for me. so i have decided to post a question too in the hopes that a solution will be found.

    As a background i have always used windows XP, and when vista came out i tried it and didn't like it. so i still used XP as of a lot of people. When the windows 7 beta came out i was skeptical but from all the forums and reviews i have read and heard i decided to test it out at home with an extra PC. I was very happy with it and it seems that it handles memory and CPU usage better than my XP. So i decided to test it out on my PC at the office so that when the official OS is launched the company can easily migrate from using XP to the new windows 7. I have already installed it here at the office and i am actually using it now, with just one minor setback. We have a NAS here and altho i can see the drive when viewing the Netwrok i cant seem to log on to it.

    Systems and Equipment : I am using a core 2 duo PC with a 2Gb RAM running Windows 7 (7600). There are 7 computers here (all windows XP) connected to a switch connected to a Netgear RangeMax 240 wireless router (altho wireless all the computers are connected thru LAN) on the network there is a netwrok printer and a network storage device and all are in the same workgroup MSHOME. the NAS is a Raid+ Dual Bay NAS. I dont know what it uses, Samba, Linux? i'm not sure. but it has a simple program that if you log in thru the IP address you get directed to a webpage where you can create folders and users and assign which folders can be accessed by which users. Normally you can just double click the icon on the network and log in and you can now access your files freely. But under windows 7 everytime i double click the icon, it asks the username and password, but when i enter the details it re pops the window again and says wrong username or password. I have tried all the usernames and even created a new one and it just keeps poping up without letting me log in. thats when i started searching for solutions.

    Solutions tried and failed:
    1.  Restarted NAS and Computer - Nothing really happened
    2.  Reformated computer and reinstalled windows 7 - Still the same problem
    3.  disabled Anti Virus and firewalls - still the same problem
    4.  Changed options in Advance sharing Setting toggling the options on or off multiple cariations (turn on file sharing, turn on network discovery, turn off password protect, ect..) - still the same problem
    5.  Added user password to the windows 7 user, and had the same User and password on the NAS - Still the same problem
    6.  Tried the popular solution in the Network Security: LAN Manager authentication level - Send LM & NTLM - use NTLMv2 session security if negotiated. - This did get me out of the user name password loop but it ended up giving me a \\NASstoragename is not accessible  you may not have permission to use this network resource. and the error is either a network error (1208) or A Remote Procedure Call (RPC) protocol error. which i am currently stuck at.
    7.  Ive also tried mapping the drive and crating shortcuts both are found in the forums here but its not possible. Everytime i map the network drive and click on the drive same error occurs. even if i type in the location same error, that also includes the shortcut solution.

    Its a good thing that i can still access the NAS thru an FTP client or else i wouldn't be able to get my files from the NAS. Altho i can log in thru ftp which thankfully the NAS has built in, shouldn't windows 7 be able to access it seamlessly? even windows Vista has the ability to access our NAS so why cant windows 7 do it?

    I am looking for a solution soon, i wouldnt want to go back to XP anymore after using win7. its just a better overall experience. Hopefully this problem will be resolved before the official launch which is coming very soon.

    Thanks


    Any solution to this as yet, I have the exact same problem, would appreciate some sort of resolution. 

    Cheers
    Wednesday, January 20, 2010 3:17 PM
  • This has been answered here MANY times..
    You have not really given any info to work with
    So I ASSUME you do not have any networking background.

    click the start button and type secpol.msc in the search function.

    Browse to "Local Policies" -> "Security Options".  Now look for the entry "Network Security: LAN Manager authentication level" and open it.  Click on the dropdown menu and select "Send LM & NTLM - use NTLMv2 session security if negotiated".  Apply the settings.

    In the Advanced sharing settings page of Network and sharing center, you need to have it set as Work/Home profile.  Try

    Enable network discovery
    Turn on  file and print sharing
    Turn off password protected sharing
    Turn on Use user accounts and passwords to connect to other computers

    Wednesday, January 20, 2010 3:32 PM
  • This has been answered here MANY times..
    You have not really given any info to work with
    So I ASSUME you do not have any networking background.

    click the start button and type secpol.msc in the search function.

    Browse to "Local Policies" -> "Security Options".  Now look for the entry "Network Security: LAN Manager authentication level" and open it.  Click on the dropdown menu and select "Send LM & NTLM - use NTLMv2 session security if negotiated".  Apply the settings.

    In the Advanced sharing settings page of Network and sharing center, you need to have it set as Work/Home profile.  Try

    Enable network discovery
    Turn on  file and print sharing
    Turn off password protected sharing
    Turn on Use user accounts and passwords to connect to other computers


    Do you think I would be asking again if I had not already tried this?  Yes I have a networking background (CompTIA Netowrk + & CCNA), this is a Samba issue, but a workaround is not good enough.
    Monday, February 22, 2010 4:28 PM
  • Well update samba then
    Monday, February 22, 2010 7:22 PM
  • I connected my NAS to my new network card via crossover and Se7en found and mapped it with no issues. I hope this helps some one.

     

    Tuesday, June 08, 2010 5:39 AM
  • This worked for me: accessing the drive via the root folder names . Like:

    \\Iomega-n1\ADMIN

    \\Iomega-n1\PUBLIC

    Trying to access "\\Iomega-n1" results in the "\\IOMEGA-N1 is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions. Network error (1208)." error, even after changing the "LAN Manager authentication level" and  "Minimum session security" settings.

    (Suggestion found here: http://windows7forums.com/windows-7-networking/1669-cannot-access-nas-2.html )

     

     

    Monday, July 26, 2010 9:01 PM
  • You obviously didn't read the post you are replying to as most of these steps are covered!

    Yes this has been answered many times, but many times has fallen short of solving the issue in all cases. Just revisit all of the posts and note the comments after the answer has been given and the post has been marked as solved.

    The plain and simple fact is that you shouldn't have to map a network share to access it. The answers also don't differentiate between Home and Pro/Ultimate which sometimes have different solutions (Microsoft doesn't seem to want these guys talking to each other (If I have a laptop connected to a dhcp network at work, I then take it home I have to reconfigure the network to a Home Network before I can join a HomeGroup)).

    The answers are never 100% clear, never work in all cases and are often inappropriate (i.e. setting folder access on the NAS to 'everyone' or worse 'administrator').

    If Windows 7 can't handle devices that other versions of windows can, then it is hardly fit for purpose.

    • Proposed as answer by Sarthak5 Saturday, May 14, 2011 7:38 AM
    • Unproposed as answer by Sarthak5 Saturday, May 14, 2011 7:38 AM
    Wednesday, February 16, 2011 3:35 PM
  • Here is how I did for NAS: Coomax CN-590

    1. Go to Control Panel\System and Security\Administrative Tools, open "Local ecurity Policy\Local Policies\Security Options" and edit the value of "Network Security: LAN Manager Authentication Level" to "Send LM and NTLM responses"
    2. Create one account in the Windows 7, say userid = Sarthak and Password is left blank.
    3. Create one account in the Coomax CN-590 Samba server with the same userid = Sarthak and Password is left blank.
    ( I think instead of leaving it blank, you can have the same password in both places, I have not tested it though)
    4. Then browse the NAS down to a folder, such as my NAS is http://storage-2044/, but when I access it from the windows explorer, I browse a folder in it, such as \\storage-2044\public and it works (just \\storage-2044 does not work)
    Thanks.
    Saturday, May 14, 2011 7:39 AM
  • Hi

    I have DLINK DNS-323 NAS with the same problem and tried all the above proposed fixes but none worked for me. 

    The only band-aid solution I found is creating a batchfile with the following where 192.xx.xx.xx is the NAS IP followed by the hard drive volume name.

     "net use * \\192.168.1.111\Volume_1 /user:admin"

    Runing this "net Use" will prompt you to enter the NAS password and allows maping only one of the two NAS drives, but when I need access to the second drive I would need to disconect the volume 1 drive then run another batch file with Volume 2.

    I have given up with finding a permanent solution and have found this to be the best work around.

    CG

    Sunday, March 11, 2012 3:40 PM