none
Old DOS Game - Full Screen - Windows 7 Enterpise Virtual PC

    Question

  • I have an old DOS game that I would like to run Full Screen on a Windows XP Virtual PC under Windows Enterprise Build 7600 however I cannot get it to go to Full Screen mode. I also have 2 mouse pointers showing up when I try to run in the non full screen mode. If I install the Integration Features things get worse. In addition to getting an error message (The Video Device failed to initialize for full screen mode. Choose 'Close' to terminate the application) I am continually prompted to Log In whenever I try to do anything.

    The same old DOS game works perfectly in full screen mode on my Microsoft Virtual PC running under Windows Vista Ultimate 64bit system on the same triple boot box.

    # CPU: AMD Athlon(tm) 64 X2 Dual Core Processor 5200+
    # Motherboard: Asus
    M2NPV-VM

    # Memory: 4x Kingston 1GB 5400 (667mhz) DDR2
    # Video card: EVGA e-GeForce 9600 GT 512MB DDR3
    # Hard drives: 2x Seagate 320GB Sata2 + 2x WD 40GB IDE

    # Other devices: MSI TV@Anywhere Plus, 2X Asus 1814BL Lightscribe Sata 2 DVD burners
    # Operating systems: Windows Xp Pro, Windows Vista Ultimate 64bit SP2, Windows 7 Enterprise Build 7600

    Saturday, October 31, 2009 4:57 PM

Answers

All replies

  • A similar post - It seems XP Mode doesnt support 'Full Screen' - Not sure why this restriction has been imposed.

    http://social.technet.microsoft.com/Forums/en-US/w7itprovirt/thread/642a1cd8-082f-4a88-ac0a-b479017af6f3


    C# Fan! ananda84(at)gmail(dot)com
    Monday, November 02, 2009 7:08 AM
  • Please let us know if you have gone through the post provided in the above reply and if it has answered

    your question.

     

    Link:

     http://social.technet.microsoft.com/Forums/en-US/w7itprovirt/thread/642a1cd8-082f-4a88-ac0a-b479017af6f3

     

    Veeresh

    • Proposed as answer by Veeresh-H Monday, November 09, 2009 6:30 PM
    Monday, November 02, 2009 9:43 PM
  • Hi,

     

    I have the same problem: I can not have the full screen when I run an application with .EXE extension.

     

    The Windows XP mode is in full screen.

    I put the icon of the .EXE application on the desk of Windows XP mode. In the properties of the icon (obtained by right click) in monitor tab, I put Full Screen.

    But when I run the application, it appears in a small windows inside the Windows XP mode.

     

    It is the same if I put a Command Prompt icon and in option tab I choose Full Screen. I have also a small windows.


    I do as written in the link : 

    http://social.technet.microsoft.com/Forums/en-US/w7itprovirt/thread/642a1cd8-082f-4a88-ac0a-b479017af6f3


    If I have "integration features", I have a small windows inside the Windows XP mode desktop.

     

    If I have not integration features", the application appears in the whole Windows XP mode but it is the Windows XP mode which is in a small windows and not in full screen and it is not possible to maximize it.

     

    It is the same with the Command Prompt icon. It is easy to test with the Command Prompt icon.

    In this case, if you enter  EXIT then you come back in Windows XP mode but now in a windows and it is possible to maximize it.


    Thanks for your help.

     

    Dominique

    Sunday, November 15, 2009 10:09 PM
  • WDDM (Vista/win7) graphics drivers are unable to run DOS or 16-bit programs in fullscreen anymore since the new driver model is incapable of doing so.

    See the link below for details:
    http://support.microsoft.com/default.aspx/kb/926657

    - JoelbX
    JoelbX's favorite threads | Contact me | 'Gadget' programs: Visit websites
    • Proposed as answer by JoelbX Sunday, November 15, 2009 10:18 PM
    • Edited by JoelbX Tuesday, February 02, 2010 6:27 PM edit sig
    Sunday, November 15, 2009 10:18 PM
  • All rights but your link is for Vista.

     

    If I understand everything, Windows 7 is supposed to correct the problems of Vista.

     

    Now in Windows 7, there is a Windows XP mode which do not exist in Vista. It is necessary that we can do the same than we do with Windows XP.

    With Windows XP, I can run Dos based programs and Command prompt without problems in full screen.

     

    I think that it is normal that I can do the same with Windows 7.

    Monday, November 16, 2009 7:33 AM
  • All rights but your link is for Vista.

     

    If I understand everything, Windows 7 is supposed to correct the problems of Vista.

     

    Now in Windows 7, there is a Windows XP mode which do not exist in Vista. It is necessary that we can do the same than we do with Windows XP.

    With Windows XP, I can run Dos based programs and Command prompt without problems in full screen.

     

    I think that it is normal that I can do the same with Windows 7.

    Win7 uses the same graphics drivers as Vista so the article still applies to win7.

    With a virtual machine running XP (aka XP mode) it still is up to the host OS (win7) to get the info from the guest OS (XP) onto the screen, and Vista and win7 is incapable of running these old programs with the new graphics drivers.

    - JoelbX
    JoelbX's favorite threads | Contact me | 'Gadget' programs: Visit websites
    • Edited by JoelbX Tuesday, February 02, 2010 6:28 PM edit sig
    Monday, November 16, 2009 3:23 PM
  • I encoutered this issue as well; it appears Vista's graphics driver doesn't support full-screen mode. However, I got around this after reading several forums by:

    1. Changed the driver in Vista to standard VGA (accessed on display adapters properties "driver" pane through the Update Driver button. This will permit full screen mode on the computer, but lose some of the bling associated with Vista's Aero driver. One forum entry I saw said this may not work on all machines, but it did on mine.

    2. Set up Virtual PC 2007 on the Vista machine.

    3. Create a client Windows O.S. (not DOS!) compatible with running DOS applications. I installed Win 2k Pro.

    4. Now run your DOS program/game under the Win 2K client, or whatever you installed by setting up a shortcut to it with the following properties: Under the Program tab - Run = Maximized, Under Screen Tab - Usage = Window. (Don't try it with Full-screen it will lock up, but keep reading for the finale)

    5. Your DOS program should start up successfully in a window inside the Win 2K client. To view it full screen, click the upper left corner icon, go to Properties, set the Display Options to Full Screen, Click OK, and leave it as "Apply to current window only". Again, don't try to save it for future windows - it will cause it to lock up next time it is run if you do, but this procedure seems to work for me, and now your application should be in full screen mode.

    • Proposed as answer by Gator Engineer Tuesday, February 02, 2010 5:37 PM
    Tuesday, February 02, 2010 5:36 PM
  • Install DOSBox (http://www.dosbox.com/) to run old DOS games in Fullscreen.
    "A programmer is just a tool which converts caffeine into code" CLIP- Stellvertreter http://www.winvistaside.de/
    Tuesday, February 02, 2010 10:49 PM