none
How to make Win7 handle eight GPUs properly ?

    Question

  • Hi,

    Hardware part of the system consists of TYAN FT72B7015 barebone, two Xeon 5690 CPUs, 144 GB of RAM and 8 Zotac GTX 580 cards with 3GB of RAM each. This system used to work under XP64 without any problems and issues, however, system does not work under Win7 64 Ultimate (original question can be found here).

    After a number of experiments I have localized the problem: system works just fine when only seven (not eight) GTX 580 cards are installed, however, as soon as the eighth card is installed OS starts to work very slow (extremely slow visualization of even simple windows GUI, all applications that use CUDA technology work very slow, FurMark test works slow and jumpy). It all happens with latest official Nvidia drivers (285.62).

    I have an impression that this happens due to the lack of resources that OS distributes among various installed devices. Good experience with XP64 as well as a number of examples of successfull FT72 + GTX 580 based builds makes me think that configuration with 8 GTX 580 cards can also be handled by Win7 properly.

    What must be done in order to make such a configuration work fine under Win7 64 Ultimate ?

    Thanks in advance.

    Sunday, February 19, 2012 9:48 PM

Answers

  • Solution is found, thanks to Tyan support. It is a bug in Win7, system has problems related to RAM counting.

    Say, there are 72 gigabytes of RAM installed.

    1. Run "msconfig"
    2. Click "boot" tab
    3. Click "advanced" option
    4. Check the "max memory" box, the max memory field will automatically put "73728" (72GB)
    5. Enter "72704" and apply the changes, restart the system, the system will run at what appears to be normal speed

    The key basically is to change the max memory from whatever it shows to 1GB less than what it shows (subtract 1024).
    This will insure proper operation of the system regardless of the total amount of memory installed.

    Wednesday, February 22, 2012 8:07 AM

All replies

  • Hi,

    I think the issue is more hardware or driver related than system. It is recommended that you contact NVIDIA for help:

    NVIDIA Support

    http://www.nvidia.com/page/support.html

    Thanks.

    Monday, February 20, 2012 10:05 AM
  • Solution is found, thanks to Tyan support. It is a bug in Win7, system has problems related to RAM counting.

    Say, there are 72 gigabytes of RAM installed.

    1. Run "msconfig"
    2. Click "boot" tab
    3. Click "advanced" option
    4. Check the "max memory" box, the max memory field will automatically put "73728" (72GB)
    5. Enter "72704" and apply the changes, restart the system, the system will run at what appears to be normal speed

    The key basically is to change the max memory from whatever it shows to 1GB less than what it shows (subtract 1024).
    This will insure proper operation of the system regardless of the total amount of memory installed.

    Wednesday, February 22, 2012 8:07 AM