none
remote desktop won't return to full screen

    Question

  • Hi there,

    I'm using Windows 7 Home Premium x64.
    I have an issue with Remote Desktop Connection program.

    What happen is, I can start it up with full screen no problem.
    But when I click on the "restore down" button so I can re-size it temporarily, it won't return to full screen when I click on the "maximize" button.

    What it does instead is it make the window as large as possible covering the entire screen like when you open up internet explorer, still with the 3 "minimize", "restore down", "close" button at the top-right.
    Not a full screen as I initially start with.

    How do I make it return to full screen?

    Tuesday, May 04, 2010 9:44 AM

Answers

  • found it in some forums.

    there's some kind of a "bug" with certain resolution that cause it to refuse full screen.

    the only way to force it back to full screen mode is by pressing Ctrl+Alt+Break

    • Marked as answer by p.andrew Thursday, May 13, 2010 12:35 AM
    Thursday, May 13, 2010 12:35 AM
  • Change the color deep of the display tab to anything below Highest Color ( 32 bit ). This will solve the problem and you will be able to switch from window to fullscreen or fullscreen to window.


    If it doesn't work, change your screen resolution from 1366x768 to 1360x768 or below, this will solve the problem.

    • Marked as answer by p.andrew Tuesday, March 20, 2012 11:32 AM
    Tuesday, March 20, 2012 11:24 AM
  • I spoke too soon...there is a hotfix for this issue http://support.microsoft.com/kb/2582172. I just tested it on one laptop and it seems to be working. 
    • Proposed as answer by yehuda1 Tuesday, April 03, 2012 5:16 PM
    • Marked as answer by p.andrew Wednesday, April 04, 2012 9:58 AM
    Tuesday, April 03, 2012 4:51 PM

All replies

  • found it in some forums.

    there's some kind of a "bug" with certain resolution that cause it to refuse full screen.

    the only way to force it back to full screen mode is by pressing Ctrl+Alt+Break

    • Marked as answer by p.andrew Thursday, May 13, 2010 12:35 AM
    Thursday, May 13, 2010 12:35 AM
  • Thank you, p.andrew!  I just hate the interruption it was causing while trying to get work done, so a workaround was all I needed.  Thanks again.

    Sunday, June 06, 2010 3:26 PM
  • thanks a lot p.andrew. 
    Sunday, June 27, 2010 10:22 AM
  • Found in this thread:

     

    http://social.technet.microsoft.com/Forums/bg-BG/w7itproinstall/thread/04717e71-b365-4ffb-9155-ee2670831175?prof=required

     

    -Start "Remote Desktop Connection".
    -Click on "Options".
    -Click on the "Display" tab.
    -On "Display configuation" settings, you can change the "Remote Desktop Connection" display by moving the slider from "Small to Large".
    -By moving the "Slider" all the way to large, the display settings will automatically set to "Full Screen".

    • Proposed as answer by Mysterchr Friday, March 23, 2012 5:36 PM
    • Unproposed as answer by p.andrew Wednesday, April 04, 2012 1:03 PM
    Monday, January 17, 2011 6:46 PM
  • Same issue here on a Win 7 desktop running at 1366x768. I hope Microsoft provides a fix soon. I see no reason a minor bug like this would not be fixed in years.

    Sunday, February 19, 2012 7:03 PM
  • Change the color deep of the display tab to anything below Highest Color ( 32 bit ). This will solve the problem and you will be able to switch from window to fullscreen or fullscreen to window.

    • Proposed as answer by stevenkho Tuesday, March 20, 2012 11:12 AM
    • Unproposed as answer by p.andrew Tuesday, March 20, 2012 11:18 AM
    Tuesday, March 20, 2012 11:11 AM
  • Change the color deep of the display tab to anything below Highest Color ( 32 bit ). This will solve the problem and you will be able to switch from window to fullscreen or fullscreen to window.


    If it doesn't work, change your screen resolution from 1366x768 to 1360x768 or below, this will solve the problem.

    • Marked as answer by p.andrew Tuesday, March 20, 2012 11:32 AM
    Tuesday, March 20, 2012 11:24 AM
  • wow, didn't realized this thread still alive!

    @dogfight
    that only works on initial connection.
    Problem arises when you restore the windows size (from maximize to restore and vice-versa).

    @stevenkho
    The Color Depth settings seems to have no influence at all.
    Changing the resolution as suggested seems the only fix for now.

    While on 1366x768, changing the color depth even as low as 15 bit still not doing it.

    it seems the only fix (for a laptop / wide screen 1366x768 resolution at least) is by pressing Ctrl+Alt+Break


    Andrew P.


    • Edited by p.andrew Tuesday, March 20, 2012 11:31 AM updated due to new reply
    Tuesday, March 20, 2012 11:24 AM
  • @stevenkho

    The Color Depth settings seems to have no influence at all.
    Changing the resolution as suggested seems the only fix for now.

    Same experience here. We use up-scaled 1360x768 resolution for now, and still look forward to a solution.

    Friday, March 23, 2012 2:41 AM
  • The problem has been bugging me for a few years on two different laptops with 1366x768 resolution. Ctrl+Alt+Break would be okay except neither of my laptops has a Break key. Changing to a custom resolution like 1360x768 seems to be a workaround but the downside is that the display now looks considerably worse since it's a non-native resolution. 

    This is obviously a Windows bug that has been around for a while. Would be awesome if Microsoft would provide a fix.

    Tuesday, April 03, 2012 4:40 PM
  • I spoke too soon...there is a hotfix for this issue http://support.microsoft.com/kb/2582172. I just tested it on one laptop and it seems to be working. 
    • Proposed as answer by yehuda1 Tuesday, April 03, 2012 5:16 PM
    • Marked as answer by p.andrew Wednesday, April 04, 2012 9:58 AM
    Tuesday, April 03, 2012 4:51 PM
  • Awesome, thanks for sharing.

    Tuesday, April 03, 2012 5:17 PM
  • thanks socalit!

    It's strange why MS didn't include this as part of windows automatic update!
    anyone knows anything about this?


    Andrew P.

    Wednesday, April 04, 2012 10:01 AM
  • Maybe it is scheduled for SP2?
    Wednesday, April 04, 2012 12:44 PM
  • Just speaking my (sometimes paranoid) thought out loud ...

    Maybe the hotfix got some "hidden" side effect(s), which is why MS didn't push this out to everyone as part your regular automatic updates. Moreover, the 1366x768 resolution is awfully common with 16" laptop for a long time so this has been a known issue as well.
    But hey! At least they got a fix :)

    For those who applied the hotfix as suggested by socalit, let us know if you got any side effect.


    Andrew P.

    Wednesday, April 04, 2012 1:06 PM
  • I have a solution,

    How To Return Remote Desktop View To Full Screen

    just make sure you can see the hidden files on your Windows 7 PC, i guess you know how to do that,

    Close any Remote Desktop connection that is running.

    Go to your Documents (Start - Documents)

    Find this file, Default... (this file will be hidden)

    Delete that file, and then start remote desktop connection now.

    Hope you will find this working for you.

    Thank you,


    • Edited by bench3 Wednesday, April 04, 2012 2:10 PM
    Wednesday, April 04, 2012 2:02 PM
  • thanks for contributing, bench3.

    that method is essentially deleting the current remote desktop settings so when you start rdc again after deleting that file, it will re-create that file with the default settings: full screen display on start of rdc.

    unless you deleting the file every time you re-size the rdc display, the issue will persist for people who use 1366x768 resolution.


    Andrew P.

    Wednesday, April 04, 2012 2:26 PM
  • Thanks Andrew.

    BTW my laptop didn't had break but Ctrl+Alt+Pause worked for me.

    Tuesday, February 19, 2013 11:56 AM
  • Worked for me - thanks so much
    Monday, September 23, 2013 3:25 PM
  • Thank Q
    Wednesday, December 11, 2013 5:15 AM