none
WMP 12 - Windows Media Player encountered a problem while playing the file (C00D11B1)

    Question

  • Hello,

    I am having difficulty playing the majority of .avi files in WMP 12. Upon opening the video I get the error "Windows Media Player encountered a problem while playing the file". When I click the web help link, this is what the site says:

     

    Windows Media Player C00D11B1
    
    Windows Media Player can't play the file.
    
    Things to try: 
    
    •Use Windows Update, or go to the sound device manufacturer's website to see if an updated driver is available. 
    
    •Use Device Manager to check the status of your sound device.
    
     To check the status of your sound device 
    
    Click Start, right-click Computer, and then click Manage.
    In the left pane, click Device Manager.
    In the right pane, expand Sound, video and game controllers, and then look for the name of your sound device.
    Do one of the following:
    If your sound device is listed but the icon includes a red "X," the device has been disabled. To enable the device, right-click the icon, and then click Enable.
    If your sound device isn't listed, in the right pane, expand Other devices. If Multimedia Audio Controller appears in the list, right-click the icon, and then click Update Driver Software. Follow the on-screen instructions to find and install the driver software.
    If you aren't able to find and install the correct driver software, go to your computer manufacturer's or sound device manufacturer's website for further assistance.
    
    •If you don't have a sound device installed on your computer, install a sound device, and then try to play the file again. For details, go to your computer manufacturer's or sound device manufacturer's website.
    
    •If you're trying to play a file on the Internet, try again later. The server might be temporarily unavailable or there might be a network issue.
    
    •If you're trying to play an MP3 file that contains compressed ID3 headers, make a copy of the file, and then use a non-Microsoft ID3 tag-editing program to remove or reset the file's ID3 headers. 
    
    The ID3 header is a portion of the file that stores the song's album information (for example, the song name, artist name, album name, and genre). This information is sometimes called a tag. After you remove the ID3 headers, Windows Media Player should be able to play the MP3 file.
    
    Warning
    Attempting to remove ID3 headers might damage the file and make it unplayable. Therefore, always make a copy of the file before you edit it.
    

     

    Upon looking in device management there are no errors pertaining to my sound card/devices. If I try to update the driver it tells me that I am already running the best driver.  I have looked around on Google and have come across no solutions that have helped me fix this error. What is weird is that WMP will play about two or three of the .AVIs out of the folder they are in, but will throw the error message on the rest of them. I have the K-LITE codec pack installed.

     

    Wednesday, May 26, 2010 5:12 PM

Answers

  • Hi,

    I would like to suggest the following solutions:

     

    Step 1: Please read:

     

    Windows Media Player C00D11B1

     

    Step 2: Reset the Windows Media Player.

    Step 3: Disabling enhancements in Sound option.

    Go to Control Panel > Sound> Select Speakers and Properties > Click on Enhancements tab > Disable all the enhancements > Click Apply.

    Step 4: Changing the Registry value:

    Note: You must be logged on as an administrator to perform these steps. If you aren't logged in as an administrator, you can only change settings that apply to your user account. Before you make changes to a registry key or subkey, we recommend that you export, or make a backup copy, of the key or subkey. You can save the backup copy to a location you specify, such as a folder on your hard disk or a removable storage device. If you make changes that you want to undo, you can import the backup copy.

     

    1)    Click Start and type: regedit in the Search box.

    2)    Open the Registry Editor and navigate to the following path:

     

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Audio

     

    3)    Create the following new entry:

     

    Name: DisableProtectedAudioDG

    Type:  REG_DWORD

    Value: 0

     

    4)    Restart the computer and play the media file again.

     

    Best Regards

    Dale

     

    Thursday, May 27, 2010 3:37 AM
    Moderator

All replies

  • Hi,

    I would like to suggest the following solutions:

     

    Step 1: Please read:

     

    Windows Media Player C00D11B1

     

    Step 2: Reset the Windows Media Player.

    Step 3: Disabling enhancements in Sound option.

    Go to Control Panel > Sound> Select Speakers and Properties > Click on Enhancements tab > Disable all the enhancements > Click Apply.

    Step 4: Changing the Registry value:

    Note: You must be logged on as an administrator to perform these steps. If you aren't logged in as an administrator, you can only change settings that apply to your user account. Before you make changes to a registry key or subkey, we recommend that you export, or make a backup copy, of the key or subkey. You can save the backup copy to a location you specify, such as a folder on your hard disk or a removable storage device. If you make changes that you want to undo, you can import the backup copy.

     

    1)    Click Start and type: regedit in the Search box.

    2)    Open the Registry Editor and navigate to the following path:

     

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Audio

     

    3)    Create the following new entry:

     

    Name: DisableProtectedAudioDG

    Type:  REG_DWORD

    Value: 0

     

    4)    Restart the computer and play the media file again.

     

    Best Regards

    Dale

     

    Thursday, May 27, 2010 3:37 AM
    Moderator
  • Thanks Dale!

    I was not able to play audio nor video files but Windows sounds were working. Disabling enhancements in sound option did it for me.

    Regards,

    Andres

    Monday, February 21, 2011 11:57 PM
  • I have the same problem...I'm running Windows Media Player 12 and try to disable all enhancements as well as entered the registry but still get the same error.

     

    Any ideas?

    Thursday, September 22, 2011 2:35 AM
  • H_L: is this also when playing AVI files? Do you get the same error for the sample AVI file at http://support.microsoft.com/kb/316992 ?
    Tim De Baets
    http://www.bm-productions.tk
    Friday, September 23, 2011 7:41 PM
  • Wow!  Thanks for this advice!  I have been having the same problem since I got this computer months ago and you just fixed it :)
    Tuesday, January 24, 2012 4:08 AM
  • Dale your a genius! I tried hundreds of different ways to try to get my media player to work and by following your instructions its finally working! not only that but my itunes wasn't working with the same problem and thanks to you thats working too! thank you very much!
    Tuesday, December 18, 2012 11:52 PM
  • wonderful! thanks thanks thanks thanks a lot
    Sunday, December 01, 2013 6:38 PM