none
Task Bar network icon Show "Yellow Tringle" and show " No Internet conncetion"

    Question

  • I use Windows 7 . I connect to the internet In Huawei E156G Modem with static IP . My internet connection is OK, everything works, but there is a yellow triangle in the connection icon in tray (Task bar) . If I put the cursor over it, I can read: " No internet access" if i click that icon and go to its status i can see " IPv4 and IPv6 Connectivity : No internet connection"
    Then i go to "Network and sharing center i can again see no internet connection. I setup my Broadband connection as a "Public connection" If i start Windows network Diagnostic wizard for detect error it also can't detect error.
    Tuesday, July 27, 2010 2:15 PM

Answers

  • The following article explains How does Network Connectivity Status Indicator (NCSI) work.

    Appendix K: Network Connectivity Status Indicator and Resulting Internet Communication in Windows Vista

    Please change the Registry branch HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet. If the key EnableActiveProbing exists and its value is 0, that may be the problem.

    Another possible cause is your firewall or antivirus blocks the reverted data from http://www.msftncsi.com. Please temporary disable them and check the result. Do you connect to Internet via a router? If so please also disable the firewall in the router.

    If the above suggestions do not help, please let us know if there is any other computer in that network and whether they have same issues. If you can take your computer to another network, please let us know if it works. Because the firewall on your Internet Service Provider side may also cause this issue.

    The last possible reasons is that the NCSI service or Network Location Awareness Service (NLA) service is corrupt. In this case I suggest you do In-place Upgrade to repair the system. If the issue occurs even in other networks, you may consider to repair your system.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Thursday, July 29, 2010 8:03 AM
  • The default value of HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet\EnableActiveProbing is 1. It is for that I don't think it is the cause of your connectivity problem. It is used to collect network connectivity information and makes it available through an application programming interface (API) to services and applications on a computer running Windows 7.

    This is a link that will explain you more the rule of this register entry:

    http://technet.microsoft.com/en-us/library/cc766017%28WS.10%29.aspx

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Best regards.

    Friday, July 30, 2010 7:19 AM

All replies

  • Try to disable the IPv6 addressing and check if the problem is persisting.

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Best regards.

    Tuesday, July 27, 2010 2:33 PM
  • It's not work!
    Please Give your Answer in "Simple English""!
    Thursday, July 29, 2010 3:58 AM
  • The following article explains How does Network Connectivity Status Indicator (NCSI) work.

    Appendix K: Network Connectivity Status Indicator and Resulting Internet Communication in Windows Vista

    Please change the Registry branch HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet. If the key EnableActiveProbing exists and its value is 0, that may be the problem.

    Another possible cause is your firewall or antivirus blocks the reverted data from http://www.msftncsi.com. Please temporary disable them and check the result. Do you connect to Internet via a router? If so please also disable the firewall in the router.

    If the above suggestions do not help, please let us know if there is any other computer in that network and whether they have same issues. If you can take your computer to another network, please let us know if it works. Because the firewall on your Internet Service Provider side may also cause this issue.

    The last possible reasons is that the NCSI service or Network Location Awareness Service (NLA) service is corrupt. In this case I suggest you do In-place Upgrade to repair the system. If the issue occurs even in other networks, you may consider to repair your system.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Thursday, July 29, 2010 8:03 AM
  • My PC currently IPv6 Disabled so i want try enable it. Please tell me how do i enable IPv6 in  windows7. Then i think it will be ok

    Please Give your Answer in "Simple English""!
    Friday, July 30, 2010 6:52 AM
  • my PC registry "HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet\EnableActiveProbing" key value is 1. Should i change it to"0"

     

    I use Huawei E156G HSDPA modem.


    Please Give your Answer in "Simple English""!
    Friday, July 30, 2010 6:57 AM
  • Follow these steps to enable IPv6:

    1. Right click on the network icon

    2.select Open the Network and Sharing Center.

    3. In the resulting window, select "Change adapter settings".

    4. In the Network Connections window, select the "Local Area Connection" for the onboard NIC (or whatever it's called), then "Change settings of this connection" or file>properties.

    5. In the connection property page, check the box for "Internet Protocol Version 6 (TCP/IPv6)

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Best regards.

    Friday, July 30, 2010 7:14 AM
  • The default value of HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NlaSvc\Parameters\Internet\EnableActiveProbing is 1. It is for that I don't think it is the cause of your connectivity problem. It is used to collect network connectivity information and makes it available through an application programming interface (API) to services and applications on a computer running Windows 7.

    This is a link that will explain you more the rule of this register entry:

    http://technet.microsoft.com/en-us/library/cc766017%28WS.10%29.aspx

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Best regards.

    Friday, July 30, 2010 7:19 AM