none
Keeping Dial up connections up after logoff

    Question

  • In Windows XP, there was a way that a RAS connection could be kept up by adding the KeepRasConnections key.   I tried it on Windows XP and it worked perfectly.   As per document KB950918, this should work for Windows 7.  I tried that on Windows 7, but that did not work.  Am I missing anything?
    Friday, March 18, 2011 7:31 PM

Answers

  • Hi,

     

    As this thread has been quiet for a while, we assume that the issue has been resolved. At this time, we will mark it as ‘Answered’ as the previous steps should be helpful for many similar scenarios. If the issue still persists, please feel free to  reply this post directly so we will be notified to follow it up. You can also choose to unmark the answer as you wish.

     

    BTW,  we’d love to hear your feedback about the solution. By sharing your experience you can help other community members facing similar problems. Thanks for your understanding and efforts.

     

    Regards,

    Leo   Huang

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, April 04, 2011 12:56 AM
    Moderator

All replies

  • This Link may help you too...

    --Harjit

     

    Saturday, March 19, 2011 2:30 AM
  • Hi,

     

    Like EvenWin replied, please go to  Device Manager---Network adapters, right click your network card and click “properties”, go to Power Management tab and remove the option “Allow the computer to turn off this device to save power”

     

    In addition, not all KB work on Windows Vista will still work on Windows 7.

     

    Thank you for your understanding.

     

    Regards, 

    Leo   Huang

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, March 21, 2011 8:41 AM
    Moderator
  • This is not what I am asking for this.  Essentially, I am trying to keep the a RAS connection on even after logoff.  There was a key in Windows XP that you could edit to make this work, but does not work in Windows 7.   I tried the recommendation KB950918, but that did not work.  This is does not have anything to do with sleep mode.
    Monday, March 21, 2011 3:06 PM
  • Hi,

     

    You need not  to use this KB, because Windows 7 have already installed this hotfix, the value of registry key “KeepRasConnections” exist and  set to 0 by default.

     

    Please kindly give me about more information about your workaround and what problem you have met.

     

    Thank you for your cooperation.

     

    Regards,

    Leo   Huang

     

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, March 22, 2011 8:04 AM
    Moderator
  • I don't have a work around.  I have tried that key, but it does not seem to work.  Do you know of a way of making this work.
    Thursday, March 24, 2011 7:44 PM
  • Hi,

     

    You can try to change the default value 0 to 0x1.

     

     

    Regards,

    Leo   Huang

     

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com

     


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Friday, March 25, 2011 9:23 AM
    Moderator
  • Hi,

     

    Did your issue solved? Please feel free to give me any update.

     

    Thanks.

     

    Regards, 

    Leo   Huang

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, March 29, 2011 2:39 AM
    Moderator
  • Hi,

     

    As this thread has been quiet for a while, we assume that the issue has been resolved. At this time, we will mark it as ‘Answered’ as the previous steps should be helpful for many similar scenarios. If the issue still persists, please feel free to  reply this post directly so we will be notified to follow it up. You can also choose to unmark the answer as you wish.

     

    BTW,  we’d love to hear your feedback about the solution. By sharing your experience you can help other community members facing similar problems. Thanks for your understanding and efforts.

     

    Regards,

    Leo   Huang

    TechNet Subscriber Support in forum. If you have any feedback on our support, please contact tngfb@microsoft.com


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Monday, April 04, 2011 12:56 AM
    Moderator
  • this issue has not been resolved.  I have tested the KeepRasConnections under HKLM\System\CurrentControlSet\Services\RasMan\Parameters.  That key was set to 0x1
    Monday, June 13, 2011 4:13 PM
  • Hi,

    I've got the same problem under Windows 8. I've two users - both are already logged in. I use Windows+L to switch bewteen them and eac htime the RAS connection is terminated. I have tested a solution with KeepRasConnections=1 under HKLM\S\CCS\S\RasMan\Parameters but it doesn't work.

    Any solutions?
    Monday, November 19, 2012 12:38 PM