none
Home network via ethernet switch - Unidentified Network problem

    Question

  • The nub of my issue is that when I plug in my ethernet cable which is connected to my switch, I get an unidentified network. When I run the network diagnostics tool (Windows 7), I get an error saying I have an invalid IP configuration.

    I have searched a lot and tried many things without success. I do not have the Bonjour service installed. I am aware that it sometimes has a strange name, but I don't have it under either name.

    I haven't tried assigning a static IP because I don't really understand what the default gateway is, other than that it is related to routers, which I don't have (I connect to the internet using a usb mobile broadband device).

    I have disabled ipv6 on the LAN connection.

    The setup I have worked with Vista. My ethernet hardware is a Marvell Yukon on-board device (came with my Asus P6t deluxe board). My switch is a D-Link DES-1005D.

    Here is my ipconfig:

    Windows IP Configuration

       Host Name . . . . . . . . . . . . : BLACKBOX
       Primary Dns Suffix  . . . . . . . :
       Node Type . . . . . . . . . . . . : Hybrid
       IP Routing Enabled. . . . . . . . : Yes
       WINS Proxy Enabled. . . . . . . . : No

    PPP adapter O2 Mobile Connect:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : O2 Mobile Connect
       Physical Address. . . . . . . . . :
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv4 Address. . . . . . . . . . . : 89.204.255.220(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.255.255
       Default Gateway . . . . . . . . . : 0.0.0.0
       DNS Servers . . . . . . . . . . . : 62.40.32.33
                                           8.8.8.8
       Primary WINS Server . . . . . . . : 10.11.12.13
       Secondary WINS Server . . . . . . : 10.11.12.14
       NetBIOS over Tcpip. . . . . . . . : Disabled

    Ethernet adapter Local Area Connection:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Marvell Yukon 88E8056 PCI-E Gigabit Ether
    net Controller
       Physical Address. . . . . . . . . : 00-24-8C-48-D7-6D
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       Autoconfiguration IPv4 Address. . : 169.254.57.158(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.0.0
       Default Gateway . . . . . . . . . :
       NetBIOS over Tcpip. . . . . . . . : Enabled

    Tunnel adapter isatap.{7B7D585F-623C-4C07-A950-59D3B9238681}:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter isatap.{0A0CF815-1F4F-42AD-B8F9-085D1D5C56E6}:

       Media State . . . . . . . . . . . : Media disconnected
       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes

    Tunnel adapter 6TO4 Adapter:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Microsoft 6to4 Adapter #2
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv6 Address. . . . . . . . . . . : 2002:59cc:ffdc::59cc:ffdc(Preferred)
       Default Gateway . . . . . . . . . : 2002:c058:6301::c058:6301
       DNS Servers . . . . . . . . . . . : 62.40.32.33
                                           8.8.8.8
       NetBIOS over Tcpip. . . . . . . . : Disabled

    Tunnel adapter Teredo Tunneling Pseudo-Interface:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
       Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
       DHCP Enabled. . . . . . . . . . . : No
       Autoconfiguration Enabled . . . . : Yes
       IPv6 Address. . . . . . . . . . . : 2001:0:5ef5:73ba:3c0a:2ba2:a633:23(Prefer
    red)
       Link-local IPv6 Address . . . . . : fe80::3c0a:2ba2:a633:23%11(Preferred)
       Default Gateway . . . . . . . . . :
       NetBIOS over Tcpip. . . . . . . . : Disabled

    If anyone could help me I would greatly appreciate it. Thank you.
    Monday, March 08, 2010 12:18 AM

Answers

  •  I have no cable or dsl modem and no router. The purpose of the switch is to create a home network, and that's what is not working.
    A switch by itself does not include all you need to make a well functioning network. You should either have a dhcp server or static addresses as a minimum, even though in your case you should actually be able to communicate with another computer which also gets it address auto-assigned (169...). A dns server is also nice to have to avoid using ip-addresses all the time. You can get both dhcp and dns in a lot of cheap routers. Something to consider?

    To set static ip-addresses: Start -> Run... -> type: ncpa.cpl -> OK -> right click Local Area Connection -> Properties -> Mark Internet Protocol v4 -> Properties

    On the following page, enter the ip info, i.e.:
    IP-address: 192.168.0.10 (The last number (10) should be different for every computer or device you connect)
    Subnet: 255.255.255.0
    Gateway: Blank (This would be your router if you had one connected to the internet)
    DNS 1+2: Blank
    • Marked as answer by EpF27 Wednesday, March 10, 2010 10:18 PM
    Wednesday, March 10, 2010 2:24 PM

All replies

  • Ethernet adapter Local Area Connection:

       Connection-specific DNS Suffix  . :
       Description . . . . . . . . . . . : Marvell Yukon 88E8056 PCI-E Gigabit Ether
    net Controller
       Physical Address. . . . . . . . . : 00-24-8C-48-D7-6D
       DHCP Enabled. . . . . . . . . . . : Yes
       Autoconfiguration Enabled . . . . : Yes
       Autoconfiguration IPv4 Address. . : 169.254.57.158(Preferred)
       Subnet Mask . . . . . . . . . . . : 255.255.0.0
       Default Gateway . . . . . . . . . :
       NetBIOS over Tcpip. . . . . . . . : Enabled


    It seems your network cable is not connected (possibility of faulty cable) to that switch, or.. your switch doesn't have DHCP-server enabled.
    Autoconfiguration IPv4 Address shouldn't be 169.254.57.158 it should be:
     - 10.0.0.0 – 10.255.255.255 
     - 172.16.0.0 – 172.31.255.255
     - 192.168.0.0 – 192.168.255.255 (often)

    Try:
     - connecting it to other port of switch (1-5? no sure no. of ports) - be sure not connected to WAN port (it's RJ-45 too?)
     - using other network cable (no matter if crossover or not)
     - assigning static ip (look in manual for values)

    Or your firewall blocks DHCP communication.. maybe you set BLOCK in windows 7 firewall for all outgoing connection? (not sure if it's posible to block DHCP there)
    • Edited by Bachor Monday, March 08, 2010 6:12 PM DHCP option
    Monday, March 08, 2010 12:57 PM
  • Hi,

     

    169.#.#.# is a APIPA (Automatic Private IP Addressing) address; it indicates that the computer was unable to get a valid IP Address.

     

    Additionally, I would like to suggest the following:

     

    1.    Manually assign IP address, subnet mask, default gateway and the DNS settings to this network adapter referring to your router’s settings or the good computes’ configurations and check if it works.

     

    2.    Update the drive of the network adapter.

     

    3.    Boot the computer to Safe Mode with networking to have a check.

     

    4.    I noticed you are using a switch, if you have a router, please change the switch with it and see how it works.

     

    Hope this helps. Thanks.


    Nicholas Li - MSFT
    Tuesday, March 09, 2010 9:23 AM
  • Hi - thank you both for replying. Here are reponses to your questions and suggestions:

    Connecting to another switch port: No improvement (the manual says it's RJ-45)
    Using another cable: No improvement
    Updating driver: I have had this problem with any driver version installed
    Safe Mode: No improvement
    Changing to router: I don't have a router
    DHCP server: I found no mention of DHCP in the manual at all. It would appear that it is not DHCP enabled.
    Firewall: Both in and out rules allow DHCP
    Assigning static IP: I could use some help with this, as I don't know what values to use. If I choose any value from the 192 range as the IP, what do I use for the default gateway and DNS servers?

    I'm not very knowledgeable about this kind of thing, but I did have this setup working with Vista.

    Thanks again.
    Wednesday, March 10, 2010 1:11 AM
  • Try bypassing the switch and plug directly into your your broadband modem (cable or DSL), see if it works there.

    Anything else connected to the switch? If so does it work correctly?
    Rich Why can't I be different and original like everybody else? - Vivian Stanshal
    Wednesday, March 10, 2010 2:11 AM
  • I have had this same problem for three weeks...nothing that I see on any forum helps, I just keep getting the same thing. I am very frustrated because I am usually a very good troubleshooter with these kind of problems....I just don't have the mojo for this one. It does seem as though whatever our problem is, Ep, it is definetly not common. I have only seem four cases on the net so far....maybe we are just doing something wrong.

    Anyone that can give help on this problem, please....I'm just about ready to go Mac after this.
    Wednesday, March 10, 2010 4:09 AM
  • Try bypassing the switch and plug directly into your your broadband modem (cable or DSL), see if it works there.

    Anything else connected to the switch? If so does it work correctly?
    Rich Why can't I be different and original like everybody else? - Vivian Stanshal

    Ztruker;

    Critical to understanding my problem is the fact that it is nothing to do with the internet. I have a usb broadband mobile modem connected to my computer and it works fine - I have no cable or dsl modem and no router. The purpose of the switch is to create a home network, and that's what is not working.
    Wednesday, March 10, 2010 1:57 PM
  • I have had this same problem for three weeks...nothing that I see on any forum helps, I just keep getting the same thing. I am very frustrated because I am usually a very good troubleshooter with these kind of problems....I just don't have the mojo for this one. It does seem as though whatever our problem is, Ep, it is definetly not common. I have only seem four cases on the net so far....maybe we are just doing something wrong.

    Anyone that can give help on this problem, please....I'm just about ready to go Mac after this.
    Yes, it's extremely frustrating. As I said, I had this working with Vista - I reformatted, installed Windows 7 and had the problem immediately. I tried finding out how to fix it then (months ago now), but gave up after a while, finding nothing. Recently I decided to tackle it again, as I thought there must be a solution now. Your post is not very optimistic, but I'm hoping that somebody here can help me figure it out.

    If anyone can tell me what I should enter in the Default Gateway and DNS section of the IPv4 properties for a static address, I would be grateful so that I can at least test that out.
    Wednesday, March 10, 2010 2:09 PM
  •  I have no cable or dsl modem and no router. The purpose of the switch is to create a home network, and that's what is not working.
    A switch by itself does not include all you need to make a well functioning network. You should either have a dhcp server or static addresses as a minimum, even though in your case you should actually be able to communicate with another computer which also gets it address auto-assigned (169...). A dns server is also nice to have to avoid using ip-addresses all the time. You can get both dhcp and dns in a lot of cheap routers. Something to consider?

    To set static ip-addresses: Start -> Run... -> type: ncpa.cpl -> OK -> right click Local Area Connection -> Properties -> Mark Internet Protocol v4 -> Properties

    On the following page, enter the ip info, i.e.:
    IP-address: 192.168.0.10 (The last number (10) should be different for every computer or device you connect)
    Subnet: 255.255.255.0
    Gateway: Blank (This would be your router if you had one connected to the internet)
    DNS 1+2: Blank
    • Marked as answer by EpF27 Wednesday, March 10, 2010 10:18 PM
    Wednesday, March 10, 2010 2:24 PM
  • set the static IP's as the above posting states

    then if you need to change the network type


    You need to change the security settings which causes the network to be classified as public.

        Here is a description from a previous discussion on this.


    To do this on your local server , follow these steps:

    1. Start --> run --> MMC --> press enter

    2. In MMC console , from menu file select Add/Remove Snap-in

    3. Select Group Policy Object editor --> Press Add --> select Local computer --> press finish -->press OK

    4. Now under the "console Root" you have 'local computer Policy", expand it and Open the "Computer configration" -->Windows Settings -->Security Settings -->select Network list manger policies
    on the right Side you will see options for :

    double click -->Unidentified networks

      Then you can select the option to consider the Unidentified networks as private and if user can change the
    location.

    • Proposed as answer by Bachor Sunday, March 14, 2010 2:27 AM
    Wednesday, March 10, 2010 2:32 PM
  • I have been mostly successful in fixing this, so thank you Bachor, Nicholas Li, Eirik Hamer and Bubbapcguy! I can now access files on both computers, so basically problem solved.

    Strangely, after following Bubbacpguy's suggestions for changing the network classification, my network is now classified as Unidentified Network - Work network. I can't change the location, even though I chose this option in MMC. However, at the moment this is just a niggle - I can access my files! Thanks again.
    Wednesday, March 10, 2010 10:18 PM