none
Homegroup : No other homegroup computers are currently available

    Question

  • Hello everyone,
    I have two computers, a laptop and a desktop. When i installed W7 Beta, homegroup worked without a htich and has been working since. Today i upgraded the laptop to the RC, and after that i coudlnt see the desktop anymore in the homegroup (could still see it through the network). So i thought it was an issue with the beta and RC not playing well together so i upgraded the desktop as well, and they still dont see eachother in the homegroup get an error saying "No other homegroup computers are currently available", only through the network tab.

    I tried leaving and joining the homegroup, both from the laptop and PC. IPv6 is enabled, times are synced with the time server,same user and pass on both pcs, all settings under advanced are turned to on besides password protected sharing. I tried switching to work then home on both pcs. When i join one to the homegroup the other does get an invitation to join however when it does join it cant see the other computer.



    Any help would be greatly appriciated.
    Monday, June 29, 2009 9:14 PM

All replies

  • Do you have a 3rd party Firewall installed?

    How is your network configured (Ethernet Router or Wireless)?  Older or newer?  (older network hardware may need NetBIOS IN/OUT [Trusted Zone] rule(s) in the Firewall (if 3rd party)




    GA P35 DQ6 Mb, Intel Wolfdale 8600 3.33Ghz C2D CPU., 4x2Gb Mushkin DDR2 1066 PC2 8500 Ascents Memory Mods., PNY-nVidia GE Force 8800 GTS (640MB), 4-Western Digital Caviar SATA(2) HDD's (internal), 1 EIDE-USB External; Hauppauge PVR 1600 TV tuner, Dual Monitor: (1) Standard up top, (1) WideScreen below; Altec Lansing Speakers. Here Kitty, Kitty...that's my Kitty Kat, he's a Kat, because he is kat...kat.
    Tuesday, June 30, 2009 2:49 AM
  • The desktop is hooked up directly with the wireless routher through Ethernet and the laptop wireless, its a linksys wrt54g2 , no third party software of any kind is installed, and like i said it worked flawlessly without any hiccups whatsoever in the Beta
    Tuesday, June 30, 2009 6:16 AM
  • There is no need to point out what Operating Systems it worked with, as there is always a difference that can explain why it would work with one but not the other. Do you have network discovery turned on?
    Tuesday, June 30, 2009 1:16 PM
  • yes network discovery is turned on on both computers.
    Tuesday, June 30, 2009 1:21 PM
  • Have you run the homegroup troubleshooter yet?
    Tuesday, June 30, 2009 1:36 PM
  • yes ran the troubleshooter on both PCs, went through every possible scenario, with no luck
    Tuesday, June 30, 2009 1:45 PM
  • Have you set up shared folders with contents inside them on each computer?
    Tuesday, June 30, 2009 2:00 PM
  • yes, I can see and access the shared folders through the network icon (ex: \\Desktop PC\music) but nothing comes up when i click on the homegroup i con
    Tuesday, June 30, 2009 2:03 PM
  • hahaha, Fascinating that the so called "experts" here have had no answer for over a year, and looks like they can't be bothered with it anymore. What a bunch of losers!

    And Adam, you pompous git with your comment of "There is no need to point out what Operating Systems it worked with, as there is always a difference that can explain why it would work with one but not the other" - Well hello! -  the reason for pointing it out was to demonstrate that the settings with the router and computer setup cannot be to blame, and can be ruled out and so therefore it must be an operating system issue... Never tell someone not to offer information!

    I too have the exact same issue. All I can say is that this homegroup sharing is absolute rubbbish. Why not just share folders over a network like we could in XP?

    • Edited by Rogerthe1st Tuesday, August 17, 2010 3:01 PM typo!
    Tuesday, August 17, 2010 3:00 PM
  • Agreed - it's a complete junk. In 20 years of graphical OS Microsoft can't (or won't) figure out a way to easily share files over network. It's ridiculous. If they don't know how, why don't they just copy Apple's OS X software.

    I have 3 computers all connected to the same group, all having stuff shared using homegroup and none of them are visible to each other. No, I don't have firewalls. Only way to share is to create a guest account on each of my computers and pray the gods Windows will figure out that it should allow me to access shared folders. 

    Friday, December 03, 2010 7:09 PM
  • Ok I know this sounds completely simple, but I was having the same frustrating problem as you. For the past few hours I couldn't figure out why every time I set the "share" folder settings for all my documents, music, etc... only the printer would stay checked after I went back in. It didn't click with me that this may be my whole problem. If I simply went to my "libraries" tab and selected "Share with" all the folders were set to NOBODY. With one click to "SHARE READ/WRITE" with Homegroup, VOILA, my desktop instantly appeared under my "Homegroup" and when I did the same to my notebook settings, my notebook appeared under my Desktop homegroup. Hope this helps. I was getting completely pissed by not being able to find any answer ANYWHERE online. I really hope this helps you!
    • Proposed as answer by theguided1 Wednesday, December 15, 2010 3:44 AM
    Wednesday, December 15, 2010 3:38 AM
  • I know this is a 2 year old topic but I just had the same issue the 2 PC's running similar systems, and got here after a google search.

    the 1st system had had a homegroup with no other computers on the network for a while and the 2nd system (the 1 that could not find the 1st in homegroup) was just set up a day ago. after setting up the network I had the issue (2nd system not see 1st in HG), so I got both computers to "leave the homegroup" under homegroup settings and made a new new homegroup with the 1st system, the 2nd system instantly got a message saying the 1st system had just made a new homegroup "do you want to join?" I joined and entered the password and now I can see the opposite system under homegroup on both systems.

     

    both running win 7 pro x64

     

    hope that helps any1 having similar issues.

    Thursday, December 16, 2010 6:37 PM
  • I've been having the same issues with the desktop vs. laptop in the homegroup.  After a few hours of tinkering I decided to see what would happen if I tried to create the homegroup from the laptop (connected wirelessly).  Here's the message I got which would explain why I'm not seeing my laptop from my desktop in the homegroup:

    "This computer belongs to a domain.  Domain-joined computers can create homegroups or share content with a homegroup.  Domain-joined computers can join existing homegroups and can access content shared by other homegroup members, but they wont be visible on the homegroup.  To join a homegroup, open HomeGroup in Control Panel."

    I also came across this tid-bit from Microsoft: "Computers on a home network must belong to a workgroup, but they can also belong to a homegroup. A homegroup makes it easy to share pictures, music, videos, documents, and printers with other people on a home network."

    At this point, i realized that I was still configured to work with my workplace domain.  So, I changed my domain and workgroup settings to be a member of a workgroup again and... voila!  I can now see one computer from the other, nothing blocked.  As far as what I'll do about having to be on a work domain on one network and a workgroup at home, maybe I can work something out with task scheduler. 

    Go here for more info on HomeGroup, WorkGroup, and Domain differences and settings: http://windows.microsoft.com/en-US/windows7/What-is-the-difference-between-a-domain-a-workgroup-and-a-homegroup

    Hope this helps out more than two years down the road for the next Joe who hits this problem.

    Sunday, February 20, 2011 6:19 AM
  • Same crap as above. I got mine to work by resharing the folders even though they were already shared and could be got at from the old network tab. The home group quits working once and a while and a quick reshare works.
    Sunday, February 20, 2011 3:29 PM
  • I have recently encountered this issue with my home PCs. Two Windows 7 x64 machines had HomeGroup up and running for over a year without any problems. I am using a simple wired (cat6) connection though a gigabit switch to connect the PCs. I have a router and a printer that also connect to the same switch so the PCs can share the Internet connection and printer. Wireless has been deactivated since I never use it. This configuration remains unchanged since I set it up. I have no idea what changed that caused my main PC to stop seeing my other PC in HomeGroup.

    A few weeks ago I first noticed that I couldn't see the 2nd PC in my HomeGroup. I just got the "No other homegroup computers are currently available" message whenever I tried to look at it. On the Desktop, the HomeGroup folder shows as "empty." Oddly, from the 2nd PC, I can see the 1st one without problem, and move files between them. But only from the 2nd PC. The 1st still behaves as if there are no other HomeGroup computers connected. In the HomeGroup control panel, it shows that both have "joined" the HomeGroup, and that both are on a "Home" network.

    I tried leaving the HomeGroup and starting a new one, using the new password to connect them. Again, the 2nd PC sees the 1st in the HomeGroup, while the 1st sees nothing. I have read every post in this and a dozen other threads on Technet, and spent days trying to find an answer in whatever applicable forum Google would find. I have no 3rd-party Antivirus or Firewalls. I use Microsoft Security Essentials and Windows' built-in Firewall. I have confirmed that the appropriate services (Core Networking, File and Printer Sharing, HomeGroup, and Network Discovery) are running and set to "automatic" on both machines, and that they are not being blocked by the Windows Firewall. I have manually set all the folders/libraries I want to share on both PCs to be accessed (read & write) by the HomeGroup, just to be sure that I am sharing.

    I can access both PCs from each other using the Network panel. It's just HomeGroup that has mysteriously stopped working, and only from one side. Any advice would be appreciated!


    i7-920@3.3 • GA-EX58-UD5 • 4870X2 • 6GB OCZ Plat 1600C7 • ~7TB storage • Lian-Li PC-A71B • PCP&C S750 • S1283DK • G9 • MS Ergo 4k • Senn HD595 • Musiland 02 US • BenQ FP241W • Win7 64 Ult
    Friday, March 25, 2011 8:54 PM
  • Forgive me for being critical. I truly respect people who know what's going on who join groups like this to answer questions from know-nothing jerks like me but...

    I'm confused. This discussion about a feature that's described as "easy" has been up for years with no real solution. Easy means the instructions say something like "open this, click here, select that, press enter" and it's done. My "homegroup" still consists of a USB flash drive on the desk between the two computers (doesn't work so well when the laptop is two floors away).

    I think this is pretty well the same info that we've heard before but here goes:

    • Windows 7 on both machines
    • networked with same workgroup name, on the same router with a strong signal
    • both set to "Home" network
    • Norton IS running on both with permissions set properly (I've completely shut down Norton on both machines with no improvement)
    • Repeatedly set everything to share "everybody (read write)" (why it keeps going back to "nobody" I don't know)
    • Essentially I've turned off every restriction, password, blockage, firewall, had the computers physically touching (just in case) and mummered incantations over the whole desk to no avail.
    Occassionally I get excited because I (again) set up a new homegroup on one computer and the other computer actually sees it and joins it. Then I end up in the ridiculous situation of having both computers reporting that they are members of the same homegroup (same password displayed) while simultaniously reporting that "no other homegroup computers are currently available").

    What do I have to do??

    Monday, May 30, 2011 3:02 PM
  • ^^ This! Please help us out here!
    i7-920@3.3 • GA-EX58-UD5 • 4870X2 • 6GB OCZ Plat 1600C7 • ~7TB storage • Lian-Li PC-A71B • PCP&C S750 • S1283DK • G9 • MS Ergo 4k • Senn HD595 • Musiland 02 US • BenQ FP241W • Win7 64 Ult
    Monday, May 30, 2011 6:35 PM
  • to theguided1 - I had the problem of one computer recognizing the other but not the other way around.  After hours of researching and following all the recommendations for settings changes, I still had no luck.  I came across your posting.  On the unseen computer, I went to libraries, highlighted documents, right clicked and changed the sharing options to share with homegroup - VOILA - my unseen computer immediately showed up.  thanks for posting.
    Sunday, June 26, 2011 11:12 PM
  • I have a netbook and a desktop.  After hours I could not get homegroup to work at all.  What I didn't realise until much later is that BOTH my pc's were named as the default 'USER PC'.  This was preventing the Holy Grail of 'Join Now' from appearing.  After changing the USER PC on both machines, with simply a different number on the end, the coveted 'Join Now'  appeared and I clicked on it.  

     

    Windows Button/Control Panel/System and Security/System/

    You will see a computer name, domain and workgroup settings.  Below this will be the name of your computer.  Click on change settings to the right.  Now a system properties window will pop up.  

     

    Click 'change' to rename your computer.  Once you enter the name you have chosen, the computer will restart.  That worked for me.  I started off with two hairs on my head.  Now I have none :)

     

    But if this posting saves somebody even ten minutes less - it has been worthwhile.

    Thursday, July 07, 2011 9:44 PM
  • Ok I know this sounds completely simple, but I was having the same frustrating problem as you. For the past few hours I couldn't figure out why every time I set the "share" folder settings for all my documents, music, etc... only the printer would stay checked after I went back in. It didn't click with me that this may be my whole problem. If I simply went to my "libraries" tab and selected "Share with" all the folders were set to NOBODY. With one click to "SHARE READ/WRITE" with Homegroup, VOILA, my desktop instantly appeared under my "Homegroup" and when I did the same to my notebook settings, my notebook appeared under my Desktop homegroup. Hope this helps. I was getting completely pissed by not being able to find any answer ANYWHERE online. I really hope this helps you!

    Your solution is right on!  Eventhough I had run through the Homegroup setup several times, one computer could not find the other's homegroup.  The Troubleshooter did not help.  Finally I noticed that the Library categories on one computer were shared with Nobody!  I had to manually correct this one by one. Microsoft still does not have this Homegroup setup perfected in spite of Windows 7 being at SP1.
    Gary VanderMolen, MVP (Mail)
    Saturday, July 23, 2011 12:07 AM
  • Thank you! Complex soln. made simple.

    Wednesday, September 14, 2011 12:20 PM
  • Rebooting my router fixed this issue for me.
    Saturday, September 15, 2012 9:59 PM
  • I too had the same problem with homegroup not seeing each computer and I did as the previous posting suggested. I went to each library and right clicked and it was set to share with nobody. I set it to "Homegroup (read/write). The only other thing I did was change the computers name (under properties), both computers had the same name (as birsealmighty mentioned previously). This was done simultaneously with changing the sharing properties of my folders so I was not sure if it is one or both properties being changed that allowed me to "join" the homegroup. So just for fun I tried to change the one computer back to its previous name (so both computers had the same name again) and I received an error message that there is already another computer on the network with the same name. I have restarted both computers and both are still recognized on the homegroup. After hours of searching on the internet (on Microsoft specifically) I found my answers here. Thank you to all who were frustrated enough to share. :)
    Friday, December 28, 2012 10:34 PM
  • +1 to the above!

    Same symptoms for me: A could see B, but B could not see A, even though they worked before. Even though the homegroup settings on both computers said that all libraries were shared, they actually weren't on A; I had to right-click them individually and choose to share with the homegroup. Very frustrating problem solved.

    Saturday, December 29, 2012 8:52 AM