none
Taskbar will not stay hidden in auto-hide

    Question

  • I haven't had this problem for long (A total of 1 day), but it is making my gaming experience horrible.

    I dowloaded the microsoft update last night and afterwards, despite my task bar being on auto-hide, my task bar is up all the time. It never hides.  I tried switching off of auto-hide and then back to it. That does make the taskbar hidden, but only until I move my cursor of it and then it will not go back into hide.

    Any fixes? What should I do?
    Friday, January 11, 2008 2:02 AM

All replies

  •  

    I am having the exact same problem and I suspect it is when I have installed some new programs, not sure if it is from MS Update.

     

    But it is very annoying.

     

    What is auto hide if it does not auto hide! And it is Vista which is giving me this one! I found a way to fix this but it is definitely not elegant way of fixing an issue:

     

    Just kill the process tree for explorer.exe in task manager, then rerun it from the task manager.

    Tuesday, January 15, 2008 1:48 PM
  • I just noticed the same problem.  I downloaded and installed many vista updates the past week.

    Today I notice the taskbar will not hide!  Microsoft please fix this asap.  I enjoy having the taskbar out of the way.  Have no idea if there is a way to fix this.  Hopefully another update will solve the problem.

     

    • Proposed as answer by SacPrince Friday, October 15, 2010 6:41 PM
    Wednesday, January 16, 2008 12:02 AM
  • I'm also having this problem. I'm not sure why this hasn't been fixed if it has been noticed since January. I hope Microsoft can look into this issue as it's a very noticeable and annoying defect.
    Thursday, May 08, 2008 2:51 AM
  • I just noticed my task bar is having the same problem. I hope Microsoft looks into this problem. I like it they way it used to work. Gives me more screen area. I am running Windows XP Profesional.

    Thursday, May 22, 2008 5:53 PM
  • I am new to vista,  but not to this issue.  This same issue has been with Microsoft Windows operating systems for years now!  This happens on XP x64 too. 

     

    I do not understand how a problem like this .  . . so prevelant and so visible could remain unsolved for so long.

     

    Steve

     

    Thursday, May 22, 2008 6:36 PM
  • Hello, I'm back again, with good news in my case.

    I use R-drive image to back up my CBig Smilerive, as I am not completely confident with system restore, so I first made an image of my CBig Smilerive, so I could recover if systems restore screwed my system. Then I proceeded to do a system restore, to a date about a week ago. When I rebooted my system, the task bar started hiding like normal, so I undid the system restore and, after booting to like I was earlier, and the task bar to my surprise still acted normal.

    I was going to try and find out what update had screwed my system, but I was not able to as like I say after playing the game to find out what update caused the problem.  I do not know is you want to try the steps I did, hopefuly, and then undo the system restore. The only risk is if the system restore does not work properly, you might end up with a vegetable puter. Any way it is something you need to evaluate, is it worth the risk or live with the non hiding task bar. Good luck

    Thursday, May 22, 2008 6:59 PM
  • Not sure if this will help, but no harm trying ! In Taskbar properties,

     

    Check this:
    Auto-hide the taskbar
     
    Uncheck this:
    Keep the taskbar on top of other windows

    • Proposed as answer by organiste Saturday, November 24, 2012 11:51 AM
    Saturday, May 24, 2008 12:31 PM
  • Nope, this didn't work.  The taskbar just stays hidden.  I hope Microsoft comes up with a fix for this soon.
    • Proposed as answer by meklu Thursday, February 02, 2012 12:39 PM
    Friday, June 20, 2008 8:08 PM
  • I just started having the same problem, Maybe its time for a MAC

    • Proposed as answer by meklu Thursday, February 02, 2012 12:39 PM
    Sunday, June 29, 2008 9:52 PM
  • I have been experiencing this same problem for a couple of months now. I tried to put up with it, having searched for a solution/fix without success. But I can honestly say that I am experiencing true PHYSICAL pain due to frustration and despair in trying to fix this. My work (Graphics, web design) depends on a relaxed and smooth work experience has been affected. I have resorted to using another OLD computer with windows XP home edition to avoid the pain of using the other computer.
    Some may actually think I am exaggerating, but I promise you I am not. This may seem like trivial to some It is very serious to me and I may grab a sledge hammer and pound my whole system into a million pieces as I move on to try a MAC for the first time and in the process throwing away my 15 YEARS of Windows "love affair".

    The distressing part about this is that, someone posted this  issue on (11 Jan 2008, 2:02 AM UTC), And 6 months later, we've yet to see any official reply by any MS representitive. You can even tell us that this issue is  as hard to fix as landing on the moon and we should not expect a fix any time soon and we will understand, but GEEZ, show a little support, and post anything,  even LIE TO US but show us that YOU ARE ALIVE and aware of this  issue.

    Very disappointed

    Tuesday, July 01, 2008 5:14 PM
  • This has been driving me nuts for weeks now so I empathise with everyone here. Good news is that I eventually fixed it.  For XP, find your Prefetch folder (usually under Windows) and delete the contents.  Restart your machine.  It's been working for two days now.

    Tuesday, July 29, 2008 5:18 AM
  •  

    Having the exact same problem here. I also had this problem in XP on my older computer. I got tired of deleting the prefetch folder over and over so I just left it till I got a newer machine.

     

    Of course I thought they had this fixed in vista, but clearly I was mistaken... Hopefully they will get this fixed soon, but as someone above mentioned, this thread is almost a year old with no replies from any staff...

     

    Eh, hope I'm not necroposting too badly here

    Wednesday, August 06, 2008 3:55 PM
  • Wow, I never imagined that something like this would be a problem, but sure enough, my taskbar stopped autohiding yesterday. I've been running XP Home forever and "poof" it starts happening.  It's too bad Microsoft doesn't even consider it enough of an issue to address it here.  I'm really beginning to like those MAC commercials...

    Tuesday, August 12, 2008 1:34 AM
  • I've had this issue for like 2 weeks in Vista now. Driving me insane. It'll work fine for a few minutes to hours after I boot up, then suddenly at random it just won't go away.

    I got used to having a similar issue with XP... I used to get annoyed by the incessant balloon tips, so I always turned them off. But turning them off meant the taskbar would still unhide to show the tip, but you didn't know which app was calling for your attention. Clicking each tray icon would make it go away (after a while I started to figure out the usual suspects... often MS stuff). This isn't the problem with Vista, since I've not gotten sick of the balloons yet, and clicking each icon in turn doesn't do anything.

    I find it horribly frustrating too. I run my taskbar 3 rows high, so when it's not hidden, the bottom row of desktop icons is inaccessible.
    Tuesday, August 26, 2008 9:52 AM
  • I am like you.  I do the same thing with three rows of task bars and quick Launches.  Is there a key that I can hit that will display the task bar if I keep it hidden?
    Tuesday, August 26, 2008 7:41 PM
  • I just realized that I had this problem too, I did however remedy the problem by restarting explorer.exe

    It is a temporary solution to what I hope is not a permanent problem...
    Thursday, August 28, 2008 5:38 AM
  • Delete everything in c:\windows\prefetch. This is the same solution for the same problem that XP had. Nice to see they still have not done anything about it. /sigh

    Tuesday, September 02, 2008 3:01 AM
  • my love of ms is dying.
    Wednesday, October 01, 2008 8:00 AM
  • I also have this problem .... seems like Microsoft figures (corectly) that they have a monopoly and do not ned to be responsive to thier customers or put out a quality product.  I have had more problems with Vista than I ever had with XP.  Unfortunately, I am trapped by Microsoft's monopoly, since the switch to anything else would be costly in terms of a learning curve in addition to the financial burden and time consimunig process of transferring software to another operating system. 

     

    Tell me again how Microsoft won thier anti-trust suit?

     

    Sunday, October 26, 2008 12:48 AM
  • SOLUTION TO TASKBAR AUTOHIDE BUG :-

    Locate your Prefetch folder in your root/WINDOWS/Prefetch/ directory.

    Back up the entire folder in another location just in case anything goes wrong.

    Delete the entire contents of the original folder located as described above.

    got this from http://forums.thatcomputerguy.us/index.php?showtopic=16753

    anw this problem occurs usually after windows update for some reason.


    this solution worked for me.
    Tuesday, October 28, 2008 2:18 AM
  • didn't work for me... and this have been a problem I've experienced on every version of windows - seems to be a feature rather than a bug... i wish i could find out how to stop this annoying feature!

    Saturday, November 29, 2008 5:35 PM
  • Try checking the top three boxes.
    Lock the Taskbar (that's the one I still needed)
    Auto Hide the taskbar
    Keep the taskbar on top
    • Proposed as answer by tyler0896 Wednesday, February 24, 2010 2:35 AM
    Wednesday, December 24, 2008 3:26 PM
  • i have this same problem that just started this morning with my work computer.  i usually leave my computer on over night all week.  today is tuesday and it worked perfectly yesterday, but this morning it's stuck.  i haven't tried deleting the contents of my prefetch directory yet.  i thought i'd try restarting my computer but i have everything running and am trying to not have to shut everything down and restarting everything, but this is the only answer that i've found so i guess i'm going to have to do this.  hopefully it will work and continue to work.  i'd hate to have to do this every day.

    i've already tried unchecking applying and checking and applying the first three options in the task bar properties windows to no avail.  so i try the prefetch and reboot option and, like i said, hope it's a mostly permanent fix.
    Tuesday, January 13, 2009 1:32 PM
  • This may be caused by something wanting your attention.  Similar to when someone sends you an Instant message, the item in the task bar lights up and you have to bring focus to messenger to make it go away. 

    Check all your system tray icons to see if any of them are in a state of alert.  For example: email faling to sync, anti-virus failing to retrieve definitions, Security Center with a Red shield, anything else with an exclamation point.

    This was driving me nuts for days.  I tended to some of these system tray issues and the problems have ceased.
    • Proposed as answer by Decian Thursday, September 02, 2010 12:00 PM
    Wednesday, January 14, 2009 3:11 PM
  • Ok, got it.  It's the damn PC-Cillin one.  There was no alert, nothing needing attention.  But when I exited, it popped up a red-x shield thing saying that I was unprotected (due to exiting).  Started it back up and autohide works again.  Thanks, Vista, for sucking.
    Friday, January 16, 2009 3:19 AM
  • realgar2001 said:

    SOLUTION TO TASKBAR AUTOHIDE BUG :-

    Locate your Prefetch folder in your root/WINDOWS/Prefetch/ directory.

    Back up the entire folder in another location just in case anything goes wrong.

    Delete the entire contents of the original folder located as described above.

    got this from http://forums.thatcomputerguy.us/index.php?showtopic=16753

    anw this problem occurs usually after windows update for some reason.


    this solution worked for me.

     

    I've been running XP Home for years with autohide and never had an issue. Just upgraded to Vista Home Premium last week. Autohide was fine until some updates the past couple days. Noticed it wasn't working this morning and found your posts here while searching for a fix.

    Backed up WINDOWS/Prefetch. Deleted contents. Rebooted. Autohide is working fine now. Thanks.

    Friday, February 27, 2009 4:33 PM
  • Oh man!  This started happening to me TODAY!  It was working fine, and then it stopped for no reason.  I tried the Prefetch idea, and it didn't work.  Come on Microsoft.  This is ridiculous.  I use Rocketdock too, so the taskbar is extremely annoying when it won't hide.
    Tuesday, April 28, 2009 1:29 PM
  • Count me in too!

    I have never experienced this problem using XP, but it has plagued me since switching to Vista.

    My setup is a little different from the others described here.  I have the Taskbar on the left edge of my screen, and it Auto-hides just fine.  Then I have a set of toolbars on the right edge of the screen.  They auto-hide when they are in the mood, and then they don't don't if they are in a bad mood. Perhaps I should mention that I usually run a dual display, and it seems this problem is worse when I have a second monitor active - but I have not measured it - that's just my perception.

    1) I've tried clearing the prefetch directory - that did not fix the problem.
    2) I've tried stoping and starting a new explorer.exe through Task Manager.  That fixes it.  But the next time I boot it's broken again. (maybe).  So that is not a fix, and it's really annoying to have to kill your OS's primary UI manager to get it to work properly!

    I sure hope Someone at Microsoft will actually fix this for us...
    Wednesday, April 29, 2009 5:21 AM
  • He's right. I had the same problem. For some reason or the other Windows Update could not search for updates as was the case with Defender. So I just set Update to never check for updates and closed Defender. Its fine now. I never found any difference in my computer before and after an update.
    • Proposed as answer by kingGypsy Thursday, May 28, 2009 5:17 PM
    Sunday, May 17, 2009 12:42 AM
  • OK, I found an old entry about this issue under Win 95/98. The parallel solution under Vista would be:

    • Click anywhere on the desktop and choose "Personalize"
    • Choose "Windows Color and Appearance"
    • In the "Appearance Setting" dialog box, click the "Effects..." button
    • Check the "Show Windows contents while dragging" checkbox
    For reference, here is the original KB article:

    http://support.microsoft.com/kb/169554

    Amazingly, this seemed to fix the taskbar issue for me.


    Rick in Phoenix
    Rick
    Thursday, May 28, 2009 5:22 PM
  • I hope I can be of some help...

    Often times Windows XP (and Vista) will refuse to hide because it mistakenly believes there is still a tooltip balloon open. (I see this a lot myself with APC's Powerchute Personal Edition.) Unfortunately the only way to get your taskbar to properly hide again (and I don't mean uncheck the "Keep the taskbar ontop of other widows" option for a quick fix) is to restart the machine so that Windows resets the tooltip balloon status. What a pain!

    Thankfully through my inability to let it go and hatred for this problem I have written a file that will fix this! (Works great on my Vista machine!) All the program does is overwrite the phantom tooltip balloon and then clear the tooltip balloon and Tahdah!

    The tooltip will stay up for 10 seconds so that you can read the info on it (just telling you what it does and how you can contact me if you have any problems). You can close this tooltip balloon like any other by clicking on it, or if you mouse over the program tray icon it will close itself instantly.

    You can find my "Taskbar Slapper®" hosted by FileFactory at the following address:

    <a target=_blank href="http://www.filefactory.com/file/ag932d0/n/Taskbar_Slapper_exe">http://www.filefactory.com/file/ag932d0/n/Taskbar_Slapper_exe</a>

    If you have any problems or questions (or would like to know what other little programs I've made such as Task Stopper® - for when any program generates a CPU intensive loop that even taskmanager can't pull you out of) please feel free to email me at: NovaFrost@cox.net

    I hope this helps you like it did me!
    • Proposed as answer by Cole26 Friday, April 16, 2010 2:50 AM
    Sunday, June 28, 2009 11:26 AM
  • Hmm, I'm afraid your Taskbar Slapper didn't work but thats for trying to help. 

    You could make a lil batch file that backed up and cleared the prefetch folder at system startup (rather than on log in). But why bother, I think unchecking 'Keep the taskbar on top of other windows' probably works fine. Just hit start when you wanna see the taskbar, or just deal with less space (although similar to other users I'm using Rocket Dock so this is not an option) 

    or just completely forget about taskbars not auto-hiding by getting a mac and one of their nice large HD Displays. sorry to sound like some sort of Mac Authorised Seller, just seems pathetic that at least 100's of people if not 1000's are having to moan about this all over the internet when Microsoft could probably fix it in a matter of minutes if they could be bothered. 

    Quite why they are spending so much time on new Windows OS's when OS's going back even to 95 from what I can see still have very noticable bugs that cannot be fixed I don't know. Anyone tried to recreate the bug in a Windows 7 RC yet?
    Saturday, July 04, 2009 10:59 PM
  • It seems this happened to me either as a result of Outlook popping up a notification, and then Vista hiding it (with me never having acknowledged it), in which case restarting Outlook fixed the problem, OR, a McAfee virus scan going into "Paused" state when I'm using the machine, in which case viewing the scan details and then closing them does the trick.

    I'm guessing the root of the problem is actually that when the task-bar is in "auto hide" mode, sometimes windows will "hide" notifications along with the task bar and then you'll never see them again.

    Monday, July 06, 2009 3:13 PM
  • This trick works for me!
    Thank you Rick!

    Friday, July 10, 2009 5:12 AM
  • I hope I can be of some help...

    Often times Windows XP (and Vista) will refuse to hide because it mistakenly believes there is still a tooltip balloon open. (I see this a lot myself with APC's Powerchute Personal Edition.) Unfortunately the only way to get your taskbar to properly hide again (and I don't mean uncheck the "Keep the taskbar ontop of other widows" option for a quick fix) is to restart the machine so that Windows resets the tooltip balloon status. What a pain!

    Thankfully through my inability to let it go and hatred for this problem I have written a file that will fix this! (Works great on my Vista machine!) All the program does is overwrite the phantom tooltip balloon and then clear the tooltip balloon and Tahdah!

    The tooltip will stay up for 10 seconds so that you can read the info on it (just telling you what it does and how you can contact me if you have any problems). You can close this tooltip balloon like any other by clicking on it, or if you mouse over the program tray icon it will close itself instantly.

    You can find my "Taskbar Slapper®" hosted by FileFactory at the following address:

    <a target=_blank href="http://www.filefactory.com/file/ag932d0/n/Taskbar_Slapper_exe">http://www.filefactory.com/file/ag932d0/n/Taskbar_Slapper_exe</a>

    If you have any problems or questions (or would like to know what other little programs I've made such as Task Stopper® - for when any program generates a CPU intensive loop that even taskmanager can't pull you out of) please feel free to email me at: NovaFrost@cox.net

    I hope this helps you like it did me!

    woaaaaa youre a genius. thanks so much. all is ok now
    Saturday, July 25, 2009 3:37 PM
  • What I do to fix this problem is I click "Auto-Hide the taskbar", then I grab the top of the taskbar, and force it to hide, by dragging it down. *IT WILL NOT POP UP AFTER THIS, YOU HAVE TO MANUALLY DRAG IT BACK UP*. This resolves the issue for me, since I use alt-tab to switch between programs, and I press the windows key (one of the RARE times its of any damn use) to bring the start bar up. Eliminated the frustration permanently.
    Monday, August 17, 2009 4:14 AM
  • <a target=_blank href="http://www.filefactory.com/file/ag932d0/n/Taskbar_Slapper_exe">http://www.filefactory.com/file/ag932d0/n/Taskbar_Slapper_exe</a>
    Is this for XP or Vista or both?
    Wednesday, August 26, 2009 12:05 PM
  • I've been having this problem on and off for years on the systems I support... There is a VBS script that simply resets default Windows values for the Start/Task Bar... It works every time I need to use it.. You can download a copy from:

    http://www.kellys-korner-xp.com/regs_edits/xp_taskbar_desktop_fixall.vbs

    Hope its helps all..
    Monday, September 07, 2009 1:36 PM
  • I was having the same problem.

    Taskbar auto-hide not working on my Windows XP Pro SP3.

    Since I am no expert, after reading all the entries around here I decided to give it a try to kill the explorer.exe in the Windows Task Manager. I know it looks like a sloppy & clumsy way to fix it, but it worked like a charm.

    (Use at your own risk)

    · Save all your work and close all your windows (you only see your clean Desktop)
    · Ctrl + Alt + Delete opens the Windows Task Manager
    · Select the Processes tab
    · Make sure the "Show processes from all users" is checked
    Now, if you are able to see the extensions ".exe" after every process:
    · Look for explorer.exe and select it
    · Click on the "End Process" button. Next thing you see is all icons and toolbars dissapear from your Desktop (probably your wallpaper as well), and you have the feeling your PC went 'kaput", but don´t panic. There´s only one more thing to do.
    · Press and hold the main power button of your PC until you know for sure your computer is shutting down and wait until its completely turned off.
    · Turn your computer back on

    Good luck.
    Monday, September 14, 2009 6:32 AM
  • + 1

    Dual/Multi monitor setup (occasionally) here as well with vertical (auto-hide/or not;) taskbar and latest MS OS available:

    Microsoft Windows [Version 6.1.7600]
    Copyright (c) 2009 Microsoft Corporation. All rights reserved.

    but I had this happen with Vista/Server 2008 and XP 32/64bit editions/horizontal taskbar etc as well (AFAIR).

     

    So.. As some things just don't seem to change, here's a one liner I'm going to use when the taskbar get's stuck the next time:

    runas /noprofile /user:Administrator "cmd /c taskkill /F /IM explorer.exe && explorer.exe"

    (You can copy/paste this to START Search box or START/RUN and press ENTER -- substitute Administrator with the user that has admin rights on your system)

    If you prefer to open the command prompt manually (in administrator context of course: write "cmd" in "START Search" box and right click/click "Run as administrator") the command(s) are:

    taskkill /F /IM explorer.exe && explorer.exe
    NOTE that this killes all the explorer instances currently open and (re)opens just one, so I would not use this when other users are logged on to the system or there's a bunch of important explorer windows open (nothing to do with Internet Explorer though).


    Hope that this helps (also with the frustration;)!
    • Proposed as answer by leafminer Tuesday, December 07, 2010 1:15 AM
    Thursday, October 15, 2009 9:53 PM
  • I do not have the same problem as posted in this blog, but I do find the peek-a-boo feature a bit annoying.  I usually have so many windows open that I put the task bar on the left or right side of the screen.  It makes the stacking and reading of icons easier to follow.  However, when I attempt to use my scroll feature in open windows, my mouse activates the task bar.  Same happens for left side of screen.  

    Is there a way to have the task bar unhide with a key combination.  In other words, the task bar will not reappear until I hover over the area and hit the shift key. 

    That would be a nice feature.  

    Wednesday, November 18, 2009 11:51 PM
  • Solution?

    The problem is, as pointed earlier, that the system recognizes some item in the taskbar or notification area that needs attention.  For example, if you don't use microsoft's firewall/antivirus software but something like Symantec antivirus, you will see a little red cross over a flag in the notification area, indicating that they have sent you messages.  This may explain the different experiences because people use different antivirus programs.  It is not a problem for earlier versions, but it seems to keep the bar up with Windows 7.  If you turn off the messages related to the item that needs attention or deal with it, autohide works again, until something else starts to bug you, of course.  What a pain!   Give it a try and see if it works, because it at least tells you where to look.  It worked for me, for now. 
    Monday, November 30, 2009 2:48 AM
  • http://www.ghacks.net/2008/10/06/restore-windows-taskbar-auto-hide/


    This helped me., And It is working Absolutely Fine Now :)

    Tuesday, December 01, 2009 5:55 AM
  • Same problem here, Windows XP Pro, will not be upgrading to Vista or 7. Taskbar just *loves* popping out of autohide and staying unhidden for the most asinine reasons. Every day my wireless goes down a few times, and Pidgin goes spastic, flashing the taskbar since I have told it not to steal focus. So I have to click Pidgin, then click the taskbar again just to resume what I was doing. If I set the taskbar to auto-hide, that means I want it to stay hidden unless I call it up, period, no ifs ands or buts. If something in the tray wants to notify me of something, it can wait until I choose to access the taskbar. Ideally, I could choose to override this on a per-process basis, but beggars can't be choosers, and I will be very happy if this Win98 feature finally EVER works correctly. Hilarious to see that it is still broken in Vista.
    Saturday, December 12, 2009 5:26 AM
  • Apparently their behaviour is the same as any other windows. Find the window using their API (you can use both c# or c++), 

    IntPtr winPtr = FindWindow("Shell_TrayWnd", "");

    and then

    ShowWindow(winPtr, (

    int)WindowState.SW_HIDE);



    This will force it to hide, or you can show. Works on XP, should work on the rest like vista too.

    regards,
    Kenny

    Tuesday, December 15, 2009 2:09 PM
  • SOLUTION - FOR ME WAS TO FIND A PROGRAM THAT IS IN THE TASKBAR (IN MY CASE IT WAS WINZIP) THAT IS CALLING FOR AN ACTION.  AS SOON AS I REMOVED IT THE TASKBAR AUTOHIDE BEHAVED PROPERLY.  I THEN REMOVED IT FROM THE STARTUP PROGRAMS SO IT DOESN;LT COME BACK TO HAUNT ME.
    Saturday, December 26, 2009 11:15 PM
  • What do you mean it just stays hidden?  I thought the problem was that it won't hide.





    If this was helpful, please vote by clicking the green triangle. If it solves the issue, click Propose as Answer. Thanks!
    Friday, January 08, 2010 3:24 AM
  • I purchased Windows 7 (Ultimate) after suffering through Vista (Business Edition).  Windows 7 has not solved this problem and it's obvious Microsoft doesn't give a damn about resolving it either.

    This is a company that doesn't read the forum's it supports.  This problem started two years ago and you don't see any solutions nor comments from tech support. 

    When my wife saw the problems I had with Vista, she bought a Mac.

    Windows 7 was the last sucker punch for me.     My next computer will be a Mac Pro.  After years of putting up with Microsoft's lame excuse for an operating system and benign "customer care", there will be no Windows 8 for me.
    Monday, January 18, 2010 3:15 PM
  • yeah, to get it gone... do like Zionykl said. First Ctrl+Alt+Delete. Then go to task manager. Once there head to processes. Find explorer.exe and end process. Your task bar will now disappear... don't worry. Go back into task manager again. Move back to applications and Add New Task. Type in explorer.exe. This will be added back to your processes and the problem should be fixed. Unsure if it works after shut down but even if it don't. That bit of time with it in Auto-Hide is amazing. Hope this helps C=

    Tuesday, January 19, 2010 6:11 AM
  • Maybe none of the developers care because so few people, proportionally, use auto-hide.  I don't mean that to say it doesn't matter, but over on the their blog, Microsoft noted that only 4.97% of people use that option (about 3/4 of the way down that page, there's an image).

    So maybe they just don't hear that this is a problem:  things usually have to be big to get all the way up the chain of customer service back to the developers.




    If this was helpful, please vote by clicking the green triangle. If it solves the issue, click Propose as Answer. Thanks!
    • Edited by Shawn B. KeeneMVP Tuesday, January 19, 2010 6:30 AM to add direct link to the image.
    Tuesday, January 19, 2010 6:29 AM
  • I've been fighting this problem for months on a Lenovo SL510 laptop with W7.  Today I got a clue:  I had both the Lenovo power mgr and the Windows power manager on the task bar.  Perhaps they were contending with each other somehow.  When I customized the systray to hide icons and notifications for the "Power" manager, my autohide started working again. 

    No long term testing yet, but it's working now, for the first time in a long while.
    Wednesday, February 03, 2010 10:04 PM
  • Maybe only 5% use it because it's broken....lol :\
    Sunday, February 07, 2010 6:15 PM
  • You might be right, honestly.  I haven't tried it myself because I'm obsessive about wanting to see what's there.  I don't know why.
    Sunday, February 07, 2010 6:19 PM
  • Try checking the top three boxes.
    Lock the Taskbar (that's the one I still needed)
    Auto Hide the taskbar
    Keep the taskbar on top

    I haven't had this problem for maybe 5 years. Reading this post finally jogged my memory that I figured out how to fix it way back then. I unchecked everything under taskbar, then re-checked them one at a time in this order (using apply for each one).
    Wednesday, February 24, 2010 2:38 AM
  • Saw a post down at the bottom... checked the flag icon. it wanted me to set up backups. clicked on the open action center. said to turn off notifications about backups and the problem cleared up.

    this is windows 7, but it may be the same kind of message that wants you to look at it.
    Wednesday, February 24, 2010 7:07 PM
  • so you spent 1000 dollars to buy a new computer plus software? geez. i fixed this by answering the flag icon and turning off notifications about backup
    • Proposed as answer by prodevel Friday, February 26, 2010 2:49 AM
    Wednesday, February 24, 2010 7:09 PM
  • yes, in my case it was the windows flag with a backup setup message. went to action center, turned off backup messages, and it works fine
    Wednesday, February 24, 2010 7:10 PM
  • Saw a post down at the bottom... checked the flag icon. it wanted me to set up backups. clicked on the open action center. said to turn off notifications about backups and the problem cleared up.

    this is windows 7, but it may be the same kind of message that wants you to look at it.
    I'm happy to have stumbled upon this thread.  Problem solved on my new win7 x64 home premium build.

    Thank you.
    Friday, February 26, 2010 2:48 AM
  • WARNING!
    This file contains a virus, according to my Comodo CIS 4.0.
    Regards
    Mats H

    HP Pavillion a6412.sc 4Gb RAM, Windows 7 x64 Home Premium, Comodo CIS 4.0, Samsung SyncMaster T200, Seagate Freeagent 500 Gb, HP 1510PSC
    Wednesday, March 17, 2010 11:37 PM
  • Check your system tray.  Any program that has an "!" sign, say an antivirus program that wants your attention, is causing the auto hide not to work (since it wants your attention).  Simply disable the program's alerts or go to task manager and kill the process.  I use AVG and don't use its email scanner, so it is constantly telling me that it is not scanning my email.  Killing the process let's the taskbar autohide again. 

     


    Tim G.
    Friday, April 02, 2010 11:32 PM
  • My virus warning was poorly described. Sorry for that!

    I was reffering to the "Taskbar Slapper".

    Got the warning as I downloaded for a trial, before recommending it, as a solution.

    Thank you for your intrest!

    Regards

    Mats H


    HP Pavillion a6412.sc 4Gb RAM, Windows 7 x64 Home Premium, Comodo CIS 4.0, Samsung SyncMaster T200, Seagate Freeagent 500 Gb, HP 1510PSC
    Saturday, April 03, 2010 8:38 AM
  • I hope I can be of some help...

    Often times Windows XP (and Vista) will refuse to hide because it mistakenly believes there is still a tooltip balloon open. (I see this a lot myself with APC's Powerchute Personal Edition.) Unfortunately the only way to get your taskbar to properly hide again (and I don't mean uncheck the "Keep the taskbar ontop of other widows" option for a quick fix) is to restart the machine so that Windows resets the tooltip balloon status. What a pain!

    Thankfully through my inability to let it go and hatred for this problem I have written a file that will fix this! (Works great on my Vista machine!) All the program does is overwrite the phantom tooltip balloon and then clear the tooltip balloon and Tahdah!

    The tooltip will stay up for 10 seconds so that you can read the info on it (just telling you what it does and how you can contact me if you have any problems). You can close this tooltip balloon like any other by clicking on it, or if you mouse over the program tray icon it will close itself instantly.

    You can find my "Taskbar Slapper®" hosted by FileFactory at the following address:

    <a target=_blank href="http://www.filefactory.com/file/ag932d0/n/Taskbar_Slapper_exe">http://www.filefactory.com/file/ag932d0/n/Taskbar_Slapper_exe</a>

    If you have any problems or questions (or would like to know what other little programs I've made such as Task Stopper® - for when any program generates a CPU intensive loop that even taskmanager can't pull you out of) please feel free to email me at: NovaFrost@cox.net

    I hope this helps you like it did me!

    This worked perfectly for me on Windows 7 Home. It is annoying to reply on a tool for basic functionality like this, but it is better then it being broken. THX!
    Friday, April 16, 2010 2:51 AM
  • All this proves to me is that microtrash is the worst consumer product on the market. if I had a business i would not allow ANY micrsoft product on any company owned computer. I think i will give Linux a try. it could not be any worse than what i have now. Microsoft Please do not release any new O.S. just fix all the security issuse and bugs in what you have out now. is that too hard???
    Wednesday, April 21, 2010 5:23 PM
  • I think i found the solution! And its very easy! do you use accounts on the computer eg theres 3 different accs on 1 computer instead of just 1 user. Its so simple! just log off and log back in! the taskbar will auto hide as normal!
    Tuesday, April 27, 2010 7:19 PM
  • Even though he is quite an arrogant ____ Jobs does believe in product support and Apple does test all new products to work the bugs out before release. Unlike some others. It might be time to tell Mr.s Lewis and Gates stick it where the sun don't shine and try a Mac. or a different O.S. I like Xandros pro desktop linux distro I run a dual boot system. But there are some apps for work that have to have windows to run or else I would remove windows. Microsoft got to where they are by having a captive market. Up until the mid nineties every Intel based machine was sold with windows on it. So you had two choices Windows or Mac. Now we have other operating systems to pick from. the way it should have been from the beginning.
    Tuesday, April 27, 2010 7:40 PM
  • woooowww thanks soo much man!

    This thing works everyone!

    Thursday, May 06, 2010 1:00 AM
  • @Shawn B. Keene

    I'm not really happy with this answer.

    I'm not sure about vista, but at least as far as XP is concerned, maximised programs WILL still fill the space behind the taskbar. So having the taskbar constantly up means your losing the all important slide control (and possibly more stuff) at the bottom of any software window. MAKE SENSE??? 

     

    Everytime you want to use the slider, you'd have to meddle with taskbar settings. Is this acceptable? NO!

     

    If microsoft want us users to have the taskbar constantly up, then maximised programs should respond intelligently to that, and NOT USE THAT SPACE and until they do, i'm afraid it's no solution.

     

    Sunday, July 11, 2010 1:09 AM
  • I want to stick my oar in here, as I’ve had this problem for some time, even back to Win XP HE SP 1. Now I’m running WinXP SP3, and it still happens. It’s an intermittent problem.  Maybe because its intermittent, nobody cares to fix it.  And now that Micro$oft has issued Vista (yech!) and Wiin7, odds are that they never will. I traced this problem back to 2002. I see on other forums that its still happening in Vista. I dunno about Win7.

    For me the taskbar gets stuck in some known circumstances: in Firefox, the task bar sometimes won’t hide until I pass the cursor over the Downloads window. Or when Im running Framemaker in full screen mode, the taskbar gets stuck either hidden or visible. Or after I play an old Win-16 full-screen game. Or else the taskbar gets stuck whenever it feels like it.  

    Usually I can just right-click the taskbar, click (or un-click) auto-hide, and Apply, then OK, then do it again, and the problem disappears.  Usually.  Not always.  The problem stays “solved” until I start Firefox or some other full-screen application.  Or until it wants to ____ out again.

    In any case, when it’s really locked and setting/resetting taskbar properties doesn’t help, then killing and restarting the explorer process fixes it. Use the Ctrl-Alt-Delete task manager for that. No need to log of and on. Usually Explorer.exe will restart on its own. If not, just start it from task manager. (New Task: type in explorer.exe).

    But I have another solution many people won’t like, but I use it all the time.  (I wish it worked for the MS Office Shortcut Bar.)

    I use the autohotkey scripting language (free from www.autohotkey.com). There is a script called RunAndHide.ahk, available from www.donationcoders.com. Its only 668  bytes (!), stays in the background, and causes the Windows Keyboard right-Windows key to toggle the taskbar between Normal and hidden.  So if it’s set to autohide, and it doesn’t autohide, then hit Right-Winkey, and it disappears.

    Forcing the taskbar to hide/unhide with a simple and easy keystroke is often very handy. This way the hidden taskbar won’t pop up all the time when I run the mouse too close to the edge of the screen.

    Hope you folks find this info helpful.

     

    -Harry

     

    Thursday, July 29, 2010 4:03 PM
  • I thought I would not have to experience this same exact issue as I have in Windows XP since the end of 2001, but alas, it has reared its ugly head in Windows 7!

    AAAAARRRGGHHHH!!!!

    For the love of humanity, M$ PLEASE FIX THIS DREADED BUG AFTER 9 YEARS!!!!!!!

    Tuesday, August 03, 2010 5:36 AM
  • Worked beautifully. Great script.
    Thursday, August 05, 2010 9:18 PM
  • So I've been having this problem since I got my laptop for college. I'm running Windows 7. I absolutely hate it. But I was noticing that the taskbar wouldn't autohide...I've had this computer for six months, and I just realized that it was staying up because somehow I would click on it and the window would no longer be active. Completely worked. That may be you problem, if it is ouila, if not, I feel ya...

    -Rob

    Friday, August 06, 2010 6:07 PM
  • This problem drives me nuts. WHO decided that we ALWAYS want to know every little thing that wants attention or a pat on the back for completing something or that new updates have been downloaded or be told every few seconds that something I intentionally disabled with full presence of mind IS disabled and to click here to enable ahhhhhh! NUTS.Why can we not truly choose to AUTOHIDE the taskbar?!! Why can't we choose to not be bugged by Windows proud alerts when we are working on OTHER things? I promise to check in with all those issues later! When I am finished working! Now STAY DOWN TASKBAR!

    See. Driven insane.

     

    Thursday, August 12, 2010 3:21 PM
  • The same thing happened to me. i NEED my taskbar to go down. I can't even chat on facebook any more!!! This really sucks and SOMEONE needs to put a stop 2 this or I will!
    Wednesday, August 18, 2010 1:49 PM
  • I have talked to several techs and they can get it working again but for only short periods. Also, the options available in XP and Vista are different from 7 x 64 bit..
    Wednesday, August 18, 2010 3:51 PM
  • YOU ARE RIGHT ON THE MONEY, ANTIDOTE X -- Your simple solution makes perfect sense and WORKED FOR ME on my Windows 7 PC.  Skype was alerting me and when I quit it, it let go of my task bar which now auto-hides beautifully.  THANKS A MILLION, NO, A TRILLION (inflation), AX!!!
    Thursday, September 02, 2010 12:00 PM
  • You were absolutely correct! I had a download waiting. As soon as I clicked on it the task bar went to autohide.

    Thanks!

    Tuesday, September 07, 2010 1:04 AM
  • OK, I have been fighting it for about a mounth. I just fixed it. I went to the Right hand task bar and clicked on the up arrow (show hidden icons) then went to customize and changed everthing But the Volume to only show notification . The bar is working great!!!!!
    • Proposed as answer by SacPrince Friday, October 15, 2010 6:41 PM
    Friday, October 15, 2010 6:40 PM
  • OK, I have been fighting it for about a mounth. I just fixed it. I went to the Right hand task bar and clicked on the up arrow (show hidden icons) then went to customize and changed everthing But the Volume to only show notification . The bar is working great!!!!!
    Friday, October 15, 2010 6:42 PM
  • Try checking the top three boxes.
    Lock the Taskbar (that's the one I still needed)
    Auto Hide the taskbar
    Keep the taskbar on top

    I haven't had this problem for maybe 5 years. Reading this post finally jogged my memory that I figured out how to fix it way back then. I unchecked everything under taskbar, then re-checked them one at a time in this order (using apply for each one).


    Happened again after 10 months, and the same order made it work. Again,

     

    1. Uncheck all. Apply. OK.

    2. Check lock the taskbar. Apply. OK.

    3. Check Auto-hide the taskbar. Apply. OK.

    4. Check Keep the taskbar on top of other windows. Apply. OK.

     

    Only that order works for me. Hopefully it'll last at least another 10 months.

     

    (btw I saw someone mention the Firefox Downloads window. I recently installed firefox for the first time in a year or two, and yeah, that window seems to be related. Taskbar won't auto-hide until you mouse over it. This was a precursor to the larger problem though, of having to go through these steps to fix it)

    Friday, October 22, 2010 6:22 AM
  • Open task manager, find explorer.exe and end the process then go to new task and put in explorer.exe, hit enter and that will fix the problem. it restarts explorer.
    Tuesday, October 26, 2010 8:59 PM
  • I solved this problem by installing a program called Taskbar activate which worked well in delaying the taskbar popping up by the time you set----it is free and got from

    http://www.brothersoft.com/taskbar-activate-12017.html

    • Proposed as answer by Jotherstoli Thursday, November 04, 2010 4:32 PM
    Thursday, November 04, 2010 10:50 AM
  • TO GOOD TO BE TRUE??????         PLEASE Read BEFORE YOU INSTALL

    I came across this link while checking it out.

    http://www.prevx.com/filenames/2936931068067510035-X1/TASKBAR+SLAPPER.EXE.html

    Sunday, November 21, 2010 2:39 AM
  • WOW! so simple and it worked like a charm on my windows 7,  THANK YOU
    Wednesday, November 24, 2010 1:12 PM
  • Thanks Alan Tamm for putting it simply

    i.e. kill explorer.exe and restart it.

    Cost me time and good humour so often as I tried to remember how i had cured it before,
    which usually meant finally getting to this manually, never quite believing that the problem would recur.

    Well it does!

    NOW my taskbar has a batch file with a suitable *^%^$&# icon on it which does exactly this!

    KILLME.BAT
    taskkill /F /IM explorer.exe && explorer.exe

    Good humour slowly returning ....

    Tuesday, December 07, 2010 1:24 AM
  • XP Pro

    Just joined up to get some help.  Come home from a gig and auto-hide will not get the heck out of the way.  Go to Start properties and uncheck auto-hide, hit apply, wait forever then re-check auto-hide and see the taskbar go down..., Yipeee!!  I do about two keystrokes and the task bar won't vacate my screen again.  I am almost blind so I enlarge the screen quite a bit so I need to use the bottom screen bar to move screen left or right so I can read the full sentence.  I know I can use the keyboard but I'm really lazy and have my finger on the mouse anyway.  With the auto-hide up, no lower bar so I just end up going to a bar.

    Help!!!

    How do I receive answers..., like I said I am lazy so if someone can tell me how to use this place in a short message, I may spend more time here...., my liver will thank you

    Told you I was lazy..., didn't have the strength to even scroll down. I see some fixes and will let you know how it comes out..., or not (remember, I am a lazy drummer/percussionist who sits around doing nothing counting measures. ;)
    • Proposed as answer by CatharineC Wednesday, January 26, 2011 6:42 PM
    Sunday, December 26, 2010 11:45 AM
  • To any one who is having a problem with the Task Bar I may inadvertently have solved the problem.

    I started getting it a lot recently and was getting really fed up. Suddenly I could not play any my games on Facebook. (may be an adult but I am an addict to them especially farmville and the task bar just gets in the way).

    I cleared the browsing history and cleared everything and it was as simple as that. Task bar stays out of the way as it should. 

    If this helps anyone else just let me know.

    Wednesday, January 26, 2011 6:49 PM
  • To any one who is having a problem with the Task Bar I may inadvertently have solved the problem.

    I started getting it a lot recently and was getting really fed up. Suddenly I could not play any my games on Facebook. (may be an adult but I am an addict to them especially farmville and the task bar just gets in the way).

    I cleared the browsing history and cleared everything and it was as simple as that. Task bar stays out of the way as it should. 

    If this helps anyone else just let me know.

    Wednesday, January 26, 2011 6:51 PM
  • To any one who is having a problem with the Task Bar I may inadvertently have solved the problem.

    I started getting it a lot recently and was getting really fed up. Suddenly I could not play any my games on Facebook. (may be an adult but I am an addict to them especially farmville and the task bar just gets in the way).

    I cleared the browsing history and cleared everything and it was as simple as that. Task bar stays out of the way as it should. 

    If this helps anyone else just let me know.

    Wednesday, January 26, 2011 6:52 PM
  • To any one who is having a problem with the Task Bar I may inadvertently have solved the problem.

    I started getting it a lot recently and was getting really fed up. Suddenly I could not play any my games on Facebook. (may be an adult but I am an addict to them especially farmville and the task bar just gets in the way).

    I cleared the browsing history and cleared everything and it was as simple as that. Task bar stays out of the way as it should. 

    If this helps anyone else just let me know.

    • Proposed as answer by halfountainsr Thursday, February 10, 2011 6:09 PM
    Wednesday, January 26, 2011 6:53 PM
  • To any one who is having a problem with the Task Bar I may inadvertently have solved the problem.

    I started getting it a lot recently and was getting really fed up. Suddenly I could not play any my games on Facebook. (may be an adult but I am an addict to them especially farmville and the task bar just gets in the way).

    I cleared the browsing history and cleared everything and it was as simple as that. Task bar stays out of the way as it should. 

    If this helps anyone else just let me know.


    There isn't a problem with Micrsofts auto-hide on the taskbar. What it is the majority of the time is there is something in your notification area that needs your attention. This works for me evertime my taskbar won't auto-hide. One more thing if you have recently added a new program that put an icon in the notification area it could be the culprit. I hope this helps most of you.
    Thursday, February 10, 2011 6:47 PM
  • This is just an addition to my previous info. Try hovering your mouse over each icon in th notification ares (far bottom right) and pay special attention to the white flag. Thats where most of your problems arise. It's a safty measure so you don't forget about those notifications when you auto-hide the taskbar. Not a flaw with Windows.
    • Proposed as answer by MuthuPugal Tuesday, February 22, 2011 3:37 PM
    • Unproposed as answer by MuthuPugal Tuesday, February 22, 2011 3:37 PM
    Thursday, February 10, 2011 6:56 PM
  • My problem is i can get the task bar back by simply pressing ctrl + esc or ctrl + f7 and many other ways but everytime i get it back if i click somewhere else bam! the task bar has gone again :( its only there on my desktop and i cannot work it out someone please help!
    Sunday, March 06, 2011 10:55 AM
  • This can be for several reasons 1 first you must right click the Task bar and check auto hide and apply. If that did not work then make sure nothing is flashing in the task bar. for I.E a recent download in Mozilla or new email in Microsoft email. That should fix your Issue. This is probably cause some want to notice it .
    Wednesday, April 06, 2011 8:17 PM
  • This is just an addition to my previous info. Try hovering your mouse over each icon in th notification ares (far bottom right) and pay special attention to the white flag. Thats where most of your problems arise. It's a safty measure so you don't forget about those notifications when you auto-hide the taskbar. Not a flaw with Windows.


    Like hell it's not a flaw with Windows.  If there's something I need to be notified about, pop up a window to notify me and let me dismiss it.  Don't stick it on the task bar and hope I'll notice it, while disabling the function I've specified on the task bar.  I turned off Windows Defender to get rid of all the messages from the "white flag", and I still can't get the task bar to hide.

    Plus, that's not the problem in my case anyway.  I don't have ANY notifications, and the damned task bar still won't go away.  I unclick and apply "auto hide taskbar", then click and apply "auto hide taskbar".  The task bar goes away for a tenth of a second just to show me it can, then pops right back up again. 

    Damn, you figure being a late adopter would avoid this type of problem, but I see that people have been complaining about it since 2008 (THREE YEARS) and it's still not fixed.  Well, at least they aren't telling me the task bar will work the way I want if I upgrade to the PROFESSIONAL EDITION.

    Linux is looking better all the time...


    Wednesday, April 20, 2011 5:57 PM
  • Stumbled on another way of "jiggling the handle" to make the taskbar hide.

     

    My taskbar would not auto-hide, no matter how many times I checked / applied / unchecked the auto-hide option.

    After doing the following the task bar magically started auto-hiding:

     

    1.  Right click task bar and go to properties.

    2. Click the toolbars tab.  Choose one or more of the toolbars (address, links, desktop, etc.) and click Apply.

     

    Quite unexpectedly, the taskbar started auto-hiding after I did that. 

    Hope this helps someone.

     


    Brett
    Friday, May 20, 2011 1:47 AM
  • I had the same problem and fixed it by ending the explorer.exe process and restarting it with task manager.
    Thursday, May 26, 2011 10:40 PM
  •  

    Here's a VB Script that will kill and restart Explorer. Fixes the AutoHide problem for me in Win 7 - 64.

    Just paste the code into Notepad and save with the .vbs extension (e.g. killexplorer.vbs).

     

    strComputer = "."
    Set objWMIService = GetObject("winmgmts:" _
        & "{impersonationLevel=impersonate}!\\" & strComputer & "\root\cimv2")

    Set colProcessList = objWMIService.ExecQuery _
        ("SELECT * FROM Win32_Process WHERE Name = 'explorer.exe'")  
    For Each objProcess in colProcessList
        objProcess.Terminate()
    Next

    set WshShell = CreateObject("WScript.Shell")
    WshShell.Run """C:\windows\explorer.exe"""


    Sunday, May 29, 2011 6:59 PM
  • Zenai's post WORKS GREAT.  I PUT A SHORTCUT ON MY DESKTOP FOR IT, AND SIMPLY CLICK ON IT EVERY TIME TASKBAR FREEZES. 

     

    I AM USING WINDOWS 7-64 BIT.  ANYWAY TO KEEP THE "LIBRARIES" FOLDER WINDOW FROM OPENING WITH I RUN THIS SCRIPT THOUGH?


    Tuesday, June 14, 2011 2:43 PM
  • I AM USING WINDOWS 7-64 BIT.  ANYWAY TO KEEP THE "LIBRARIES" FOLDER WINDOW FROM OPENING WITH I RUN THIS SCRIPT THOUGH?



    Just remove the last two lines:

    set WshShell = CreateObject("WScript.Shell")
    WshShell.Run """C:\windows\explorer.exe"""

     


    Wednesday, June 15, 2011 9:19 AM
  • Hi, it is THAT simple:

    Set tasbar to auto-hide,

    Set taskbar behavior to default. No prog-icons should show despite windows default.

    Now enable ( pardon, I'm using a german system) every single icons behavior in single steps.

    You should find out which prog-icon disturbs, let that be hidden (no sign, no notice) if you can afford it.

    With that everything works fine.

    BTW: It's NOT always Microsofts fault. I'm using win7x64 on a MacBook, so there is everytime an other option

    for me ( LÖL). Hope that helps.

    Saturday, July 09, 2011 11:22 PM
  • Umm hello leafminer, You wrote..

       i.e. kill explorer.exe and restart it.

     

    ahh yes. Do this simply by logging off and logging back into Windows again I think. System should be a lot more stable that just taking out explorer.exe with a script or via taskmanager etc. Hope this doesn't hurt anybody's feelings. I guess you can't beat a good myth though. ;-)

     

    Regards. pkn2011

     

    • Proposed as answer by pkn2011 Sunday, July 10, 2011 1:33 AM
    Sunday, July 10, 2011 1:31 AM
  • This may be caused by something wanting your attention.  Similar to when someone sends you an Instant message, the item in the task bar lights up and you have to bring focus to messenger to make it go away. 

    Check all your system tray icons to see if any of them are in a state of alert.  For example: email faling to sync, anti-virus failing to retrieve definitions, Security Center with a Red shield, anything else with an exclamation point.

    This was driving me nuts for days.  I tended to some of these system tray issues and the problems have ceased.

    Nailed it. I am a procrastinator and windows updates are the worst for me. "37,436 important updates and security fixes need to be installed...." not really, but kinda feels like it. Ran the updates, no problems at all. I can imagine the guys at MS were looking for a creative way to get people to install the updates. Annoying them seems to have been the answer to me. Pretty dang effective and, if true, quite brilliant. WTG MS! I will, from now on, keep my stuff up to date.
    Sunday, July 10, 2011 8:16 PM
  • Hi Zeggman, you said

    Plus, that's not the problem in my case anyway. I don't have ANY notifications, and the damned task bar still won't go away. I unclick and apply "auto hide taskbar", then click and apply "auto hide taskbar". The task bar goes away for a tenth of a second just to show me it can, then pops right back up again.

     

    Do you have 'balloons tips' set as off too. Can't recall offhand where you do this though - someone's bound to know in here though.

    I've my Taskbor UNhidden here - I like seeing what's running. But if you want it hidden then the systray popping up alert notifications you should consider as  helpful in alerting you to any problems. Once the alert is dealt with then the Taskbar can go back to auto-hide. I'd suggest that's how it's SUPPOSED to work.

    It's not really the taskbar NOT auto-hiding. It's the systray alert that's forcing it to be displayed.

    Btw if you know how to code (or someone else?) perhaps you can PIPE any output display heading for items in the systray into a pop-up console window instead?

     

    Regards, pkn2011

     

    Sunday, July 10, 2011 10:02 PM
  • Do you have 'balloons tips' set as off too. Can't recall offhand where you do this though - someone's bound to know in here though.


    I've tried to turn off ballonos in XP, in the registry. It did remove the ballons, but the taskbar still popped up whenever a ballon was supposed to show up. That was even worse, for you could not click the balloon to make the taskbar hide again.

    Don't know if they've fixed this in Win 7.

     

    Monday, July 11, 2011 5:48 AM

  • Hi Zenzai, you said..

    I've tried to turn off ballonos in XP, in the registry. It did remove the ballons, but the taskbar still popped up whenever a ballon was supposed to show up. That was even worse, for you could not click the balloon to make the taskbar hide again.

     

    I'd think most of the balloons are coming out of software running. You'd really need to go to every programs' settings that you normally run and turn off any balloons and notifications - perhaps even auto-updates. from there. I just thought Windows would have a master switch that could turn them on and off in one click. Not sure if it does. I'll write back here if I spot something.

    All the programs output to the system tray as a default, there must be someway you could intercept them before they get there and PIPe them into a logfile or a console window even play them as a soundfile through the speech interpreter. <g> I don't have the skill to do this though. Maybe you could intercept the output with your .vbs type code?

    But yes, like with turning notifications OFF. Just because you can't see them doesn't mean they're still not making a call to the systray which in turn tells the taskbar to reappear.. And if you can't see them they can't be closed. And if they don't receive that signal they also likely won't tell taskbar to go back to auto-hide..

     

    Regards, pkn2011

     

    Monday, July 11, 2011 6:17 AM
  • I'd think most of the balloons are coming out of software running. You'd really need to go to every programs' settings that you normally run and turn off any balloons and notifications - perhaps even auto-updates. from there. I just thought Windows would have a master switch that could turn them on and off in one click. Not sure if it does. I'll write back here if I spot something.

    All the programs output to the system tray as a default, there must be someway you could intercept them before they get there and PIPe them into a logfile or a console window even play them as a soundfile through the speech interpreter. <g> I don't have the skill to do this though. Maybe you could intercept the output with your .vbs type code?

    But yes, like with turning notifications OFF. Just because you can't see them doesn't mean they're still not making a call to the systray which in turn tells the taskbar to reappear.. And if you can't see them they can't be closed. And if they don't receive that signal they also likely won't tell taskbar to go back to auto-hide..


    To my experience, many programs do not have an option for turning off balloons, unfortunately

    I found a interesting link here however, about turning off the balloons in Win 7:

    http://4sysops.com/archives/how-to-turn-off-balloon-notification-messages-in-windows-7/

    Quote: "Even better is that it is now possible to turn off notification messages selectively. If you click on “Change Action Center Settings” in the navigation bar of the Action Center, you can tell Windows 7 what kind of problem messages you want to be notified about in the future. Nine types of messages can be turned off or on separately (see screenshot). Considering that Microsoft hid this notification switch in former Windows versions, this is a remarkable step."

     

    Monday, July 11, 2011 7:08 AM
  • Hi Zenzai, you said..

    Quote: "Even better is that it is now possible to turn off notification messages selectively. If you click on “Change Action Center Settings” in the navigation bar of the Action Center, you can tell Windows 7 what kind of problem messages you want to be notified about in the future. Nine types of messages can be turned off or on separately (see screenshot). Considering that Microsoft hid this notification switch in former Windows versions, this is a remarkable step."

     

    Yes, I had action centre telling me to check my backup settings due to a scheduled backup failing because I didn't have the backup HD connected at the time, turned off the prompting on both 64bit and 32bit Win7's without any complaints. Vista let's you tell the pop-up to stop popping up the error; hehe well at least until the next scheduled backup possibly sets it off again. 8-). 

    I'll snap that link though. Thanks

    pkn2011

    Monday, July 11, 2011 7:25 AM
  • I can see how annoying that must be for you, although i don't do any work with graphics my work does require me to have a lot of screen space to my disposal, i honestly cant believe Micro$oft are just ignoring this issue, it makes no sense at all, removing the prefetch folder from C:\Windows worked for me but its beside the point, i may be a MCDST but i should NOT have to do this because Micro$oft cant be asked to fix this seemingly trivial issue.

    I wouldn't go as far to say I'm going to buy a MAC but i have never had this problem with ANY Linux operating system.

    Sunday, July 17, 2011 1:54 PM
  • Still on XP, and it happens to me once every few months. Restarting usually works, but I tried to do it without doing that this time. What worked for me was ending the explorer.exe process and running it again. Problem solved. I don't know if it was already mentioned, but the first few suggestions (deleting prefetch, checking and unchecking autohide, etc.) did not work for me.
    Thursday, July 28, 2011 2:57 AM
  • Explorer autohide stops hiding when several apps attempt to notify you of updates. examples Adobe acrobat does a pupunder. It is not worth the effort to read all the messages and notifications and try to clear them as that does not always reset the explorer. I make a set of shortcuts based on each explorer window I had open then I kill the explorer process(es) the restart it with task manager (windows 7 32 bit) I have balloons disabled. Then I reneabled them and they do not work, in an effort to locate this problem. I observe a popbehind or notification balloon or taskbar flash wehn this problem starts. Definately related to taskbar notifications.
    Saturday, August 20, 2011 12:15 AM
  • That's the ticket, for sure. I've noticed some active pop-ups that were not visible because they were underneath a window but when they were exposed and closed, the taskbar dropped out of site. However, that is not always the case. The your tip caused me to click on a a program in the task bar that wasn't running - MS' Calculator. Calculator started, I killed it and the task bar slipped down under again.

    The other cause seems to be if a program is minimized but almost full screen height and the bottom edge is below the top of where the taskbar top is, then the taskbar won't hide until I move the window or reduce it to an icon.

    This is probably something that could be fixed my merely adding a few hundred megabytes of compiled code. Isn't it strange how Windows 3.1 work work fine with 2 MB of memory and now with Windows 7, you need 8 GB of memory. Windows isn't the only culprit of code bloat, all the applications are huge too and this applies to the Linux kernel and Mac OS too. Why?

    Saturday, August 27, 2011 11:06 PM
  • I like how this problem has been around since (almost) 2007 and here it is in 2011 and I'm getting the same problem in Windows 7. C'mon, Microsoft... Do you use your own products?
    Thursday, September 08, 2011 12:39 PM
  • This just keeps my current web  page on top.   To see taskbar I must lower web page.  Not much help!
    Saturday, September 24, 2011 12:09 AM
  • Different computer type same software.  Same problems!!!
    • Proposed as answer by Novice 2008 Tuesday, January 31, 2012 8:46 AM
    Saturday, September 24, 2011 12:10 AM
  • hi

    yes, Windows' taskbar sucks, when it remains stuck instead to disappear, because it comes in conflict with the use of some other software. I just found a little software called "Autohide Taskbar 0.1", which you control with WIN+a or WIN+A to hide the taskbar. It works now finally with my Vista Home Premium version - just that I have to type the key-combination twice to kill the taskbar to the background. There is also a symbol close to the clock, but this does not work for me.

     

    Here is the link to the software:

    http://download.cnet.com/Taskbar-Autohide/3000-2084_4-10831131.html?tag=mncol;1

    There would be a newer version 0.2 around, but unfortanetaly it is not possible to download it from http://www.download.com directly.

    I wish all users good luck to give to this little application a try.

    • Proposed as answer by lixurion999 Saturday, September 24, 2011 8:59 PM
    Saturday, September 24, 2011 8:58 PM
  • I had the same problem.  Today I noticed an adobe icon in the task bar indicating an update to adobe reader.  After installing the update the adobe icon disappeared and auto hide worked perfectly.  Sounds silly but it did the trick.
    Friday, January 13, 2012 2:39 AM
  • Possible Solution!

    I right-clicked on the Windows Defender icon in my trey and as soon as I hit "Check for Updates" the task bar went back into auto-hide mode.

    Talk about annoying... and bare luck to discover the problem/solution.

    I hope this works for everyone else. It seems to have worked for me... for now.

    E.
    • Edited by Ematu Friday, February 03, 2012 3:36 AM
    • Proposed as answer by Ematu Friday, February 03, 2012 3:37 AM
    Friday, February 03, 2012 3:34 AM
    • Proposed as answer by BuyX Saturday, March 03, 2012 1:57 PM
    Saturday, March 03, 2012 1:57 PM
  • Many years later...

    Many, many posts later about the same issue...

    ... Same issue.

    It seems I solved the problem by turning off Windows updates.

    Sunday, June 10, 2012 2:36 PM
  • Thanks!  This worked for me as well.  This was driving me crazy!!
    Wednesday, June 13, 2012 1:55 PM
  • Try CTRL & ESC.  It works for me with XP SP3 and IE8.0
    Wednesday, August 15, 2012 3:45 AM
  • This notorious problem has came back to haunt me on Windows 8. The problem happened right after an recent automatic update and restart. How can Microsoft still failed to sort this out after so many years?
    Thursday, January 10, 2013 11:28 PM
  •  I was reading these solutions, and someone said, see if there is something that requires your attention.  I am using windows 8 with an emulator for vista or xp or 7 or something like that, so i can have a start button etc on desktop.

    Anyway, instead of looking on the left, I checked the notifications on the right of the taskbar.  It was saying i had files to burn.   I deleted them, because I already burned them.  Then the taskbar stayed hidden.  Then I got a box come up, Jucheck.  I always click yes on that.   The taskbar came up again and would not hide. 

    I went to the right again, and checked another notice for a java update, then the taskbar hid itself again, and Jucheck did not come up, and it is hidden now.  So it has to do with menial checks on the right of the taskbar.

    Wednesday, January 30, 2013 11:09 PM
  • I found the solution!
    I have been having this problem for a little over a week now and i was getting frustrated. i have had a few issues with it before so i know where it is in the task manager. so this is what i did.

    open task manager
    go to Processes
    click on Explorer.exe
    click End Task
    go back to applications
    click New Task
    type in Explorer.exe
    hit run
    make sure that auto hide is active. and it should start working again.

    hope it works for you as well.

    • Proposed as answer by junkdog8 Sunday, March 10, 2013 8:52 PM
    Sunday, March 10, 2013 8:52 PM
  • Thank you so much  Junkdog8 - it worked for me - after several months of wondering whether it was me or the machine.

    I struggled through many of the earlier would-be solutions posted from 2008 and onward and, like others, I'm amazed at the inability of MS to communicate with its customers. 

    I then decided to jump to this latest, yours, which was from only a week ago.  I have a three-year-old Windows 7 machine and I did have to "translate" some of the labeling in Task Manager but other than that it was a snap.  As soon as I hit "run" - two things happened: the auto-hide immediately clicked into action - and an Adobe Flash Player Install Reminder window popped up.  Hmmm.  Did the culprit reveal itself?  I've always hesitated whenever Adobe wants to install something - the frequency of these requsests to install made me suspicious....  

    Thanks again for taking the time to post.

     

    Monday, March 18, 2013 7:08 PM
  • Same thing happened to me today.  Autohide kept locking for no reason, then I can checking un-autohide, autohide, then okay.  Worked for a while, then had issue again.

    So I killed the explorer.exe process then reloaded and has been working fine ever since.


    I can't believe Microsoft can't find and fix these errors.

    Hope this helps someone else, thanks,
    David Blaine Fullerton
    Thursday, April 25, 2013 11:06 PM
  • Impressive almost 10 years after thread is started.

    I can't believe why Microsoft are trying to kill the Desktop instead of fixing the problems it seems to have grown up with or just giving it alternative approach.. However I do understand killing explorer.exe, maybe Windows 8 is just the first step, but I want to see it with a proper desktop again before even throwing a dime that way.

    Ahh well. The prefetch did it for me, but I didn't try killing explorer.exe (this time). I do remember the problem appearing after having an old game up requiring me to kill explorer.exe. Maybe that's what messed up the prefetch.

    Monday, June 03, 2013 4:29 AM
  • I have been plagued with this problem in Windows 7 for some time.  This fix worked well and takes only a few seconds to execute.  Thanks!
    Friday, July 05, 2013 5:03 PM
  • Thanks!  Brilliant and simply, who would have thunk!
    Friday, August 23, 2013 9:36 PM
  • "This may be caused by something wanting your attention.  Similar to when someone sends you an Instant message, the item in the task bar lights up and you have to bring focus to messenger to make it go away.  Check all your system tray icons to see if any of them are in a state of alert."

    This worked for me!

    I notice that this thread is 5 years old and, as far as I can see, MS has done nothing to overcome it.  I may be slow but I'm not THAT stupid.  Goodbye Redmond; Hello Cupertino!

    Thursday, August 29, 2013 6:47 PM
  • "I've been having this problem on and off for years on the systems I support... There is a VBS script that simply resets default Windows values for the Start/Task Bar... It works every time I need to use it.. You can download a copy from:

    Hope its helps all..

    Monday, September 07, 2009 1:36 PM"

    This Worked for me.

    Wednesday, September 04, 2013 4:53 PM
  • Having this problem too with Windows 8.1. Your emergency-fix resolves it for a while; damn Microsoft. 
    Saturday, January 04, 2014 9:33 AM
  • Is anybody from Microsoft reading these threats??

    Solution please pronto!!!!!!!!!

    Saturday, January 04, 2014 9:34 AM
  • I just had the same problem; then I just restarted my computer.

    All fixed. :3

    Thursday, May 01, 2014 8:53 PM
  • this worked, thanks so much
    Wednesday, May 07, 2014 3:36 AM
  • this worked, thanks!
    Wednesday, May 07, 2014 3:37 AM
  • Thanks for the detailed directions, it worked!
    Wednesday, May 07, 2014 3:38 AM
  • For me, mine sometimes refused to hide. What fixes it for me is plugging in my headphones and unplugging it and then clicking x on the notification about the headphone.
    Tuesday, July 15, 2014 3:06 AM