none
Resolution changes after every reboot

    Question

  • Hi Guys and Gals,

    Ive got an interesting one for you all here!

    Im running Beta 2 version 5384 and everytime i log on, for some reason my resolution changes to 1400x1050 (basically the biggest resolution availible)

    Every time i have to go in and change the resolution back down to a useage size, but then after a reboot/shut down it has forgotten it again and is back up to 1400x1050. It is also setting my refresh rate on my screen to 60hertz (lowest setting) so i have to change it back everytime i reboot/shut down.

    Anybody have any ideas?

    Thursday, June 29, 2006 11:26 PM

All replies

  • Hi,

    Could anybody shed any light on this issue as it is very very annoying having to change the resolution & refresh rate EVERY time i log in

    Thanks again.

    • Proposed as answer by 945 Sunday, March 29, 2009 7:57 AM
    Tuesday, July 18, 2006 4:57 PM
  • Weird problem indeed.  Only things I can suggest are to either uninstall/reinstall your current video card drivers, or uninstall your current drivers and try a different driver package.  Check with your video card manufaturer as well as with Nvidia/ATI for the latest drivers available for your card.  Also, if you haven't tried already, let Windows Update search the net for the latest drivers and see if those correct the problem.

    Good luck.

    Tuesday, July 18, 2006 5:37 PM
  • Think I had to fill out enough forms to even post here? UHG


    ANYWAY

    I Am having the same issue. EVERY Reboot 60hrz Refresh rate. Tried New drivers
    Tried all sorts of things. This happened after my vid card fan made noise taking it out replacing it and putting it back in. uninstalling drivers reinstalling new drivers.
    Again every reboot have to change the refresh rate. VERY annoying.
    ANY help here? Ive been searching for hours.

    Thanks
    Dean
    wallofchaos@yahoo.com
    Sunday, October 01, 2006 7:11 PM
  • Hi,  I am also having the same problem and I see that a lot of people posting the same things but no one knows the answer.  I have heard it's a BIOS issue, and over-heating issue (I doubt it), or a driver issue.  NONE OF THE ABOVE HELPED ME!

    Although, I see that there are similarities with people having these problems.  They all have:

    1.) The same updated drivers
    2.) Service Pack 2
    3.) Issues occur with both ATI and Nvidia.

    I suspect this is a windows registry issue.  I looked up some of the registry options.  Also to no avail.  This is a really good topic over here:
    http://forums.cnet.com/5208-10149_102-0.html?forumID=7&threadID=178764&messageID=1962539

    Hope someone find the issue and solves it!!! Thanks!

    Monday, June 18, 2007 9:46 PM
  • This is for anyone reading this thread and having the same problems. I haven't a fix to the problem but have found a work-around which is much better than having to keep resetting the resolution every time Windows restarts.

    I found a piece of freeware at:-
    http://www.12noon.com/reschange.htm

    If you google 'reschange' you'll find a download link for it. What I did was to copy the '.exe'  to a directory like 'c:\reschange' then create a batch (.bat) file to run it from there. Then I stuck the batch file in the startup directory under 'Start Menu / Programs / Startup' under XP. Works a treat except for the console window flashing up each restart but I don't mind it. Just run the '.exe' itself to get the command line options.

    I did once know of a really great piece of shareware that handled everything with your display, it had a ton of options and resided in your system tray but I can't remember what it was called. I think what I'm referring to is a display manager of some sort. If anyone knows of or finds any such software, please let me know and leave a reply.

    Just to let you know my story I've recently had to re-install Windows and I have a ATI Radeon X1650 that I downloaded the latest drivers for running under Windows XP (SP2). The system has no complaints and it works just fine in games. But when I set the resolution to '1024 x 768' it would revert back to '800 x 600'  every time I restarted Windows. but I've never had this issue before with this computer and hardware. I've had similar issues with different graphics cards before but it was usually to do with the graphics drivers being incorrect or after a recent graphic driver update.


    Tuesday, August 28, 2007 8:08 PM
  • I was having the same issue on a Compaq Notebook with Home Premium installed.

    What fixed the isse for me was changing the power settings to allow for sleep mode when sharing media, then running:

    powercfg -h on

    from an administrative command prompt.

    What happened was the hibernation file was deleted by disk cleanup.


    Hope this helps someone.
    Monday, October 15, 2007 2:34 AM
  • I had similar problem with Nvida Geforce 8600GT Resolution would Change from 1024 to 800 on reboot

    Only with SP2 No Problem with SP1

    Made Reg Changes

    All the Below Defaults were 800 x 660

    Noticed I didn't have these Defaults on any of my other Machines

    I removed them all

     

    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\nv\Device0]
    "DefaultSettings.XResolution"=-
    "DefaultSettings.YResolution"=-
    "DefaultSettings.BitsPerPel"=-

    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\nv\Device1]
    "DefaultSettings.XResolution"=-
    "DefaultSettings.YResolution"=-
    "DefaultSettings.BitsPerPel"=-

    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\nv\Device2]
    "DefaultSettings.XResolution"=-
    "DefaultSettings.YResolution"=-
    "DefaultSettings.BitsPerPel"=-

    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\nv\Device3]
    "DefaultSettings.XResolution"=-
    "DefaultSettings.YResolution"=-
    "DefaultSettings.BitsPerPel"=-

    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\nv\Device0]
    "DefaultSettings.XResolution"=-
    "DefaultSettings.YResolution"=-
    "DefaultSettings.BitsPerPel"=-

    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\nv\Device1]
    "DefaultSettings.XResolution"=-
    "DefaultSettings.YResolution"=-
    "DefaultSettings.BitsPerPel"=-

    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\nv\Device2]
    "DefaultSettings.XResolution"=-
    "DefaultSettings.YResolution"=-
    "DefaultSettings.BitsPerPel"=-

    [HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\nv\Device3]
    "DefaultSettings.XResolution"=-
    "DefaultSettings.YResolution"=-
    "DefaultSettings.BitsPerPel"=-

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E968-E325-11CE-BFC1-08002BE10318}\0000\Settings]
    "DefaultSettings.XResolution"=-
    "DefaultSettings.YResolution"=-
    "DefaultSettings.BitsPerPel"=-


    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\nv\Device0]
    "DefaultSettings.XResolution"=-
    "DefaultSettings.YResolution"=-
    "DefaultSettings.BitsPerPel"=-

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\nv\Device1]
    "DefaultSettings.XResolution"=-
    "DefaultSettings.YResolution"=-
    "DefaultSettings.BitsPerPel"=-

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\nv\Device2]
    "DefaultSettings.XResolution"=-
    "DefaultSettings.YResolution"=-
    "DefaultSettings.BitsPerPel"=-


    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\nv\Device3]
    "DefaultSettings.XResolution"=-
    "DefaultSettings.YResolution"=-
    "DefaultSettings.BitsPerPel"=-

     

    So Far So Good

    Friday, December 21, 2007 10:34 PM
  • This worked and saved me a bunch of headaches, as I built a machine for a customer and if it went out the door changing like that, it would have been a royal pain.
    Thanks!!
    Sunday, February 10, 2008 1:38 AM
  •  Its very simple and easy to correct this error.. It just matters in editing the registry... I had the problem previously and rectified myself by following this procedure.. I request you to take a backup of your registry before doing this...

    1) Go to Start --> Run  -->  regedit   and press enter

    2) Click 'Edit' and click 'Find' in the Edit menu

    3) Type ' DefaultSettings.XResolution ' (without quotes) and click 'Find' 

    4) Now double click it and change the hexadecimal value to 400 which corresponds to 1024 

    5) Click 'Find Next' and repeat Step 4)

    6) Now do the same for ' DefaultSettings.YResolution ' (without quotes) and change the hexadecimal value to 300 which corresponds to 768 and restart.

    Just reply so that others can make use of it..
    Monday, December 01, 2008 8:47 PM
  • Well folks I'm stymied.  I've never had this issue before and it has consumed two whole days of research... and yet remains a problem.

    Namely: PC - Dell Dim 2400 w/Intel 82845G onboard video.   Boots to login screen which are so huge as to be unable to see the log-in names without mouse movement. Login reveals video settings to be as left on shut down/restart: 800x600, 1024x768, other... it matters not.

    Changing these settings manually does reset the screen size to valid proportions... until you reboot.

     

    I've tried everything on this list and CNet's and Tom's Hardware and and and... this is getting ridiculous.

    I have:

    Uninstalled SP2 and reinstalled.  Tried a host of various drivers, roll backs, settings adjustments and limitations to hardware acceleration etc...

     

    This is a Business PC and needs to be returned to them asap (of course) so... any ideas?  I'd be very glad to have even untried suggestions at this point, jic I missed something.

    Thanks for your time,

    M

    Wednesday, December 10, 2008 9:34 PM
  • Answering my own question and yet...

    For once in my many years of experience using the Windows Update suggested hardware driver for that PC worked!

    Now, I have another PC, with The Same Exact Symptoms!  If it hadn't been for the 20 or so PC's in between these two I'd wonder :p

    SO, I'll just leave this one hanging out there again, once again, the Windows Update hardware driver for the Intel 82846G DID Work to correct this problem - on a different PC.
    This PC (Dell Dmi 2400) notsomuch...

    Thanks for your time,
    M

    Thursday, January 29, 2009 8:10 PM
  • I FOUND THE ANSWER!!!

    I have had a similar problem for months and tried a ton of fixes suggested on enumerable sites, and nothing worked until now.  Its amazing how many people have this problem. 

    I solved it by installing the MONITOR DISPLAY DRIVERS (different from your graphic card driver).  When I got my new monitor (an NEC MultiSync LCD2470WVX) I just plugged it in and was happy it lit up and showed me my desktop.  I guess this is what most typically do.  How many people go searching for drivers for their monitor??

    By the way I use an ATI graphics card (Radeon X1300 / X1550 Series).  I had tried uninstalling this driver, Updating it,  rolling  it back, hacking the registry, et al to get rid of the scrolling desktop I was seeing when I set the resolution to 1920 x 1200.  If somehow I was able to get the desktop to not scroll, once I rebooted the scrolling desktop would come right back.  I was living with this problem by trying my best to not reboot, but with frequent updates and other scenarios requiring reboots, I HAD to figure out this problem.

    Here's what I did:

    1) I first downloaded my monitor's display driver from NEC's website.  
    2) I then went to my system's Device Manager and under Monitors, I saw that I had two entries, Default Monitor and Plug and Play Monitor. 
    3) I right clicked on Plug and Play Monitor and chose Update Driver.
    4) Through the wizard I chose the .inf file that I downloaded from NEC and finished that process
    5) Lastly I rebooted and my resolution which is 1920 x 1200, was set perfectly and I no longer had a scrolling desktop.


    I hope this works for many...

    Thanks to all who contributed to solving this problem!

    • Proposed as answer by bizyspot Tuesday, March 24, 2009 5:24 PM
    Tuesday, March 24, 2009 5:24 PM
  • Well this is what I did and it worked.. It's similar to shanthilal solution.  I just deleted every entry rather than change the value.

     

     Its very simple and easy to correct this error.. It just matters in editing the registry... I had the problem previously and rectified myself by following this procedure.. I request you to take a backup of your registry before doing this...

    1) Go to Start --> Run  -->  regedit   and press enter

    2) Click 'Edit' and click 'Find' in the Edit menu

    3) Type ' DefaultSettings.XResolution ' (without quotes) and click 'Find' 

    4) Now click on it and press delete.

    5) Press F3 to go to the next find and repeat Step 4)
    6) keep doing this this till you reach the end of the registry.
    7) On the left pane, scroll all the way up to the top and click on my computer

    8) Now do the same for ' DefaultSettings.YResolution ' (without quotes) and click on it and press delete.

    9) Press F3 to go to the next find and repeat Step 8) until you reach the end of the registry.

     

    restart pc and you are ready!

    Friday, September 09, 2011 7:17 AM
  • got same problem on my dauth's pc.  hope microsoft be mroe morally responsible, not just a line of code change, it affect millions of people
    Sunday, November 20, 2011 5:55 PM
  • Well this is what I did and it worked.. It's similar to shanthilal solution.  I just deleted every entry rather than change the value.

     

     Its very simple and easy to correct this error.. It just matters in editing the registry... I had the problem previously and rectified myself by following this procedure.. I request you to take a backup of your registry before doing this...

    1) Go to Start --> Run  -->  regedit   and press enter

    2) Click 'Edit' and click 'Find' in the Edit menu

    3) Type ' DefaultSettings.XResolution ' (without quotes) and click 'Find' 

    4) Now click on it and press delete.

    5) Press F3 to go to the next find and repeat Step 4)
    6) keep doing this this till you reach the end of the registry.
    7) On the left pane, scroll all the way up to the top and click on my computer

    8) Now do the same for ' DefaultSettings.YResolution ' (without quotes) and click on it and press delete.

    9) Press F3 to go to the next find and repeat Step 8) until you reach the end of the registry.

     

    restart pc and you are ready!

    Same problem.  This worked.  Thank you very much!
    Sunday, April 29, 2012 4:06 PM
  • THE BEST!!!

    After reading all articles and trying all these advices - finally!!!

    So simple and so elegant!

    Thanks a lot, shanthilal!

    The BEST SOLUTION FOR MY PC!

    Thursday, December 20, 2012 1:30 AM