none
Connect to Xbox live through Windows 7

    Question

  • So i accomplished this with Vista, but haven't been able to do it yet, anyone know where to open up the network so that i can connect to xbox live through my laptop wirelessly.

    Wednesday, June 17, 2009 9:29 AM

All replies

  • This can be accomplished through a network bridge, or even better, Internet Connection Sharing. These settings are available in the Control Panel and though it will likely be different in Windows 7 RC, you may find this article about doing it in Windows Vista helpful. If you need more help, or if you've solved your problem, please respond.

    -Nick
    Wednesday, June 24, 2009 12:51 AM
  • Hey Nick FV could you give me a step by step way on how to set up xbox live using a windows 7 computer with a wireless network??? because i have been trying to set xbox live up at my friends who has windows 7 but we cant get it to work.Also all the online guides relate to XP or Vista. So you sound like you'd know what to do to set it up. 
    thanks heaps Howie.
    • Proposed as answer by Turtle Cancer Tuesday, June 08, 2010 5:20 AM
    Tuesday, July 14, 2009 11:28 PM
  • Make sure the ethernet cable you are using is crossover. I have been able to use my XBox through my Windows 7 machine via a network bridge. I have found that using static IP addresses usually helps me stay connected, but the bridge sometimes acts flaky and disconnects. I think that has more to do with the implementation of the bridge. Hopefully that will clear up once all the drivers are certified etc. Let me know if you have questions.

    -Mark
    Wednesday, August 19, 2009 12:18 AM
  • hey i'm new, but can you go through how to connct it through windows 7, and is thei any other alteniives to a connectin bridge, and what ip adress to use or how to fnd it, thanks, just cause i try connection bridges but i always disconnect with 7, so help would be great.

    Sunday, September 06, 2009 11:21 AM
  • Hey, I was having the same problem, I wanted to bridge my connections, so the 360 would run on my laptop's wireless. Well I figured out how to do this

    You go to the Netowrk and Sharing center, then click on "Change Adapter Settings" and you highlight the 2 connections you want to bridge. (Wireless and LAN in my case)

    Hope this helps all of you.
    • Proposed as answer by zerolgk5 Saturday, December 18, 2010 4:29 PM
    Wednesday, January 06, 2010 11:34 AM
  • yea helped me out :) i'm on live, its all working :)

    Thanks
    Wednesday, January 06, 2010 3:37 PM
  • Hello, I Went To Bridge The Two Connections Together But There Wasn't A " Bridge Connections " Button Any Ideas, Thanks.
    Saturday, January 09, 2010 6:57 PM
  • Hi, 

    Go to 'Change Adapter Settings'. Make sure Internet Connection Sharing is turned off on both the connections you want to bridge. Then select both at the same time (i.e. Ctrl + click). When both are selected right click one of them and you will see a 'Bridge Connections' option. This applies to Windows 7.
    Saturday, January 16, 2010 2:53 PM
  • Thanks a bunch everyone! i now have Xbox Live through my Windows 7 laptop. by the way everyone, i'm pretty sure this doesn't work at all if you have the wireless connection you're using set to "private".

    '

    Saturday, April 17, 2010 5:01 AM
  • Hi, 

    Go to 'Change Adapter Settings'. Make sure Internet Connection Sharing is turned off on both the connections you want to bridge. Then select both at the same time (i.e. Ctrl + click). When both are selected right click one of them and you will see a 'Bridge Connections' option. This applies to Windows 7.
     it didnt work for me. I tried all of your suggestions and nothing will work. anything more?
    Saturday, April 24, 2010 4:51 AM
  • Step 1 On the computer running Windows 7 click the following:
    Start, Control Panel, Network and Internet
    Step 2 Select "Home Group and Sharing Options"
    Step 3 Click "change advanced sharing settings"
    Step 4 Under "Media Streaming" click "Choose Media Streaming Options"
    Step 5 Click "Turn on media streaming"
    Step 6 You will now have the option to name your media library if you want to, but is not necessary
    Step 7 Click "Choose Default Settings". You can choose star ratings and parental controls here if you want to, and then click "OK". You are now done with setting up the PC.
    Step 8 Turn on your XBOX 360 and go to the "My Xbox Channel" and select "Music", "Photos", or "Video" library.
    Step 9 Select your pc from the list and the file you wish to play

    technocrate,

    Thank you for helping the community by providing answers to threads. However, continually posting a link to a paid support site violates the posted Code of Conduct. Moderators have mentioned this to you in the past, so please be aware that you will be banned if violation continues. Being banned will prevent you from posting in any Microsoft forum. We value your contributions and ask that you continue to participate in the forums without the SPAM. Thank you.

    Sincerely,

    -Tony Mann


    Windows Client IT Pro Audience Manager for Web Forums
    Wednesday, April 28, 2010 12:53 PM
  • I figured out how to do this

    First: open control panel

    Second: open the network and sharing center

    Third: click on "Change Adapter Settings" located to the right of the window, it should be second from bottom

    Fourth: highlight both the LAN connection and your wireless card

    Fifth: once they both glow blue right click and on the drop down list click "Bridge Connections"

    after a little while a small box should appear that has a picture of a small box with an antennae sticking out of it. This means that the connection was successfully bridged. it should also take on the name of the wireless network that you are connected to. it should also say MAC Bridge Miniport (well it did for me anyway) you should now be able to use your 360 0n live throo your computer

    Hope this helps!

    Tuesday, June 08, 2010 5:20 AM
  • hey, i bridged the connection and the bridge appeared correctly, but my xbox360 is saying that my pc isnt listed

    does anybody have an answer???

    Monday, June 21, 2010 2:34 AM
  • i used to be able to connect without a bridge. i ran ncpa.cpl went to properties on my wireless connection. then i went to sharing and checked 'allow other devices to connect to the internet through my computer' box.

    i went to get onto xboxlive today and it said omething about a network error. i looked at my connection and it no longer displays LAN connection or the sharing tab in my internet connection. what do i do now?

    Saturday, July 10, 2010 11:17 PM
  • i used to be able to connect without a bridge. i ran ncpa.cpl went to properties on my wireless connection. then i went to sharing and checked 'allow other devices to connect to the internet through my computer' box.

    i went to get onto xboxlive today and it said omething about a network error. i looked at my connection and it no longer displays LAN connection or the sharing tab in my internet connection. what do i do now?

    I bridged the two connections together and its still just not working

    FML i just MWF 2

    Monday, July 19, 2010 8:26 AM
  • Ok, like some other people with problems such as these mine is a little different.

     

    normally when im at home I have my xbox plugged into my Cisco E3000 router and everything works perfectly both for my xbox and laptop. (laptop being wireless)

    But on some occasions ill go to a friends house who as wireless internet, now I have my xbox plugged into my laptop via an ethernet cable and im trying to get xboxlive through the laptop which has windows 7. Now I have gotten this to work through a network bridge once and a shared network once by just getting lucky with a static ip address. 

    To knock these off the list first, making a bridge alone does not automatically give me a good ip address.Nor does being shared and running the tests. Everytime I have had to do this i have had to put in a static ip and usually after trying as many bloody numbers that can cross my mine I can get it.

    But now im back at my friends place and im trying to connect again but this time the ip settings the auto show on my 360 are much different then usual and no matter what i put in for the ip/subnet/or gateway seem to work. not even previous ones that I have tried.

    when I do ipconfig on CMD I get 192.168.1.X

    255.255.255.0

    192.168.1.254

     

    For my computer.

     

    for my xbox im getting 192.168.137.1

    255.255.255.0

    and no gateway.

     

    HOWEVER, when I run the xboxlive test on the system and it fails I get 169.254.80.169

    255.255.0.0

     

    The worst and most irritating part of this is that my friends dad's room where the router is located, he is to stupid and stubborn to let me try turning it off and back on. He seems to think it will cost him money or something.....

    Monday, October 18, 2010 12:04 AM
  • For all those still wondering, and for those who cant set up a bridge follow these steps.

    1. open the "network and Sharing center"

    2. click on the left side "change adapter settings"

    3. right click on your internet connection and select "status"

    4. click on the "details" tab

    5. write down the number to the right of "Server Ipv4 address"

    6. right click on your "Lan" connection (you need your cable plugged in, and you DON'T need a crossover cable, the one that came with the 360 works just fine) select "properties"

    7. select "internet protocol version 4"

    8. then click "proprieties"

    9. select "use the following DNS server address"

    10 next to "preferred dns server" type in the number that you previously wrote down

    11. click "ok" until you are back to the window with all your connections

    12. right click on your internet connection and select "properties"

    13. click on the "sharing" tab

    14. check "allow other network users to connect....." then look down and check "allow other network users to control..."

    15. you now need to select "Local Area Connection" under the drop down box titled "Home Networking Connection"

    16. after all this you may have to disconnect and reconnect your cables and or internet connection.

    • Proposed as answer by Dustin4111 Wednesday, November 24, 2010 8:52 AM
    Monday, November 15, 2010 2:54 AM
  • I Have had problems with my internet company and have had to Manually set up connections for my Xbox 360 and my Laptop to connect to the internet, I was wondering if anyone knows how i can connect to Xbox Live through my laptop with manual connections.
    Wednesday, November 24, 2010 8:56 AM
  • For all those still wondering, and for those who cant set up a bridge follow these steps.

    1. open the "network and Sharing center"

    2. click on the left side "change adapter settings"

    3. right click on your internet connection and select "status"

    4. click on the "details" tab

    5. write down the number to the right of "Server Ipv4 address"

    6. right click on your "Lan" connection (you need your cable plugged in, and you DON'T need a crossover cable, the one that came with the 360 works just fine) select "properties"

    7. select "internet protocol version 4"

    8. then click "proprieties"

    9. select "use the following DNS server address"

    10 next to "preferred dns server" type in the number that you previously wrote down

    11. click "ok" until you are back to the window with all your connections

    12. right click on your internet connection and select "properties"

    13. click on the "sharing" tab

    14. check "allow other network users to connect....." then look down and check "allow other network users to control..."

    15. you now need to select "Local Area Connection" under the drop down box titled "Home Networking Connection"

    16. after all this you may have to disconnect and reconnect your cables and or internet connection.

    Thank you so much, this worked perfectly for me :D  I was just reading this thread when I had some trouble connecting and had to say thanks when it worked

    Wednesday, December 15, 2010 11:19 PM
  • Hey, I was having the same problem, I wanted to bridge my connections, so the 360 would run on my laptop's wireless. Well I figured out how to do this

    You go to the Netowrk and Sharing center, then click on "Change Adapter Settings" and you highlight the 2 connections you want to bridge. (Wireless and LAN in my case)

    Hope this helps all of you.
    worked perfectly, thank you!
    Saturday, December 18, 2010 4:30 PM
  • For all those still wondering, and for those who cant set up a bridge follow these steps.

    1. open the "network and Sharing center"

    2. click on the left side "change adapter settings"

    3. right click on your internet connection and select "status"

    4. click on the "details" tab

    5. write down the number to the right of "Server Ipv4 address"

    6. right click on your "Lan" connection (you need your cable plugged in, and you DON'T need a crossover cable, the one that came with the 360 works just fine) select "properties"

    7. select "internet protocol version 4"

    8. then click "proprieties"

    9. select "use the following DNS server address"

    10 next to "preferred dns server" type in the number that you previously wrote down

    11. click "ok" until you are back to the window with all your connections

    12. right click on your internet connection and select "properties"

    13. click on the "sharing" tab

    14. check "allow other network users to connect....." then look down and check "allow other network users to control..."

    15. you now need to select "Local Area Connection" under the drop down box titled "Home Networking Connection"

    16. after all this you may have to disconnect and reconnect your cables and or internet connection.

    11.  I don't have a sharing tab...

     

    i have windows 7 starter (its a netbook) does that matter? 

    Monday, December 20, 2010 11:21 AM
  • Hey everyone, new here.

    I have Windows 7 Ultimate, and I can connect to Xbox Live with no issues.

    The only problem is that each time I go to play, I have to go back through my 360, sign off, go to Settings > Network Connections > Test Xbox Live Connection each time to connect.

    Is there a way to setup whenever I connect my laptop and then power the Xbox on, it will automatically connect to my network and Xbox Live?

    I'm not running my connections bridged, I'm using Internet Connection Sharing.

     

    Thanks

    Monday, December 27, 2010 7:52 PM
  • ok im REALLY new: ive been following wat every1 has been saying but i dont know if i did it correctly I have a NETGEAR connection(my wireless modem) and an unidentified network tht i got wen i plugged the ethernet cable from my xbox to my Toshiba Satellite L505 with Windows 7. I bridged the connections together using wat u said but i dont no if i should undo this and if i should, how?

    Monday, January 17, 2011 2:19 PM
  • so I am completely a beginner at this, so please forgive me. Firstly I want to know if I am even in the right place. I want to connect my laptop to my xbox to access xbox live. I have the ethernet cable and my interent connection is through a wireless usb modem type thing. Like I said I am not that technological savvy, but i think it maybe sort of like a dial-up process, because the picture lol in the network connections window shows a phone. So I am thinking this may be the problem, but I have tried everything that u recommended. Nothing seems to be working, or one little step doesn't work, I am becoming very frustrated. Another thing I noticed is that where it was recommended to write the Server Ipv4 address from the details tab, mine was 0.0.0.0, and then when i tried to enter it in preferred dns server it said you could not enter just 0s, but above that it says client Ipv4 address has other numbers.

    Like I said im very confused, any help or adivce would be awesome, sorry if none of what i said is useful or makes sense

     

    Monday, January 24, 2011 8:04 AM
  • thanks, you just helped me so much :)
    Thursday, January 27, 2011 9:05 AM
  • where is this drop box home network connection?
    Friday, January 28, 2011 5:15 AM
  • For all those still wondering, and for those who cant set up a bridge follow these steps.

    1. open the "network and Sharing center"

    2. click on the left side "change adapter settings"

    3. right click on your internet connection and select "status"

    4. click on the "details" tab

    5. write down the number to the right of "Server Ipv4 address"

    6. right click on your "Lan" connection (you need your cable plugged in, and you DON'T need a crossover cable, the one that came with the 360 works just fine) select "properties"

    7. select "internet protocol version 4"

    8. then click "proprieties"

    9. select "use the following DNS server address"

    10 next to "preferred dns server" type in the number that you previously wrote down

    11. click "ok" until you are back to the window with all your connections

    12. right click on your internet connection and select "properties"

    13. click on the "sharing" tab

    14. check "allow other network users to connect....." then look down and check "allow other network users to control..."

    15. you now need to select "Local Area Connection" under the drop down box titled "Home Networking Connection"

    16. after all this you may have to disconnect and reconnect your cables and or internet connection.

    11.  I don't have a sharing tab...

     

    i have windows 7 starter (its a netbook) does that matter? 

    I have the same problem! Can someone please help me out?
    Sunday, March 06, 2011 9:30 PM
  • I have the same problem! Can someone please help me out?

    So do I! I have a windows 7 TOSHIBA Starter, there is no sharing tab, and there is no bridging option! What do I do, I dont want to pay 70$ for an adapter, and I'm running out of xboxlive. What CAN I do?
    Wednesday, April 27, 2011 2:51 AM
  • can you help me with this problem? ive bridged the connections and ive plugged in the ethernet cable but it still doesnt get through the network when i test the connection to xbox live,can you tell me what im doing wrong?
    Sunday, May 08, 2011 9:43 PM
  • If you have a laptop computer with a wired and wireless network adapter, you can use your laptop to connect your Xbox 360 console to Xbox LIVE. This type of connection is called a network bridge connection.

    This connection is quick and easy, but you cannot access the Internet on the laptop when the laptop is connected to your Xbox 360 console.

    To use a network bridge connection, you must have the following:
    • A computer with two network adapters
    • Windows XP, Windows Vista, or Windows 7

      Note The Windows 7 Starter edition does not support this feature.
    • High-speed Internet access
    • A standard Ethernet cable

    All the best
    Jessica Bhola
    Friday, May 27, 2011 5:25 PM
  • hey! i've been having the same trouble here and i barely discovered how to make the bridge work on windows 7:

    DONT TURN ON YOUR XBOX YET!

    1. go to "change adapter settings" in the network and sharing center

    2. right click on your current wireless connection and click on properties

    3. go to "sharing" tab and select "allow other network users to connect through this internet connection" and hit ok

    4. now turn on your xbox and go to the test connection tab

    5. click on start button on your laptop and on the search box type cmd and if you find it open it

    6. now type ipconfig on the command and find your wireless settings on the top

    7. go back to the window showing your connections and find your LAN ethernet connection (it should be enabled btw)

    8. right click, go to properties and find "Internet Protocol Version 4", highlight it and click on properties below

    9. go to the "alternate configuration" tab and select "user configed" and just type in the ip adress, subnet mask, and default gateway for IPv4 as they appear on the command where you have ipconfig opened

    10. make sure "validate settings upon exit" at the bottom is checked

    11. and now just click ok, close everything and wait a couple of seconds and now run the xbox live test on the xbox and it should be up and running!!

    sorry for all the hassle but i tell you its worth trying it cuz it worked for me :)

    • Proposed as answer by tahtguy Sunday, June 12, 2011 4:21 AM
    Sunday, June 12, 2011 4:21 AM
  • all is you have to do is click your wireless bars on the side then at the bottom open network sharing center after that in the top left you should see change adapter settings click this, then highlight your connection and the xbox connection and right click and it should say bridge connections. thats pretty much it you might have to change you network settings on your xbox to wired if you havent done this already: (by the way make sure you have an ethernet cable running from your xbox to your laptop) i have to do this all the time.
    G
    • Proposed as answer by Glen1221 Thursday, January 05, 2012 9:43 PM
    Thursday, January 05, 2012 9:42 PM
  • This topic should probably be closed...  If anyone comes accross this thread looking for the answer, as you can read from various posts, you have two options if you need to connect through a Windows system.

    1) Bridge the network adapters - This action will have your Windows computer act as a switch.  Both network adapters installed on your computer will be on the same subnet.  For example, one adapter (wired or wireless) will be connected to your LAN, and the other will be connected to the other device that you want to share the connection with.  The other device can be another computer, XBox, or any other TCP/IP host.

    2) Internet Connection Sharing - This option will turn your Windows computer into a router with NAT capabilities, much like your typical internet router.  One network adapter (wired or wireless) is connected to the LAN, and the other is connected to the other TCP/IP host (computer, XBox, etc...) that you want to be on the network.  In this scenario, both adapters are on different network segments and any traffic that passes through the Windows computer will be NAT'd by the Windows computer.

    Which is the best option?  Either one, its up to you on how you want your network to be designed. If possible, a preferable option is to purchase a wireless adapter for your XBox, or plug it into a wired port on your network.  

    The steps to use either option 1 or 2 can be found above in this very long thread....

     


    Guides and tutorials, visit ITGeared.com.

    itgeared.com facebook twitter youtube
    Friday, January 06, 2012 1:25 AM