none
Can't get work email (Outlook Exchange) to work on Surface

    Question

  • Exchange email won't work!

    Hi, 

    Very frustrating. I have two email accounts (Google email) working great. But, can't get my work email to operate. I know I have all the addresses, etc. correct. I'm a very experienced user. I set it up, no problem, at both iPad and iPhone. I used the same exact settings, no dice. 

    1. When I used the Outlook Exchange option, did not connect at all
    2. I was able to use IMAP and successfully downloaded emails, but can not send - keeps getting stuck in Outbox 
    Tuesday, October 30, 2012 2:36 PM

All replies

  • Hello, Jeff,

    Could you please specify, what options you've used to connect to Microsoft Exchange? I've been struggling through connecting my Mail app to Exchange Server and finally got it working...

    Please also read these threads:


    Well this is the world we live in And these are the hands we're given...

    Tuesday, October 30, 2012 2:53 PM
  • I've tried all the various combinations of entries referenced in other threads, along with anything else I can think of and even some stupid things that make no sense.  Basically, like you, I cannot get the Mail app to connect to my Exchange account.

    We want our users running Outlook 2010 anyway, but since the Mail app is included in Windows 8, sure enough people would try to use it.  So we've been looking at what this app can do, but if you can't connect to Exchange, we can't even evaluate how bad or good the app is, or what features it even offers since it won't open.  So our approach most likely will be to remove the Mail app from the Windows 8 clone we would develop for use on our workstations, since it's obviously useless.

    Tuesday, October 30, 2012 3:40 PM
  • i have same problem ... and i diagnostic this ... and see its not working with a self signed certificate ...

    so all employé that install windows 8 dont receile email from exchange

    i waiting a fix on that ...

    Wednesday, October 31, 2012 1:13 PM
  • Has anybody tried this suggestion, I am quoting here:

    Kindly try the following steps and let us know the status.

     

    1. Open the Windows 8 Mail app.
    2. If you see the Add an account button on the page when you start Mail, click Add an account >
    3. Exchange. If you don’t see the Add an account option, open the main charm menu on the right side of the page, and then click Settings > Accounts > Add an account > Exchange.
    4. On the Add your Exchange account page, type your email address and password, and then click Connect. Make sure that you enter your full email address (for example, tony@contoso.com) as your user name.

    After you click Connect, Mail will perform an online search to find your email server settings.

    1. If you see the message “Your email account is successfully configured.”, click Finish. If you see the message “The mail server for <email address> needs this PC to be more secure before it starts syncing”, click Next. Then, in the Make my PC more secure box, click Enforce these policies. When you see the message “Your email account is successfully configured”, click Finish.


    Well this is the world we live in And these are the hands we're given...

    Friday, November 02, 2012 9:45 AM
  • Thanks, but it just says in red "Unable to connect. Ensure the information you've entered is correct." It does not have a "Finish" option. This is Surface RT. 
    Saturday, November 03, 2012 12:25 AM
  • Heck, I was about to propose a suggestion on analyzing traffic, but with Surface RT the only way is to create a gateway and monitor this traffic on the gateway, what's not as viable... That's a pity. Are you using certificates in your Exchange organization?

    Well this is the world we live in And these are the hands we're given...

    Saturday, November 03, 2012 10:20 AM
  • Go to the desktop version of your Surface.. "Right click" on IE icon, "Right click" on 'Internet Explorer" > Run as Administrator.

    You can then add the certificate for exchange. 

    This worked for me. Problem is, now my surface requires a password if it sleeps for more than 10 minutes. Not a big problem but annoying.

    Friday, November 09, 2012 3:38 PM
  • I don't think the surface has a desktop mode - its a pure RT environment.

    Sadly I don't have anything helpful to offer...it just bugs me that this highlights one of the glaring weaknesses in the new "it just works" paradigm, if it doesn't you have no tools at your disposal to investigate with.

    Someone wants to make a mint - write a Metro set of debugging/diagnostic tools!

    Friday, November 09, 2012 11:08 PM
  • First you need a certificate from your exchange server and you have to load that certificate on your surface. To do this you have to launch the mmc console and load the manage certificate option. go to import certificate and up load the certificate that you exported from exchange server once this done your mail will connect. because you are using a self signed certificate for your exchange server and the security on the surface it will not allow you to connect until it has your exchange certificate in the certificate root folder. Hope this helps
    • Proposed as answer by Jamrock60 Tuesday, November 20, 2012 4:06 AM
    • Unproposed as answer by Jamrock60 Tuesday, November 20, 2012 4:06 AM
    Tuesday, November 20, 2012 4:05 AM
  • Surface RT has a desktop mode it also has a c:\ prompt you can launch MMC.exe from there and configure any option on the device
    Tuesday, November 20, 2012 4:10 AM
  • Why do you need to add a certificate to the Surface? Exchange autodiscover/activesync does not require a client-side certificate normally. For a quick confirmation - go to your OWA logon page. View the certificate when it connects via HTTPS. If the certificate points to an external third-party root (ex. digicert, godaddy, etc), then you shouldn't need a client-side certificate and you're barking up the wrong tree. Either that or your Exchange admins haven't set up your services correctly.

    1> autodiscover strips off everything before the @ sign and pre-pends autodiscover. For example if your e-mail is me@domain.com - then it will attempt to locate autodiscover.domain.com

    2> The e-mail client then looks up autodiscover.domain.com and connects via port 443 and verifies the cert.

    3>  It then pulls the XML file and locates the Microsoft-ActiveSync URL location. That's it. That's how activesync/autodiscover works.

    4> For a true test - does it work from an iPhone, Android, iPad, or Windows phone? If so, and you didn't need to install a certificate on those devices - then you don't need a certificate on your surface. It uses the EXACT same connection methodology (or at least it should). Same thing as a banking site - you don't need to install every certificate on the Internet to get HTTPS sites to work - that's not how certificates are supposed to work.

    If Steps 1-4 all work - then I'm afraid the only answer I have is that the surface and/or Metro mail client simply suck (and IMO - both RT and the Metro mail app truly do suck regardless of this particular issue). You may need to stick with OWA, find a different e-mail app that actually works, or consider your future fun with Windows RT may be not so fun after all.

    • Edited by ABCFED Tuesday, November 20, 2012 4:41 AM
    Tuesday, November 20, 2012 4:31 AM
  • Hello,

    everybody having problems with SSL and certificates, please read the Windows 8 Mail App - Can't add IMAP account thread and look for post from Barb Bowman and I_C, I am quoting here:

    "Thanks Barb! That did the trick. Basically you have to:

    1. generate a self-signed certificate which has a CN with the same name as the mail server (http://www.cert-depot.com/ is very handy here - NB download both the .zip and the .pfx)

    2. configure your mail server to use this certificate (which depends on your mail server)

    3. then generate a certificate file in .cer format (using mmc.exe is easiest - as described here =  http://stackoverflow.com/questions/403174/convert-pfx-to-cer)

    4. and then add this .cer to the Trusted Authorities Certificates on the Surface (again using mmc.exe is easiest)

    At this point you'll be able to add the account in Win8 Mail App on the Surface."


    Well this is the world we live in And these are the hands we're given...

    Friday, December 07, 2012 12:25 PM
  • I AGREE that the Mail Client for W8, especially on Surface where there is no way
    to install a REALmail client, does not measure up to email clients elsewhere. I
    am extremely disappointed in the lack of updates to bring it up to par, too.
     
    I offered a kludgey pointer to a work around that may help some people who can
    implement accordingly. If you don't have admin access to the mail server in
    question to install the cert, it doesn't work.
     
     
     
    On Fri, 7 Dec 2012 15:07:28 +0000, ABCFED wrote:
     
    >That is ridiculous. You don't need to do that on any other device (iPhone, Android, Windows Phone, iPhone, Macbook, etc). All you should have to do is type in your e-mail address and password - and it should "automagically" work with nothing further needing to be configured. It appears that Win8 Mail truly sucks if you have to go through all of that rigamarole and manually configure certs. What on earth was Microsoft thinking?
     

    Barb Bowman

    http://www.digitalmediaphile.com

    Friday, December 07, 2012 4:27 PM
  • I AGREE that the Mail Client for W8, especially on Surface where there is no way
    to install a REALmail client, does not measure up to email clients elsewhere. I
    am extremely disappointed in the lack of updates to bring it up to par, too.
     
    I offered a kludgey pointer to a work around that may help some people who can
    implement accordingly. If you don't have admin access to the mail server in
    question to install the cert, it doesn't work.
     
     
     
    On Fri, 7 Dec 2012 15:07:28 +0000, ABCFED wrote:
     
    >That is ridiculous. You don't need to do that on any other device (iPhone, Android, Windows Phone, iPhone, Macbook, etc). All you should have to do is type in your e-mail address and password - and it should "automagically" work with nothing further needing to be configured. It appears that Win8 Mail truly sucks if you have to go through all of that rigamarole and manually configure certs. What on earth was Microsoft thinking?
     

    Barb Bowman

    http://www.digitalmediaphile.com

    So, we have to go and ask our e-mail admins to give all of us a CER file and manually import the certificate onto the surface in order to get mail working?

    HAHAHAHAHAHHAHA!!!!!! Oh my...that is indeed HILARIOUS! That is one of the most kludgy solutions I've ever heard of just to get a mail client to work.

    Let me say again...HAHAHAHAHAHHA!!!!

    Friday, December 07, 2012 7:07 PM
  • Well, although I don't advocate for such complications, I don't see anything problematic here. Rolling up PKI infrastructure and configuring autoenrollment in Group Policy is not a rocket science. Plenty of organizations deploy user certificates automatically to every Active Directory computer.

    Here is how you can do it with Windows Server.


    Well this is the world we live in And these are the hands we're given...


    Saturday, December 08, 2012 12:45 PM
  • hmm not sure what the hiccup is - my connection to Exchange worked without a hitch - email address (short form with uid) + password was enough. Accepted the message to apply secure policies and done(how the x#@$% do I take screen shot 😈
    Tuesday, January 01, 2013 1:15 AM
  • When I try to set up an Exchanges account I get the message "To use this account, you need to install a digital certificate on this PC. Contact your system administrator for more info". I tried installing various certificates based on what I've read here and other places but have not gotten it to work yet. I think I've also stmped the Sys Admin with this one. All I can say is that I've gotten this to work on and iPhone AND on a Google Nexus 7 running Jelly Bean.

    Not sure what to try next!

    Tuesday, January 08, 2013 8:13 PM
  • That's how mail from an exchange server works!  It's the same for configuring Exchange on an android, blackberry or iphone.
    Tuesday, August 20, 2013 1:55 PM