none
Windows 7 RC - I can't change my network from public to work

    Question

  • After a lot of job, I connected my W7 beta PC with my XP PC, but when I upgrade to W7 RC, I am unable to do this.

    I have two net adapters: one linked to the internet cable modem and it is OK (public network). The other linked with a switch but W7 assigned this as unknown public network and I can't change it to home or work network. In W7 beta I assign a work network and it worked.

    Thanks.
    Friday, May 08, 2009 9:01 PM

All replies

  • I have the exact same issue, I've read on other forums that this is due to Windows 7 not being able to see a DHCP server on the LAN, and therefore it doesn't know what kind of network it is and defaults to the safest Public one.  To me this is a definite bug to solve, windows since 98SE have been able to negotiate LAN IP's without a DHCP in workgroup LAN's....and now with Win7 this is broken??

    Jon
    Saturday, May 09, 2009 5:47 AM
  • I too have a similar setup with the same problem. What's more scary is upon initial setup, Windows 7 automatically set my NIC attached to my cable modem as the home network. The other NIC, like yours, is my home network and I cannot change the settings to be as such. I never did like how Windows Vista and Windows 7 Beta handled these settings, but at least they were configurable though they constantly needed to be recheck if you changed some other network setting.
    • Proposed as answer by DoomIsNow Monday, July 02, 2012 3:30 PM
    • Unproposed as answer by DoomIsNow Monday, July 02, 2012 3:30 PM
    Saturday, May 09, 2009 6:02 AM
  • I have same problem so am binning the RC and going back to 7 beta. i do not understand why we have no "expert" opinion re this matter;
    Saturday, May 09, 2009 4:03 PM
  • The experts are still ignoring us :(
    Monday, May 11, 2009 8:18 PM
  • If it works in an earlier version of Windows then you can be almost certain that the Registry holds the answer... google for changing DCHP flags...

    Tuesday, May 12, 2009 12:54 AM
  • If it works in an earlier version of Windows then you can be almost certain that the Registry holds the answer... google for changing DCHP flags...

    Well technically the peer networking still works, it's Win7's new network categories and properties that is the source of this bug.

    Jon
    • Proposed as answer by expresslube2 Monday, September 05, 2011 8:58 PM
    • Unproposed as answer by expresslube2 Monday, September 05, 2011 8:58 PM
    Tuesday, May 12, 2009 2:47 AM
  • I'm having the same problem.. >.< I have my main comp with w7 rc1  7100 on it, and trying to net work it with a sp3 version of win xp. but it keeps coming up as unidentified network. wont let me share files or anything. any sugestions?

    naz
    Tuesday, May 12, 2009 2:48 PM
  • This really needs an answer, a Microsoft MVP needs to recognize this a problem that might be shipped with Windows.
    Wednesday, May 13, 2009 9:03 PM
  • I repeat my situation:

    After a lot of work I can set up my network on W7 beta: main PC with W7 and secondary with XP SP2.

    When I installed RC I can never setup my network again.

    My W7 PC have a net card (onboard) connector with the internet modem, and a second card connected with a net switch. It always worked with XP on both PCs.

    When I installed W7RC my second adapter was set as public network and I can't change it on no way. When I made work the network with W7 Beta I changed this to Work network.

    Is there a hiden command or a secret way to do this?

    I can access the shares on the W7 PC from the XP one, but not the W7 shares from the XP one.

    PS: I have set on the discovery network, and sometimes it sees the XP pC, but I can´t access the coputer.


    Is there a Microsoft expert who can answer us?

    Tuesday, May 19, 2009 5:27 PM
  • Had the same problem W7 x64 trying to use my second NIC to PXE boot a laptop to do a network install.
    Finally found a way around it and here it is.

    Go to start>Search>secpol.msc
    Network List Manager Policies>Unidentified Networks
    Double Click>Change Location Type to Private  !!Warning, this means from now on all Unidentified Networks will be set as private!!

    I tried setting the user permissions to allow changing location, but it didn't make any difference.
    • Proposed as answer by DK12000 Monday, May 25, 2009 5:42 AM
    • Unproposed as answer by Adam M MCP Saturday, June 13, 2009 3:58 PM
    • Proposed as answer by OranL Monday, July 06, 2009 11:04 PM
    Monday, May 25, 2009 5:42 AM
  • Hello DK12000 tried no luck for me still stuck with public! I did pose the question to the engineering guys but thet were no help at all in fact they did not seem interested just hope the support picks up at go live.

    Unless we have some satisfaction I for one will bin 7 when the beta runs out and just wait for next year.

    john
    Monday, May 25, 2009 5:14 PM
  • I'm angry. I am very angry.

    Why are we ignored by the experts?

    Are we second class members?

    Requires windows 7 an expertise to configure a damned home network?

    Is windows 7 a bad network OS?

    I AM ANGRY!
    Monday, May 25, 2009 6:37 PM
  • Network and Sharing Center - click on Publick Network (if it's clickable) and a new pop-up window will appear, where you will be able to select the type of network you want (Home, work or Public).

    Let me know if it works, if not  I'll try something else.
    Running Windows 7 RC1 32-bit on AMD Athlon 64 X2 Dual Core 5000+ (2.70 GHz), 4 GB DDRII, onboard GeForce 6150SE nForce 430
    • Proposed as answer by SavySB Monday, May 25, 2009 8:49 PM
    • Unproposed as answer by Adam M MCP Saturday, June 13, 2009 3:57 PM
    Monday, May 25, 2009 8:48 PM
  • Hi SavySB
    not available in NSC all I have is unidentified network click on that and up comes troubleshooter which obviously gives no solution. I chose home at installation but on accessing connection prefs it shows public as the default location. It really is a step backwards from the beta! as is the lack of Win 7 expert input
    john
    Tuesday, May 26, 2009 4:27 PM
  • Network and Sharing Center - click on Publick Network (if it's clickable) and a new pop-up window will appear, where you will be able to select the type of network you want (Home, work or Public).

    Let me know if it works, if not  I'll try something else.
    Running Windows 7 RC1 32-bit on AMD Athlon 64 X2 Dual Core 5000+ (2.70 GHz), 4 GB DDRII, onboard GeForce 6150SE nForce 430

    Thanks, but it isn't clickable. In beta I change this network as home or work (and as work netwok it does well), but since RC it is public and not clickable. I can access internet from my XP machine, but even when one day I can access the shared folders on my W7 PC from my XP one, it can't be done after again. And I can never access the shared folders on my XP PC from my W7 PC.
    Tuesday, May 26, 2009 6:30 PM
  • I CAN'T CHANGE MY NETWORK FROM PUBLIC TO WORK OR HOME.

    IS THERE SOMEONE WHO CAN ANSWER THIS?
    Wednesday, May 27, 2009 6:04 PM
  • Wednesday, May 27, 2009 7:41 PM
  • The workaround is to open the Network folder - open an Explorer window by clicking on Computer from the Start Menu and then selecting Network from the left hand pane.
    Then click on the “Network discovery and file sharing are turned off.  Network computers and devices are not visible.  Click to change…” goldbar. 
    Then choose “Turn on network discovery and file sharing” when prompted.
    You'll be then asked if you want to turn it on for all public networks or if you want to make the network private.  Choosing private will give the network a work location.

    • Proposed as answer by PhilCorps Inc_ Sunday, January 12, 2014 11:36 AM
    Thursday, May 28, 2009 2:17 AM
  • The workaround is to open the Network folder - open an Explorer window by clicking on Computer from the Start Menu and then selecting Network from the left hand pane.
    Then click on the “Network discovery and file sharing are turned off.  Network computers and devices are not visible.  Click to change…” goldbar. 
    Then choose “Turn on network discovery and file sharing” when prompted.
    You'll be then asked if you want to turn it on for all public networks or if you want to make the network private.  Choosing private will give the network a work location.

    Did not work for me same old story stuck on public! Interesting comments on the forum http://social.technet.microsoft.com/Forums/en-US/w7itpronetworking/thread/878f7c4f-f287-4c75-a708-a2097f931435 seems like windows is really in reverse!

    I await another suggestion or perhaps an update from the gods come on MS play the game.

    john
    Thursday, May 28, 2009 10:38 AM
  • I agree.
    Thursday, May 28, 2009 6:12 PM
  • I'm reposting my comments I made on the other thread to make it easier to follow along!


    I think we are dealing with a problem that actually goes back to the introduction of the Windows Vista code base. What I have noticed in all versions of windows released since then is that NIC card connected to a residential gateway device always get setup as the home network. The second NIC card where you actually want to have the Home or Work setting seems to get ignored and becomes the "Unidentified Network." At least this situation was still correctible until the release of Windows 7 RC1. A theory I have is that Microsoft is probably trying to fix another problem I have noticed when one goes in and corrects the network designations is that the settings may not always stick where you want them to be. Take for example, doing something as simple as enabling printer sharing, your settings may revert back to your intial setup values without you knowing it. I have found that I have always needed to go back in and double check my settings each time I needed to change something related to the network. My hope is that someone at Microsoft can realize what is really happening with network detection and get it right. How hard can it be to have Windows reverve the network assignments on initial setup? 
    Thursday, May 28, 2009 6:21 PM
  • Maybe, but is not good t nobody from Microsoft says a word.
    Thursday, May 28, 2009 10:25 PM
  • unfortunately, since you are using the test version, Microsoft will not officially support this product until the retail versions comes out to my knowledge.  I am sure Microsoft support teams are being trained to assist you when the official release comes out for christmas.  For now, Most are probably obligated to support only XP and Vista.  Hopefully, a update will fix this issue.
    Saturday, May 30, 2009 12:25 AM
  • Hello all inc MS
    Well I have my sony and the RC working using "home" at last!!! Solution for me was to find old driver for my LAN express  AS IEEE 802.11g mini. I then used the drivers own install rather than the Windows procedure and it worked. I got the idea from browsing the other forums especially  Wi-Fi Issues in Windows 7 build 7100(RC)

    just rebooted and it is still working!

    hope this helps you all by the by I went back to a 2007 driver
    John


    • Proposed as answer by charles-john Saturday, May 30, 2009 5:17 PM
    • Unproposed as answer by DrGerry Tuesday, June 23, 2009 5:55 PM
    Saturday, May 30, 2009 3:40 PM
  • Maybe. I can't find no drivers for my card.
    Saturday, May 30, 2009 7:37 PM
  • Having installed win 7 on 9 differnet PC's /  laptops (most Dells)
    I can say that MS networking works just fine (well not logging into my NAS boxes but that is a user / password thing present in VISTA as well I am told)
    I have had to install the XP driver for 5 of the PC's and 2 laptops but once that is done all is well

    I had sleep issues with coming out of sleep and having no inet, but that was fixed with the second set of updates I did.

    So find the XP driver for the NIC and give it a shot, cuz the networking part (PC 2 PC) works just fine.
    Saturday, May 30, 2009 11:48 PM
  • To Bubbapcguy,
    I'm sure using a single network card on a laptop won't manifest the problem we are having, but thanks for the input.
    The problem we are complaining about is not being able to assign network designations when we are using our PC's in Internet Connection Sharing mode using two network cards. Invaribly, the wrong card gets designated as the Home Network card which can potentially open up your PC to the World Wide Web if you are not careful!

    Sunday, May 31, 2009 3:21 AM
  • Rick-m
    Just to sqare the circle the public/home problem for me was related to one Sony laptop connecting to the Internet via ISP router, so only the one card so saying the problem will not occur with single network card on a laptop is simply not true, sorry. Still the solution stays same roll back the drivers but I suggest use the manufactures install keep clear of the win procedures.
    john

    ps I do have this sleep prob so Bubbapcguy may I ask what were the 2n set of updates yours or MS.
    Sunday, May 31, 2009 7:52 AM
  • My apologies...
    Sunday, May 31, 2009 2:40 PM
  • Hi do not apologize  problem lies with poor old "bill gates" and is gang of con artistes
    j
    Sunday, May 31, 2009 6:57 PM
  • My problem is to access the XP shares from W7, from my XP PC I can access Internet and the shars on my W7 PC (after a lot of patient)
    Sunday, May 31, 2009 7:44 PM
  • I'm having the same problem. I have two Windows 7 machines. One has a wireless USB Sprint modem and connects to a switch to share Internet access via ICS with another Windows 7 machine. The network on the machine with the modem is set up as a public network, and I can't change this. The other machine is set up as a home network.

    I ran into this problem while trying to set up Homegroup. A computer on a public network can't join Homegroup. I found this thread while searching for a way to change from public network to home network.
    Sunday, June 07, 2009 6:40 AM
  • Here's a Powershell script that will change the 'Unidentified network' from public to work (same as Home except without Homegroup).

    // 
    // Name: ChangeCategory.ps1 
    // Copyright: Microsoft 2009 
    // Revision: 1.0 
    // 
    // This script can be used to change the network category of 
    // an 'Unidentified' network to Private to allow common network 
    // activity. This script should only be run when connected to 
    // a network that is trusted since it will also affect the 
    // firewall profile used. 
    // This script is provided as-is and Microsoft does not assume any 
    // liability. This script may be redistributed as long as the file 
    // contains these terms of use unmodified. 
    // 
    // Usage: 
    // Start an elevated Powershell command window and execute 
    // ChangeCategory.ps1 
    // 
    $NLMType = [Type]::GetTypeFromCLSID(‘DCB00C01-570F-4A9B-8D69-199FDBA5723B’)
    $INetworkListManager = [Activator]::CreateInstance($NLMType)
    
    $NLM_ENUM_NETWORK_CONNECTED  = 1
    $NLM_NETWORK_CATEGORY_PUBLIC = 0x00
    $NLM_NETWORK_CATEGORY_PRIVATE = 0x01
    $UNIDENTIFIED = "Unidentified network"
    
    $INetworks = $INetworkListManager.GetNetworks($NLM_ENUM_NETWORK_CONNECTED)
    
    foreach ($INetwork in $INetworks)
    {
        $Name = $INetwork.GetName()
        $Category = $INetwork.GetCategory()
    
        if ($INetwork.IsConnected -and ($Category -eq $NLM_NETWORK_CATEGORY_PUBLIC) -and ($Name -eq $UNIDENTIFIED))
        {
            $INetwork.SetCategory($NLM_NETWORK_CATEGORY_PRIVATE)
        }
    }
    

    Be sure to run this only on networks that you trust since changing from public to work will affect firewall policies.
    This information is also available at http://blogs.msdn.com/dimeby8/archive/2009/06/10/change-unidentified-network-from-public-to-work-in-windows-7.aspx along with instructions on how to run it in Powershell.

    Wednesday, June 10, 2009 10:18 PM
  • Is anyone having any real success with this patch?
    For me, it temporarily changed the icon in my network control panel, but I was not able to do anything with the settings.
    • Proposed as answer by FastSteve Friday, June 12, 2009 6:33 PM
    • Unproposed as answer by Adam M MCP Saturday, June 13, 2009 3:56 PM
    Thursday, June 11, 2009 12:34 AM
  • Is anyone having any real success with this patch?
    For me, it temporarily changed the icon in my network control panel, but I was not able to do anything with the settings.


    I am having a hard time making replies to this thread., because the reply box opens in several places. I hope this will go in okay.

    On the blog, it says the script needs to be re-run every time the network is connected.  That seems like a very poor fix to me.

    By the way, you don't need two LANs to get this problem.  I have one LAN, an ethernet connection between this Win7 machine and my XP machine.  It is "unidentified network", "public network", and can't be changed.

    In contrast, my dialup internet connection is fully configurable.

    The XP machine has no problem accessing this Win7 machine, but to allow this Win7 machine to access the XP machine, I must turn on "network discovery" for public networks.

    Friday, June 12, 2009 6:41 PM
  • I can´t do this. I recieve the next message:

    The term 'ChangeCategory.ps1' is not recognized as the name of a cmdlet, functi
    on, script file, or operable program. Check the spelling of the name, or if a p
    ath was included, verify that the path is correct and try again.
    At line:1 char:19
    + ChangeCategory.ps1 <<<<
        + CategoryInfo          : ObjectNotFound: (ChangeCategory.ps1:String) [],
       CommandNotFoundException
        + FullyQualifiedErrorId : CommandNotFoundException


    Suggestion [3,General]: The command ChangeCategory.ps1 was not found, but does e
    xist in the current location. Windows PowerShell doesn't load commands from the
    current location by default. If you trust this command, instead type ".\ChangeCa
    tegory.ps1". See "get-help about_Command_Precedence" for more details.


    I copy/pasted the text and saved as D:\ChangeCategory.ps1 (as I installed W7 from inside XP, the W7 root is D: ). I go to run --> powershell and I runned set-executionpolicy remotesigned and then d:\ChangeCategory.ps1.

    Friday, June 12, 2009 7:27 PM
  • Double post....

    I can do this (I have to delete the "//" lines) but I see no results.

    I have two networks (with two adapters of course) and the first one (connected to Internet) aleays worked and if I want, I can change it. My problem is with the second one. Maybe must I change something in the script?
    Friday, June 12, 2009 7:39 PM
  • I had the same problem with the script when I first tried it. The only way I could get it to remotely work was to go into my control panel, then go into user accounts and family safety, then into user accounts, then change user account control settings. After weaving my way into all of this, you will finally get a slider control which I had to set down to never notify. This slider controls whether or not a program can make changes to your computer. When you make the control change, you will be asked to re-boot your computer.
    After doing all of that, it was the only way I could get the script to work,....sort of, but it still didn't do the trick for me and as I mentioned before, it only changed the icon in my network control panel.
    Saturday, June 13, 2009 12:13 AM
  • First of all, you shouldn't have upgraded. I would try a clean install. But failing that, what is your network card, since you said you can't find a driver, maybe we can help you find one.
    Saturday, June 13, 2009 4:19 PM
  • I don't know if I understand you well (english is not my first language). I have made a fresh installation (even formatting) when I installed the RC.
    Sunday, June 14, 2009 5:53 PM
  • You said in your first post you upgraded to Windows 7 RC. So what is your NIC card?
    Monday, June 15, 2009 2:12 PM
  • What happen with the forum software? It is horrible.... I wrote this post three times now (and counting?) and it appears as an empty post (???????????) (I'm using IE8) I said: I upgraded from beta to RC by formatting the partition and from inside XP. Where can I find the card NIC?
    • Edited by DrGerry Monday, June 15, 2009 4:31 PM text vanish twice
    Monday, June 15, 2009 4:25 PM
  • After a lot of job, I connected my W7 beta PC with my XP PC, but when I upgrade to W7 RC, I am unable to do this.

    Your NIC card should be in device manager.
    Monday, June 15, 2009 6:46 PM
  • hello all

    i go back to my original solution identify the card go to manufacturer web site download xp drivers and I tink you will be ok. (Install using manufacture install) Not networking but I ad to do the same with my sound card (Sigmatel) hopefully microsoft will find a driver expert before go live as my solutions are not really useful across large networks.

    john
    Tuesday, June 16, 2009 7:07 AM
  • Sorry, but I can't find the NIC. Where in the device manager? I open it, expand Network Adapetrs, select one of it, go to Properties but I can't found the NIC.
    Wednesday, June 17, 2009 6:05 AM
  • Sorry, but I can't find the NIC. Where in the device manager? I open it, expand Network Adapetrs, select one of it, go to Properties but I can't found the NIC.

    It will be an unidentified device in device manager.

    You will need to find the model and manufacturer.  There are several ways to do this.  If it's a well known store bought computer brand, you might find this information on the manufacturer's website.

    Usually the NIC, also known as the ethernet adapter or LAN adapter, is part of the motherboard.  But you could use a LAN PCI card.  You should be able to see the brand and model number of the motherboard if you enter the BIOS setup when you power on your computer.  Also there are some nice programs you can run that will show you the motherboard brand and model number, but the ones I use cost money.  I use Everest Ultimate, but it costs around $30.

    Once you know the motherboard model number, you can search the internet, assuming the LAN adapter is on the motherboard.

    When Device Manager shows an unknown device, it will show you a string of numbers known as the hardware ID.  Click Properties > Details tab.  Select Hardware ID.   I don't know much about them, but they can be used to identify the device. Apparently there are programs that can help you do this.

    Check these out:
    http://www.emergingtechs.com/posts/how-find-drivers-unknown-devices-device-manager/comment-page-1/#comment-450

    http://www.smashingdownloads.com/2008/12/16/find-drivers-for-unknown-devices-with-unknown-device-identifier/

    http://www.pcidatabase.com/

    If there is no driver available for your NIC, you can buy a LAN PCI card.
    Wednesday, June 17, 2009 12:23 PM
  • One thing I forgot to mention.  Did you check Windows Update?  It had a driver for my on-board audio under "optional updates".

    I guess there are several ways to access the Windows 7 style "windows updates".  If you run I.E.8, click Safety > Windows Update.

    P.S.  This forum software is working well today.  In past days, the reply function was insane.
    Wednesday, June 17, 2009 12:29 PM
  • Did you at least try copy-pasting the script? It is obvious the shell didn't like the file you saved.
    Wednesday, June 17, 2009 1:24 PM
  • @FastSteve: Thanks. I know how to identify an unknown device by the visible yellow sign. It don't have change much since W95 or W98 as I remember.

    I used the program Unknown Device and, of course, don't find any unknown device. I really don't know what the nic number is. I founded a Hardware ID.

    I have two cards:

    1 - onboard, nVidia/ASUSTEk manufacturer, Hardware ID - VEN_10DE&DEV_07DC&SUBSYS_816A1043&REV_A2. This is the one connected to Internet and it works fine.

    2 - LAN card, Realtek manufacturer, Hardware ID - VEN_10EC&DEV_8139&SUBSYS_813910EC&REV_10. This is the one connected to the Local network. This works because the XP PC can connect to Internet throu the W7 PC and I can see the shared folders of the W7 PC. What I cannot do is to see the shared folders on the XP PC from the W7 PC.

    And the Active networks viewer (W7) shows me the second connection as Unidentified network, Public network, but no options to change it.

    Of course I have copied/paste the script, and of course I have checked the Windows update.
    Wednesday, June 17, 2009 4:50 PM
  • You are in the same boat as everyone else.  To see the files on the XP machine, you must enable "network discovery" for public networks.

    I don't remember exactly how I did this.

    This ought to work.  Go to "network and sharing center".  You've probably been there a hundred times.  You can get there from control panel > network and internet.  Click "advanced sharing".  Click on  "public".

    Wednesday, June 17, 2009 4:58 PM
  • I did it, but I can't see the files/folders.

    Whay I said is, with the W7 beta I enabled the "network discovery" and when I change the second connetion to work, I can work fine. Since RC, I cannot change the connection type.

    I ran the script again, no errors, but no results. The icon has cjanged and I can click it, but I cannot change anything.
    Wednesday, June 17, 2009 4:59 PM
  • Well, your situation may be different from mine.  I only have one NIC.  My interniet connection is a dial-up.  I guess I'm one of the lucky ones, because with public network discovery enabled, I can see my XP machine.
    Wednesday, June 17, 2009 5:27 PM

  • Setting up workgroup on RC 32 and 64 need xp access so can't set up homegroup. Have had trouble getting even basics. Pretty much auto-configures network connection to 10/100 hub and can see computers and use printers on network. Can network print,  basic .jpg and .pdf scans to browser only through HP EWS. 

     Network states unidentified network

    Attempt network map and it states cannot map location type public.

    Windows network diagnostics states investigate router or broadband issues,  it's a pass though hub and pc communicates fine though hub but is a 10/100 connected to realtek gigabit NIC's.

    Cannot figure out how to change unidentified local area network from public to workgroup. Internet network can be configured public, work or home by clicking on blue config link but Cannot  configure NIC named Local area connection. Have  named computer and set workgroup to workgroup.

    Cannot use net work scanner except through ews set up of hp vista drivers reads networks printer seems to complete install and then suddenly reads failed, try Xp and Vista compatibility and windows update drivers as well.

    Having a difficult time checking progress on Win 7 GUI on XP I have two network icons and both have animated icons very useful for diagnosing, can view hub activity directly and connection status and can easily check third party firewall in real time on XP. Any way to get separate notification area icons for different networks its confusing

    To see no internet access, disconnected, and limited access notifications on a single icon when only one network has issues or it's just plain disabled intentionally, internet access is intentionally disconnected etc. is confusing wastes time and to me is a big security risk. Lets say I disable firewall to check workgroup network forget and an ICS call connectes to network then I will have no notification.


    Problem is  not firewall related.

     

    I didn't try the script yet seems like there are fundamental GUI and program issues.


    Wednesday, June 17, 2009 5:41 PM

  • ". . . Cannot figure out how to change unidentified local area network from public to workgroup. Internet network can be configured public, work or home by clicking on blue config link but Cannot  configure NIC named Local area connection. . . ."

    ". . . on XP I have two network icons and both have animated icons very useful for diagnosing, can view hub activity directly and connection status and can easily check third party firewall in real time on XP. Any way to get separate notification area icons for different networks its confusing"

    ". . . seems like there are fundamental GUI and program issues."


    I couldn't agree more.

    Wednesday, June 17, 2009 7:04 PM
  • I have the same problem.
    I can't change unidetified network to home.

    It's very important.
    It's need fix.
    Wednesday, June 17, 2009 9:20 PM
  • If someone can't access their XP machine from Win7, there may be a workaround.  My situation is different from most of you because of only one LAN, but these things work for me.

    Enter the other computer in Windows Explorer's address bar.  Use this syntax: \\<other_computer_name>

    where <other_computer_name> is the name of the other computer.  When I do this, I immediately see all the shares on the other computer.

     

    Map a network drive.  If you click on "computer" you will get a "map network drive" button on the menu bar.  You won't be able to browse for the other computer, but you can enter something like this: \\<other_computer_name>\<share name>


    I also find I can see the other computer under "network", if I enable network discovery for Home and Work, even though my LAN is "public network".

    I also used secpol.msc to enable everything I could find about public networks.  It didn't seem to do anything at the time, but maybe it improved things later on.  Like the rest of you, I still can't change the LAN from "public network", but I can access my XP machine.

    P.S.  This forum software just got insane again.  I have no idea what this post will look like.  It sure would be nice if they had a "preview" button.

    Thursday, June 18, 2009 1:31 AM
  • I tried the method you say but it doesn't work.

    About the forum software.... I suggest Microsoft to try phpBB :lol:
    Thursday, June 18, 2009 5:26 PM
  • Got Home network enabled I sent an ICS request to another computer and the home, public work dialog appeared I clicked work and set up work network and ICs was enabled.

    I tried the same procedure in reverse and it worked but the other computer reverted back to public network with no dialog box or prompt.

    Cannot enable work network on both computers at same time and lose ability to see any part of network except the ICS internet connection.


    Hers the deal I can set up network to share internet connection or set it up to view files, printers other network devices etc.


    Internet connection and the rest of the network are mutually exclusive.

    Attempted static ip on host and auto dhcp on client and tried auto-auto and the reverse static client dhcp host even though I though they would not work I tried it anyways, because the help file for ICS seemd to indicate auto-auto ip config.

    Mouse over does indicate internet connection enabled or disabled but would really prefer two network notification area icons for two connections for several reasons I don't want to stare at yellow warning or red x though a common icon and I want to know if there is traffic on one network v another example did my host or client computer start downloading updates or more importantly accesing the internet without my knowledge.

    I think I understand MS logic and agree with it to an extent that the OS should work in the background and the end user can focus on working rather operating the OS judging by getting rid of defrag GUI.

    I'm sure most of us want that but it appears there are to many variables to leave out manual or semi-manual network config options and to me it seems a security risk to delete network acitivivity indication.
    Saturday, June 20, 2009 6:05 AM
  • I greatly miss the network icons in the XP system tray (or whatever you call it).  I want to know when there is traffic in either network for various reasons.  Beyond that, the mouse hover is very handy.  I can see the bytecount and connection speed on my dial-up.  I can disconnect the dial-up by right clicking.  Yes, yes, I do hope someone will come up with the XP style network icons.
    Saturday, June 20, 2009 4:48 PM
  • I use my second LAN card on my PC for a direct connection to my laptop (crossover cable).  I can transfer my files only by enabling file sharing on public networks.

    DrGerry,
    1.  Enable file sharing for public networks.
    2. Find the IP address of the computer you are trying to connect to by walking over to that computer, open a command prompt and type (without quotes) "ipconfig /all"
    3. Walk back to your computer, click start, type in the search box the address of the computer you want to connect to.  For example:
    \\169.254.2.185

    That's it, your connected.  If it doesn't work first time, doublecheck you have the correct IP and then try again.

    Since the IP addresses will change regularly, you will eventually want to assign a static IP for each computer on the network.  Once you have static IPs then you can create shortcuts to them and save you the walking.  You can find information how to set up a static IP from here: http://www.portforward.com/networking/staticip.htm





    Saturday, June 20, 2009 8:40 PM
  • Thanks. Everything you say I have done a lot of times.

    The connections exists, in fact from the XP computer I can access the sahred folder of the W7 PC, even to access internet. What I can't do is the opossite: to access the shared folders of the XP from the W7.
    Sunday, June 21, 2009 5:33 AM
  • Helooooooo!!!!!!
    Tuesday, June 23, 2009 5:55 PM
  • Did you try this yet?
    Saturday, June 27, 2009 8:32 PM
  • hi, go into the network and sharing center, click manage network connections. when the window opens, click the network adapter that is set to public. click trubleshoot and it will give you the option of changing the network location to work or private e.g. home.
    Saturday, June 27, 2009 11:36 PM
  • Did you try this yet?

    The entire thread is older than the W7 RC version. Maybe is my bad english, but I don't understand what I have to try from this (?)

    I repeat: I have two net adapters: the first one is set as Public, connected to internet an work fine. This is clickble and I can change it to other kind of network if I want.

    The second one is connected to a switch, is setted as Public but I can't click on it, is only a text.

    I tried by changing the physical connections but it doesn't worked.

    I can navigate on internet from my XP PC and I can see the folders shared on my W7 PC if I look from my XP PC, but I cannot see the folders shared on the XP from the W7.

    And repeat: with W7 Beta I change the second adapter to Work network and it worked, since RC I can't change my second adaptor; it is only Public.
    Sunday, June 28, 2009 7:35 PM
  • hi, go into the network and sharing center, click manage network connections. when the window opens, click the network adapter that is set to public. click trubleshoot and it will give you the option of changing the network location to work or private e.g. home.

    I go to Network and sharing center, but I haven't a "manage connections" link. In the main screen I see the two networks, but if I click on Troubleshoot problems I see a Mac-like "sit and see what I do", what is nothing. I want to have the chance to change the settings by myself.
    Sunday, June 28, 2009 7:46 PM
  • "I see a Mac-like "sit and see what I do", what is nothing."  And there lies the heart of the problem and Microsoft's dilemma. Microsoft software is free market software Mac is a closed market hardware/software system of course an integrated hardware/software system can have a simpler interface because it only operates a small selection of hardware in a limited set of configurations.

    I think MS is pestered to create a more mac-like seamless integrated GUI which is fantastic if you can pull it off but a can of worms if you can't.

    XP's network configuration worked in numerous circumstances and it appears Windows 7 works in limited circumstances with much "tricking" of default setting required to make changes.

    I used the set up ICS trick and as soon as the ICS was removed work network disappeared as if it had never been there and returned to public default settings.

    For lack of better terms Windows by nature has to operate a harware/software ecosytem MAC OS is the dictator or a proprietary hardware/software dictatorship.

    Point blank advice to MS Windows 7 development, you can't have a MAC like GUI controling non-mac like hardware environment there are to many variables and it causes to many problems for end users at this stage.

    There just plain needs to be additional work network setup options.

    I will try setting up home and implimenting these suggestions, I had already done that and attempted to change home to work but will try more workarounds. While I appreciate these workarounds they seem like band-aides to fundamental program and GUI issues and  hope MS has a parrallel team with a backup or XP/2003 fallback solution.


    Sunday, June 28, 2009 8:21 PM
  • my apologies, wrote this comment from vista business. the link is called "change adapter settings". win 7 rc is driving me round the bend. i have 12 machines domained to server 08. took a long time to set up the connections. try setting the network adapters with static ip adresses, if you are using internet connection sharing, set the ip adress on the host to 192.168.0.1 subnet mask 255.255.255.0. go onto the client computers and set the static ip adress to 192.168.0.2-255
    subnet mask 255.255.255.0, default gateway to 192.168.0.1 dns server to 192.168.0.1. this will allow the client computer to access the internet through the host which is connected to the internet. just make sure you have shared the internet connection.
    Sunday, June 28, 2009 9:25 PM
  • I don't know if anyone has tried this yet but give it a go and see what happens. Click start, type in secpol.msc, click network list manager policies. These options let you change how Windows identifies networks, and change what type your existing networks are.
    • Edited by Adam M MCP Monday, June 29, 2009 7:32 PM
    • Marked as answer by Adam M MCP Monday, June 29, 2009 7:52 PM
    • Unmarked as answer by DrGerry Tuesday, June 30, 2009 5:53 PM
    Monday, June 29, 2009 7:10 PM
  • Well it worked for me though I've no idea how insecure I've made things.

    I was only hit by this today - all was OK with a LAN wireless connection but I added a dial-up via a Vodafone mobile device and presumaby made the mistake of aying that network was public (well, it seemed sensible enough at the time). Since then I've had the problems described above. I can't believe I was lucky enought to start looking just as Andrew posted his suggestion.


    Monday, June 29, 2009 7:50 PM
  • PS - it still says my LAN is unidentified. What might I do to change its mind?
    Monday, June 29, 2009 7:52 PM
  • What did you tell Windows to label it as? You would also have to change the setting for unidentified networks to be home or work as well as change what it says your network is, unplug the ethernet or reboot and see what happens.
    Monday, June 29, 2009 8:02 PM
  • Well, this powershell hack/fix seems to work for me anyway. Beautiful!
    Tuesday, June 30, 2009 10:59 AM
  • I don't understand why 2 ethernet ports are required.  Can't one port connect to everything by using a hub or router?

    Tuesday, June 30, 2009 1:02 PM
  • I am confused... but that's not unusual.   Once I plugged ethernet in things improved and it labelled both the wireless and wired as the same network.  I instructed unidentified networks to be be private in secpol BTW.

    This morning without wired and although I did have internet access initially it's now gone back to saying I have none.  The unidentified network has reappeared as public but the secpol still says that unidentified should be private. Clicking on that looks like it should give me the opportunity to change the name but, in fact, I can't edit it.

    Once I plug in the wired I get 'multiple networks' showing at the top of the network centre.  Aaargh!  I can't paste screenshots in here but my multiple are listed as SKYXXX wireless with internet and 'unidentifed' as wired LAN with no internet. If I unplug the wired all is OK with wireless until I restart.  Next restart all is OK - no need to plug in wired.

    The next gamble will be to try the Vodafone 3G dongle again.

    Tuesday, June 30, 2009 2:49 PM
  • I don't know if anyone has tried this yet but give it a go and see what happens. Click start, type in secpol.msc, click network list manager policies. These options let you change how Windows identifies networks, and change what type your existing networks are.

    I done but everything's all the same. I cannot click the text Public Network, so I cannot change it. I can click the icon, and the text Unidentified network is in a textbox, and selected, but I can't change it.

    I have "forced" the network address (I mean 192.168.0.1, and so on), I have unplugged the network cable, I have removed and reinstalled the network card. Of course, I have restarted several times my computer.

    The problem is still there.
    Tuesday, June 30, 2009 5:57 PM
  • Yes if you connect it to a router, no if you connect it to a hub or switch.

    Of course I can buy a router and maybe I wiill solve all of my problems. The same, I can buy a Rolls Royce and I will not have more problems with my car, or I can buy a supercomputer and everything will go faster.

    What I want is to solve a problem I am not the only one who have it, and, in my case, it appears with RC.
    Tuesday, June 30, 2009 6:01 PM
  • SOLUTION :

    WINDOWS 7 WILL AUTOMATICALLY TAG THE CONNECTION AS UNDEFINED NETWORK WHEN IT IS UNABLE TO DETERMINE THE TYPE OF THE CONNECTION AND YOU ARE NOT ALLOWED TO CHANGE THE NAME AND TYPE OF THE NETWORK

    The possible reasons are :

    a. You are connecting to a network with TCP/IP configuration to automatic but the network doesn't have a DHCP server;
    b. You configured the TCP/IP manually with static values but didn't specify a Default Gateway;

    The possibles solutions are :

    a. you are using dynamic IP, so you have to set up a software DHCP server on the 2nd subnet

    b. you are using static IP, so set up a default gateway on the 2nd subnet NIC

    ( Source : http://windows7forums.com/windows-7-networking/4416-how-change-network-type-2.html )

    Hope this helps ^^

    • Proposed as answer by rgbigel Sunday, August 09, 2009 11:03 AM
    Wednesday, July 01, 2009 11:31 PM
  • Isendaloft, you da man!

    It was the bleepin' default gateway that caused my problem.  In the default gateway field, I typed in the fixed address of the other computer. That did the trick.  Then I could make it a Work network and change it's name, etc..
    Thursday, July 02, 2009 12:40 AM
  • Looks like I'm having a similar problem. I using an Intel PRO/100 VE NIC. I was able to connect to the internet fine with the beta version of Windows 7, but not with RC.

    I am stuck with an Unidnetified Network, and can't change to Home Network. The strange part is that this worked when I first setup up the PC, but after the first reboot it stopped working.

    I'm getting the message "The homegroup is not available because you're not connected to the home network". 

    Anyone have a clue?

    Thanks.



    - SD
    Thursday, July 02, 2009 4:24 PM
  • Hi SD

    Hope this isn't to basic but I'm not sure if the problem you described is due to the home network problem or non-problem. Did you check to see if there is any conectivity by going to the start orb and typing cdm in search programs and files box and  typing ipconfig /all see if there is any connection. You may just try opening taskmanger and checking for connectivity under networking tab. Perhaps try right clicking your network icon in the notificcation area and click diagnose problems. By your description it doesn't sound like you having the same problem we are but perhaps I'm wrong and your network configuartion or lack of configuration is preventing internet connectivity.

    Do you have a red x on your network icon? Have you navigated to network and sharing center and clicked adapter settings. Actually before any of that does device mgr show the nic card is installed properly? again sorry about the very basic questions perhpas you already checked all that plus of course the number one network killer the firewall.

    Other than that I'd check issues like network protocal which an ipconfig /all log should give a better clue since you did have connectivity at intial install and then lost it but perhaps I'm wrong because I can prompt Windows to ask for homegroup/workgroup setup and configure the network based on an ICS request from another computer and then as soon as the ICS connection is removed the Work network entirely disappears as if it never existed.

    I'm no network expert just going though the steps I would take since you have not described whether you are connected or trying to connect to a computer or computer/device network. My big problem has been setting up network scanners and printers due the the inability to set up a work group that can connect to XP work groups. I don't see why you would need homegroup in order to get an internet connection though the nic which should have autoconfigured on setup.
    Thursday, July 02, 2009 5:14 PM
  • SOLUTION :

    WINDOWS 7 WILL AUTOMATICALLY TAG THE CONNECTION AS UNDEFINED NETWORK WHEN IT IS UNABLE TO DETERMINE THE TYPE OF THE CONNECTION AND YOU ARE NOT ALLOWED TO CHANGE THE NAME AND TYPE OF THE NETWORK

    The possible reasons are :

    a. You are connecting to a network with TCP/IP configuration to automatic but the network doesn't have a DHCP server;
    b. You configured the TCP/IP manually with static values but didn't specify a Default Gateway;

    The possibles solutions are :

    a. you are using dynamic IP, so you have to set up a software DHCP server on the 2nd subnet

    b. you are using static IP, so set up a default gateway on the 2nd subnet NIC

    ( Source : http://windows7forums.com/windows-7-networking/4416-how-change-network-type-2.html )

    Hope this helps ^^


    I done this and didn't worked (I hope my verbs are correct) I repeat:

    1 - Win 7 + internet
    2 - XP

    I can navigate on 1 and 2 (thru 1). I can open files on 1 from 2. I can't open files on 2 from 1.

    That's simple.

    When installed W7 beta I had the same problem but I solved it by changing the second network to Work. When installed RC my two networks are setted as Public and I can't solve it.
    Friday, July 03, 2009 5:59 AM
  • I had a similar problem with network.
    I use two win7(7229 RC) samples to get a connection by LAN cable. I can change my network from public to work or home.
    when doing a home network testing,one of them create a network with home profile , and it will show a password for other units to get connection in the same home network.
    but another sample want to join this home network and enter the same password . It always show that I had a wrong password . Is it a issue from MS ??

    Friday, July 03, 2009 9:34 AM
  • This worked for me. It doesn't say that the network is Private (still says Public), but it works with the computer as though it's a Home network.
    Monday, July 06, 2009 11:05 PM
  • I have 2 network adapters. Adapter 1 is used for my internet connection configured on 192.168.10.* and Adapter 2 is used for my workgroup configured on 192.168.1.*  I guess I'm lucky to have a network printer because when I set the default gateway to my printer's IP address, the "Unidentified Network" disappeared and it became a regular network and I now can rename it and change it to Work and all my workgroup computers are now discovered and accessible.
    • Proposed as answer by rgbigel Sunday, August 09, 2009 11:02 AM
    • Unproposed as answer by DrGerry Tuesday, August 11, 2009 1:12 PM
    • Proposed as answer by NTauthority T.Welch Saturday, December 11, 2010 8:53 PM
    Thursday, July 30, 2009 12:00 PM
  • SOLUTION :

    WINDOWS 7 WILL AUTOMATICALLY TAG THE CONNECTION AS UNDEFINED NETWORK WHEN IT IS UNABLE TO DETERMINE THE TYPE OF THE CONNECTION AND YOU ARE NOT ALLOWED TO CHANGE THE NAME AND TYPE OF THE NETWORK

    The possible reasons are :

    a. You are connecting to a network with TCP/IP configuration to automatic but the network doesn't have a DHCP server;
    b. You configured the TCP/IP manually with static values but didn't specify a Default Gateway;

    The possibles solutions are :

    a. you are using dynamic IP, so you have to set up a software DHCP server on the 2nd subnet

    b. you are using static IP, so set up a default gateway on the 2nd subnet NIC

    ( Source : http://windows7forums.com/windows-7-networking/4416-how-change-network-type-2.html  )

    Hope this helps ^^


    This solution works -- but unfortunately it requires the other network adapter to be on DHCP. If you want two adapters with fixed IP, you get messages that having two default gateways "does not work properly".  I tried it anyway -- this resulted in an unreachable internet via router. This all is in Win 7 RC, I will try it on a RTM (Ultimate) in a few moments, but I'm not expecting an improvement.

    There is one thing you can do to ignore the problem without most of the negative aspects: turn off the firewall for your "private" network adapter. I don't see much danger here as that's roughly what would happen anyway if you could set it to private.

    Having one line set to DHCP (to the router) and the other to use fixed IP will also not be without side effects. Suppose the DHCP line is only 100 Mb, while the internal net uses 1Gb. This will result in all network trafic using a computer name to pass via the 100 Mb line, which is probably not what you wanted. Maybe you could remedy that with a route command; but I have not succeeded in a non-temporary solution to this as the routes are not kept across reboots -- any help welcome.

    Getting a DHCP server into this business will also not solve the problem, because then this computer needs to be online all the time, which is not what I would want. If your router (like mine) provides DHCP, you also get problems, because having two DHCPs will usually get you into trouble (this I read from other posts, never did it myself.)

    Whoever is responsible for this mess at Microsoft should either provide a very good explanation or preferably fix it as fast as possible.
    Sunday, August 09, 2009 11:04 AM
  • I got this solution to work but after rebooting the network is gone as if it never existed. The default gate way solution does allow work network to be setup but printer disappears on dhcp when rebooted I get a bunch of duplicate printers because they need to be reinstalled.

    THe home network might be great I haven't used it becuase I need to network with XP.

    I think the basic point is there are some basic issues that need to be worked out XP worked was faily easy to set up, was reliable easir to diagnose and gave better indcations of its operation such as separte tray notifiactions that showed network activity. I would have to say the interface and procedure is just plai to MAC like. MS needs to work with far to many hardware combos for the current setup to work out well.
    Monday, August 10, 2009 4:29 AM
  • SOLUTION :

    WINDOWS 7 WILL AUTOMATICALLY TAG THE CONNECTION AS UNDEFINED NETWORK WHEN IT IS UNABLE TO DETERMINE THE TYPE OF THE CONNECTION AND YOU ARE NOT ALLOWED TO CHANGE THE NAME AND TYPE OF THE NETWORK

    The possible reasons are :

    a. You are connecting to a network with TCP/IP configuration to automatic but the network doesn't have a DHCP server;
    b. You configured the TCP/IP manually with static values but didn't specify a Default Gateway;

    The possibles solutions are :

    a. you are using dynamic IP, so you have to set up a software DHCP server on the 2nd subnet

    b. you are using static IP, so set up a default gateway on the 2nd subnet NIC

    ( Source : http://windows7forums.com/windows-7-networking/4416-how-change-network-type-2.html  )

    Hope this helps ^^


    This solution works -- but unfortunately it requires the other network adapter to be on DHCP. If you want two adapters with fixed IP, you get messages that having two default gateways "does not work properly".  I tried it anyway -- this resulted in an unreachable internet via router. This all is in Win 7 RC, I will try it on a RTM (Ultimate) in a few moments, but I'm not expecting an improvement.

    There is one thing you can do to ignore the problem without most of the negative aspects: turn off the firewall for your "private" network adapter. I don't see much danger here as that's roughly what would happen anyway if you could set it to private.

    Having one line set to DHCP (to the router) and the other to use fixed IP will also not be without side effects. Suppose the DHCP line is only 100 Mb, while the internal net uses 1Gb. This will result in all network trafic using a computer name to pass via the 100 Mb line, which is probably not what you wanted. Maybe you could remedy that with a route command; but I have not succeeded in a non-temporary solution to this as the routes are not kept across reboots -- any help welcome.

    Getting a DHCP server into this business will also not solve the problem, because then this computer needs to be online all the time, which is not what I would want. If your router (like mine) provides DHCP, you also get problems, because having two DHCPs will usually get you into trouble (this I read from other posts, never did it myself.)

    Whoever is responsible for this mess at Microsoft should either provide a very good explanation or preferably fix it as fast as possible.

    Maybe I don't understand you, but, if I have a router I don't need to use two adapters, I simply use the router as server and connect all of my computers to it.
    Tuesday, August 11, 2009 1:15 PM
  • Maybe I don't understand you, but, if I have a router I don't need to use two adapters, I simply use the router as server and connect all of my computers to it.
    Well, what will you suggest if I need I 1 Gb Line between my PCs and my router can only handle 100 Mb? Hint: two network cards...?
    Tuesday, August 11, 2009 6:00 PM
  • Well, it is hopeless. The RTM do the same cr*p....
    Saturday, August 15, 2009 5:44 PM
  • I've just stumbled onto this myself - for me it's particularly galling, since I have a tunnel into work, as well as the wireless for "general i/net work".

    Since I move the laptop between home and the office, I'm going to have to manuall change the default gateway on the non-DHCP NIC every time Io between the two.

    Not being able to set a non-identified network as a "yes, I know it's safe", is just plain baloney.

    If this isn't resolved, I'll just go ahead and install openSuSE as the baseline O/S on the system, and VM off anything I absolutely *have* to do in Windows - Windows doesn't own me - I own it.
    Thursday, October 29, 2009 2:59 PM
  • has this been fixed in w7 offical release? i have just installed W7 official release and i am having this exact problem. Trying to network W7 with an XP machine. I can see the drives on the XP machine from W7 but the other way around (trying to look at drives on the W7 machine from XP) i get no luck in XP. And the network between the PC's is listed as "Unidentified - Public" in W7 and i cannot change it no matter how hard i try.

    It does not seem like there are many posts on here since August which leads me to believe the quiet traffic means it was fixed in the W7 official release but i am having the same problem!!!!

    My internet port is actually listed as "Home" now that i look at it, which means my PC is potentially open to the internet!!! damn what the ____, i hope M$ have not screwed up on this one as well for the official release as i am experiencing....please help!

    Friday, October 30, 2009 4:46 AM
  • No, the problem does not appear to be fixed.
    My computer is still doing the exact same thing on the official release software as it did on the RC1 software.
    As for no new posts since August, the RC Code was "frozen" at that time so no new changes could be put into the official release software.
    Friday, October 30, 2009 2:04 PM
  • How about a separate account for office network with manually configured IP, AND Default gateway settings? The network will remain unidentified until windows has enough  info to identify it.

     My computer is set up with a separate internet account anyways for configuration, and file access/organization reasons and because you can just delete the account if it gets messed up for any reason. Better yet would be office and internet accounts and you would gain office documents folder and different desktop if desired, If your really security conscience as I am the high security account could have security settings for services.

     MS will offer a fix or third party will offer a network program to fill the gap.

    I share your security concerns and tried MAC and Linux as a quick and simple internet access solution, as it turns out hackers cut their teeth on Unix based systems and I had far more problems with targeted attacks and much less firewall, network logging, and network monitor options, and serious kernel ppp issues there are far more programs and solutions for Windows.

    Perhaps we can pester MS to flag this issue and get out a KB.

    I haven't addressed this issue more comprehensivley because I figured the code was frozen.
    Friday, October 30, 2009 5:02 PM
  • I think the this problem with networking would have been addressed properly by Microsoft if it was released into the beta code for testing. Why Microsoft waited until the Release Candidate to spring the new networking scheme on us without an easy avenue to complain about it is beyond me. I will guess we might just have to wait until Service Pack 1 before the problem might be fixed if someone at Microsoft is reading this!
    Friday, October 30, 2009 9:00 PM
  • Guys, can anyone who has W7 release Prof or Ult go to secpol.msc and try to play policies related network manager? Do they already work or just left as stubs?
    Monday, November 02, 2009 8:52 AM
  • I have 5 items for "Network List Manager Policies".  They are all "Not configured".  I'm not about to change anything.  My network works, but I have only one LAN, and a dial-up.
    Monday, November 02, 2009 7:40 PM
  • Playing with the settings kind of works, but not quite giving me the results I'm looking for.
    I'll have to play with them some more.
    Monday, November 02, 2009 10:04 PM
  • i am using W7 Home Premium, it doesnt have secpol.msc. tried finding it and it just came up as "could not be found". which just makes things more frustrating....

    its crazy that my first port, my internet connection has the word "Public Network" in blue in my Networking & Sharing Centre (which means i can change it) but my actual second port, which is my home network port, just lists "Public Network" in black and cannot be selected to change.

    i thought it might be the drivers as ppl have mentinoed here but changing around the ports made no difference.

    please fix this Microsoft!!


    Tuesday, November 03, 2009 12:03 AM

  • its crazy that my first port, my internet connection has the word "Public Network" in blue in my Networking & Sharing Centre (which means i can change it) but my actual second port, which is my home network port, just lists "Public Network" in black and cannot be selected to change.

    If you have two ethernet LAN connections, you are probably screwed according to what I've read here.

    But if you have one ethernet LAN to connect your home computers, and a dial-up to connect to the internet, the problem can be fixed.
    Tuesday, November 03, 2009 12:55 AM
  • FastSteve im not actually screwed, i have access to the internet ok thru my Netcomm ADSL which does the logging on with my first LAN port. And i have access to my other PCs on my home network with the other LAN with filesharing just fine. So everything is working. Its just that i should be able to list that second LAN and my Home Network connected to it as a Home Network. Which i cant. W7 decides for me that its a Public location.

    Frustrating. 
    Tuesday, November 03, 2009 2:02 AM
  • Frustrating and potentially dangerous.
    Networking between your computers may work, but you could potentially be exposing yourself to the web. In my case, what I have done is to shut off "Client for Microsoft Networks" and "File and Printer Sharing for Microsoft Networks" on my NIC connected to my cable modem. In this way you can limit access to your computer and personal network from someone on the outside who might be able to see you through the web.
    The other problem without being able to define your personal network as being the Home Network is not being able to use the HomeGroup stuff. It's kind of neat to be able to play a video directly from your computer onto a TV with an ethernet port, but this feature does not work on a "Unidentified Network" port and not being able to change the setting to what it should be...
    • Proposed as answer by gstratto Tuesday, November 03, 2009 12:21 PM
    Tuesday, November 03, 2009 3:13 AM
  • Ok, I think i worked it out - 4 hours of playing with settings.

    Bear with me and follow these instructions.
    Some of these commands may be unneccessary, but i wrote down everything i did.
    It worked for me.

    Go to Control Panel
    Network settings and sharing Center
    Click Advanced Sharing Settings

    Under Public  -
    Turn off    Network Discovery
    Turn off    File and Printer Sharing
    Turn off    Public Folder Sharing

    Under Home or Work -
    Turn off   Network Discovery
    Turn off   File and Printer Sharing
    Turn off   Public Folder Sharing

    Once you have done this, go back to your Network and Sharing Center window.

    Under your Internet connection or Lan that is connected to your Modem / Router ( This is usually the top connection)
    Next to the picture of the House is the link HOME NETWORK. Click on this.

    In the next window that comes up make sure you select,  WORK NETWORK.
    Then click  " View computers and devices on this network "    - this seems to refresh the network settings.

    Now, go back to Network and Sharing Center.
    Click Homegroup (down the bottom left under the "see also" heading)

    A new window will come up titled  " Change Homegroup Settings "
    You will notice an Alert box that says - " Homegroup not Available as you are not connected to the Home Network "

    Click the link after that which says  "What is network Location"

    At this point a new window will pop up which says,   Do you want to turn on Network Discovery and File Sharing for for all Public Networks?

    Underneath this..  Click the first option, which is.. " NO, Make the network I am connected to a Private Network "

    Success!


    Under your Unidentified Network, it should now say Work Network  instead of Public Network.
    Now under the Network map, you should be able to see your XP PC shares or Vista shares :)

    Hope this helps.

    Again as i said some of this may not be necessary, but its the exact steps i took.

    You can also now change your Internet from Work to Public without affecting your bottom connection that is on work

    [IMG]http://i35.tinypic.com/dq50rn.jpg[/IMG]

    Cheers,
    Gstratto
    • Edited by gstratto Tuesday, November 03, 2009 12:46 PM added in picture to show
    Tuesday, November 03, 2009 12:38 PM
  • Sucks...
    Didn't work for me. Link "What's the network location" leads to the initial network management page.
    Thinking about moving to XP x64 or Ubuntu Linux.
    Wednesday, November 04, 2009 9:27 AM
  • Thanks gstratto, I am using the retail Windows 7 home premium 64-bit and found the " NO, Make the network I am connected to a Private Network " option after turning all sharing off according to your instructions and finally trying to browse the network in "Computer".

    It showed up after clicking the top yellow ribbon message, and now my unidentified network connected to the LAN adapter is of type "work network"


    Saturday, November 07, 2009 12:19 AM
  • well the urbnik method actually allowed me to find the setting when i opened up the Computer and tried to browse "network" and then the popup box at the top of the screen finally allowed me to change my network as it listed "No, Make The network I am Connected to a Private Network". All and great, until you reboot. then back to Public again.

    seriously this is rediculous i hope Microsoft fix this asap. Why one of the Active Networks is highlighted in blue writing to be able to be changed and the second Public icon below it simply has the writing in black and is not a link to change the setting is beyond me. Please fix this Microsoft!!!
    Wednesday, November 11, 2009 4:54 AM
  • Well, I too experience this strange behavior, however with only one NIC. This NIC is connected to my home LAN (Homegroup) via a switch, and one of the switchports is attached to my ADSL modem, which is also the default gateway and DHCP server.
    After a cold boot, the system comes up and Windows 7 gets the right IP address, the right DHCP server and the right default gateway. So far so good. However, somehow, Windows doesn't only find this Home network, but somewhere, somehow finds an Undefined network as well. Because of that, all network traffic is blocked.

    What helps is to disable the NIC and directly enable it. So I've made a shortcut on the dekstop to the adapter settings and after a cold boot, you only have to right-click this icon twice: the first time to disable it and the second time to enable it. It will continue to work good as long as the PC isn't turned off. No matter how many times you boot or switch user, Windows will only find one trusted Home network. Until you shut down.

    As stated earlier: it is possible that applying manual IP settings will solve this behavior, but I don't like it to do so. DHCP should work and I'm waiting for Microsoft to come up with a reasonable solution/patch.
     
    Thursday, November 12, 2009 2:36 PM
  • This problem is also driving me to distraction. My "wired pc" drops my internet every reboot and often on resume from sleep. the "wireless pc" has no trouble!. A temp fix for constantly reseting my Network controllers was to msconfig>services>hide all MS services> uncheck the Apple string or Bonjour. This saves constantly reseting while we wait for a real fix. I am useing W7 ultimate retail. I had the same install exactly with the W7 release candidate with no problems!
    Thursday, November 12, 2009 2:56 PM
  • Also been having this irritating issue on a laptop using wireless.  The only work-around I have come up with is to not use DHCP and assign a static address.  So far this has resolved my problem.  Other wirless devices on the network do not run Windows and therefore do not have this problem.

    Go figure...
    Tuesday, November 17, 2009 12:28 PM
  • I am having this problem also.

    I have bought Win7 Professional, PC has 2 NIC's but only one is used (connected to modem/router). I have tried both NIC's and disabled the second one in BIOS just to be thorough.

    I have managed to change my network to "work network" using secpol.msc but it is still and "unidentified network" and therefore I cannot seem to acces the internet.

    All my PC's are set up with static IP's with the router acting as DHCP server.

    This makes no sense - what the ____ is stopping me from accessing the network? Why do I not have the option to tell windows that I trust this network. This is incredibly bad form from Microsoft.

    Why did I spend $400 (AU) on a bloody OS that just doesn't work. Am I just supposed to keep my gaming PC as a paperweight until MS gets off their bums and address this glaring problem?!?

    Absolutely Disgusted!
    Thursday, November 19, 2009 1:15 PM
  • Couple of Guesses ProfessorAnthrax I'ts been a few  months but I recall not being able to make  network map of my router had intended to try another router/switch but had other priorities therefore perhaps Win7 cannot indentify network since it can't indentify router. Another is  perhaps DHCP of router is preventing Win7 from identifying network due to changing network since address is assigned by hardware outside of OS.

    A thought I had about this whole issue is that perhaps a compatibility add-on would be better overall than incorporating this functionality out of the box due to security, performance and bloat concerns. More features and compatibility is probably difficult to achieve without adding more attack vectors and more running processes. Security especially from the aspect of targetted attacks and network performance are high on my list.
    Thursday, November 19, 2009 7:29 PM
  • Sorry, but my english is a little poor, so probably I don't understand it right.

    I understand that W7 have problems to recognize a net connected via router?

    I havent a router now, but I believe if I have the next: internet modem (cable or ADSL) --> router --> a number of computers, I can have navigation on every computer and a private network too. Is it false?
    Friday, November 20, 2009 5:10 PM
  • Well I just updated my router's firmware - no dice. I have a Netgear DG834G v4 if anyone knows of any issues with this particular router. I'm not really sure what to try next. This is ridiculous!
    Saturday, November 21, 2009 11:29 PM
  • I was able to resolve my problem. I'm not sure this will work for your particular setup, but this what I did. First my setup:
    Nic 1: Connected to DSL modem - Shared connection using ICS
    Nic 2: Connected to Netgear switch on my internal lan

    In the Network and Sharing Center I see Nic 1: Identified as Public. Nic 2: also identified as Public - Unidentified network and I can't change it.  When I enabled ICS, it automatically assigned IP address 192.168.137.1 to Nic 2. I changed the IP's on the other pc's on my internal lan to match the 192.168.137.x network as well. Also had to assign 192.168.137.1 as the gateway on the other pc's. Internet access is working on all of them. However, Nic 2 was still labeled as Public - Unidentified network, which meant the Windows Firewall was blocking access to apps that I don't want blocked on my internal lan.

    I then unplugged the cable going into Nic 1, and the Network and Sharing Center only showed the Nic 2 Public Unidentified network. I turned on Network Discovery and Windows gave me the option to set Nic 2 as Public or as Home/Work network.  I selected Work network, and my Nic 2 is now identified as Work Network.  I reconnected my DSL connection, and Nic 1 reappeared as Public.  I rebooted and my pc, reopened Network and Sharing Center and I still see Nic 1 as Public and Nic 2 as Work, which is how I want it. 
    Tuesday, November 24, 2009 3:39 AM
  • Ok my network is working now out of the blue.

    I hadn't turned my PC on for about a week because i'd been away, and last night we had a storm so I like to unplug my computer to save it from any power surges during storms. When I turned on the PC this morning the network was working - just like that.

    I had rebooted and unplugged my router countless times but I never thought to unplug my PC. I can't really explain why this would work - maybe some part of the motherboard that is always in standby needed to reset or something.

    I just got my "public network" problem back a few minutes ago and I have a feeling that it was caused by sleep mode. When I came out of sleep mode I had to click my profile to log on (which i don't have to do at startup) and looking through the advanced power settings I cannot change the value for "require password on wakeup" to "no"

    After unplugging the PC and plugging it back in again my network is back though, and I have just disabled sleep mode altogether (as i didn't want it anyway)


    I hope this helps somebody out there.
    btw I have an ASUS striker II formula MoBo with dual Marvell 881116 NIC's if that's relevant.


    Cheers.
    Monday, November 30, 2009 5:09 AM
  • Hehe, the same happens to me a lot of times with XP. With W7 I haven't this "fine surprise" yet, but, who knows!

    Maybe there's something magic about computers :-D
    Monday, November 30, 2009 2:23 PM
  • Is Microsoft planning on fixing this problem? I have a setup that you will probably see much more often in the future. I'm have a wired LAN in one house, and the same in another. My homes are close to each other, so I have DSL turned on at one house, and I connect wirelessly to the other. I have to use ICS at one house to give access to the other PCs on my LAN, but I can't share anything with them because I can't change the network.

    Come on guys, you're killing me...

    Later,
    RushReb
    Thursday, December 17, 2009 3:53 AM
  • As we can see, no, Micrsoft believes everything is OK.
    Thursday, December 17, 2009 5:26 PM
  • RushReb not sure what issue you are talking about, but an easy fix for you is to use a mesh network or just create a wireless bridge between the two homes.

    If you have wifi at the DSL home use a bridge device (linksys wrt or any wifi bridge that works with the current wifi) make sure it will pass mutli mac addy's

    plug a hub into the bridge and you have a single network between homes, now you can plug a AP into the hub and have wifi in the second home.

    you can do this many ways all of them better from a end user point. Have you looked at Ad-hoc networking..you can ad-hoc on one and get what you want.


    and I "THINK" your issue is network awareness is that right?? Search here I am sure you can turn that off.

    the "cheap" way to do this is open mesh
    https://www.open-mesh.com/store/categories.php?category=Lowest%252dCost-Mesh
    Thursday, December 17, 2009 5:41 PM
  • it is the problem of the gateway service..so you have to take LAN connection properties button .Then you have to select  TCP(IPV4) ,from there you can put default gateway address or you can select the automatic ip address selection.the the system will automatically change settings and you can access the network.
    Friday, June 25, 2010 11:10 PM
  • Just faced the same problem on my "new" win7 machine which i am not liking very much due to all blue screens. I was able to find a way to set my home network to be recognized as Home instead of Public.
    Go to control pane > Network and Sharing Center.

    Under View your active networks section on that screen, click on the link that says public network or it could say something different like unrecognized or join network, dialog will pop up to allow you to set what type of network this is.

    Friday, July 09, 2010 12:50 AM
  • I had the same problem.  Newly installed Windows 7 Pro HP Desktop would not connect to my existing office network consisting of two XP Pro desktops + Netgear router + cable modem.

    Solution for me : Go into the router set up and look at the DCHP setting under LAN settings.  On mine the box was unchecked (= the manual setting).  Clicked the box to set it to automatic (the default) and the new HP was instantly recognised.  All was then OK.  Network and internet all perfect.

    In addition 'Public network' in the Network and Sharing Centre then became capable of being changed to 'Work network' whereas before it could not be altered.  Hope this helps someone.

    Friday, November 05, 2010 8:59 AM
  • 18 months later and still no fix.  And DirectX 10 is still a dog.  Between its innumerable bugs, hangs, slowdowns, hateful UI and half-baked networking I think we can now all agree that Windows 7 was a massive blunder.  Here's hoping Windows 8 will actually be worth using.
    Tuesday, November 30, 2010 1:38 AM
  • They're not ignoring you, they are still scratching their heads too !  Try this site below, for help with server product issues also :

    "http://support.microsoft.com/fixit/default.aspx/". This is MICROSOFT'S new, FREE, fully automated, anonymous support portal, which can help users resolve windows and other product issues with a few mouse clicks. BOOKMARK THIS SITE, EVERYBODY !!!
    Saturday, December 11, 2010 8:50 PM
  •      "Bugs", "hangs" and slowdowns, as phrased, all have their roots in specific causes that can be traced through and then eliminated: Are you aware of the site at the end of my answer ?  And if it can't help you fix this problem, at least the data will be reported back to the makers of your windows!

    "http://support.microsoft.com/fixit/default.aspx/". This is MICROSOFT'S new, FREE, fully automated, anonymous support portal, which can help users resolve windows and other product issues with a few mouse clicks. BOOKMARK THIS SITE, EVERYBODY !!!
    Saturday, December 11, 2010 9:04 PM
  • The answer is that your computer's settings to require a password lie in the screen-saver part of the display controls, not in the power section !

    "http://support.microsoft.com/fixit/default.aspx/". This is MICROSOFT'S new, FREE, fully automated, anonymous support portal, which can help users resolve windows and other product issues with a few mouse clicks. BOOKMARK THIS SITE, EVERYBODY !!!
    Saturday, December 11, 2010 9:09 PM
  • No magic necessary...We do it all with smoke and mirrors !

    "http://support.microsoft.com/fixit/default.aspx/". This is MICROSOFT'S new, FREE, fully automated, anonymous support portal, which can help users resolve windows and other product issues with a few mouse clicks. BOOKMARK THIS SITE, EVERYBODY !!!
    Saturday, December 11, 2010 9:10 PM
  • On a Windows 7 machine, all I did was delete the adapter and then allow it to recreate (scan new hardware). Once it recreated, the Network Type changed from "Unidentified" to "Public Network" in the Network and Sharing Center. At this time, I was able to click the phrase "Public Network" and change it to "Work network".
    • Proposed as answer by Etherdesk Tuesday, June 14, 2011 11:44 PM
    • Unproposed as answer by Etherdesk Tuesday, June 14, 2011 11:46 PM
    Monday, December 13, 2010 4:21 PM
  • I encounterd the same problem today. It is not just on the beta ver. this applies to on all windows 7. You have to assign a Gateway IP address if you are using a Static IP. This will solve the issue. Then it will let you choose the network location.
    Thursday, July 14, 2011 3:48 PM
  • hi ALL

    I had the same problem, and found the solution !!

    my configuration

    laptop1 :  windows 7

    laptop2:  windows xp

     

    laptop1:  connected to the Internet using cellhpone!   

    laptop 1 and laptop2 connected together using crossover UTP  ( simulation of LAN) right .  small network

     

    and I saw two public networks for both LAN and WAN, also LAN was unidentified

     

    what happedn  TCP/IP configuration,   I had IP addresses as follow

    192.168.1.2  /24

    192.168.1.5 /24

    but THERE WAS MISSING DEFAULT GATEWAY !!!!

    so I added for laptop1  IP of laptop2  as a Default gateway and tuuu tuu tuuu  I CAN cange netowrk location now!

     

    regards

    tomt

    Thursday, July 21, 2011 5:19 PM
  • WIRED PROBLEMS.....

     

    1. MAKE SURE YOU'RE CONNECTED TO A LAN.

    2. START>CONTROL PANEL>NETWORK AND SHARING CENTER

    3. CHOOSE "HOMEGROUP AND SHARING OPTIONS"

    4. CLICK "WHAT IS THIS LOCATION".

    5. CLICK "HOME OR WORK".

    6. GO TO "CHANGE ADAPTER SETTINGS"

    7. DISABLE THE ADAPTER

    8. ENABLE THE ADAPTER

    9. YOU'VE SUCCESSFULLY CHANGE YOUR ACTIVE NETWORK. ;)

    • Proposed as answer by JHONIEBOYYY Monday, August 01, 2011 4:17 AM
    Monday, August 01, 2011 4:16 AM
  • Dr. Gerry,

    I too have had your problem forever now.  After reading through this, I have found that the only things I have found relating to its fix are:

    1) make sure you are on a dhcp address and not a static.  This was the first part for me...

    2) make sure you have IPv6 checked in your network card's settings.  I guess the home connections need this set up for some dumb reason.

    After turning these one and then rebooting, I got mine to 'finally' show up as an option to change the network home/pub/priv option.

    I might be wrong, but this might be only affecting win7 ult. and pro. since home edition doesn't have some options with the networking side of things.

    Let me know if this helps in any manner.  WTF is MS on this issue?  You would think after 2 years they would have noted something.

    -Jim Ponder, MCP

     

     


    JimPonder
    Wednesday, August 03, 2011 6:51 PM
  • Control Panel --> Device Manager -->Network Adapters

    Right Click on your WiFi Adapter (mine was ms virtual WiFi Miniport Adapter) and choose UNINSTALL

    Leave the "delete driver" box UNCHECKED

    Once the wifi adapter is gone, right click on "Network Adapters" and choose scan for hardware changes.  It will re-find your adapter.

    Now go connect to the wireless network of your choice and in the network and sharing center the words "Public Network" should be a clickable link that you can then change to Home Work etc.

    • Proposed as answer by szegheo Wednesday, September 21, 2011 12:33 AM
    Friday, September 16, 2011 6:46 PM
  • This is really, really, really, really frustrating!!!

    Since the first post of the OP there is no reliable solution.

    Work around such are reinstalling the driver, setting a Gateway when the network is DHCP, disabling windows firewall, etc. is just plain ridiculous! One way or another you are already compromising the security of your your system!

    In the first place the network is working fine!

    As the OP said, i too is very angry. And even after SP1, still having the same issue.

    Monday, October 03, 2011 6:14 AM
  • I don't know if this will help but it worked for me. I added WPA-2 Personal sercurity with a passkey and it seemed to correct the problem. it seems unsecured networks are treated as public. I don't know why it works, but tryed 100's of differnt things and this is the only way to get it work.

    Hope it works for you


    chuck
    Friday, October 07, 2011 11:18 PM
  • The possible reasons are :
    a. You are connecting to a network with TCP/IP configuration to automatic but the network doesn't have a DHCP server;
    b. You configured the TCP/IP manually with static values but didn't specify a Default Gateway;
    The possibles solutions are :
    a. you are using dynamic IP, so you have to set up a software DHCP server on the 2nd subnet
    b. you are using static IP, so set up a default gateway on the 2nd subnet NIC


    Thanks  Isendaloft , this solved my problem.

    (have 2 computers connected, manual tcp/ip, and needed a private network for some tests; the default gateway solved the problem) 


    • Edited by Tud_ Friday, January 06, 2012 9:52 AM
    Friday, January 06, 2012 9:50 AM
  • Hi all,

    My network used to be just fine, but I've just noticed that it no longer automatically sees connected devices on my network (such as my NAS). Bemused I did some investigation and found that my network profile had switched from Home to Public - I've no idea why, and suspect that its got to do with a recent service update - who knows.

    If this helps others, heres what i did to switch the profile back from Public to Home:

    - Control Panel=>Network and Internet=>Network and Sharing Center

    - Under the little house on the left (Something like Network 1 or Network 2) it will say Public Network (or Home Network etc)

    - Click on that and you should get prompted to choose from 3 choices : Home, Work or Public

    This worked for me - hopefully it will be of help to others

    S

    Sunday, January 22, 2012 2:28 PM
  • i have look at a few systems where this has happened

     i find removeing andy firewall software help

     then it releases the option

     the last one had mcafee on it

    the network location is controlled by the fire wall

    hope this helps

    • Proposed as answer by MOJODUDE Wednesday, February 15, 2012 10:50 AM
    Saturday, February 11, 2012 7:21 PM
  • Hi,

    I had the same issue on new Win 7 Pro 64bit SP1.

    1. Stopped Windows Firewall

    2. Disabled Windows Firewall

    3. Restarted

    4. Disconnect LAN Cable

    5. Logged on with cached profile

    6. Enabled Firewall

    7. Started Firewall

    8. Connected Network Cable

    9 Voila and DHCP connection connected to Domain location

    Wednesday, February 15, 2012 10:52 AM
  • Right click on the computer icon, properties, Device manager, network adapters. Right click and delete. Be sure you have the driver for the NIC available. Reboot. It should install without needing the NIC driver when you login to the PC, you don't have a network so it's a local login, but . . ., just in case be sure you have the driver. Should setup and configure itself on DHCP and ask what kind of network it is and select work. Else you have to go into the network and sharing center, change adapter setting, local area connection, properties, Internet Protocol 4, enter an IP, SM, gateway, dns server. The previous post to this should work too.
    Monday, February 27, 2012 8:30 PM
  • They leave this sort of issue to get more support calls.

    Because they are evil.

    Saturday, March 10, 2012 12:07 AM
  • Hi all,

    The reason the Network Location is fixed as "Public" is because the default Gateway and Primary DNS settings you have set on that adapter are not pingable:

    If this is a secondary NIC it doesn't really matter what you type in for these IP values, BUT they must be pingable.

    For instance, I have a crossover cable from a second NIC on my laptop through to a Hyper-V server (10.10.2.10)

    The second NIC on my laptop was fixed at "Public" with these IPv4 Settings:

    1. IP  10.10.2.50
    2. SN 255.255.255.0
    3. GW <blank>
    4. Pri DNS <blank>

    I changed the second NIC to this:

    1. IP 10.10.2.50
    2. SN 255.255.255.0
    3. GW 10.10.2.10 
    4. Pri DNS 10.10.2.10

    After clicking "OK", the NIC re-identified and then allowed me to choose Public, Home or Private 

    As I said before, it does not matter that (in my case) 10.10.2.10 is not actually functioning as either my DNS or Gateway, it only matter that this IP address is pingable.

    Hope this helps.

    Saturday, March 17, 2012 12:20 AM
  • After a little tinkering on this, I've determined one conditional way to solve the problem. One of your networks must connect via DHCP and, futhermore, that one must be the one you will use to access the internet. Disable both adapters. Uninstall the adapter that you intend to use with fixed IP and no gateway. Reinstall the same adapter and punch in the IP and mask. It will identify and let you choose network type as well as name and icon. Then reenable the other adapter and let it connect via DHCP. You will be able to choose type, name and icon on this adapter as well. It seems that the root of the problem is gateways AND the order in which you do things. If you perform setup of these adapters in reverse order, it will not work! Also, if you use an adapter with fixed IP, gateway, etc. to access the internet and try to use DHCP on the other, they will connect and let you choose types, names, etc. However, you'll have 2 gateways and therefor, multiple default routes. Yet another battle against safety and user-friendliness! I realize this is technically only a work-around but we'll have to see if MS does any better on Windows 8. I doubt they're going to spend any time on this. 
    Wednesday, March 21, 2012 5:51 PM
  • Annoying right? Well here's how I fixed mine. I have a wired and wireless adapter, but I can't use the wired one (too far from the router) so I disabled it. The moment I did that, the pop-up appeared asking how I wanted to treat my wireless. I selected Home and life is grand now. I know that may not solve your particular issue (since I think you said you were using more than one network adapter, but it may help others :D
    Saturday, May 26, 2012 4:41 PM
  • Hi all,

    The reason the Network Location is fixed as "Public" is because the default Gateway and Primary DNS settings you have set on that adapter are not pingable:

    If this is a secondary NIC it doesn't really matter what you type in for these IP values, BUT they must be pingable.

    For instance, I have a crossover cable from a second NIC on my laptop through to a Hyper-V server (10.10.2.10)

    The second NIC on my laptop was fixed at "Public" with these IPv4 Settings:

    1. IP  10.10.2.50
    2. SN 255.255.255.0
    3. GW <blank>
    4. Pri DNS <blank>

    I changed the second NIC to this:

    1. IP 10.10.2.50
    2. SN 255.255.255.0
    3. GW 10.10.2.10 
    4. Pri DNS 10.10.2.10

    After clicking "OK", the NIC re-identified and then allowed me to choose Public, Home or Private 

    As I said before, it does not matter that (in my case) 10.10.2.10 is not actually functioning as either my DNS or Gateway, it only matter that this IP address is pingable.

    Hope this helps.

    I disagree. I have set our network to static IP, the default gateway, pri dns and sec dns can be ping but i still encounter this problem.

    And this problem is running for almost 3 years and no viable solution. Its really getting annoying and frustrating as we are ordering more and more Win 7 PCs.

    Friday, July 20, 2012 3:33 AM
  • PLEASE TELL WHAT DO I DO NOW OR WHAT ARE MY CHOICES HERE I NEED A WORKING PC AND MY VOLUME BACK AND MY PRINTER TO COPY ITEMS PLEASE ADVISE WAITING THANKS SO MUCH APPRECIATE YOUR TIME AND EFFORT .CCR sellrackselectus@gmail.com

    never use one CCR

    Saturday, September 01, 2012 10:15 PM
  • NEVER USA A COMPUTER ARE YOU SERIOUS PLEASE RECOMMEND SOMETHING I NEED IT FOR WRITTING . THANKS SO MUCH WAIT REPLY IF YOU HAVE ONE CCR

    never use one CCR

    Saturday, September 01, 2012 10:17 PM
  • This is what I did (after many frustrating hours of reading threads and trying to figure it out on my own:

    1) Disconnected network adapter on Win7 machine.
    2) Reconnected adapter
    3) Computer > Network > Network and Sharing Center > Choose homegroup and sharing options > "Leave homegroup..."

    I know that sharing with XP or Vista is supposed to have nothing to do with homegroups, but this is what happened:

    4) A message popped up saying 'your network is set to public, click here to set it to private to allow homegroups' (or something like that)

    BINGO; was then able to change my "únidentified network" network to private. Kind of obsurd that THAT seemed to be the only way.. pretty ridiculous, but hey - it worked.
    Saturday, September 15, 2012 1:37 PM
  • I am able to change Public to Home freely in the Network and Sharing center. This function seems to be set (and separately) for every network you connect to, for example, when you're home, or at the coffee shop, or hotel. Each network you connect to, can be set to Public, work, or Home, each of course having different associated permissions . In my Network and Sharing center, the current network I am connected to, has a blue clickable descriptor below it. I am at a hotel, and it says Public. I changed it to home briefly, went back to Advanced Sharing settings, and lo and behold "Home or Work" had become the current profile. I noticed when I changed to Home, that Homegroup became active. I turned that off, I don't like it, because for me, I need to have all my computers at home talking freely, and Homegroup is a Win 7 thing.
    Wednesday, September 26, 2012 1:52 AM
  • There sure is, very simple fix.  Set your Network Adapter to Static and set the dns to Google Public DNS  8.8.8.8  and 8.8.4.4, make sure you click verify settings upon exit, you will then get a apply fix window pop up, click on it and it will bind your DHCP properly.
    • Proposed as answer by Geeks Galore Saturday, August 10, 2013 2:31 PM
    Saturday, August 10, 2013 2:30 PM
  • SugarV, you're a GENIUS!!    Do you know how many forums and posts I've scoured trying to solve this problem? Your solution was the first that worked for me! Thanks!
    Tuesday, January 21, 2014 1:16 AM
  • I found a fix on Microsoft's site that also fixes this issue.http://support.microsoft.com/kb/2578723

    • Proposed as answer by BoostedG Friday, January 24, 2014 6:01 PM
    Friday, January 24, 2014 5:54 PM
  • SugarV, I'm bookmarking this page just because of your answer.

    I found a fix for this on a machine w/ 2 nics, and ICS enabled, which was to disable "File and Printer sharing for MS". (If I can't fix it, I try to break it even worse, then try to fix. You'd be amazed at the success rate with this approach).

    I have yet to try your, or my, fix on the VM host machine having the same issue. I just unteamed the Nics, and am only using one right now. I'll try again on Monday when I'm in front of the console.

    Saturday, June 28, 2014 4:01 PM