none
How can I get Windows 7 to display in widescreen on my 42" LCD TV?

    General discussion

  •  I have integrated Intel graphics, with the most current driver I can find installed. 7 recognizes my Westinghouse screen only as a Generic PnP monitor with a max res of 1280x1024. However, in my Windows XP boot, everything looks great in a widescreen resolution so I know my crappy onboard graphics are widescreen capable. (forgetting what exactly that XP resolution is right now)

    Also, when I get the dual boot OS choice screen when I first boot I can't read all the text, I can only see what would be in the 4:3 section of the screen, with the black bars on the sides obscuring most of the text so I assume this is a related problem.

    Any thoughts appreciated...
    Tuesday, January 13, 2009 7:42 AM

All replies

  • are there downloadable drivers for your screen from the manufacturer?

    i had a similar issueto your boot up issue when i first used my monitor, however that had a resize function i used built into it and since then its displayed perfectly. not sure if you might have something similar on your screen
    Tuesday, January 13, 2009 8:25 AM
  • I have the most current firmware for the screen and as I said, it works with XP.  I have a resize function on the TV as well, but all it does is center my square shaped picture. I use it in XP constantly but that's just when the whole widescreen image is off the screen to one side, but in that case resize works flawlessly.

    Tuesday, January 13, 2009 10:19 AM
  • Have you tried updating your graphics card drivers?  It could be any generic drivers will only allow a maximum resolution of 1280x1024 even though the card is physical capable of higher.

    I would check this before looking for monitor/TV drivers.
    Tuesday, January 13, 2009 1:04 PM
  • As I said, I have the most current drivers for the integrated graphics. I downloaded Powerstrip to try to write a monitor driver, so 7 now picks up that my screen is a Westinghouse, but PS (Vista version) doesn't seem to want to cooperate with 7 as far as forcing the card to display at 1360x768 @ 60Hz which is what works on my XP partition.
    Wednesday, January 14, 2009 2:09 AM
  • I know this is an old post but for anyone else who needs help with this

    1. Right click on desktop and click Screen Resolution
    2. Click Advanced settings
    3. Click list all modes
    4. Choose your resolution from the list.

    That sets the resolution correctly.

    Friday, July 03, 2009 11:12 AM
  • That so DOES NOT work if your resolution is not listed. I can't believe you replied to such an old thread with such a generic mindless answer.
    Tuesday, July 07, 2009 8:24 PM
  • That so DOES NOT work if your resolution is not listed. I can't believe you replied to such an old thread with such a generic mindless answer.

    Bite the hand that feeds you?
    Tuesday, July 07, 2009 10:33 PM
  • We'll you better believe it. This "generic mindless" answer has resolved mine as well as other peoples resolution issues.
    Did it not work for you? bugger.
    Wednesday, July 08, 2009 6:59 PM
  • This is basic knowledge for anyone who uses Windows, even the 7 beta.

    Oh and I'd hardly call it biting the hand that feeds when there is clearly no real useful food for help.
    Thursday, July 09, 2009 9:38 PM
  • we are having the same exact issue as ozeransky.  did you figure this out or did you have to revert to vista?

    Saturday, November 14, 2009 9:22 PM
  • The only conclusion I came to was that my integrated graphics card could not display Windows 7 at a resolution compatible with my TV, so I never came up with a fix and am back to XP.

    Sorry I can't be any more help.
    Tuesday, November 24, 2009 6:51 AM