none
Metro apps have no internet

    Question

  • I'm running Windows 8 RTM.  I use wireless internet. All of my apps are unable to communicate to the internet.

    Desktop apps works fine.  I'm able to open the store for updates and installing apps.  I'm at home and don't use any kind of proxy.

    Sunday, October 14, 2012 6:25 AM

Answers

  • Finally solved my issue.  I had noticed that everytime I run the command ipconfig /flushdns, I would get this error:  Could not flush the DNS Resolver Cache: Function failed during execution.

    Searching for that error lead me to this KB article:  http://support.microsoft.com/kb/919746

    I then discovered my DNS Client service was disabled.  After starting it, all Metro apps now have internet access.

    • Marked as answer by Stephen Olsen1 Tuesday, October 23, 2012 10:10 PM
    Tuesday, October 23, 2012 10:10 PM

All replies

  • Can you try to connect via wired connection? If it works with wired connection, you may try to upgrade the wireless network adapter driver and see if it helps. 

    Additionally the issue can be caused by programs such as firewall or antivirus. You may troubleshoot in Clean Boot Mode.

    http://support.microsoft.com/kb/331796


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    Monday, October 15, 2012 6:35 AM
    Moderator
  • Plugging into Ethernet didn't make a difference.  I tried rebooting as well.

    I don't have any anti-virus installed, just the default windows defender.  I haven't changed any firewall settings from their defaults.

    Tuesday, October 16, 2012 2:52 AM
  • This post may help.

    Resolutions of Metro Apps issues in Windows 8

    Situation 1: If Windows 8 was upgraded from previous windows OS, it could be 3dr party software issue for example Firefox may be setup as default internet browser. .
    Resolution 1: Make sure IE is default Internet Browser. Please refer to this post:
    How to setup default Internet Browser in Windows 8 -
    To setup an Internet Browser for example Internet Explorer as the default web
    browser, please follow these steps: 1. If you are in Start screen, ...
    viewtopic.php?f=3&t=16388

    Resolution 2: it could be 3dr party software conflict with Windows 8. Try clean boot for troubleshooting. How to run Windows OS with a clean boot -
    With MSCONFIG, you also can configure a clean boot to disable common startup
    programs, settings, and drivers to eliminate possible software ...
    viewtopic.php?t=57
    Resolution 3: Check the Proxy settings.
    Resolution 4: Make sure Apps to run is 1024x768 (i'd recommend 1366x768)
    Resolution 5: Try to do fresh installation.

    Situation 2: All apps in Windows 8 have issues.
    Resolution 1: It could be display issue. Try to install the latest video driver or switch to Microsoft driver if there is one available.
    Resolution 2: Check the Event Viewer for any errors. If you see DCOM with Event Id 10010, try to delete the OLE key and reboot. Please refer to this post: Metro apps won't start in Windows 8 preview - viewtopic.php?f=3&t=16400
    Resolution 3: It could be the hardware issue, please check device manager for any errors.
    Resolution 4: Try to logon different account or local administrator account for a test.
    Resolution 6: Do clean boot as mentioned before.

    Bob Lin, MVP, MCSE & CNE Networking, Internet, Routing, VPN Troubleshooting on

    http://www.ChicagoTech.net

    How to Setup Windows, Network, VPN & Remote Access on

    http://www.howtonetworking.com


    • Edited by chicagotech Saturday, November 10, 2012 4:06 PM
    Wednesday, October 17, 2012 4:41 AM
  • Thanks for all the suggestions.  I tried every single one and nothing.

    It's a clean install of windows, no upgrade.  There's no errors or unknown devices in device manager.  I'm using the latest Nvidia display drivers.  No event 10010s in event viewer.  Other accounts have the same issue.  Did a clean boot where I disabled all startup items and all non-Microsoft services.

    Wednesday, October 17, 2012 6:14 AM
  • I haven't changed any firewall settings from their defaults.

    Try turning on firewall logging?   <eg>

    Alternatively, see what NetMon is showing?   You could also get some clues from ProcMon's Network event class.   If the protocol is HTTP you could also use Fiddler2 but for Metro apps you would need to use Eric Lawrence's EnableLoopbackUtility too.

    http://blogs.msdn.com/b/fiddler/archive/2011/12/10/fiddler-windows-8-apps-enable-loopback-network-isolation-exemption.aspx

     

    HTH

    Robert Aldwinckle
    ---

    Sunday, October 21, 2012 5:26 PM
  • I've tried disabling windows firewall and it doesn't make a difference.

    Interestingly, I was just at a hotel where they had wireless and Ethernet available.  I noticed all my metro apps connected to the internet while I was there, on wireless or wired.

    Now I'm back at home and once again, no metro internet access.  Before you go and say my router must be blocking it, I have 3 other computers here running Windows 8, and none of them have this problem at all.

    Tuesday, October 23, 2012 6:08 PM
  • Even more strangeness.  I just tried using Fiddler.  When running it, you have to select which Windows 8 app you will monitor.  For any app that I selected to monitor, all the sudden that app would have internet access.  After closing Fiddler, Metro would loose internet access again.

    Tuesday, October 23, 2012 7:40 PM
  • Finally solved my issue.  I had noticed that everytime I run the command ipconfig /flushdns, I would get this error:  Could not flush the DNS Resolver Cache: Function failed during execution.

    Searching for that error lead me to this KB article:  http://support.microsoft.com/kb/919746

    I then discovered my DNS Client service was disabled.  After starting it, all Metro apps now have internet access.

    • Marked as answer by Stephen Olsen1 Tuesday, October 23, 2012 10:10 PM
    Tuesday, October 23, 2012 10:10 PM
  • Many, many thanks!!!!  Somehow, I luckily found this post.

    I was having the exact same issue.

    I had disabled the DNS Client on Windows 7 because I was using a large hosts file.

    This solution worked perfectly!

    Thanks you!

    Friday, October 26, 2012 10:24 PM
  • Glad I could be of help.
    Friday, October 26, 2012 10:26 PM
  • Didn't solve my problem even though it looks like I was under the same situation!
    Wednesday, October 31, 2012 7:15 AM
  • Finally solved my issue.  I had noticed that everytime I run the command ipconfig /flushdns, I would get this error:  Could not flush the DNS Resolver Cache: Function failed during execution.

    Searching for that error lead me to this KB article:  http://support.microsoft.com/kb/919746

    I then discovered my DNS Client service was disabled.  After starting it, all Metro apps now have internet access.

    After the upgrade from Winows 7 Ultimate to Windows 8 Pro my PC had the problem that Apps allowed to use the local network were working fine but the once only allowed to use the internet connection as well as the IE App did not work at all.

    I have been searching for two weeks until I found out that:

    1. Non working Apps on my PC where the once that only have the right to use the internet connection.
    2. The reason was a deactivated DNS Client service.

    Thanks, this post gave the solution for my problem!


    Best regards Me@TechNet



    • Edited by MeAtTechNet Saturday, November 10, 2012 12:05 PM
    Friday, November 09, 2012 7:21 PM
  • Stephen, I have been killing myself over this issue too for the last week - I turned off dns client when I installed HOSTSMAN (http://www.abelhadigital.com/hostsman) as I always have on non domain machines in the past... I did it a few days before and never put the two together....

    Thank you for posting the solution.

    Monday, November 26, 2012 12:04 AM
  • Thank you, zillion times!
    Sunday, June 23, 2013 5:51 AM
  • I can conform this. Without DNS Server, the apps have no internet access.

    "A programmer is just a tool which converts caffeine into code"

    Sunday, June 23, 2013 6:18 AM
    Answerer
  • In my case the DNS Cache service was running fine, but Metro apps were still not resolving DNS.

    The solution was to run "netsh winsock reset" using an elevated command prompt, then restart.

    Thursday, March 06, 2014 9:46 AM