none
Media Center Extender (xbox 360) won't connect when Computer is part of a domain

    Question

  • I've been racking my brain trying to figure out this problem.  I've searched the web and can't seem to crack it.  I'm running a windows server 2008 r2 domain at my house.  I've also got a computer running windows 7 and has windows media center running.  When I'm not connected to the domain using my xbox 360 as an extender is no problem.  When I am however I get this message.

     

    "The Xbox 360 could not connect to the Windows Media Centre PC. Turn your Xbox 360 off then on again, and try to connect again."

     

    This is really starting to bug me.  I've even tried this with a fresh install of windows with virtually nothing installed. I can't get it working.  It's not the firewall as I've even resorted to turning it off without effect. My group policy settings are very minimal and deal mainly with passwords.  I've even changed some of the default security settings to try fix it.  Any help would be VERY appreciated.

    Tuesday, August 24, 2010 2:03 AM

Answers

  • A quick Google search gets me this post at thegreenbutton, where someone found the policy settings that were killing their Extender's logon.
    Give that a try?

    HTH,
    Chris


    MS-MVP (Media Center) [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Tuesday, August 24, 2010 2:39 AM

All replies

  • A quick Google search gets me this post at thegreenbutton, where someone found the policy settings that were killing their Extender's logon.
    Give that a try?

    HTH,
    Chris


    MS-MVP (Media Center) [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Tuesday, August 24, 2010 2:39 AM
  • Wow, awesome thanks! I'm trying it out now.  I didn't find that because I was searching for the whole text of my error.  He didn't type the whole error.  We'll see if it holds.

    Zach

    Wednesday, August 25, 2010 2:33 AM
  • OK, sounds good.  Got it working, I take it?
    As to my search:  I kept it quite simple - IIRC, I Googled windows 7 extender domain, or something like that. 
    Sometimes, less is more.  ;)

    -Chris


    MS-MVP (Media Center) [If this post helps to resolve your issue, please click the "Mark as Answer" or "Helpful" button at the top of this message. By marking a post as Answered, or Helpful you help others find the answer faster.]
    Wednesday, August 25, 2010 11:45 AM
  • I have not yet tested this, but my google search led me here.  When I clicked on the link to the solution I got an error that this domain is not licensed or something like that.  thebreenbutton seems to have been ported over to experts.windows.com so I had to start there and do a search for windows 7 extender domain I found this :http://experts.windows.com/frms/windows_entertainment_and_connected_home/f/116/p/78447/388000.aspx#388000

    The text of which is (in case the link doesn't work):

    Posted by
    Joined on Wed, Sep 9 2009 | 1 Posts
     

     

    Hi,Ever since I installed Windows 7 RC and then RTM, I have had a problem with connecting my extender to my Media Center PC. I have been able to successfully configure and connect one day, but when I then tried to use it the next day it would just present the error message 'Error connecting, please switch off and switch back on your extender'. I searched and searched the internet looking for a solution, assuming it was a Windows 7 issue as when I had been running Vista everything worked fine.

     Not having any success with Google, I dug a little deeper and eventually, last night I managed to get to the bottom of the issue.

    It turns out that when configuring the extender account in windows 7, the permissions that that account gets are different to that in Vista. The account is added directly to the local group policy setting for allowing Remote Desktop connection. If, in your domain you have a Group Policy that sets this access right to the machine, this local setting is over written.

    The solution I have used to fix this is to ensure that the BUILTIN\Remote desktop Users group is added to the group policy setting, Computer Configuration/Windows Settings/Security Settings/Local Policies/User Rights Assignment/Allow log on through Terminal Services. I then added the MCX account to the group on my Media Center Remote Desktop Users group and forced a group policy update.

    Hurray, my extender successfully connected!!

    Just wanted to share this in case it helps anyone else...


    not so lean, not so mean, programming machine
    Tuesday, September 13, 2011 2:48 PM