none
Windows Update is Breaking HDMI (In Vista and Windows 7)

    Question

  • Our family has several different laptops (HP, Acer, Toshiba, E-machines).  We use an HDMI cable to connect them to a TV.  Until last week this worked wonderfully (you plug it in, it recognizes the TV, automatically sets the resolution and works.).  After the latest update to Windows this stopped working (no video or audio signal).  It took 3 laptops having this problem before I turned off automatic updates on the remaining laptops so they wouldn't be broken as well.  Now any laptop that has received the latest update will not connect to the TV via HDMI.  Two days later I get a call from my sister-in-law.  She was trying to use an HDMI cable to connect to a projector for a presentation, and it wasn't working.  Switching to VGA got her going again.  Since this has now happened to 4 laptops, (3 running Windows 7, 1 running Vista), in just the last week I was a bit surprised that there aren't more posts about this.  The symptoms are to have a laptop, cable, TV combination that is working, then do the update, after the update it acts as if the cable isn't connected (no signal to the TV).

     

    As I go wandering the web looking for the latest video drivers and BIOS settings (so far updating both to the latest version hasn't fixed this problem... but I've only tried this on one HP laptop), I can't help but wonder if the people at Microsoft know of this problem, and if there is a fix.  Any help would be appreciated... and to anyone else experiencing this problem, the Windows update that broke us occurred for us on November 24th and 25th, 2011.  (I believe it was called "Service Pack 1").

    Wednesday, November 30, 2011 4:58 PM

Answers

  • You need to check for updates for the video card/chip and sound card/chip.  HDMI is controlled by the video and audio drivers.  This is not a generic problem with SP1.  I have SP1 on my computers and the HDMI works on all of them.
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Wednesday, November 30, 2011 5:51 PM

All replies

  • You need to check for updates for the video card/chip and sound card/chip.  HDMI is controlled by the video and audio drivers.  This is not a generic problem with SP1.  I have SP1 on my computers and the HDMI works on all of them.
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”
    Wednesday, November 30, 2011 5:51 PM
  • This just happened to me. I had my laptop hooked up to TV via HDMI and it wanted to restart to install updates. After a restart there was no signal getting to the TV. I tried 3 different chords as well as two other TV's and a LCD monitor, nothing. 

    The only updates that it shows installed at that time were Microsoft updates. nothing regarding Video cards. Weird coincidence if you ask me....

    Thursday, December 15, 2011 7:38 PM
  • mine is doing the same... No video, but there is audio via HDMI.  computer just finished its update before this happened.
    Thursday, December 15, 2011 10:43 PM
  • anyone find a solution for this issue?  My windows 7 desktop and Vista laptop no longer connect via HDMI after the Windows Update.
    Monday, January 16, 2012 7:04 AM
  • I have exactly the same problem for a long time and it's making me crazy please if anybody has any solution to this problem come forward. I've seen many people have the problem and microsoft still doesn't do any thing about it!!!!
    Wednesday, May 23, 2012 1:16 PM
  • I've been having same issue for over 8 months now. I reinstalled all the display and sound drivers and I still cannot get my HDMI to work. On my TV (Sony Bravia) it says that toshiba laptop is connected but i have only black screen. 

    As said, this had happened right after win7 updates obn my laptop. Any help is appreciated.

    Tuesday, July 24, 2012 11:57 AM
  • I am having the exact problem+ more. Movie Maker stopped. I installed 2011. Have to have Essentials 2012 to get Photo Gallery. It's driving me nuts! I just want my old computer back!
    Sunday, December 02, 2012 8:45 PM
  • Hi,

    I have a W8 Pro. until last week everything was working even the HDMi output from my grafic card.

    after a Windows updating the driver is not recognised working properly from my PC. Any try of updating both W8 and Nvidia card  were successfully.

    W8 cannot  goes back to any date previous the updating. any W8 updating solve this problem

    I´M VERY UNSATISFIED of the Microsoft support! UNPROFESSIONAL!

    Saturday, May 25, 2013 6:01 PM
  • FabionePi posted on 2013.05.25:

     Hi,

    I have a W8 Pro. until last week everything was working even the HDMi output from my grafic card.

    after a Windows updating the driver is not recognised working properly from my PC. Any try of updating both W8 and Nvidia card  were successfully.

    W8 cannot  goes back to any date previous the updating. any W8 updating solve this problem

    I´M VERY UNSATISFIED of the Microsoft support! UNPROFESSIONAL!

    If you have a problem with Windows 8 the appropriate place to post your problem in the Windows 8 forums @ http://social.technet.microsoft.com/Forums/en-US/category/w8itpro

    This is a Windows 7 forum for problems in Windows 7.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    Saturday, May 25, 2013 6:37 PM
  • I also have this problem.

    Windows 7 Pro 64 bit SP1.  Dell Studio 15 laptop.  ATI Mobility radeon HD 3400.

    My setup has worked flawlessly for a number of years.  I use my laptop to connect to displays and projectors via HDMI to deliver presentations for work.

    Last week I allowed my laptop to accept a number of Windows updates, now my HDMI output doesn't work.  I've since updated to the latest ATI drivers from the official site and still no joy.

    Please advise of an available corrective patch for this problem created by Microsoft.


    Tuesday, June 18, 2013 9:30 PM
  • I think I know the answer if you follow me

    What do we get with HDMI? Well, the public gets free tv, access to downloading free movies, and pretty much things we don't always have to pay for to watch.  I think Xfinity is breaking mine. Honestly. I think companies like Xfinity, which I don't subscribe to their tv service, but watch it online for free, is sending stuff into my computers to break them. They traced me torrenting. 3 laptops all broken up HDMI's and my boyfriends too goes in and out. His is an expensive SONY so it lasted longer but I'm getting about 2-3 yrs use of each computer before they are GARBAGE - no on will buy them for more than $80, and even my warrenty on my Samsung Win8 I just got which has no HDMI already - 6months of watching only HDMI- has said they'll probably just send me a new laptop because the HDMI port isn't worth fixing under warranty. 

    I run malwarebites, usually it gets rid of them. Now tho, my Asus is the only one that works. I had to use CCdrivewiper and all of a sudden after 6 months in the closet of no use, HDMI pops right on. As I've used it over the past 3-4 months, tho, HDMI is loosing itself again. I'm waiting up to an hour of unplugging, turning on and off the tv, trying to get the thing to work.

    AND, these computer companies know our HDMI is PRECIOUS to us; what better way than to make us upgrade to a new computer than install the HDMI right in the motherboard -like nothing else- so we can't repair these machines and those who have the $ just buy new ones. THey cant' be lettin us get away with watching all these "free" tv shows!!!!

    elephant3152@hotmail.com
    Sunday, October 13, 2013 6:27 PM