none
How to delete unwanted TCP/IP Printer Ports

    Question

  • Windows 7 64bit; I have created, in error, one TCP/IP Printer Port which I would like to delete to keep the Ports clean of rubish, but I am unable to find how to do so.

    Can anyone help?

    Nevio
    Sunday, November 22, 2009 6:29 PM

Answers

  • Ok, then we have a problem! But as we know all problems can be fixed :)
    Start regedit.exe and browse to HKEY_LOCAL_MACHINE\SYSTEM\Currentcontrolset\Control\Print\Monitors\Standard TCP/IP Ports and remove the entire key (folder) with the name of the port you are deleting. You might have to restart the Print Spooler service after deleting that key to see the change go through. As always when working with the registry be careful and to be on the safe side create a System Restore Point before doing the edit.
    Sunday, November 22, 2009 8:11 PM
  • There is an easier way. Please:

    1. Launch Control Panel\All Control Panel Items\Devices and Printers
    2. Click on any of the listed printers.
    3. Click “Printer server properties”.
    4. Click the Ports tab.
    5. Select the port and click “Delete port”.


    Arthur Xie - MSFT
    Wednesday, November 25, 2009 8:42 AM

All replies

  • You can do it by starting Print Management (printmanagement.msc) and go to Print servers > <COMPUTERNAME> > Ports and delete the ports there.
    Sunday, November 22, 2009 7:32 PM
  • Many thanks Andreas,

    my version of W7 is Home Premium and it does not appear to have Print Management (printmanagement.msc) installed; I have followed various internet links which indicate that this W7 version may not have Print Management available; there seems to be much confusion on this issue. I have also looked into the Windows\System32 folder where these files should be for installing, but they are not there.
    So what is going on?

    Nevio
    Sunday, November 22, 2009 7:52 PM
  • Ok, then we have a problem! But as we know all problems can be fixed :)
    Start regedit.exe and browse to HKEY_LOCAL_MACHINE\SYSTEM\Currentcontrolset\Control\Print\Monitors\Standard TCP/IP Ports and remove the entire key (folder) with the name of the port you are deleting. You might have to restart the Print Spooler service after deleting that key to see the change go through. As always when working with the registry be careful and to be on the safe side create a System Restore Point before doing the edit.
    Sunday, November 22, 2009 8:11 PM
  • Thanks again Andreas,

    followed your advises and that resolved the issue. You would think that there should be an easier and safer way to delete PORTS, as you correctly pointed out, working with the registry can be dangerous and not for everyone.

    Why don't you suggest making this easier to Microsoft.


    Thank you again,


    Nevio
    Sunday, November 22, 2009 8:34 PM
  • I'm glad it worked out! I will keep a note about this issue for further reference :)
    Sunday, November 22, 2009 8:43 PM
  • There is an easier way. Please:

    1. Launch Control Panel\All Control Panel Items\Devices and Printers
    2. Click on any of the listed printers.
    3. Click “Printer server properties”.
    4. Click the Ports tab.
    5. Select the port and click “Delete port”.


    Arthur Xie - MSFT
    Wednesday, November 25, 2009 8:42 AM
  • Yes Arthur, you are correct that is a much easier and safer way to delete unwanted port. I will remember that way of going it for the future.

    Thanks,

    Nevio
    Wednesday, November 25, 2009 9:10 AM
  • Easier yes, but not an option if you do not have any other printers installed, therefore not listed, in 'Devices and Printers'; right?

    Of course you might say, there is always something listed in there, even on a brand new machine, even if you never installed a printer before. This is true, a (windows) 'Fax' is almost always installed (there is on my Windows7 Ultimate (x64) machine) but again I am not sure if this is a universally common fact.

    And even the Fax printer properties will not allow you to do anything with the ports since they are all greyed out, so this is also not an option.

    IMHO, Andreas Stenhall has provided us with the only two viable solutions to the problem. And the one editing the registry -although the riskiest- is the most widely available, since some versions of windows -strangely enough- do not support the 'printmanagment.msc' console.

    Everyone's comments will be greatly appreciated.

    Thank you,

    Xwris ONOMA.

    Saturday, March 27, 2010 7:51 PM
  • I cannot get into the ports section.  I have several computers and although I am administrator, I am kept from changing this area.  Can you tell me what to do to get into this section.
    Tuesday, November 08, 2011 3:49 PM
  • 1 - Add a new Local printer (Choose any driver,and choose LPT1 for the Port)

    2 - Right click the newly created printer and choose "Printer Properties"

    3 - Choose the ports tab and delete the ports that you want to get rid of

    4 - Choose ok when finished

    5 - Delete the printer from your computer

     

    - Joe

    • Proposed as answer by Joe Boomer Friday, December 02, 2011 11:54 PM
    Friday, December 02, 2011 11:54 PM
  • That hasn't worked on 3 machines I tried it on.  I get the message that the port is in use.  Even when nothing is running.  Even rebooted and tried again. 

    John

    Tuesday, May 29, 2012 7:51 PM
  • Still didn't work..   error - port is in use comes up.  Even when spooler not running.


    John

    Tuesday, May 29, 2012 7:52 PM
  • Seriously Microsoft!? I need to enter the registry to change my wireless printer's port?? Thanks for making things simple...
    Wednesday, July 04, 2012 6:04 AM
  • You get the 'port is in use' error message if the port is currently assigned to a printer. It has nothing to do with print spooler - it's just that you can't delete a port that is already assigned to a printer.

    1. When you open properties and go to the 'Ports' tab, you have your printers listed with headings - Port, Description, Printer.
    2. Identify the printer using the port that you want to delete, exit out of printer properties window and delete the printer.
    3. Right Click on any of the remaining listed printers and select 'Properties' (if there is none left then you craft create a fake printer).
    4. Click the Ports tab.
    5. Select the port and click “Delete port".
    6. Check any available port and exit out of 'properties' window.

    Monday, July 09, 2012 5:45 PM
  • There is an easier way. Please:

    1. Launch Control Panel\All Control Panel Items\Devices and Printers
    2. Click on any of the listed printers.
    3. Click “Printer server properties”.
    4. Click the Ports tab.
    5. Select the port and click “Delete port”.


    Arthur Xie - MSFT

    When I do this I get error "The requested resource is in use".
    Tuesday, July 09, 2013 6:28 AM
  • You get the 'port is in use' error message if the port is currently assigned to a printer. It has nothing to do with print spooler - it's just that you can't delete a port that is already assigned to a printer.

    1. When you open properties and go to the 'Ports' tab, you have your printers listed with headings - Port, Description, Printer.
    2. Identify the printer using the port that you want to delete, exit out of printer properties window and delete the printer.
    3. Right Click on any of the remaining listed printers and select 'Properties' (if there is none left then you craft create a fake printer).
    4. Click the Ports tab.
    5. Select the port and click “Delete port".
    6. Check any available port and exit out of 'properties' window.

    I can't delete the port, despite the printer listed next to the port name has been already removed. It appears that the printer list in the port configuration is not updated after the printer is deleted from the printer list.

    Tuesday, July 09, 2013 6:39 AM
  • I'm in Windows 7 64 bit as well.  I tried to remove an extra printer port, USB002, but when I go through the procedure, steps 1 through 6 above, I get the message "Selected port cannot be deleted.  The request is not supported."  What do I do to fix this?
    Saturday, October 19, 2013 12:18 PM
  • I just read in a Windows Server 2003/XP thread that USB printer ports cannot be deleted manually.  Is that the case here?
    Saturday, October 19, 2013 12:21 PM
  • Nevermind, it works.
    Saturday, October 19, 2013 12:28 PM