none
Back Button on IE8 stops working

    General discussion

  • On both of my eval W7-64 installs, the back button in the browser will occasionally stop working.

    I can still use the 'back' drop list to select the last site, but the back button itself will not function. Restarting the app does not fix it, switching from regular flavor to 64 bit IE or visa versa does fix it, as does restarting the machine. BTW, the button graphic state still changes correctly when depressed, but nothing happens.

    Once, dragging the browser to a position that was partially clipped off of the screen seemed to fix it.

    It looks like the add-to-favorites button also stops working. I still need to confirm that one.
    Friday, August 07, 2009 3:30 PM

All replies

  • Hi,

     

    Thanks for posting in Microsoft TechNet Forum.

     

    Try to run Internet Explorer in no add-on mode, through this method we can identify if an incompatible browser add-on or extension is at the root of your troubles. To do this, please take the following steps.

     

    1.    Click Start -> All Programs -> Accessories -> System Tools, and then click Internet Explorer (No Add-ons).

    2.    To isolate the specific browser add-on that is contributing to the issue, you can use IE’s Manage Add-ons feature to pick specific add-ons to disable:

     

    1)    Click Tools -> Internet Options.

    2)    Click the Programs tab, then Manage add-ons.

     

    Note: The Manage Add-ons option under Tools is disabled in No Add-ons mode so you must go to Internet Options, Programs, Manage add-ons to manually enable/disable add-ons.

     

    3.    Select an add-on in the Name list, and then click Disable.

    4.    Click OK, OK again, OK again and then close IE.

     

    5.    Restart IE normally and see if your problem is resolved.

     

    1)    If it is, you should uninstall the specific add-on via Control Panel’s Add/Remove Programs or the applications own uninstaller.

    2)    If the problem persists, you will need to repeat steps 1-3 until you have identified the specific add-on causing the problem.

      

    Tip: Disable several add-on’s at once to speed up your process of elimination.

     

    If the issue persists, I suggest you installing Internet Explorer updates.

     

    Internet Explorer 8 Delivery through Automatic Updates

    http://technet.microsoft.com/en-us/updatemanagement/dd365125.aspx

     

    Best Regards.

    Dale Qiao

    Monday, August 10, 2009 10:02 AM
  • I think it must be something else.

    The slower system has no add-ins at all. It is just as installed. The only software installed is Bulldog Security. No Flash, Acrobat, Java, etc.

    On the faster system, I attempted to install Flash, but there is a known issue with 64bit OS's, so it failed. The only apps on it are Call of Duty, World at War (DirectX 9, 10, 11) and Kaspersky Anti-Virus.

    Both machines still have the problem off and on. The back button will work normally for some period of time, then just stop responding.

    Thursday, August 13, 2009 4:48 PM
  • this is most likely happend due to any uncompatible toolbar or addon installed, check them and disable the addons which are not useful for you.....
    Thursday, August 13, 2009 9:10 PM
  • Hi,

     

    Thanks for your update.

     

     

    How about trying to turn off and re-turn on Internet Explorer to see if it works? To do this, please take the following steps.

    1. Click the Start menu and click Control Panel.
    2. Click Programs and click Turn Windows features on or off under Programs and Features item.
    3. Uncheck Internet Explorer 8 and click Ok.
    4. Restart the computer and turn back on Internet Explorer in Turn Windows features on or off window.

    Best Regards.

    Dale Qiao.

    Friday, August 14, 2009 5:45 AM
  • I will try that tonight.
    I am trying to isolate the issue and get it to be reliably reproducable. No set pattern yet.
    Friday, August 14, 2009 3:22 PM
  • I had the same problem. I disabled all add ons, but this did not solve the problem. I solved the problem by switching to Firefox. I had avoided the switch to Firefox for several years, even though all my friends said it was faster, because I did not like the set up. IE7 and 8 have become so much like Firefox, there was no reason for me not to change, especially since it doesn't have the back button problem. In my opinion, Windows had become more and more user UN-friendly since 98. I don't want a search bar in my toolbar. My homepage has one. I don't like that I can't reduce my toolbar to one thin line (navigation buttons, address bar and file, edit, etc. menus). I hate the new search in the start menu. The old style was much easier to use. The new one is very difficult to refine searches. I can't reduce my search to one folder or one type of file. I don't like that I can't open a new text file from the drop down menu within a folder. I have to open a text file, right click the file from the status bar and click on notepad to open a new file. Then when I save it, I have to navigate to the folder I want to put it in. You use to be able to open a text file from the folder drop down menu and it would save to that folder.
         CONGRATULATIONS Microsoft, You have taken a 10 year user of Windows and made him decide that his next computer will be an Apple. Library sucks, Search sucks, IE sucks!
    Thursday, December 31, 2009 1:29 AM
  • That will only work for a while and the problem will come back again. Btw, why don't you guy at MSFT try to duplicate the problem first and then work on a solution, instead of sending out suggestions that may or may not relevant.
    Tuesday, January 12, 2010 2:00 PM
  • Now running the release version of Home Premium 64.

    The problem has morphed to one of, the IE icons go away, leaving a blank page icon. Clicking the icon results in an error of "This application can not be found" so, I browse to the exe and launch it (32 or 64 version) manually. They both mostly work, but occasionally hard lock the machine, requiring a force restart.

    2 totally fresh installs, one on an i7 920 box and one on a dual core Athlon machine. I goota admit, I am close to looking into Firefox or Chrome.

    (Plus plenty of, "you do not have sufficient privledges to delete the file you created, on your own PC" dialogs, which are still highly offensive.)
    Tuesday, January 12, 2010 4:27 PM
  • Easiest solution was mentioned by JDTrue. In a day where browsers are free and competition rules, STOP USING INTERNET EXPLORER! Microsoft techs say, "try this!" and then "Try that!".  They don't know the real reason. Maybe if you stand on your head and hold the mouse in your left hand while whistling the theme from Starsky and Hutch.....

    Downloaded Firefox. Problem solved.... 

    And while you're at it, try OpenOffice instead of Microslop's bloatware.
    Wednesday, January 27, 2010 12:48 AM
  • I have the same problem with IE8 on Windows 7. I had IE 8 on Windows Server 2008 since the beginning and never had any problem.
    Wednesday, February 24, 2010 5:00 AM
  • Easiest solution was mentioned by JDTrue. In a day where browsers are free and competition rules, STOP USING INTERNET EXPLORER! Microsoft techs say, "try this!" and then "Try that!".  They don't know the real reason. Maybe if you stand on your head and hold the mouse in your left hand while whistling the theme from Starsky and Hutch.....

    Downloaded Firefox. Problem solved.... 

    And while you're at it, try OpenOffice instead of Microslop's bloatware.

    There is a couple things wrong with that, first of all, we *PAID* for IE8 when we bought windows, so M$ is obligated to fix it. #2, firefox is *NOT* any better! It has it's own set of problems.

    @microsoft - Here is a golden opprotunity to fix something before it becomes a great big issue and creates more upset customers like Mike here .. who does have a point.

    I just bought this computer new, with your new OS (7 Ultimate) and the internet browser is broken? I know you are a huge company and could care less, but it's things like this that drive away customers... but YOU SHOULD KNOW THIS!

    FIX it! (A hotfix would be best), Be "man" enough to tell me "Hey we screwed up, sorry", and for the love of all that's holy, stop tellimg me "I know how you feel" or "I appreciate your situation" - you know what ... NO YOU DON'T.

    ehh i'm wasting my time even posting this. I'm going to http://www.gamenonstop.com and get my GAME ON!

    C yas
    Tuesday, March 02, 2010 4:23 PM
  • I found an answer or work around to the following problem:

    My back button completely stopped working. I have Win7 and IE8, it is a 64 bit machine (most of them are anymore)

    I tried several remedies and finally saw that:

    Start button/all programs/scroll up and down list/mine had and I think should be on all 64 bit machines - internet explorer 64 bit/make a shortcut of this to your desktop/and/or pin to task bar.

    When you use ie be sure to use the 64 bit version.

    By the way, for those whose preferences for "do not suggest query" will not save, be sure to go in: tools/internet options/browsing history - make sure check box is UNchecked (that answer I did see somehwere else but it worked on mine :))

    Tuesday, March 23, 2010 1:39 PM
  • I found an answer or work around to the following problem:

    My back button completely stopped working. I have Win7 and IE8, it is a 64 bit machine (most of them are anymore)

    I tried several remedies and finally saw that:

    Start button/all programs/scroll up and down list/mine had and I think should be on all 64 bit machines - internet explorer 64 bit/make a shortcut of this to your desktop/and/or pin to task bar.

    When you use ie be sure to use the 64 bit version.

    By the way, for those whose preferences for "do not suggest query" will not save, be sure to go in: tools/internet options/browsing history - make sure check box is UNchecked (that answer I did see somehwere else but it worked on mine :))


    Thanks techiewoman, this has been driving me nuts for sometime now and that worked without having to do a reboot, only thing that has of all the other suggestions.    One would think Microsoft would have replicated this issue as well by now as it doesn't appear to be all that isolated of a problem judging by the number of the similar search terms suggested by Google when I went to look it up
    Thursday, March 25, 2010 8:30 PM
  • i am using IE 8, in Windows 7 64 bits,,,,i had the back button issue...
    i was using the 32 bits version, open the 64 bits IE 8 and that one works fine, i guess the 32 bits is not compatible why i still have it in my PC??
    Thursday, May 06, 2010 5:42 PM
  • Well, I've been using the 64bit version for a while now and I also had the problem happen in that version so while it may be more robust it doesn't appear to be immune from the back button not working problem.   Also there are a lot of websites where unfortunately flash is required in order to navigate so that 64bit version can't work on those.

    Thursday, May 13, 2010 5:16 PM
  • Hello: i was able to solve the issue following the following steps  from that Microsoft engineer called Steven, you know i could not find which service or startup caused that, but disabling all of them and reenabling them later and reboot the computer seemed to fix that in my IE* 8 32bits.....now the back button is working....

    i used to leave my computer in sleep mode, have not rebooted for a couple weeks till now .so i am not really sure if that can be related to that issue but i just wanted to mention that in case you are doing the same.

    Best of Lucks 

     

    Steven - Support Engineer<abbr class="affil">Microsoft Support</abbr><abbr class="affil">, Moderator</abbr>Users MedalsUsers MedalsUsers MedalsUsers MedalsUsers Medals

     Answer

    Hello Tannette,

     

    Welcome to the Microsoft Answers Community!

     

    Let’ try resetting Internet Explorer’s settings back to default, then after that restarting into a clean boot. This process will isolate out any third party influences.

    Reset Internet Explorer:

    ·         Open Internet Explorer

    ·         Click Tools

    ·         Click Internet Options (you can also access Internet Options from the Control Panel, you may have to switch view from Categories to Icons)

    ·         Click the Advanced tab

    ·         Click Reset…

    ·         Click Reset

    ·         Click Close

    ·         Click OK

    ·         Click OK

    ·         Close Internet Explorer

    ·         Open Internet Explorer

     

    Clean boot:

    Test Internet Explorer to make sure that the problem still exists. If so then next step will be to restart into a clean boot.

    ·         Click Start

    ·         Type msconfig into the search field

    ·         Press Enter on your keyboard

    ·         Click Continue on the User Account Control (If prompted)

    ·         Click Selective startup

    ·         Uncheck Load startup items

    ·         Click the Services tab

    ·         Check the Hide all Microsoft services box

    ·         Click Disable all

    ·         Click OK

    ·         Click Restart Now

    Once your computer has finished restarting, test to see if you still get the same problem in Internet Explorer. If not then you just have to identify which service/startup item was causing the problem.

    ·         Click Start

    ·         Type msconfig into the search field

    ·         Press Enter on your keyboard

    ·         Click Continue on the User Account Control (If prompted)

    ·         Click the Services tab

    ·         Check the Hide all Microsoft services box

    ·         Check (Enable) the top half of the service boxes

    ·         Click OK

    ·         Click Restart Now

    Once your computer has restarted, again test to see if the problem is still gone. If so, then the services you enabled are good to stay. Repeat the enabling process for half of the remaining disabled services and continue this process until the problem returns or all services are enabled. If the problem returns then you will need to test the last batch of services you enabled one by one to find which was causing the problem to occur.

     

    If you enable all services and the problem still hasn’t returned:

    ·         Click Start

    ·         Type msconfig into the search field

    ·         Press Enter on your keyboard

    ·         Click Continue on the User Account Control (If prompted)

    ·         Click the Startup tab

    ·         Check (Enable) the top half of the service boxes

    ·         Click OK

    ·         Click Restart Now

    Follow the same process as before, with testing after each restart. If the problem hasn’t returned, go back and enable half of the remaining list of startup items and continue the process until the problem has returned. Then you will need to test the last batch of startup items you enabled one by one to find which causes the problem to occur.

     

    Once you have identified which service/startup item causes the problem in Internet Explorer you will need to either disable/uninstall/update the program to avoid further problems.

     

    Repair script:

    If you restarted into a clean boot and you still experienced the same problem the next step is to try using the repair script created by Kai Schatzl. This script will work on any 32-bit operating system using Internet Explorer 8.

    Repair IE8

     

    If you are using a 64-bit operating system, another forum user named OnyXxL modified the script used above to accommodate to 64-bit operating systems. You can find instructions on how to create/use the script here:

    Links will not open a new window or tab (ignore the title)

     

    Hope that helps, look forward to hearing back from you.


    Steven
    Microsoft Answers Support Engineer
    Visit our Microsoft Answers Feedback Forum and let us know what you think
    Thursday, May 13, 2010 11:41 PM
  • Well a reboot always fixes the problem anyway so I'm guessing it was the reboot and not all of the other stuff he had you do that fixed it.   If someone can figure out a way to fix it that doesn't involve a reboot I'd love to hear it.  Switching from the 32bit to 64bit works until that version also breaks.   I guess Windows 7 just needs more frequent reboots than XP or Win98se did. 

     

    Monday, May 17, 2010 5:10 PM
  • Well a reboot always fixes the problem anyway so I'm guessing it was the reboot and not all of the other stuff he had you do that fixed it.   If someone can figure out a way to fix it that doesn't involve a reboot I'd love to hear it.  Switching from the 32bit to 64bit works until that version also breaks.   I guess Windows 7 just needs more frequent reboots than XP or Win98se did. 

     


    I am using Window 7 Ultimate 64 Bit, this backwards button is not working propely, having to click it 4-5 times before it will release the website and go back to the previous site.

    None of this fancy artwork such as using MSCONFIG seems to work.

    Having a clean install after a complete format  doesn't help the issue either.

    After several reboots, it is safe to say from experience that it seems to be in the software and not the computers configurations. 

    The reboots doesn't solve the issue it either.

    Best solution get another browser!

    Wednesday, May 26, 2010 6:27 AM
  • Folks,

    This thread looks pretty old, but I have a suspicion about what's causing this. First a few facts that I've observed:

    1. I see this problem at work (2,000 Win 7 x64 desktops), and at home (2 Win 7 x86 [32 bit], 1 Win 7 x64).

    2. I've tried all of the disabling add ons, and restoration of default settings suggested elsewhere, but without resolution. And we've got very extensive Symantec anti-virus at work. At home I use Trend on the 64 bit machine and NAV on the others. And we patch religously both at work and at home.

    3. Sometimes stopping all instances of IE works, but not always. What always works is a complete system reboot.

    4. What I conclude from this is that:

    (a) It's common to both 32 bit and 64 bit  windows and 32 bit and 64 bit browsers

    (b) It's not caused by an addon or by browser extensions.

    (c) It's not caused by a virus, by addware trojan horse or similar.

    (d) Most of the more major solutions (eg re-installing IE, re-registering IE code) might be working  because they usually involve a reboot, or a fundamental re-start of processes.

    (e) I haven't tried the Google completion resolution, so I admit that I can't exclude that. However, others have tried this without success. I'll remain open to this, but no-one outside of our colleagues at Microsoft (who are paranoid about Google as a matter of company policy) seems to much agree.

    5. What is common about my usage of Windows 7 both at work and at home -- and not common to most other people -- is that I use Sleep and Hibernation mode. I sometimes go months without a system reboot. In fact the only time that I reboot is when there is a system patch to install that requires it, or when I have another system problem that can't be otherwise resolved.

    I'd suggest that there is a correlation to repeated use of power management, but a correlation may not be a cause.

    So I'm thinking that it is either a degradation caused over time (e.g. a memory leak or subtle buffer overflow) or a consequence of repeated use of power management. I'm thinking that the first of these is more likely.

    Anyone care to respond?

    Saturday, July 17, 2010 9:14 AM
  • Folks,

    This thread looks pretty old, but I have a suspicion about what's causing this. First a few facts that I've observed:

    1. I see this problem at work (2,000 Win 7 x64 desktops), and at home (2 Win 7 x86 [32 bit], 1 Win 7 x64).

    2. I've tried all of the disabling add ons, and restoration of default settings suggested elsewhere, but without resolution. And we've got very extensive Symantec anti-virus at work. At home I use Trend on the 64 bit machine and NAV on the others. And we patch religously both at work and at home.

    3. Sometimes stopping all instances of IE works, but not always. What always works is a complete system reboot.

    4. What I conclude from this is that:

    (a) It's common to both 32 bit and 64 bit  windows and 32 bit and 64 bit browsers

    (b) It's not caused by an addon or by browser extensions.

    (c) It's not caused by a virus, by addware trojan horse or similar.

    (d) Most of the more major solutions (eg re-installing IE, re-registering IE code) might be working  because they usually involve a reboot, or a fundamental re-start of processes.

    (e) I haven't tried the Google completion resolution, so I admit that I can't exclude that. However, others have tried this without success. I'll remain open to this, but no-one outside of our colleagues at Microsoft (who are paranoid about Google as a matter of company policy) seems to much agree.

    5. What is common about my usage of Windows 7 both at work and at home -- and not common to most other people -- is that I use Sleep and Hibernation mode. I sometimes go months without a system reboot. In fact the only time that I reboot is when there is a system patch to install that requires it, or when I have another system problem that can't be otherwise resolved.

    I'd suggest that there is a correlation to repeated use of power management, but a correlation may not be a cause.

    So I'm thinking that it is either a degradation caused over time (e.g. a memory leak or subtle buffer overflow) or a consequence of repeated use of power management. I'm thinking that the first of these is more likely.

    Anyone care to respond?


    Hi Tonytired,

    I have been experiencing this problem lately as well and I believe you've nailed it..

    My system's been on for about 1 week now (without a reboot). It's been set to enter sleep mode after 20mins of inactivity. Just tried rebooting my system and my IE8 is back to normal. The Back/Forward/"Add to Favorites" buttons are working now.

     

    Sunday, July 18, 2010 9:39 AM
  • Seems we are using our precious time to help Microsoft pin down the problem (or maybe just convince MS there is a problem). That is after we paid Microsoft for the product. To me that shows (again) how arrogant the company becomes over time.
    Sunday, July 18, 2010 9:46 PM
  • Tonytired. Great job, you have definitely nailed it. I run 32 bit Vista at work with IE7 and hibernate and resume once home so my laptop gets reboots once a week. At home my 64bit W7 Ultimate has IE8 and I also leave that running for days too. the back button issue happens regularly on both laptops until I perform a reboot, so the memory leak issue is most likely real. Microsoft now need a hotfix or IE9, so get on with it Microsoft.
    Wednesday, July 21, 2010 6:29 AM
  • The most complete thread about this issue can be found at:

     

    http://social.answers.microsoft.com/Forums/en-US/InternetExplorer/thread/08cec855-30e0-4d71-9aa3-27f6d4655b4a

     

    (no clear origin found, and no solution offered, to this bug as of today; only work around is to close all IE8 windows and restart one)

    Wednesday, July 21, 2010 2:20 PM
  • Sweet!  I also hibernate my Window 7 laptop at home and reboot once every two weeks or so.

    Just rebooted after reading this tread and the back button now works.

    Thanks for the diagnostics Tonytired....I'll remember this for work.

    Tuesday, August 31, 2010 2:04 AM
  • Has this been solved yet ?

    windows 7 & IE8 problem.

    non of my 40 XP computers have this problem. 

    Friday, October 01, 2010 4:57 AM
  • I am not sure if this is any help to anyone but...

    I am experiencing this issue too (win 7 64 Bit IE 8), However I attribute it to the code some people use to control back button functionality. As in the techniques web developers use to cover up issues that arise in their applications when users click the back button at certain stages of a process. I don't know which techniques it is (I may have a look into that) I just know that I have only seen this on the Intranet applications developed for IE (web developers will know what this implies ;-).

    I have found that killing all processes for IE and re-opening it gets rid of the issue, until you open a page that uses the offending technique.

    For those of you experiencing this problem across all PCs in you organisation, try changing the home page of the company Intranet site (if that's how you have it set up - just guessing) and see what happens. Unfortunately for all those suggesting using other browsers, I suspect the same Intranet site that cause this wont even work properly in other browsers.

    Hopefully if nothing else this is another reason for people to write standardised browsers ;-).

    • Edited by gordatron Monday, October 18, 2010 12:27 PM formatting goosed
    Monday, October 18, 2010 12:23 PM
  • Well, I'm using Win7-64 with IE8 and saw this prob some time ago (never reboot for weeks, desktop pc always on, no hybernation or sleep mode enabled but standard "balanced power plan" of win7).

    I possibly found a solution by disabling the following addons (listed by the visible name in "manage addons")

    - Groove GFS Browser Helper (by M$)
    - Groove Folder Synchronization (by M$)
    - Research (by M$)
    - Blog This in Windows Live Writer
    - Send to OneNote
    - Discuss

    Closed all instances of IE8, did NOT reboot, started a new instance of IE8 which immediately worked as it should.

    Eversince all worked fine (say 2 weeks now), no reboots necessary...

    • Edited by peter273 Saturday, November 06, 2010 6:59 PM added power sceme
    Saturday, November 06, 2010 6:54 PM
  • How about putting those big expensive brains together and building something that actually works for a change? A ten year old could and probably will someday build a better browser and OS. MS is a laughing stock as far as I am concerned, Only in America can mediocrity be so succesfull. Tell Bill to suck it from me, take his facist, overpriced, worthless, backwards, ignorant, OS and browsers and shove them straight up his ass.
    Monday, January 31, 2011 3:42 PM
  • I had the same problem in Windows 7, with the back button not working in 32-bit Internet Explorer.  Easy solution:  Open 64-bit IE, run a couple of web pages back and forth.  Then go back to using 32-bit, this allows it to reset itself.

    Sunday, February 27, 2011 1:16 PM
  • Problem replicated, resolved, and replicated again at will....pretty easy really.

    Source machine was Toshiba Notebook with Windows XP, IE8 installed. We regularly use a NZ news site called stuff.co.nz (http://www.stuff.co.nz) This site is heavily inflicted with advertisements, mostly sourced via doubleclick.net. On my router I blocked doubleclick.net as I am sick of paying for bandwidth for advertising. 

    IE back button died, when using sites like stuff that have adds from doubleclick.net. I have replicated this on different pages of trademe.co.nz (NZ equivalent of ebay) with the same result. If clicking back to a page with adds that page will not load. If clicking back to any page without adds it works perfectly fine.

    As soon as I unblocked doubleclick.net on my router the problem went away.

    This is the last machine in our house that has been using Internet Explorer. The fault does not happen with Firefox, or Google Chrome. 

    So, there you go. If you've got an add blocker, it seems IE8 is pretty well unable to handle page calls to pages that it cannot reach.

    Our last machine no longer uses IE......

    Cheers Matt from NZ 

    Tuesday, August 02, 2011 7:40 AM
  • It sounds from the thread below like there might be a few variants on this issue, but this just worked when I suggested it to a colleague whose Back button hadn't been working for weeks on some sites:

    • Open an administrative command prompt
    • Navigate to %systemroot%\system32
    • run regsvr32 hlink.dll

    Only takes a minute to try, so might be worth a shot.

    --Jools


    • Edited by Jools0001 Thursday, December 08, 2011 6:15 PM
    Thursday, December 08, 2011 6:14 PM
  • You know, I have read this entire page full of complaints about IE8 and its back button (and sometimes its favorite button) suddenly stopping working, and it is alarming to note that the dates of these posts go back to 2009.  It is now February, 2012, and the PROBLEM STILL EXISTS.  None of the solutions on this page work permanently -- I have tried them all.  What works for me is to simply shut down the browser and start it back up. However, although I that solves the problem (again), I often lose my place where I have looked through dozens of pages searching for something and, due to the defective browser, I lose my place in my search and have to start over from scratch, wasting sometimes hours and hours of research.

    Enough already!  Microsoft, your solutions are NOT working....read these files.  Better yet, google the issue and see hundreds and hundreds of complaints.

    I really, really don't want to switch to Firefox...or worse, Apple, but if a company can let a problem exist since 2009 and still not fix it...then perhaps I need to rethink my reluctance to switch when I buy my next laptop. 

    No more excuses.  Research this and fix it.  If you can.  If you can't, admit it and let us take our business elsewhere.

    I am appalled that I spend so much money buying Microsoft products, only to have you let this problem continue for THREE YEARS!

    Friday, February 17, 2012 3:36 AM
  • Hi All,

    I had this issue for several weeks. I tried several recommended fixes from several sites with no fix. The following solution worked for me. Please be aware though that this will unload all Add-Ins, but I figure starting again from a "clean sheet" is usually a good place to be when evaluating what "broke" things.

    • Open Tools | Internet Options | Select the Advanced Tab
    • Now Click the "Reset" Button at the bottom of the page. This will revert IE back to it's initial install.

    Restart IE and follow the initial Set Up pages as though it was the 1st time you had opened IE.

    In my case I manually set my prefences and change the Search Provider (top right of the toolbar) to Google, then I set my Homepage to Google. Finally I set my new "Open New Tab" option to open my Home Page. 

    After another restart of IE, all appears back to normal in that the "Back Button" now allows me to back out of web pages with one click when using Google to search.

    Hope this helps.

    Steve B


    • Edited by Knaphie Wednesday, April 04, 2012 8:33 AM
    Wednesday, April 04, 2012 8:31 AM
  •  

    I tried all of the fixes - I think the real answer is in the advertising dollars.  Add revenues are billed by hits to a website.  Everytime I hit the "back button" the screen refreshes on the current website, showing another hit.  This, at a minimum, doubles the hits to a website, doubling the dollars.  Everytime you hit "back", the website shows another hit, and the poor advertiser is being charged accordingly.

    Saturday, July 07, 2012 1:57 PM
  • Foxfire does have some of the same problems, and from what I see it has to do with JAVA. There are some websites that have this issue, and others that do not. This is a clue to the problem, and first of all it would be great if there were an easy way to disable all the beforeunload scripts and such so that there would not be any way a website could hold you hostage to a screen. There are ransom sites that use this technique to bilk people, one says that the FBI has locked your computer/browser. There are many others as well, and this is because of the weaknesses of the browser. 

    So far the only browser that I have found that does not have this problem is Opera, as it happens with Safari, Internet Explorer, and Foxfire.

    There is a way to solve the problem and that is to disable JAVA, until some of the programmers are willing to admit there is a problem and actually fix it. Also there are a few add-ons that can be used some are free others are not.

     
    Friday, October 25, 2013 1:40 AM