none
Bug in MS paint in windows 7

    General discussion

  • I have found a bug in Paint in Windows 7.

    Basically to reproduce it open any picture that is too large for ms paint to display on the screen in one go at 100%, scroll to the bottom of the image, select the bottom square so you can reduce the canvas size. Now reduce the canvas size by clicking and dragging the resize square upwards and let go of the mouse.

    When you let go of the mouse this causes the screen and picture to readjust to fit to the new canvas size. When this happens ms paint moves the image down and in doing so cuts off the bottom section of the image making you lose parts of the image you wanted to keep.

    I dont believe any other versions of Paint did this.
    Wednesday, August 19, 2009 9:33 AM

All replies

  • Paint in Windows 7 is a new application written in .NET I think, so this might explain the difference in behavior
    with the previous versions.
    Wednesday, August 19, 2009 9:17 PM
  • its cause u have crop selected instead of rezize crop is the default option for some reason
    Thursday, August 20, 2009 6:57 AM
  • That's not the reason, but thanks for trying.

    It is actually a bug, i wanted to crop the canvass as it was too large for the picture, and after cropping the picture is lowered on the canvass causing you to lose parts of the picture you hadn't told MSPAINT to remove.

    The older versions didn't do this, and i am a pretty experienced user with MSPAINT so i know it is not something i am doing wrong.
    Thursday, August 20, 2009 8:19 AM
  • Hi Usrhlp,

    This behavior is by design. Clicking and dragging the resize square will resize the picture by Pixels, it will lose parts of picture. You can resize the picture by percentage, it won't lose part of picture. To do this : plase click Resize in tool bar.

    Thank you for your understanding.
    Thursday, August 20, 2009 8:37 AM
  • No, this ISN'T by design.

    I will add some pictures to show you what i mean.

    This is step one, get a picture that is bigger than your current screen and open it in MSPAINT. Zoom to 50% (i dont think this matters but its what i did so i could see more of the image on the screen). Scroll to the bottom of the image so you are at the lowest point on the canvass. Your screen should look like this.

    http://deanmoncaster.byethost7.com/step1.png

    Now click the bottom middle crop square on the canvass and drag it to an arbitary location, in my above picture you can see the red line where i cropped the picture.

    The result is shown here.

    http://deanmoncaster.byethost7.com/step2.png

    As you can clearly see, MSPAINT has cropped the picture but in the process has managed to crop a lot more of the picture than I actually told it to crop, roughly 3 or 4 inches worth.

    I hope this better explains the bug that i have found in MSPAINT. This really is a bug, it isn't a feature and it certainly better not be by design! lol

    Dean
    Thursday, August 20, 2009 9:39 AM
  • i can see that but it may just be a problem with your computer or installation of your os because it works fine in mine and my uncles one works fine aswell

    im going to post 3 pictures the first one is before i have put it into paint this is so u know what the whole picture looks like just so you know


    http://i241.photobucket.com/albums/ff28/gazza126/Capture1-1.png

    the next one is in paint i have drew a red line where i am going to crop to

    http://i241.photobucket.com/albums/ff28/gazza126/Capture2.png

    as you can see i am going to crop on the outside of the middle of the red line the third pic is after i have cropped it is cropped to exactly the right place no extra's taken off

    http://i241.photobucket.com/albums/ff28/gazza126/Capture3.png

    and that is the final pic as you can see it has cropped to exactly the right place.
    • Edited by welsh4eva Thursday, August 20, 2009 11:50 AM
    Thursday, August 20, 2009 11:30 AM
  • This install is basically clean with all updates applied on the RTM version of Windows 7 (NOT RC, or BETA). If there is something wrong with the install already ill be sadly disappointed with Windows. I've only had it installed just over a week.
    Thursday, August 20, 2009 11:47 AM
  • the updates are for the release canditate as the complete os dosn't get released until 22nd october and also even the complete os will have bugs that is why microsoft have live updates so that if they do find a bug they can get it fixed as soon as possible and in terms of rc's this is a very good one and the rc install can sometimes get corrupted or have somting wrong which dosn't happen to evry1 else okay hope this helps a bit even tho it probably won't but at least i tried.

    gaz

    Thursday, August 20, 2009 11:57 AM
  • You have tried and i appreciate it.

    I am a technet subscriber so i get windows 7 a couple of months before you which is how i am using the version of Windows 7 you will get in october.

    From what i have heard a few bugs that were not in the RC have managed to find themselves into the RTM version. I think that this paint bug is one such problem.

    Can you confirm you are using the RC gaz?
    Thursday, August 20, 2009 12:02 PM
  • yes i am using the rc and no bug with paint so maybe is that not sure but im sure microsoft will fix it in a future update after the main release
    Thursday, August 20, 2009 12:03 PM
  • I can confirm this.
    I have the RTM version via an MSDN subscription.  I tried your experiment and did not see the problem when at 100% zoom.  Changing to 50% showed the bug exactly as described (except I had a different picture :-) , I used http://imgs.xkcd.com/comics/height.png)
    Paul
    Friday, August 21, 2009 2:35 AM
  • Thank you for your confirmation Paul, nice picture too, I haven't seen that one for a while and was great to look at!

    Dean
    Friday, August 21, 2009 7:20 AM
  • Thank you for all efforts.

    I will involve our feedback team on the issue.

    Again, Thank you.
    Friday, August 21, 2009 7:32 AM
  • My friend has also tried to replicate this and confirms it happens on his system too.

    Windows 7 RTM.

    Dean
    Friday, August 21, 2009 8:42 AM
  • Thanks for your input gaz, can you try to do it again only this time following the steps i mentioned?

    The image you have used at 50% zoom is not larger than your display area and as such doesn't contain a scroll bar like in BOTH of my pictures, i had highlighted them using a large RED ARROW.

    Also can you try using the middle lower resize square instead of the right lower one as shown in step 1?

    Dean
    Friday, August 21, 2009 8:50 AM
  • I have managed to work out what seems to be causing this BUG.

    First off create a canvass, that when at 50% or 25% zoom it is too large for the screen to display in one go and vertical scroll bars are displayed down the right hand side.

    Now when at 25% or 50% with vertical scroll bars on display, scroll to the bottom of the screen and note the length of your canvass, in my instance the length is 29.04 inches.

    Now click and hold the mouse button on either of the bottom two canvass resize squares and start moving the mouse up and down as though you were going to resize the canvass BUT DONT LET THE MOUSE BUTTON GO. Eventually return the mouse back to the location that it started and look at the NEW canvass length. In my instance here it is 23.75 inches. You can now release the mouse button.

    In effect, i have lost 5 inches of picture by merely grabbing the canvass resize square, extending the cavass size, then decreasing the canvass size and finally returning the canvass back to the original size before releasing my mouse button.

    It seems as though the counting mechanism for the diameters of the canvass are screwed when at 25% and 50% zoom. I cannot get paint to do this at 12.5% or anything larger than 50%.

    Hopefully you can recreate the bug and i have helped narrow it down a little.

    Dean
    Friday, August 21, 2009 10:59 AM
  • okay ill try followig your steps with a bigger picture
    Saturday, August 22, 2009 12:16 PM
  • just tried it does cut an extra bit off sure theyll fix it eventually and its not really too much of a problem just don't cut as much off
    Saturday, August 22, 2009 12:41 PM
  • You make it sound like people are randomly cutting parts off their pictures lol.

    people cut a certain amount off for a reason, having to try and work out how much to cut off in order to compensate for a software bug isn't something we should have to do.
    Saturday, August 22, 2009 12:45 PM
  • lol i understand that but it is the best thing we can do right now to just guess how much you need to actually take off t get it right will be a pain but best ny1 can do right now i also noticed the bigger the picture is the more extra it takes off

    gaz
    Saturday, August 22, 2009 12:47 PM
  • Hi, I also have this problem (on a new computer bought months after windows 7 release) did your's get fixed in an update or is it still doing this? Thanks
    Thursday, December 30, 2010 7:22 PM
  • Unbelievable. This BUG was reported back in 2009 and still reproducible in Windows 7 Professional Version 6.1.7600 Build 7600. Microsoft, DO something about it!!

     

    thanks

    Tuesday, May 03, 2011 4:59 AM
  • Bug still exists as of 26/03/12.

    This is a fucking joke that this still exists. MICROSOFT FUCKING GIVE AN UPDATE YOU FUCKS.

    Monday, March 26, 2012 12:15 AM
  • I was looking for this today to remark that it's still an issue and found that I'm only the second person to so so today. What the hell, microsoft?
    Tuesday, March 27, 2012 5:05 AM
  • Here it is, July 2nd of 2012, and this bug still persists.  It's caused me a tremendous amount of trouble, but thanks to this thread I know a work around now (do image re-sizing at 100% or 12.5%).  Thanks everyone!  (P.S. Microsoft, wake up.)
    Monday, July 02, 2012 7:33 AM
  • Almost at 3 years now...

    Unbelievable that either no one from MS reads these posts or MS think it's ok to have a bug exist for 3 years.

    Which is it?

    Sunday, July 15, 2012 7:06 AM
  • Bumping this up.

    MS Fix your shit.
    Wednesday, August 01, 2012 7:33 AM
  • Windows 8 Release Preview still has the problem so I started a new thread

    http://social.technet.microsoft.com/Forums/en/w8itproappcompat/thread/35919069-39f4-4265-bb8f-4ea3b88e9beb


    Paul Linton


    Wednesday, August 01, 2012 7:43 AM
  • This bug still persists, Microsoft should be ashamed!
    Monday, February 17, 2014 8:13 AM