none
The DNS proxy agent was unable to allocate 0 bytes of memory

    Question

  • I have 3GB memory in my laptop. The peak of memory usage was 2.5Gb. I found that my network adapter stop working and disable when this error happen. I have "Intel  Pro/Wireless 3965ABG" network card with latest drivers installed. Also that erro often happen if I use VPN connection.

    The DNS proxy agent was unable to allocate 0 bytes of memory. This may indicate that the system is low on virtual memory, or that the memory manager has encountered an internal error.

    - <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    - <System>
      <Provider Name="Microsoft-Windows-SharedAccess_NAT" Guid="{A6F32731-9A38-4159-A220-3D9B7FC5FE5D}" EventSourceName="ipnathlp" />
      <EventID Qualifiers="0">31004</EventID>
      <Version>0</Version>
      <Level>2</Level>
      <Task>0</Task>
      <Opcode>0</Opcode>
      <Keywords>0x80000000000000</Keywords>
      <TimeCreated SystemTime="2008-12-01T00:18:55.000Z" />
      <EventRecordID>17611</EventRecordID>
      <Correlation />
      <Execution ProcessID="0" ThreadID="0" />
      <Channel>System</Channel>
      <Computer>MRUMKA-PC</Computer>
      <Security />
      </System>
    - <EventData Name="IP_DNS_PROXY_LOG_ALLOCATION_FAILED">
      <Data Name="param1">0</Data>
      </EventData>
      </Event>
    Monday, December 01, 2008 12:52 AM

All replies

  • Hi,

     

    Are your using or enabled ICS (Internet Connection Sharing)?

     

    If so, please try to disable it to troubleshoot the problem. Mostly, the issue could be caused by ICS.

     

    Hope it helps.

     

    Tuesday, December 02, 2008 8:04 AM
  • I do not use ICS (Internet Connection Sharing) cause I have router in my net work and I perpforms connection to the work this case I do not need share my work network at home.
    Thursday, December 04, 2008 10:15 PM
  • Hi,

     

    Thank you for your update. I understand that you do not use ICS.

     

    However, could you please check the ICS setting? Some program may enable it previously. Thank you for your cooperation.

     

    1. Open Network Connections by clicking the Start button , clicking Control Panel, clicking Network and Internet, clicking Network and Sharing Center, and then clicking Manage network connections.

    2. Right-click the shared connection, and then click Properties.  If you are prompted for an administrator password or confirmation, type the password or provide confirmation.

    3. Click the Sharing tab, clear the Allow other network users to connect through this computer's Internet connection check box, and then click OK.

     

    Hope it helps.  

     

    Friday, December 05, 2008 9:47 AM
  • I checked all VPN and Network connection and I did not found ICS option enabled.
    Friday, December 05, 2008 5:02 PM
  • up
    Tuesday, December 09, 2008 12:16 AM
  • Hi,

     

    Thank you for your update.

     

    As ICS is not enabled, let’s disable the service to test the problem.

     

    1.       Click Start, type services.msc in Start Search bar and press Enter.

    2.       Find Internet Connection Sharing (ICS) service, and disable it.

    3.       Restart the computer to test the problem.

     

    Thank you for your cooperation.

     

     

    Tuesday, December 09, 2008 9:18 AM
  • Hi,

    Am I to understand that you're telling us that for all intents and purposes ICS is broken in a €700,- Desktop OS??

    So when do we get a fix?
    Friday, April 03, 2009 12:48 PM
  • Was this post ever answered? I have come across a lot of these unanswered posts, thus have not found a solution for the same problem. Ifanyone has a solution, please post it. Here is the original post:

    The DNS proxy agent was unable to allocate 0 bytes of memory. This may indicate that the system is low on virtual memory, or that the memory manager has encountered an internal error.

    - <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    - <System>
      <Provider Name="Microsoft-Windows-SharedAccess_NAT" Guid="{A6F32731-9A38-4159-A220-3D9B7FC5FE5D}" EventSourceName="ipnathlp" />
      <EventID Qualifiers="0">31004</EventID>
      <Version>0</Version>
      <Level>2</Level>
      <Task>0</Task>
      <Opcode>0</Opcode>
      <Keywords>0x80000000000000</Keywords>
      <TimeCreated SystemTime="2008-12-01T00:18:55.000Z" />
      <EventRecordID>17611</EventRecordID>
      <Correlation />
      <Execution ProcessID="0" ThreadID="0" />
      <Channel>System</Channel>
      <Computer>MRUMKA-PC</Computer>
      <Security />
      </System>
    - <EventData Name="IP_DNS_PROXY_LOG_ALLOCATION_FAILED">
      <Data Name="param1">0</Data>
      </EventData>
      </Event>

    Saturday, June 27, 2009 7:28 PM
  • This error is connected with Shared Access NAT (Check your Event Logs under System logs in the Administrative Tools) which means the ICS spoken of above by Robinson Zhang is the cause of this error. I can confirm this in my laptop (Vista 64 Ultimate) and have since turned OFF ICS and the error has gone away. I should not have turned it on in the first place. Disabling the service may also be necessary but in my case it has not.
    Sunday, September 06, 2009 9:07 AM
  • ____ THAT I NEED A INTERNET SHARING

    low on virtual memory, or that the memory manager has encountered an internal error

    low on virtual memory, or that the memory manager has encountered an internal error

    ____ DAMB PROGRAMERS!

    Monday, September 21, 2009 12:09 AM
  •  F FFF FF F F  YOU MICROISFDT WITH YOUR D U   MB JU N NN K!
    Monday, September 21, 2009 12:09 AM
  • I have this error on my Windows 7 x64 Professional system. It makes my ad-hoc connection for sharing my internetconnection to reset every time (that is about every 5-10 mintues). Is the only way to disable ICS ? In that case that's really crappy!
    Monday, December 07, 2009 4:19 PM
  • I could not use anything on VPN just now. Having spent about an hour attempting, I came across this post, and the solution here fixed the problem.

    It really would be helpful if there were an easier way around this (why is the service on by default, anyway?)

    Thanks Robinson!
    Thursday, December 17, 2009 11:29 PM
  • so, what's the solution? just disable ICS? shouldn't it be fixed? i really need to use ICS, what do i do in this case?
    Saturday, December 26, 2009 8:29 PM
  • I'm having the similar problem using ICS.

    I setup VMware Server 2.0.1 on Windows Vista and configure a NAT connection to each virtual host (Ubuntu Linux as web server).
    I have a database service at another server.

    I have no problem to connect to the database server from the Ubuntu Linux and I didn't configure any ICS.

    But after I upgrade to Windows 7 Professional, I cannot connect to the database server from Ubuntu Linux without configure ICS. But I can ping the database server!
    So I configure ICS and my Ubuntu Linux is able to connect to the database server.

    Now the problem is, the Ubuntu Linux always cannot access to the database server after several minutes (estimate 15~30 minutes) after I back from my lunch...
    I need to disable the VMware Virtual Ethernet Adapter which configure for NAT and enable again so the Ubuntu Linux is able connect to database server.

    I wonder why Vista can work but Win 7 having this problem?

    Anyone can answer me how to solve this problem so I no need to disable and enable the connection again?
    I need a solution only. don't tell me a long long story of whose fault it is...

    Thanks.
    Tuesday, February 02, 2010 6:33 AM
  • I am starting to think Microsoft has too many problems to fix with your current manpower- time to outsource, or is that what caused the problems in the first place?

     

    Anyway same issue here- another feature that I need and cannot use due to lack of responsiveness on Microsofts part. Dell Lattitude i7 quad core processor, 8 GB of ram (and the system needs virtual memory when I have never seen the memory usage come close to 50 % thanks to my Google Gadget Desktop bar)    Thanks, Robinson Zhang for a thorough job helping this customer through their problems. I see all of these other people having this same issue and I don't see that you have responded back in 2 years so I am guessing you got paid to respond and are now off doing others disservice.  

     

    Log Name:      System

    Source:        Microsoft-Windows-SharedAccess_NAT

    Date:          11/15/2011 5:58:12 PM

    Event ID:      31004

    Description:

    The DNS proxy agent was unable to allocate 0 bytes of memory. This may indicate that the system is low on virtual memory, or that the memory manager has encountered an internal error.

    Event Xml:

    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">

      <System>

        <Provider Name="Microsoft-Windows-SharedAccess_NAT" Guid="{A6F32731-9A38-4159-A220-3D9B7FC5FE5D}" EventSourceName="ipnathlp" />

        <EventID Qualifiers="0">31004</EventID>

        <Version>0</Version>

        <Level>2</Level>

        <Task>0</Task>

        <Opcode>0</Opcode>

        <Keywords>0x80000000000000</Keywords>

        <TimeCreated SystemTime="2011-11-15T22:58:12.000000000Z" />

        <EventRecordID>39371</EventRecordID>

        <Correlation />

        <Execution ProcessID="0" ThreadID="0" />

        <Channel>System</Channel>

        <Computer>sms-nkstewart</Computer>

        <Security />

      </System>

      <EventData Name="IP_DNS_PROXY_LOG_ALLOCATION_FAILED">

        <Data Name="param1">0</Data>

      </EventData>

    Wednesday, November 16, 2011 11:35 AM
  • Event IDs 34005 and 31004 may be logged in the System event log of Windows 7 when Internet Connection Sharing (ICS) is enabled on an available Network connection
    Мнения, высказанные здесь, являются отражением моих личных взглядов, а не позиции корпорации Microsoft. Вся информация предоставляется "как есть" без каких-либо гарантий
    Follow us on TwitterFollow MSTechnetForum on Twitter

    Посетите Блог Инженеров Доклады на Techdays: http://www.techdays.ru/speaker/Vinokurov_YUrij.html
    Friday, December 23, 2011 1:04 PM
  • Hi Robinson, what should i do if i want to use the ICS and resolve this error at the same time.

    thanks~

    Thursday, October 04, 2012 8:00 AM